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Abstract 
 
These Application Notes describe the configuration steps required for call accounting and 
billing functionality of the Tiger Communications’ Tiger 2020 Pro to successfully interoperate 
with Avaya IP Office.  
 
Information in these Application Notes has been obtained through compliance testing and 
additional technical discussions.  Testing was conducted via the DevConnect Program at the 
Avaya Solution and Interoperability Test Lab.   
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1. Introduction 
 
These Application Notes describe the compliance-tested configuration using a Tiger 
Communications’ 2020 Pro and an Avaya IP Office 4.2.   
 
DCMon (Data Collection Monitor) and Tiger 2020 Advanced Reporting are applications that are 
providing call accounting and billing functionality as part of the Tiger 2020 Pro package. 
DCMon is responsible for obtaining SMDR (Station Message Detail Reporting) records from 
Avaya IP Office and it is responsible for storing and processing of the records. Tiger 2020 
Advanced Reporting is further processing the SMDR records obtained from DCMon in order to 
provide usage analysis, call costing and billing data reports. 
 
There are four main areas of integration between the products that require validation.  These are: 

• SMDR details of intra-switch calls 

• SMDR details of incoming trunk calls 

• SMDR details of outgoing trunk calls 

• Link Failure/Recovery 

The majority of the tests were conducted to ensure the successful processing of the SMDR data. 
The last area concentrates on the connectivity between Tiger 2020 Pro and Avaya IP Office and 
the collection of SMDR data. Tests were conducted to validate that successful connection and 
recovery takes place during link failures. 
 
The configuration in Figure 1 was used to compliance test Tiger 2020 Pro with Avaya IP Office.   

• IP412 Office was configured with analog and digital expansion modules  
• TCP/IP link was established between Tiger 2020 Pro and Avaya IP Office. From Avaya 

IP Office, SMDR records were sent  to agreed port number on the Tiger 2020 Pro for 
SMDR collection and processing by the Tiger’s DCMon 

• E1 PRI Trunk card was connecting Avaya IP Office to another PBX which was 
simulating a PSTN environment for testing inbound/outbound external calls. 

• Avaya 2420 digital telephones and Avaya 4620SW and 4621SW IP Telephones were 
used to answer and/or place the calls. 
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Figure 1 – Network Topology 

 

2. Equipment and Software Validated 
The following equipment and software/firmware were used for the sample configuration: 
 

Equipment Software /Firmware 
Avaya IP412 Office 4.2(4) 
Avaya IP400 Phone 6.2(4) 
Avaya IP400 Digital Station 6.2(4) 
Avaya IP Office Manager 6.2(4) 
Avaya E1 PRI Trunk Card (PRI 30 E1) - 
Avaya 4600-Series IP Telephones (4620SW, 4621SW) 2.9 
Avaya 2420 Digital Telephones - 
Tiger 2020 Pro 4.9.4.1 
Tiger Data Collection Monitor 4.9.2.0 
Tiger 2020 Advanced Reporting 4.9.5.0 
Collection.exe (Used by DCMon) 7.8.1.0 
IPOffice.exe (Used by DCMon) 7.11.1.0 

 
Table 2: Equipment and Software Validated 
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3. Configure Avaya IP Office 
The configuration information provided in this section describes the steps required to set up 
Avaya IP Office for this solution. 
For all other provisioning information, such as Avaya IP Office installation and configuration 
please refer to Avaya IP Office product documentation in reference [1]. 
 
Step Description 

1.  Log into the Avaya IP Office Manager PC and go to Start → Programs → IP Office → 
Manager to launch the Manager application. 

 
2.  In the Manager window, select File → Open to search for IP Office in the network. 
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Step Description 
3.  Log into Avaya IP Office using the appropriate login credentials to receive its configuration. 

 

4.  In the Manager window, expand the Configuration Tree and double-click System. Select the 
CDR/SMDR tab.   
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Step Description 
5.  In the CDR/SMDR tab that appears, for Output select “SMDR only” from the dropdown list. 

In the SMDR Communications area configure IP Address with the IP Address of the Tiger 
2020 Pro server, “192.168.42.220” and for TCP Port set the Port number to match the 
configuration on the Tiger 2020 Pro server, “3025”. Leave the default configuration for other 
parameters and click OK. 
 

 
 

6.  In the Manager window, select File → Save to push the configuration to Avaya IP Office and 
wait for the system to update.  This completes configuration of Avaya IP Office. 
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4. Configure Tiger Communications Server 
The configuration information provided in this section describes the steps required to configure 
Tiger Communications’ 2020 Pro to interoperate with Avaya IP Office 4.2. Tiger’s Data 
Collection Monitor collects SMDR records generated by Avaya IP Office over a TCP/IP link and 
it is responsible for storing and processing of the records. 
 
For all other provisioning information, such as software installation, installations of optional 
components, and configuration of Tiger 2020 Pro, please refer to the Tiger Communications’ 
product documentation in reference [2]. 
 

Step Description 
1.  On the Tiger 2020 Pro server, navigate to d:\tig2020\network\bin and verify that programs 

with correct versions are installed for integration with Avaya IP Office:  
 

IPOffice.exe version 7.11.1.0 
Collection.exe version 7.8.1.0 
DCMon.exe version 4.9.2.0 
 

2.  On the Tiger 2020 Pro server, modify the IPOffice.conf file in the directory 
d:\tig2020\network\Switch\Node1. In the [Switch] section set the Type field to “ipoffice” to 
ensure that IPOffice.exe program is used by the DCMon. 
 
Contents of IPOffice.conf file 
 
[Switch] 
Type=ipoffice 
Revision=1.0 
MaxCallHoldTime=120000 
MaxTandemHoldOn=30000 
MaxSectionHoldOn=7200000 
RecordDiscardBlacklistHoldOn=3600000 
MaxLineLength=2000 
BreakYear=1980 
NodeId=1 
DiscardDuplicateRecords=1 
DiscardOutgoingWithNoCalledDigits=0 
CallTimeType=0 
SequenceNumbersHeld=28 
DefaultLatency=0 
DiversionChargedPartyRule=0 
TransferChargedParty=0 
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Step Description 
3.  Continue updating the IPOffice.conf file and in the [Input] section set the Port number to 

“3025” i.e. the same Port that is set in SMDR configuration on Avaya IP Office Section 3, 
Step 6. Ensure that Address field is commented out. Set the CreateAs field to “Server” to 
ensure that the Tiger 2020 Pro server waits for a connection from Avaya IP Office. 
 
Contents of IPOffice.conf file 
 
[Input] 
Name=Node 25 Socket Input 
Type=Socket 
Direction=Bidirectional 
BufferSize=1024 
TimeOut=200 
Sharing=none 
Protocol=TCP 
##Address= 
Port=3025 
CreateAs=Server 
Mode=Stream 
Blocking=0 
NormalReadResetInterval=1200000 
InitialReadResetInterval=3600000 
 

 
 

4.  Continue updating the IPOffice.conf file and in the [FieldDefsFile] section, configure the 
Name parameter with “d:\tig2020\Network\SwitchConf\Ipoffice4_2.conf” file. This file 
holds the field definitions that match the SMDR output from Avaya IP Office. 
 
Contents of IPOffice.conf file 
 
 [FieldDefsFile] 
Name=D:\tig2020\Network\SwitchConf\Ipoffice4_2.conf 
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Step Description 
5.  On the Tiger 2020 Pro server, navigate to d:\tig2020\network\bin and click on the dcmon.exe 

file to launch the Tiger 2020 Pro data collection configuration. On the main Data Collection 
Monitor screen toolbar, click on Options → Configure. 
 
There are two monitor types to be configured - one for the collection which interfaces with 
the Tiger 2020 Pro database and one for the switch which interfaces with Avaya IP Office.  
 
In the Configure Monitors dialog box click the Add button. In the Label field enter a 
descriptive name for the collection monitor type. In the Conf File Location field enter or 
browse to the location of the “collection.conf” file. The collection.conf file during this 
compliance testing was located at D:\tig2020\network\collection. For the Monitor Type 
select “Collection” from the drop down list. The rest of the parameters can be left with their 
default values. Click Apply. 
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Step Description 
6.  In the Configure Monitors dialog box click the Add button. In the Label field enter a 

descriptive name for the switch monitor type, “IPOffice”. In the Conf File Location field 
enter or browse to the location of the IPOffice.conf file modified in Step 2. The IPOffice.conf 
file for this compliance testing was located at d:\tig2020\network\Switch\Node1. For the 
Monitor Type select “Switch” from the drop down list. The rest of the parameters can be left 
with their default values. Click Apply 
 

 
 



 
VM; Reviewed: 
SPOC 12/15/2008 

Solution & Interoperability Test Lab Application Notes 
©2008 Avaya Inc. All Rights Reserved. 

11 of 17 
IPO-2020Pro 

 

Step Description 
7.  In the main Data Collection Monitor screen, right click on the collection monitor icon labeled 

Collection and select Start Program. Do the same for the switch monitor icon labeled 
IPOffice.  
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Step Description 
8.  After both monitors have been started the correct versions for Collection.exe - 7.8.1.0 and for 

IPOffice.exe 7.11.1.0 can be observed. The message “Waiting for connection on port 3025” 
can also be observed, which means that DCMon is ready to receive records from Avaya IP 
Office. 
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Step Description 
9.  Since the Tiger 2020 Pro server is listening on port 3025, the connection is established with 

Avaya IP Office only after the first record is received from Avaya IP Office. In DCMon the 
message: “Connection established from 192.168.42.1 on port 3025” can be observed. 
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5. Interoperability Compliance Testing 
The interoperability compliance testing included feature and serviceability testing. The feature 
testing evaluated processing of the SMDR data obtained from Avaya IP Office via secure port on 
TCP-IP link. The serviceability testing introduced failure scenarios to see if Tiger 2020 Pro 
could resume after a link failure with Avaya IP Office. 

5.1. General Test Approach 
The general test approach was to validate processing of the SMDR data for the following call 
types: 

• intra-switch calls 

• incoming trunk calls 

• outgoing trunk calls 

• calls answered by voicemail 

• transferred calls 

• calls to extensions which have forward unconditional 

• link failure/recovery 

Feature functionality testing was performed manually. The DCMon application was used for 
obtaining and processing SMDR records from Avaya IP Office. Tiger 2020 Advanced Reporting 
application was used to validate the processed data. Internal and external calls were made by 
using Digital and IP Telephones, and external inbound and outbound calls were made through an 
E1/PRI trunk.  
The last area concentrated on the connectivity between Tiger 2020 Pro and Avaya IP Office. 
Tests were conducted to verify that SMDR records were successfully obtained and processed by 
the DCMon after connection to Avaya IP Office was lost and re-established. 
 

5.2. Test Results 
All executed test cases were completed successfully. 
 



6. Verification Steps 
 

Step Description 
1.  Make calls and verify that DCMon receives the raw SMDR records and they can be seen in 

the Monitoring “IPOffice” window. 
 

 
 

2.  Verify that DCMon correctly processes the raw SDMDR data and that processed records 
appear in the Monitoring “Collection” window. 
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Step Description 
3.  Generate a Call Listing report using Tiger 2020 Advanced Reporting and verify that SMDR 

records were correctly processed.  
 

 
 

 

7. Support 
If technical support is required for the Tiger Communications’ 2020 Pro, contact the Technical 
Support Department.  

Email: support@tigercomms.com

Phone: +44 1425 891 000  

 

8. Conclusion 
These Application Notes describe the steps for configuring Tiger 2020 Pro to work with Avaya 
IP Office. All test cases that were executed have successfully passed.  
Tiger 2020 Pro version 4.9.4.1 was successfully compliance tested with Avaya IP Office version 
4.2(4) 
 

9. Additional References  
[1] Product documentation for Avaya products may be found at http://support.avaya.com 
Avaya IP Office 4.2 Manager 6.2, Issue 22d, 14th July 2008 
 
[2] Product documentation for Tiger Communication’s products may be found at: 
www.tigercomms.com
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