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Abstract 
 

  
These Application Notes describe the procedures for configuring InteractCRM SMSConnect 
1.0 to interoperate with Avaya Interaction Center (IC) Release 7.0. 
 
SMSConnect provides Short Message Service (SMS) based self service and intelligent 
communication between customers and organizations. It links up customers’ mobile phones 
with organizations’ human and information resources to provide customers quick and easy 
access to information within the organization, and extends the functionalities of Avaya IC in a 
seamless manner. 
 
Information in these Application Notes has been obtained through compliance testing and 
additional technical discussions. Testing was conducted via the DeveloperConnection Program 
at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the compliance-tested configuration used to validate 
InteractCRM SMSConnect 1.0 with Avaya Interaction Center Release 7.0. 

SMSConnect enables two way interactions between customers and Avaya IC contact center 
agents via SMS messaging. Customers can send SMS messages to the contact center and have 
their queries responded to by agents using Avaya IC. Such SMS messages are correctly 
classified by Avaya IC, thus providing a seamless integration into any Avaya IC environment. 
SMSConnect also provides the ability to collect feedback from customers that have contacted the 
contact center. An SMS message can be automatically sent to the customer at the end of a call to 
collect feedback, thus allowing the performance of the agents to be rated.  The Interaction 
Manager and Feedback Manager components of SMSConnect are utilized for integration of SMS 
messaging and SMS-based feedback survey with Avaya IC respectively. 

Figure 1 illustrates the configuration used to verify InteractCRM SMSConnect interoperability 
with Avaya Interaction Center. Avaya Interaction Center was installed on three servers running 
Microsoft Windows Server 2000 Service Pack 4. InteractCRM SMSConnect ran on another 
server running Microsoft Windows Server 2000 Service Pack 4 with a GSM / GPRS modem 
installed to send and receive SMS messages. A generic POP3 / SMTP Email server was installed 
on another server with mailboxes configured for use by SMSConnect and Interaction Center. 
Another server running Microsoft SQL Server 2000 stored the IC Repository database.  Avaya 
IC Design and Administration Tools were installed on the Administrator PC to configure the 
Avaya Interaction Center environment. On the agent PC, Avaya IC Agent client was installed 
and configured for the IC Email and Voice Channel. The Chat channel was not configured and 
tested in this configuration. All the systems are connected on the customer LAN using the Avaya 
C364T-PWR Converged Stackable Switch for network connectivity. SMS messages from 
customers are simulated using three mobile phones capable of sending and receiving SMS 
messages. The detailed configurations of Avaya S8300B Media Server, Avaya G350 Media 
Gateway, Avaya Application Enablement Services (AES) server and Avaya 4600 Series IP 
Telephone are not discussed in these Application Notes. 
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Figure 1: InteractCRM SMSConnect with Avaya Interaction Center 

 
Figure 2 shows the sample SMS messaging flow for a customer who sends an SMS message to 
the call center and the agent replies using Avaya IC Agent.  
 

 
 
Figure 2: Sample SMS Flow from InteractCRM SMSConnect to Avaya Interaction Center 
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Step Description 
1 Customer sends a SMS message to the Contact Center. This message is routed via the 

Mobile Service Provider to the GSM/GPRS modem. SMSConnect polls the GSM/GPRS 
Modem to receive the SMS message. 

2 SMSConnect converts the SMS message into an email, sets the subject of the email in a 
predefined manner with the SMS Contact details (e.g. customer’s mobile number) and 
sends the email to the IC email account (e.g. ‘icuser@avaya.com’) on the Email server. 
An example of the subject of the email is “SMS-6598646345-6598639738” where the 
number 6598646345 is the number of the GSM/GPRS modem and 6598639738 is the 
customer’s mobile number. 

3 IC Email polls the IC email account on a regular interval and retrieves the email. 
4 IC Email triggers the customized qualifyemail workflow to qualify the email. The 

workflow parses the subject of the email and sets the Electronic Data Unit (EDU) values 
with the SMS Contact details. 

5 The workflow routes the email to the call center agent. 
6 The agent uses Avaya IC Agent to read and respond to the email. 
7 The outbound email workflow sends the email to the SMSConnect email account (e.g. 

‘smsuser@avaya.com’) on the Email server. 
8 SMSConnect polls the SMSConnect email account on a regular interval and retrieves 

the email. 
9 SMSConnect converts the email back to an SMS message and sends it to the customer 

via the GSM/GPRS modem. 
 
Figure 3 shows the sample SMS-based feedback survey. After a customer hangs up on the call 
with an agent, SMSConnect sends an SMS message to the customer to collect their feedback. 
 

 
 

Figure 3: Sample SMS flow to collect feedback 
 
 
 
 
 
 
 



 
JC; Reviewed: 
SPOC 10/26/2006 

Solution & Interoperability Test Lab Application Notes 
©2006 Avaya Inc. All Rights Reserved. 

5 of 51 
SMSC-IC7 

 

Step Description 
1 The customer is connected to the call center agent. This can be a voice call or a web 

chat. 
2 When the customer hangs up, the agent wraps up the call using Avaya IC Agent. The 

wrap up event triggers an IC Script, which sends a request to SMSConnect to collect 
feedback from the customer. 

3 SMSConnect composes an SMS message based on a Feedback Template and sends to 
the customer’s mobile phone. 

4 The customer replies to the SMS message. SMSConnect analyzes the SMS message 
received from the customer. 

2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

Equipment Software 
Avaya Interaction Center Release 7.0 Service Pack 2 
Avaya S8300B Media Server 3.1.2 (R013x.01.2.632.1) 
Avaya G350 Media Gateway Firmware V25.28.0 
Avaya 4600 series IP telephones 4621SW (R2.4) 
Avaya Application Enablement Services 3.1.1 (r3-1-1-build-43-2-0) 
Avaya C364T-PWR Converged Stackable Switch 4.3.12 
InteractCRM SMSConnect 1.0 

3. Configure Avaya Interaction Center 
This section describes the configuration of Avaya Interaction Center to interoperate with 
InteractCRM SMSConnect. It is assumed that Avaya Interaction Center core servers and IC 
Agent required to handle the IC Email and Voice Channels are installed and running properly.  

3.1. Configure IC Email Account 
When SMSConnect needs to send SMS messages to the agents in Interaction Center, it does so 
by converting the SMS messages to emails and sending them to a predetermined POP3 email 
account. Interaction Center polls this email account for new messages and routes them to the 
agents using the customized email workflow as described in Section 4.2. In this configuration, 
the email account is icuser@avaya.com created on the Email server. 
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Step Description 
1. To start IC Manager, click Start→All Programs→Avaya Interaction Center 7.0→IC 

Manager. Login with an account with administrator privileges to display the main IC 
Manager screen. From the menu, select Services→Email Accounts and click New. 
 

 
 

2. In the General tab of the New Email Account window, enter the email account to be 
polled by IC Email. In this configuration, to specify the email account icuser@avaya.com, 
enter icuser for Name and avaya.com for Domain. Select DefaultTenant for Tenant and 
uncheck Disable Account. 
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Step Description 
3. Click on the Server tab to enter the parameters for the email account. In this 

configuration, enter the IP address of the Email server for Outgoing Email (SMTP) and 
Incoming Email (POP3). Enter icuser for Logon account and the password for icuser in 
Password and Confirm. Click Ok. 
 

 
 

3.2. Configure Interaction Center for SMS Messaging 
The following files are provided by InteractCRM for the integration of SMS messaging with its 
Interaction Manager component. The first four files contain the required modifications to the 
qualifyemail workflow to extend its functionality to qualify SMS messages from SMSConnect 
that have been converted to emails. The remaining four files modify the Contact History Browser 
and Electronic Data Unit (EDU) Viewer in IC Agent to display the additional parameters related 
to the SMS messages. These files are located on the SMSConnect server and need to be 
transferred to the Avaya IC Administrator PC. 
 
Note: It is assumed that Avaya IC uses the out-of-the-box workflows, EDU layout and IC scripts. 
If the Avaya IC installation has been customized, consult InteractCRM for the required 
customization to be done. 
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 File Name Folder Location 
1. wacd.prj <SMSConnect Install Dir>\InteractCRM\ 

SMSConnect\IC Connector for Interaction 
Manager\IC Flows\wacd\ 

2. qualifyemail.qfd Same as above 
3. qualifysms.qfd Same as above 
4. SymDictionary.txt Same as above 
5. eduviewer_en_US.xsl <SMSConnect Install Dir>\InteractCRM\ 

SMSConnect\IC Connector for Interaction 
Manager\Agent Files\QConsole\ 

6. Qconsole_AddContact.qsc Same as above 
7. QConsole_BuildActiveContactCriteria.qsc Same as above 
8. QConsole_BuildCHBrowserInfo.qsc Same as above 

3.2.1. Deploy the Workflows 
The new workflows need to be re-built using Avaya Workflow Designer. The following 3 
custom EDU fields will be populated for every incoming contact identified as an SMS within 
Interaction Center: 

• primarymedia 
• gatewayno 
• custmobile 

 
Step Description 

1. On the Avaya IC Administrator PC, backup the files that will be replaced. Copy the files 
wacd.prj, qualifyemail.qfd, qualifysms.qfd and SymDictionary.txt from the SMSConnect 
server to the <AVAYA_IC70_HOME>\design\IC\Flows\Avaya\wacd\ folder on the 
Avaya IC Administrator PC. 
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Step Description 
2. To start Avaya Workflow Designer, click Start→All Programs→Avaya Interaction 

Center 7.0→Workflow Designer. 
 

 
 

3. Click File→Open Project from the menu and open the project 
<AVAYA_IC70_HOME>\design\IC\Flows\Avaya\wacd\wacd.prj for editing. 
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Step Description 
4. To import the SymDictionary.txt file, click Project→Symbols→All Symbols from the 

menu to open the Symbol Viewer window. Click Import and select SymDictionary.txt in 
the folder <AVAYA_IC70_HOME>\design\IC\Flows\Avaya\wacd\. Click Open. The 
Symbol Viewer window will be updated with the symbols from the new 
SymDictionary.txt file. Click OK. 
 

 
 

5. Open the qualifyemail flow and verify that it is modified to run the flow qualifysms for 
emails converted from SMS messages, as highlighted in the screen below. Click 
Build→Build Flow Set from the menu. 
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Step Description 
6. In the Project Settings window, specify an IC account with administrative privileges to 

upload the new workflows to the database. Click OK. 
 

 
 

7. Start Avaya IC Manager as described in Section 3.1 Step 1. Double-click the Workflow 
server used for handling emails. 
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Step Description 
8. In the WorkFlow tab, click Reload Flows. 

 

 
 

9. In the Reload Flows window, check Force immediate reload and click Ok. 
 

 
 

3.2.2. Deploy the EDU Layout 
The EDU layout file provided by SMSConnect needs to be deployed using Avaya Database 
Designer. This will display the 3 custom EDU fields in the EDU Viewer in IC Agent. 
 
Step Description 

1. On the Avaya IC Administrator PC, backup the file eduviewer_en_US.xsl. Copy the new 
file eduviewer_en_US.xsl from the SMSConnect server to the 
<AVAYA_IC70_HOME>\design\QConsole\ folder on the Avaya IC Administrator PC. 
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Step Description 
2. To start Avaya Database Designer, click Start→All Programs→Avaya Interaction 

Center 7.0→Database Designer. Click File→Open and open the file ccq.adl from the 
folder <AVAYA_IC70_HOME>\design\ CallCenterQ\ as shown below. 
 

 
 

3. Click File→Generate Windows Application. Check EDU Layout browse to the file 
<AVAYA_IC70_HOME>\design\QConsole\eduviewer_en_US.xsl. For the Application 
Name field, select the application used by the agent (e.g. interaction_center). Specify the 
IC administrative account for Login Id and Password. Click OK. 
 

 
 



 
JC; Reviewed: 
SPOC 10/26/2006 

Solution & Interoperability Test Lab Application Notes 
©2006 Avaya Inc. All Rights Reserved. 

14 of 51 
SMSC-IC7 

 

3.2.3. Deploy the IC Scripts 
The new IC Scripts provided by SMSConnect need to be deployed using Avaya Database 
Designer. These scripts will read the new custom EDU fields and classify SMS messages as type 
SMS instead of email on the Contact History Browser window in IC Agent. 
 
Step Description 

1. On the Avaya IC Administrator PC, backup the files that will be replaced. Copy the files 
Qconsole_AddContact.qsc, Qconsole_ BuildActiveContactCriteria.qsc and Qconsole_ 
BuildCHBrowserInfo.qsc from the SMSConnect server to the folder 
<AVAYA_IC70_HOME>\design\QConsole\ on the Avaya IC Administrator PC. 
 

2. To start Avaya Database Designer, click Start→All Programs→Avaya Interaction 
Center 7.0→Database Designer. Click File→Open and open the file ccq.adl from the 
folder <AVAYA_IC70_HOME>\design\ CallCenterQ\ as shown below. 
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Step Description 
3. Click Edit→IC Scripts to open the IC Script Editor. In the Scripts section, select the 

script Qconsole_AddContact and click Upload. 
 

 
 

4. In the Database Login window, select defaultDBConnectSet for DB Connection Set and 
specify an IC account with administrative privileges to upload the new IC Scripts to the 
database. 
 

 
 

5. Repeat Steps 3 and 4 to upload the scripts Qconsole_ BuildActiveContactCriteria and 
Qconsole_ BuildCHBrowserInfo to the database. 
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3.2.4. Define IC Properties 
SMSConnect uses 5 new IC Properties. These properties are used by the new wacd.qualifyemail 
and wacd.qualifysms workflows provided by SMSConnect. As these are custom IC Properties, 
they have to be first created using IC Manager. Consult [1] for further guidance. The description 
of the properties is shown in Table 1. 
 
Note: Settings in this section have to be ratified with the format of the information sent from 
SMSConnect as defined in Section 4 Step 9. 
 
Property Value  Description 
param1 mediatype  Set this field to mediatype if the first word in the email subject set 

by SMSConnect is the media type (e.g. SMS). 
param2 mobileno  Setting this property to mobileno indicates that the second 

parameter set by SMSConnect is the mobile number of the 
customer. 

param3 gatewayno  Setting this property to gatewayno indicates that the third 
parameter set by SMSConnect is the number to which the SMS 
was sent (e.g. the GSM modem number).  

separator - This is the separator in the subject of an email between the 
parameters. 

fromaddress SMSConnect 
Email 
Address 

This is the email address which SMSConnect uses to send 
messages to IC Email account. The connector will monitor all 
emails coming from this account and execute message processing 
rule for them.  

Table 1: IC Properties for SMSConnect 
 
Step Description 

1. On the Avaya IC Administrator PC, start Avaya IC Manager as described in Section 3.1 
Step 1. Click Tools→Property Declarations. 
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Step Description 
2. A new section called System/SMSConfiguration needs to be created to store the 5 new 

properties used by SMSConnect. On the Property Declarations window, click New to 
create a new section. 
 

 
 

3. Enter System/SMSConfiguration for Name and a descriptive name for Description. 
Click Ok. 
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Step Description 
4. On the Property Declarations window, click New on the right-hand side to create a new 

type. 
 

 
 

5. Create the new IC Properties as shown in Table 1. Enter param1 for Name and a 
descriptive name for Description. Select string for Property Datatype. Click Ok. 
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Step Description 
6. Repeat Steps 3 and 4 to create the remaining IC properties as shown in Table 1. After 

creating the last IC property, click Ok to close the Property Declaration window. 
 

7. From the IC Manager window, click Tools→Groups. Click on the root node IC, then 
select the Properties tab and System/SMSConfiguration for Sections. Click on the 
button Create New Setting. 
 

 
 

8. In the Assign Property window, select param1 for Property and enter mediatype for 
Property Value. Leave the field Descendants May Override as checked. Click Ok. 
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Step Description 
9. Repeat Step 8 and enter gatewayno for param2, mobileno for param3, - (dash) for 

separator and smsuser@avaya.com for fromaddress. When completed, the new IC 
Properties will be shown as below. 
 

 
 

3.3. Configure Interaction Center for SMS-based Feedback Survey 
This section describes various configurations required on Avaya Interaction Center for the proper 
integration with the Interaction Manager component on InteractCRM for SMS-based feedback 
survey. 

3.3.1. Configure IC Application Design Language (ADL) File 
The out-of-the-box (OOTB) Application Design Language (ADL) file ccq.adl has been modified 
to add various components required by the SMSConnect Feedback Manager component. This 
file can be located in the folder <AVAYA_IC70_HOME>\design\CallCenterQ\. 
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Step Description 

1. To start Avaya Database Designer, click Start→All Programs→Avaya Interaction 
Center 7.0→Database Designer. Click File→Open and open the file ccq.adl from the 
folder <AVAYA_IC70_HOME>\design\ CallCenterQ\ as shown below. Right-click on 
Tables and click New Table. 
 

 
 

2. Create the custom table tb_smsconnector to store the survey details for every contact. In 
the New Table window, enter tb_smsconnector for Name and Description. Click Next. 
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Step Description 
3. Select CallCenterQ. Click Next. 

 

 
 

4. Enter tb_smsconnector for the field What is the name of the table in the database. 
Click Next. 
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Step Description 
5. Accept the default entries for Primary key name and Table field for the key. Click 

Finish. 
 

 
 

6. In the main Database Designer window, expand Components→Tables. Right-click on 
the table tb_smsconnector and select New Field. 
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Step Description 
7. In the New Field window, enter agentid for the name and a brief description of the new 

field. Click Next. 
 

 
 

8. Enter agentid for the field What is the name of the field in database to match Step 7. 
Select Text for What is type of this field, No for The field is read-only and No for The 
field is required. Click Finish. 
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Step Description 
9. Repeat Steps 7 and 8 to create the following required fields. These fields are used to store 

the relevant customer contact information to be used by Feedback Manager. 
 

Name/ Database field name Type Read Only? Required? 
customercontact Text No No 
domainname Text No No 
groupname Text No No 
mediatype Text No No 
mobileno Text No No 
stopsurvey Text No No 
surveyed Text No No 
urlreceipt Text No No 
urlsenttime Text No No 
wrapuptime Text No No 

 
 

10. In the main Database Designer window, click File→Save to save the changes. 
 

11. A table set is a group of table aliases that constrains the tables that can be displayed and 
updated in a form or browser. In the main Database Designer window, expand 
Components→Table Sets. Right-click on Table Sets and click New Tableset. 
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Step Description 
12. Enter tb_smsconnector for the name of the new table set so that it matches the name of 

the table in Step 2. Click Finish. 
 

 
 

13. To add a table alias for the table tb_smsconnector, click Add and select 
tb_smsconnector. 
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Step Description 
14. Accept the default entry and click OK. 

 

 
 

15. In the main Database Designer window, click File→Save to save the changes. 
 

16. Modules package lower-level components together into a building block for an Avaya IC 
application. In the main Database Designer window, expand Components→Modules. 
Right-click on Modules and click New Module. 
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Step Description 
17. Enter q_smsconnector for name and label and enter a description of this module. Click 

Finish. 
 

 
 

18. Click Add for Table sets and select customer. Repeat and select tb_smsconnector. 
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Step Description 
19. In the main Database Designer window, click File→Save to save the changes. 

 
20. A focus combines one or more forms and modules to create a workflow. Each workflow 

is a related sequence of activities that an application user is expected to perform. In an 
Avaya IC application, a focus appears in a window with one or more buttons that let the 
user access the forms in the focus. In the main Database Designer window, expand 
Applications→interaction_center→Focuses. Right-click on Focuses and click Add 
Focus. Select q_smsconnector from the list of modules. 
 

 
 

21. In the main Database Designer window, click File→Save to save the changes. 
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Step Description 
22. The String Table is used to add an entry which is used as a name for a custom button 

placed onto the IC Agent’s console. In the main Database Designer window, expand 
Components and click String Table. Click Insert. 
 

 
 

23. Enter User_Control_1 for Message Code and Stop Survey for Message Text. Click 
OK. 
 

 
 

24. In the main Database Designer window, click File→Save to save the changes. 
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Step Description 
25. In the main Database Designer window, click File→Database Administration. Select 

Reconfigure and specify an IC administrator login for Login Id and Password. Click 
Run to reconfigure the database. Click Close when complete. 
 

 
 

26. In the main Database Designer window, click File→Generate Windows Application. 
Check Messages and select interaction_center for Name. Specify an IC administrator 
login for Login Id and Password and click OK. 
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3.3.2. Configure IC Scripts 
The out-of-the-box IC Scripts QConsole_CompleteContact has been modified to call the 
custom IC Script SMSConnect_Survey. Another custom script SMSConnect_StopSurvey is 
called when the agent clicks on the Stop Survey button on the IC Agent console to indicate that 
SMS survey should not be sent for the current contact. 
 
Step Description 

1. Copy the custom scripts SMSConnect_Survey.qsc and SMSConnect_StopSurvey.qsc 
located in the folder <SMSConnect Install Dir>\InteractCRM\ SMSConnect\IC 
Connector for Feedback Manager\Agent Files\QConsole\ on the SMSConnect server, 
to the folder <AVAYA_IC70_HOME>\design\QConsole\ on the IC Administrator PC. 
 

2. On the IC Administrator PC, click Start→All Programs→Avaya Interaction Center 
7.0→Database Designer to start Avaya Database Designer, Click File→Open and open 
the file ccq.adl from the folder <AVAYA_IC70_HOME>\design\ CallCenterQ\ as shown 
below. Click Edit→IC Scripts.  
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Step Description 
3. Select the QConsole_CompleteContact script in the IC Script Editor. 

 

 
 

4. Scroll through this script and add the following entry under the QScript API 
Declarations section. 
 
 ‘*****Start SMSConnect***** 
 
 Declare Function SMSConnect_Survey(iApp As Application, sEDUId As String) 
 As Boolean 
 
 ‘*****End SMSConnect***** 
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Step Description 
5. Scroll the script further down and locate the following text: 

 
 QConsole_SetInteractionState sEDUId, STATE_TERMINATED 
 
Add the following entries just before this text: 
 
 ‘*****Start SMSConnect***** 
 
 Dim bSurveyResult As Boolean 
 
 bSurveyResult = SMSConnect_Survey(iApp, sEDUId) 
 
 ‘*****End SMSConnect***** 
 

6. Click File→Save to save the script and click Upload. Select defaultDBConnectionSet 
for DB Connection Set and specify an IC administrator login for Login Id and Password 
and click OK. This will upload the script to the database. 
 

 
 

7. In the IC Script Editor window, click File→View Script File to open file 
SMSConnect_Survey.qsc in the Edit mode. Click File→Save to save the script and click 
Upload. Select defaultDBConnectionSet for DB Connection Set and specify an IC 
administrator login for Login Id and Password and click OK. 
 

8. Repeat Step 7 to upload the SMSConnect_StopSurvey.qsc script file into the database. 
 

 

3.3.3. Configure IC Agent Layout Changes 
The OOTB agent layout file avaya_agent_en.cdl has been modified to place the button Stop 
Survey on the IC Agent console. When the agent clicks this button, the 
SMSConnect_StopSurvey script is called. 
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Step Description 
1. On the Avaya IC Administrator PC, open the file avaya_agent_en.cdl located in the 

<AVAYA_IC70_HOME>\design\QConsole\ folder using a text editor, e.g. Notepad. 
 

2. Locate the following entries related to the bottom frame: 
 
 <QFrame Name="Bottom_Frame" Height="150" Orientation="BOTTOM" 
 Visible="TRUE"> 
 
Navigate to the Contact Pane Definition, between the XML tags 
<QControlDictionary> </QControlDictionary>. 
 
Insert the following entries just above the definition for CHBrowser: 
 
 <QControl Name="btnStopSurvey" Label="Stop Survey" 
 ProgID="Avaya.AvayaButtonCtrl.61" Left="797" Top="10" Width="120" 
 Height="35" Visible="TRUE"> 
  <QScriptDictionary> 
   <QScript Event="Click" Name="SMSConnect_StopSurvey"/> 
  </QScriptDictionary> 
 </QControl> 

 
3. The avaya_agent_en.cdl file should look as follows after inserting the entries. Save this 

file and close the text editor. 
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Step Description 
4. Click Start→All Programs→Avaya Interaction Center 7.0→Database Designer to 

start Avaya Database Designer. Click File→Open and open the file ccq.adl from the 
folder <AVAYA_IC70_HOME>\design\ CallCenterQ\ as shown below. Click 
File→Generate Windows Application. 
 

 
 

5. Check Avaya Agent Layout and select the modified avaya_agent_en.cdl file. Specify an 
IC administrator login for Login Id and Password and click OK. This will upload the 
changes to the database. 
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3.3.4. Define IC Properties 
SMSConnect Feedback Manager uses 13 custom IC Properties in the IC Property Section 
System/SMSConnect. To create the new IC Property Section System/SMSConnect and the 13 
new IC Properties, refer to Chapter 8: Properties of reference [1] for detail instructions. The 
descriptions of the properties are shown in Table 2. 
 
Property Description Property 

Datatype 
Settings 

 
Applicable 
Property 

Levels 

Values 

action Action to be taken about the 
survey. 

string Allow typed-
in values 

IC (Root 
Node) 

sendsms 
saverecord 

activatesurvey Determines whether SMS survey 
has been activated. 

string A value is 
required 

IC (Root 
Node) 

yes 
no 

agenteligibility Determines whether SMS survey 
to be run for all agents, or for 
selective agents only. 

string A value is 
required 

IC (Root 
Node) 

all 
selective 

 
gatewayno SMS Gateway number for 

sending out SMS survey. 
string Allow typed-

in values 
IC (Root 

Node) 
NA 

host IP address of the SMSConnect 
server to connect. 

string Allow typed-
in values 

IC (Root 
Node) 

NA 

port Port number of the SMSConnect 
server to connect. 

string Allow typed-
in values 

IC (Root 
Node) 

NA 

runsmssurvey Determines if SMS survey is 
activated for the agent when 
agenteligibility is set to 
selective. 

string A value is 
required 

Individual 
Agents 

yes 
no 

 

smssurveyid SMS survey Template ID to use 
as defined in the Feedback 
Manager on SMSConnect 
server. 

string Allow typed-
in values 

IC (Root 
Node) 

NA 

surveychatchannel Determines whether SMS survey 
for chat channel is activated. 

string A value is 
required 

IC (Root 
Node) 

yes 
no 

 
surveyemailchannel Determines whether survey for 

email channel is activated. 
string A value is 

required 
IC (Root 

Node) 
yes 
no 

surveytimeinterval Sets the time interval in minutes 
where SMS survey will not be 
send to the same customer. 

string Allow typed-
in values 

IC (Root 
Node) 

NA 

surveyvoicechannel Determines whether survey for 
voice channel is activated. 

string A value is 
required 

IC (Root 
Node) 

yes 
no 

timebasedsurvey Determines whether time based 
survey is activated. 

string A value is 
required 

IC (Root 
Node) 

yes 
no 

 Table 2: IC Properties for SMSConnect Feedback Manager 
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The columns Property Datatype, Settings, Applicable Property Levels and Values correspond 
to the fields in the Property Declarations window as shown below. 
 

 
 
Figure 4 shows the values of the IC Properties used in this configuration. 
 

 
Figure 4: IC Properties for SMSConnect Feedback Manager 
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4. Configure InteractCRM SMSConnect 
This section describes the configuration of InteractCRM SMSConnect to interoperate with 
Avaya Interaction Center. 
 
Step Description 

1. On the SMSConnect server, start the web browser and browse to 
http://localhost:2020/SMSConnect. Enter the administrative login for SMSConnect and 
click Submit. 
 

 
 

2. The Administration page will be displayed. Expand Properties and click Connection to 
configure the connection to the GSM network to send out SMS messages. 
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Step Description 
3. In this configuration, a GSM/GPRS modem is used. The GSM/GPRS modem operates 

like a mobile phone subscriber. A GSM Subscriber Identity Module (SIM) card is inserted 
into the modem for it to register with the GSM network.  Enter the phone number of the 
SIM card for SIM Phone Number and COM1 for Communication Port where the GSM 
modem is installed. For Service Center No, enter the SMS Service Center Number 
provided by the mobile service provider. Click Start and then click Update to save the 
changes. 
 

 
 

4. SMSConnect polls the SMSConnect email account for new emails sent from Avaya 
Interaction Center, converts them back to SMS messages and sends them to the 
customers. From the Administration page, expand Interaction Manager and click Create 
Account. 
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Step Description 
5. In the Create New Account page, specify a name for Account Name and select 

SMSConnect A/C for Account Category. We need to specify the email account 
information for SMSConnect to log in to the Email server and retrieve the emails. In this 
configuration, the SMSConnect email account is smsuser@avaya.com. Enter POP3 for 
Account Type, the default POP3 port number of 110 for Port Number and enter the 
SMSConnect email account for Email Address. For Mail Server Address, enter the IP 
address of the Email server. Specify the login details for POP3 Username, POP3 
Password and POP3 Confirm Password. Click Save. 
 

 
 

6. Click Create Account again to create an outgoing SMTP account for SMSConnect to 
send emails to the IC Email Account. In this configuration, the IC email account is 
icuser@avaya.com. In the Create New Account page, specify a name for Account Name 
and select User A/C for Account Category. Enter SMTP for Account Type, the default 
SMTP port number of 25 for Port Number, the IC email account for Email Address and 
the IP address of the Email server for Mail Server Address. Click Save. 
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Step Description 
7. Click Create Association. In the A/C Association page, associate the incoming SMS 

messages from the GSM/GPRS modem with the two accounts created in Steps 5 and 6. 
Enter the SIM Phone Number defined in Step 3 for Enter DNIS. Select the account 
created in Step 6 for SMTP A/C and the account created in Step 5 for POP3 A/C. Click 
Save. 
 

 
 

8. Click List Association. Check on the association created in Step 7 and click Activate. 
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Step Description 
9. Expand Properties and click General. In the section Email Polling Properties, set the 

Data Items to be included in the Subject header of the email sent to Avaya Interaction 
Center. The Data Items must match the IC Properties param1, param2 and param3 in 
Section 3.2.4. In this configuration, select 3 for No of Data Items and enter - (dash) for 
Data Item Separator, 2 for No of Delimitors and Space for Last Separator. Select SMS 
for Data Item 1, gatewayno for Data Item 2 and mobileno for Data Item 3. Click OK. 
 

 
 

10. A Feedback Template has to be created in SMSConnect to correctly interpret survey 
requests from Interaction Center. Click on Feedback Manager, expand Feedback and 
click Create. Enter a name for Template Name such as Special Code Template. Accept 
the default value of 16 for Select Number of Parameters, and the default values for list 
of parameters. By default, Avaya IC is configured to sends 16 parameters to 
SMSConnect. Scroll to the bottom of the page and click Update. 
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Step Description 
11. Customize the SMS message to be sent to the customers to collect their feedback. In this 

configuration, two variables are used to personalize the message based on the Customer 
Name and Agent Name. The third variable is a Special Code assigned to this Feedback 
Template to distinguish it from other concurrent surveys running on SMSConnect. Click 
Update to complete the Feedback Template. 
 

 
 

12. To deploy the new Feedback Template, click Deploy. Check the new Feedback Template 
created in Step 10 and click Activate. 
 

 
 

5. Interoperability Compliance Testing 
The Interoperability Compliance Testing included feature testing. The feature testing focused on 
verifying the ability of InteractCRM SMSConnect to interoperate with Avaya Interaction Center.  

5.1. General Test Approach 
The feature test cases were performed manually. SMS messages were sent from 3 GSM mobile 
phones with SMS capability to SMSConnect via the GSM modem. The SMS messages were 
delivered to the agents in Avaya Interaction Center. The agents used Avaya IC Agent to read and 
reply the messages. Replies were verified to be received on the respective GSM mobile phones 
initiating the SMS messages. To test the Feedback feature, voice calls were made via incoming 
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trunks to the agents. When the calls ended, SMS messages were sent to the callers’ mobile 
phones as defined in the customer database to collect their feedback. The callers replied using 
SMS and the responses were verified to be received by SMSConnect. 

5.2. Test Results 
All test cases passed successfully.  InteractCRM SMSConnect successfully interoperates with 
Avaya Interaction Center. 

6. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of Avaya 
Interaction Center and InteractCRM SMSConnect. 

6.1. Verify Avaya Interaction Center 
Step Description 

1. When configuring the IC Email Accounts in Section 3.1, click Test below Outgoing 
Email (SMTP) field to verify that IC is able to send outgoing emails. 
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Step Description 
2. Check Send a test message using this account. Set the From field to the email address 

of the IC email account as shown in the Return address field in Step 3, and the To field 
to the SMSConnect email account configured in Section 4 Step 5. Click Test. 
 

 
 

3. Verify that the message *** SMTP test succeeded *** is displayed. 
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Step Description 
4. To verify that IC is able to log in to the POP3 email account to receive incoming emails, 

click Test below. 
 

 
 

5. Verify that the message *** POP3 test succeeded *** is displayed. 
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6.2. Verify InteractCRM SMSConnect 
 
Step Description 

1. When configuring the GSM modem connection, click Test Connection. Verify that the 
message box is displayed with the message GSM Modem Connection = OK. 
 

 
 

2. When configuring the SMSConnect A/C, click Test Connection to test the 
configuration. Verify that the message windows shows *** POP3 test succeeded ***. 
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Step Description 
3. When configuring the User A/C, click Test Connection to test the configuration. Verify 

that the message windows shows *** SMTP test succeeded ***. 
 

 
 

4. To verify SMS-based customer feedback, make a voice call to the agent. After the call, 
verify that an SMS message is received by the caller to request for feedback. Verify also 
that the caller’s feedback is received correctly by SMSConnect by clicking on Survey 
Report under the Reports tab. 
 

 
 

7. Support 
For technical support on InteractCRM SMSConnect, contact the InteractCRM Support Team at: 

• Phone:  +91 22 6695 9190 
• Fax:  +91 22 6602 1850 
• Email:  smscsupport@interactcrm.com 
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8. Conclusion 
These Application Notes describe the configuration steps required for InteractCRM SMSConnect 
1.0 to successfully interoperate with Avaya Interaction Center Release 7.0.  All feature 
functionality test cases were completed successfully. 

9. Additional References  
The following documents can be found at http://support.avaya.com: 
 

[1] Avaya Interaction Center Release 7.0 IC Administration Volume 2: Agents, Customers, 
& Queues, 07-300108, Issue 3, July 2005 

[2] Avaya Interaction Center Release 7.0 Installation and Configuration, 07-300100, Issue 3, 
July 2005 

 
The following documents are available in the InteractCRM SMSConnect installation CDROM: 
 

• SMSConnect Installation and Administration Guide, Version 1.0 
• SMSConnect Rule Design Guide, Version 1.0 
• IC Connector for Feedback Manager Configuration Guide, Version 1.0 
• IC Connector for Interaction Manager Configuration Guide, Version 1.0 
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