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Abstract 
 

  
These Application Notes describe the configuration steps required for the Oak Telecom 
aiOffice call management software to successfully interoperate with Avaya IP Office Delta 
Server.   
 
aiOffice is a call management and reporting software package designed to report on the phone 
activity of a business.  aiOffice works with the Station Message Detail Reporting (SMDR) 
records outputted by Avaya IP Office Delta Server. aiOffice collects, stores and processes 
these SMDR records to provide usage analysis, call costing and billing capabilities. During 
compliance testing, aiOffice was shown to successfully collect and process SMDR records for 
all call scenarios tested, including outbound trunk calls, inbound trunk calls and intra-switch 
calls. 
 
Information in these Application Notes has been obtained through interoperability compliance 
testing and additional technical discussions. Testing was conducted via the 
DeveloperConnection Program at the Avaya Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes describe the configuration steps required for the aiOffice 1.3.13 call 
management software to successfully interoperate with Avaya IP Office Delta Server 5.0.   
 
The IP Office Delta Server is Windows PC application designed to receive call handling and call 
event information from IP Office. Station Messaging Detail Reporting (SMDR) records are 
detailed call records output by the IP Office to the Delta Server each time a call is finished, 
transferred, etc. The Delta Server can then store and share that information with other 
applications. The Avaya IP Office Delta Server can be configured to send the SMDR records it 
receives from the Avaya IP Office to a number of destinations via an SMDR log file, using IP 
polling or sending to a specified IP address and port.  The required destination depends on which 
methods of data transfer are supported by the third-party call accounting application being used. 
For this solution, the Delta Server is configured to write SMDR records to an SMDR log file. 
One Delta Server is supported for each IP Office. aiOffice collects, stores and processes these 
SMDR records to provide usage analysis, call costing and billing capabilities.  
 
aiOffice is comprised of AIOSetup, AIOffice, AIOCommsServer, AIOConvert, OakWeb and 
ActiveReports. AIOSetup is used to configure the connection to the Avaya IP Office. 
AIOCommsServer is responsible for collecting SMDR with this information being processed 
by AIOConvert for later retrieval. Historical reports can then be run from the Win32 client 
application AIOffice which is also responsible for report scheduling. ActiveReports presents 
live information enabling live trend analysis. Finally OakWeb combines the features of 
AIOSetup and AIOffice into a web environment which clients can access through browsers. 
  

 
 

Figure 1: Avaya IP Office and aiOffice Compliance Test Configuration 
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2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided. 

Equipment Software 
Avaya IP 403 Office System 3.1(45) 
Avaya IP Office Manager software 5.1(45) 
Avaya 4620 IP Telephones 2.3 
Avaya 2420 Digital Telephones - 
Avaya IP Office Delta Server 5.0.21 
Oak aiOffice 1.3.13 

 

3. Configure Avaya IP Office 
No additional configuration is required. 
 



4. Configure Avaya IP Office Delta Server 
The configuration information provided in this section describes the steps required to set up 
Avaya IP Office Delta Server to generate SMDR records to an SMDR log file and also to a 
specified IP address and port. 
 
For all other provisioning, such as Avaya IP Office Delta Server installation, refer to the Avaya 
IP Office Delta Server product documentation reference in section 10. 
 
Step Description 

1.  Navigate to Start → Programs → Administrative Tools → Services on the Avaya IP Office 
Delta Server PC.   

2.  In the Services window that appears, verify CCC Delta Server is started.  If it is not, then 
start it manually. 
NOTE:  Following initial installation, the CCC Delta Server service is not started until either 
the PC is restarted or the service is started manually. 
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3.  Navigate to Start → Programs → CCC → Delta Server to launch the Delta Server. The Delta 
Server webpage address is http://localhost:8080. Click Comms in the left panel.  
 

 
 

4.  Click on Comms in the left panel. In the Connection Information page, select the required IP 
Office system from the Connection drop-down.  If the required IP Office system is not listed, 
enter its IP address in the Search field and click Search. Once the correct system is selected, 
click apply.  Ensure that Comms Status changes to Comms Restored.  This may take a few 
minutes.  Once this connection is established with the IP Office, the Delta Server will 
generate SMDR records for all calls that occur on the IP Office. 
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http://localhost:8080/


5.  Click on Event Viewer Selector in the left panel to enable logging of SMDR events by 
checking the SMDR checkbox and then click apply. 
 

 
 

6.  Verify the Delta Server properly logs SMDR records by placing inbound and outbound calls 
on the Avaya IP Office.  Then click Recent SMDR Entries and confirm the call activity is 
properly reflected. 
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7.  Click SMDR in the left panel.  In the SMDR page, check SMDR Log File Enabled and set 
the SMDR File name to the absolute path name of the file. The Delta Server will log the 
SMDR records to (default: c:\Program Files\Avaya\IP Office\CCC\ DeltaServer\ 
SMDR_Output\SMDR.csv). This will match the location entered in Section 5 Step 7. Click 
apply. 
 

 
 
 

 
HJP; Reviewed: 
SPOC 3/17/2006 

Solution & Interoperability Test Lab Application Notes 
©2006 Avaya Inc. All Rights Reserved. 

7 of 18 
OAKAIOffice_IPO.doc 

 



5. Configure aiOffice 
This section describes the steps required to set up aiOffice to read and import SMDR records 
generated to a file by the Avaya IP Office Delta Server. 
 
For all other provisioning information, such as aiOffice software installation, see the Oak 
aiOffice product documentation referenced in Section 10. 

5.1. aiOffice Configuration 
 
Step Description 

1.  On the aiOffice PC navigate to Start Æ Programs Æ Oak Telecom Æ AI Office Æ AI 
Office Setup. Select “Supervisor” for the User Name and enter the appropriate password. 
Click OK. 
 

 
 

2.  From the Standard Settings section in the left pane, select Telephone System to display 
the sites configured. All default installations will be provided with a default site for 
configuration. If a site name was added during installation, it will be viewable in the right 
pane. In this case, “Avaya” was entered as the site name. Select the site and click the Edit 
button. 
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3.  The Telephone System tab is pre-populated with information of the site details entered 
during the aiOffice installation. 
 

 
 

4.  Select the Data Collection tab. The Working Directory will be the folder to which all 
collected and processed SMDR information will be stored. Pressing the three dots at the 
end of the entry box will present a folder selection dialog box where this location can be 
set. In a Client/Server environment a Uniform Naming Convention (UNC) path should be 
used so that data is visible to other network clients. To set the Collector field, click the 
Select button.  
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5.  Pressing the Select button launches a selection dialog displaying the available Collector 
types. Double click on the collector named IP Office.  

 

 
 

6.  To set the Settings click on the Configure button.  
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7.  The SMDR CSV Filename entry box should contain the location of the csv file that the 
Avaya Delta Server outputs. It will have a default location that matches the default 
location of the Avaya IP Office Delta Server output in Section 4 Step 8. If the Avaya 
Delta Server csv output file was modified then this entry box must match it. 
 

 
 
 

8.  Select the Translation tab. Select “AVAYA” from the Manufacturer drop-down 
followed by “IP OFFICE” from the Device drop-down followed by Avaya IP OFFICE 
ENHANCED from the Translator (VCE) drop-down. Click OK to return to the Main AI 
Office Setup. 
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9.  From the main AI Office Setup window, select the File menu from the task bar and select 
the Save Changes option as shown below. 
 

 
 

10.  To launch the AI Commserver to start collecting the SMDR records select Start Æ 
Programs Æ Oak Telecom Æ AI Office Æ AI Office Commserver. To verify data 
collection is taking place, right click on the collector and select Intercept Collector. Any 
SMDR being collected will be shown in the bottom left pane. 
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11.  A green ‘play’ icon and a Status change to Started will be shown as below to indicate that 
the application is connected and collection has started.  
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5.2. Generating aiOffice Reports 
 
Step Description 
1.  Navigate to Start Æ Programs Æ Oak Telecom Æ AI Office Æ AI Office Reports. From 

the taskbar, select the File menu Æ Convert. 
 

 
 

2.  A dialog box will appear. Select continue to process the new SMDR records collected. 
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3.  Select the Traffic Reports section from the left pane, then click the Itemised By Time 
report within that section. This report shows details of each call. The report does not 
include tandem and internal calls as standard. To enable tandem and internal calls, click 
the Criteria button then select the Custom tab in the Custom selection section. Enter 
“int(o,r)” to include internal calls and “tan(o)” to include tandem calls in the Custom 
Criteria field. Click Save Criteria. Now click the Run Report button. 
 

 
 

4.  An example of a Traffic Itemised By Time report is shown below. 
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6. Interoperability Compliance Testing 
The interoperability compliance testing included feature and performance testing.  The feature 
testing evaluated the ability of aiOffice to collect and process SMDR records for various types of 
calls. The performance testing involved generating bulk calls for a two hour period to generate 
around 20,000 SMDR records.  

6.1. General Test Approach 
The general test approach was to manually place intra-switch calls, inbound trunk and outbound 
trunk calls to and from telephones attached to the Avaya IP Office and verify the aiOffice 
collects the SMDR records and properly classifies and reports the attributes of the call.  For 
performance testing, a call generator was used to place calls over a two hour period of time. 

6.2. Test Results 
All test cases passed.  aiOffice successfully collected the SMDR records from the Avaya IP 
Office Delta Server CDR file for all types of calls including intra-switch calls, inbound/outbound 
PSTN trunk calls, inbound/outbound private IP trunk calls, transferred calls and conference calls.   
Performance testing verified that aiOffice collected call records during a sustained high volume 
of calls for over two hours. 
 
aiOffice reports all calls, including conference and transfer, as one of the following types: 
internal, inbound or outbound.   In other words, aiOffice does not report calls as being part of a 
conference or transfer.  Users wishing to know if a transfer or conference call occurred must 
manually verify this information. 

7. Verification Steps 
The following steps may be used to verify the configuration: 
 

• Use the ping command to verify IP communication between the aiOffice PC, the Avaya 
IP Office Delta Server PC, and the Avaya IP403 Office. 

• Verify the Avaya IP Office Delta Server is connected to the Avaya IP Office (Section 4, 
step 4). 

• Place an inbound or outbound call.  After completing the call, verify the SMDR record 
for the call appears in the SMDR Diagnostics page on the Delta Server (Section 4, step 
6). 

• Verify aiOffice Commserver connection to Avaya IP Office Delta Server (Section 5.1, 
step 10 - 11) 

• Verify information appears correctly in a report (Section 5.2). 



 
HJP; Reviewed: 
SPOC 3/17/2006 

Solution & Interoperability Test Lab Application Notes 
©2006 Avaya Inc. All Rights Reserved. 

17 of 18 
OAKAIOffice_IPO.doc 

 

8. Support 
Technical support for aiOffice can be obtained by contacting OAK Telecom. at: 

• Phone: 0870 2000 247 
• E-mail: support@oak.co.uk 
• Web: www.oak.co.uk 

 

9. Conclusion 
These Application Notes describe the procedures required for configuring aiOffice to collect 
SMDR records from Avaya IP Office Delta Server SMDR log files. aiOffice was successfully 
compliance tested with an Avaya IP403 Office and Avaya IP Office Delta Server. 
 

10. Additional References  
This section references the Avaya and Oak Telecom product documentation that are relevant to 
these Application Notes. 
 
Avaya product documentation can be found at http://support.avaya.com. 
� Avaya IP Office 3.1 Installation Manual, Issue 13j (Dec 2005) 
� Avaya IP Office  3.1 Manager Manual, Issue 17d (Sept 2005) 

 
 
Visit the website www.oak.co.uk for on Oak Telecom and aiOffice information.  

mailto:support@oak.co.uk
http://www.oak.co.uk/
http://support.avaya.com/
http://www.oak.co.uk/
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©2006 Avaya Inc. All Rights Reserved. 
Avaya and the Avaya Logo are trademarks of Avaya Inc.  All trademarks identified by ® and ™ 
are registered trademarks or trademarks, respectively, of Avaya Inc.  All other trademarks are the 
property of their respective owners.  The information provided in these Application Notes is 
subject to change without notice.  The configurations, technical data, and recommendations 
provided in these Application Notes are believed to be accurate and dependable, but are 
presented without express or implied warranty.  Users are responsible for their application of any 
products specified in these Application Notes. 
 
Please e-mail any questions or comments pertaining to these Application Notes along with the 
full title name and filename, located in the lower right corner, directly to the Avaya 
DeveloperConnection Program at devconnect@avaya.com. 
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