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Abstract 
 

  
These Application Notes describe the configuration steps required for Nuance OpenSpeech 
Attendant to successfully interoperate with Avaya Interactive Response. Nuance OpenSpeech 
Attendant allows callers to speak the name of a person, department, service, or location and be 
automatically transferred to the requested party. OpenSpeech Attendant can route callers 
through menu-driven options and provide frequently requested information such as operating 
hours, mailing address, and driving directions. Information in these Application Notes has 
been obtained through compliance testing and additional technical discussions. Testing was 
conducted via the DeveloperConnection Program at the Avaya Solution and Interoperability 
Test Lab. 
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1. Introduction 
These Application Notes describe the configuration for the compliance test between Avaya 
Interactive Response and Nuance OpenSpeech Attendant (OSA). 
 
Figure 1 provides an overview of the OpenSpeech Attendant solution consisting of Avaya 
Interactive Response, Avaya Communication Manager, Nuance speech recognizer and Nuance 
OpenSpeech Attendant.  The OSA runs on a dedicated application server, running Windows 
2003 Server. The Avaya Interactive Response system interfaced to Avaya Communication 
Manager using T1-PRI QSIG. Avaya Interactive Response system also manages the interactions 
with the speech and text recognizer’s resources used by the VXML applications. VXML pages 
generated by the OSA system are loaded and interpreted by Avaya Interactive Response system, 
which in turn controls the interaction with the user.   In order to access the VXML applications 
which reside in the OSA server, a voice channel in the IR must configure to invoke the VXML 
application using HTTP request when an incoming call terminates at that channel.  



 
Figure 1: Compliance Test Configuration 

 
 

2. Equipment and Software Validated 
The following equipment and software/firmware were used for the test configuration provided. 
 

 
KB; Reviewed: 
SPOC 7/28/2006 

Solution & Interoperability Test Lab Application Notes 
©2006 Avaya Inc. All Rights Reserved. 

3 of 16 
nuance-app.doc 

 

Equipment Software/Firmware 
Avaya S8700 Media Server with G650 Media Gateway Avaya Communication Manager 

3.0.1 (R013x.00.1.346.0) 
Avaya Interactive Response  1.3 
Avaya 4620 IP Phone Release 2.3 
Avaya 4624 IP Phone Release 2.3 
Avaya Interactive Response Packages 
 

AVvoicxml2-0 
AVxfer 
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Equipment Software/Firmware 
AVosr204 
AVsproxy 
AVsrproxy 
AVttsprxy 

Avaya Interactive Response Patches tsm13001 
nms13005 
ir13005 
xfer13002 
o2041300 
vxml2013007 
sc13002 
wadm13001 

Nuance OpenSpeech Attendant  2.1 
Nuance OpenSpeech Recognizer 3.0.4 
Nuance Speechify 3.0.4 

3. Configuring the Avaya Interactive Response 
The following steps show how to configure Avaya Interactive Response to invoke the Nuance 
VoiceXML application.  These Application Notes do not explain how to configure the T1 PRI-
QSIG integration between Avaya Interactive Response and Avaya Communication Manager.  
The configuration for the Scansoft OpenSpeech Recognizer is not included in this Application 
Notes. 
 

Step Description 
1.  Log in to the Avaya Interactive Response web console. 
2.  Click on the Channel Services under the Voice Equipment group. 

 

 
 

3.  Click on the Assign Selected button. 
 



 
 

4.  Select VXML URI for Assign.  Enter the URI of the Nuance OpenSpeech Attendant 
voice application.  An example of the Nuance OpenSpeech Attendant is 
http://192.45.121.200:8080/OpenSpeech/Attendant/servlet/aa .  Enter the range of 
channels assigned to use this voice application.  Click Submit. 
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http://192.45.121.200:8080/OpenSpeech/Attendant/servlet/aa


 
 

Step Description 
5.  The channel service page should display all the channels associated with the Nuance 

voice application. The screen capture below displays a partial view of all the channel 
services. 
 

 
 

4. Configure Nuance OpenSpeech Attendant 
The OpenSpeech Attendant is a turnkey solution that comprises the OpenSpeech Attendant 
application software pre-installed on a server running Windows Server 2003. This section 
describes how to configure the OpenSpeech Attendant application. 
 

Step Description 
1.  Log in to the auto-attendant computer with the appropriate credentials. If you do not see 

the Admin Tools window on the desktop, double-click on the OSA shortcut. The Admin 
Tools window appears on the desktop as shown below. 
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4.1. Accessing the configuration panel 
There are two access levels to the configuration panel: 
- Level 2, which provides access to all settings, including the gateway dependant options, 
- Level 1, which provides access only to the customer-related settings. 
 
The following steps modify the Nuance OpenSpeech Attendant settings. 
 

Step Description 
1.  In the Admin Tools window, click Configuration Panel. 
2.  When prompted, select Level 2 and enter the appropriate password. 

Note: Nuance’s distributor provides the password. 
 

 
 

3.  In the left pane of the configuration window, select the setting to change.  In the right 
pane of the window, specify the new value. 
 
For the Avaya Interactive Response, the option Gateway Transfer Mode Supervised 
needs to be set to NO.  If the phone number of the live operator is different than 0, 
change the Operator Extension Number to the phone number of the live operator.  In 
the left pane of the window, a red checkmark appears next to the setting name, 
highlighting the change.  Click Apply. The checkmark turns into a green bullet. 
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4.  Close the Configuration window when complete. 

4.2. Editing Transfer Entries 
Most of the entries created in the application are transfer entries. Transfer entries must be created 
for each employee or service to which the auto-attendant application can transfer calls. A single 
transfer entry can contain several different phone numbers, such as: office, cell phone and pager. 
The following steps create entries to transfer a caller to a selected destination. 
 

Step Description 
1.  Choose File > New >Transfer Entry. The Creating transfer entry window appears.  

Add the first and last names of the employee, for example John Smith. For a service 
such as Customer Support, enter an alias. Spell names correctly to allow the system to 
recognize caller requests. Do not enter titles such as Mr., Mrs. or Doctor in the First 
names field.  Multiple names can be entered in the First Name field for nicknames, or 
shortened forms of names The First, Middle and Last names, along with the Alias 
field, are used to generate the text-to-speech (TTS) voice file played to confirm caller 
requests and to announce transfers, until it is replaced by a recording.  Check Can 
access personal functions to allow an employee or a service to access personal 
administration mode (PAM). Access to PAM allows employees and services to record 
their own names and change their personal identification numbers (PINs), passwords, 
and access codes.  Enter the numbers where the employee or service can be reached. 
Additional destination can be specified for each employee or service. 
 

 
 

2.  To create another transfer entry, click Apply, then New and repeat step 1. 
3.  Click OK when complete. 
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4.3. Activating Changes 
The following steps apply the changes to the directory.  Activate the changes at the end of every 
Phone Directory and Menu Editor session. Otherwise, new or updated directory entries are not 
available to the callers. 
 

Step Description 
1.  In the Menu Editor toolbar, click [ac] (for Activate changes). 

 
 

2.  Click OK to acknowledge the progress message. 
 

 
 

3.  The system now generates updated grammars with the new name(s). 
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4.4. Testing Speech Recognitions and Transfers 
The following steps test the speech recognitions and transfer. 
 

Step Description 
1.  Dial the pilot number that accesses the OpenSpeech Attendant VXML application.   
2.  Ask for the new entry just created, e.g.: John Smith. 
3.  Validate that system now recognizes the entry. 
4.  Validate that system plays the TTS-generated voice name file 
5.  Validate that the system transfers the call to the phone number of the new entry. 

 

4.5. Recording Names by Telephone 
With the name recorder, people can individually record their names for their own extension. 
These recordings are used to confirm caller requests or to announce transfers. The following 
steps explain how employees can record their own names.  
 

Step Description 
1.  Dial the pilot number that accesses the OpenSpeech Attendant VXML application.   
2.  Press *99 to access the personal administration mode (PAM). 
3.  Identify employee by saying the employee name. 
4.  Enter employee PIN (provided by the system administrator, default is 0000) and press #. 
5.  Once in the PAM, follow the instructions and say “name recording”. 
6.  Record employee name. 
7.  Hang up when recording is completed. 
8.  Call the OpenSpeech Attendant and ask for the just recorded name. 
9.  Validate that as system transfers the call, confirmation of name is done with the new 

name recording. 
 



 

4.6. Dynamic Call Routing 
Dynamic call routing enable the OpenSpeech Attendant to route the caller to a specified 
directory menu based on the DNIS and CLID information provided by the PBX.  The following 
steps explain how to create a directory menu with the DNIS number. 
 

Step Description 
1.  Choose File > New >Top Level Menu. The Creating Menu entry window appears. 

 

 
 

2.  Enter the name of the menu, e.g. D.N.I.S Test in the Aliases field. 
3.  Click OK when complete. 
4.  In the Menu Editor toolbar, click [ac] (for Activate changes). 
5.  Click OK to acknowledge the progress message. 
6.  The system now generates updated grammars with the new name(s). 
7.  When the system has completed updating the grammars, exit the Menu Editor. 
8.  In the Admin Tools window, click Phone Directory and Menu Editor. The Menu 

Editor window appears. 
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Step Description 

9.  Choose Edit -> Ports and Entry Points. The Ports and Entry Points entry window 
appears. 
 

 
 

10.  In the Port assignment pane (right), select the first port group. 
11.  Choose Add -> Entry Point.  
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Step Description 

12.  In the Ports and Entry Points screen, enter a description and choose the newly created 
menu, for example, D.N.I.S test from the Home menu and Main menu drop down 
fields. In the DNIS field, enter the number of a second DNIS used to reach the 
OpenSpeech Attendant. 
 

 
 

13.  Click OK. 
14.  Call the OpenSpeech Attendant application. The application should answer directly in 

the menu identified to the DNIS. 
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5. Interoperability Compliance Testing 
The interoperability compliance test included feature functionality and serviceability testing. 
Feature functionality testing focused on verifying that the Nuance OpenSpeech Attendant 
solution successfully supports Avaya Interactive Response. Serviceability testing verified that 
the Nuance PC recovered from adverse conditions, such as rebooting the PC and removing the 
PC network connection. 

5.1. General Test Approach 
The general test approach was to verify that the Nuance OpenSpeech Attendant operates 
successfully with the Avaya Interactive Response to provide directory name recognition, to 
handle calls transfers and the to return the system to normal operation when the network 
connection is interrupted. 

5.2. Test Results 
All feature functionality and serviceability test cases passed. Nuance OpenSpeech Attendant 
solution successfully supports the Avaya Interactive Response platform. For serviceability 
testing, calls did not get answered when the OSA system was disconnected from the network, 
however, operations returned to normal when network was brought back in service. 

6. Verification Steps 
The following steps may be used to verify the configuration: 
 

Step Description 
1.  Restart the OSA application server. 
2.  Log into Windows and start the Admin tools. 
3.  Choose Monitor. Select yes if prompted to close the window. 
4.  Call the IR pilot number.  The IR pilot number is the number in the PBX assigned to 

each channel service. 
5.  Verify that one channel is blinking in the OSA call monitor. 

 

 
 

6.  Ask the name of a person which is in the directory. Verify that the name is recognized 
and the call transferred to the correct extension. 

7.  Call the OpenSpeech Attendant number.  
8.  Dial the DTMF “0” and verify that the call is transferred to the number of the operator 
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that has been configured in the system. 

 

7. Support 
Technical support for Nuance OpenSpeech Attendant can be obtained by calling the Customer 
Service Center.  By phone: 

• From Montreal: (514) 390-3922 
• Elsewhere in Canada or the United States: 1 866 434-2564 
• Outside Canada or the United States: 1 (514) 390-3922 
• By fax: 1 (514) 954-1588 
• By email: SpeechAttendant.Support@nuance.com 

 

8. Conclusion 
These Application Notes describe the required configuration steps for Nuance OpenSpeech 
Attendant and Avaya Interactive Response solution. The compliance test verified the features 
and service functionalities of Nuance solution have all passed. 

9.  Additional References  
 
Nuance product documentation is installed with all versions of the product.  Visit 
http://www.nuance.com/autoattendant/openspeech/ for more information. 
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property of their respective owners.  The information provided in these Application Notes is 
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