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Abstract 
 

  
These Application Notes describe the configuration steps required for Resource Software 
International Shadow Call Management Software (CMS) to work with Avaya IP Office.  
Shadow CMS is a flexible, feature rich application that captures Simple Message Detail 
Records (SMDR) / Call Detail Records (CDR) from the Avaya IP Office. Call activity can be 
reported by extension, trunk, account code, and authorization code. 
 
Information in these Application Notes has been obtained through DevConnect compliance 
testing and additional technical discussions.  Testing was conducted via the DevConnect 
Program at the Avaya Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes describe the configuration steps required for Revolution Software 
International (RSI) Shadow Communication Management Software (CMS) to work with Avaya 
IP Office.  Shadow CMS is a comprehensive call accounting solution providing flexible and 
accurate call pricing. This call accounting product is distributed under the brand name Shadow 
CMS within the United States and TeleCOST outside of the United States.  This software can 
price calls using most commercially available carrier rate plans subscribed to by customers.  The 
easy to use Report Generator provides users with access to both detail and summary reports.  
This comprehensive product is multi-site ready.  It can support up to 10,000 unique locations 
each with up to 10,000 extensions.  The software can price calls using up to five different 
carriers or rate plans.  A built-in Job Scheduler permits automatic, unattended generation of 
reports at scheduled intervals (i.e., daily, weekly, monthly, etc.).  Most environments can install 
this application on an existing non-dedicated computer.  
 
Shadow CMS is a flexible, feature rich application that listens for CDR/SMDR records from the 
Avaya IP Office.  The Shadow CMS winlink data collection module is used to listen for 
CDR/SMDR information from Avaya IP Office.  This module is normally installed on the same 
computer as the Shadow CMS Administration/Reporting module.  It can, however, be deployed 
on a different computer.  Call activity can be reported by extension, trunk, account code, and 
authorization code. 
 
The configuration in Figure 1 shows a network consisting of an Avaya IP412 Office, Avaya 
IP406 Office V2, Avaya IP Office Manager/Voicemail Pro Personal Computer (PC), Shadow 
CMS, and Avaya 4600 series IP Telephones connected to an Avaya C364T-PWR Converged 
Stackable Switch. The Avaya IP412 Office has PRI and Analog trunks to the central office.  The 
Avaya IP406 Office V2 can also access the central office facilities over the Small Community 
Network (SCN) network, but first must pass through the Avaya IP412 Office system.  
Consequently, a CDR record of this transaction is created and processed. 
 
The Avaya IP412 Office has T1, PRI and Analog trunks to the central office.  The Avaya IP412 
Office is configured to generate CDR data for all inbound, outbound, and internal calls, and for 
calls made to and from other Avaya IP Office systems over SCN.  The Avaya IP412 Office is 
configured to send the CDR records to a user configured IP address and port.  The Shadow CMS 
winlink module is configured to listen on the port configured on the Avaya IP412 Office for 
CDR data.  Once winlink receives the raw CDR data from the IP Office, Shadow CMS translates 
the CDR record then stores it into its database for later record retrieval and/or reporting by the 
end user. 
  
 



 
Figure 1 – Network Configuration Diagram 
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2. Equipment and Software Validated 
The following products and software were used for the configuration in Figure 1: 
 

Product Software/Version 
Avaya IP412 Office 4.0.10 
Avaya IP406 Office V2 4.0.10 
Avaya IP400 Digital Station Module 6.0.10 
Avaya IP Office Manager 6.0.10 
Avaya Voicemail Pro 4.0.23 
Avaya 4620SW IP Telephones 2.3 
Avaya 5620SW IP Telephones 2.3 
Avaya 2420 Digital Telephones 5.0 
Avaya 5420 Digital Telephones 5.0 
Avaya C363T-PWR Converged Stackable Switch 4.3.12 
Revolution Software International Shadow Call 
Management System 

4.1.0.366 

PCs for Avaya IP Office Manager, Avaya Voicemail 
Pro and RSI Shadow CMS 

Windows XP Professional 
Service Pack 2 

 
Table 1 – Product and Software Version  

3. Configure Avaya IP412 Office 
The configuration information provided in this section describes the steps required to set up 
Avaya IP412 Office to generate CDR data to a user-defined destination IP address and port. 
 
Note:  Steps 4, 5 and 7 are also performed on the Avaya IP406 Office V2. 
 
For all other provisioning information, such as Avaya IP Office installation and configuration, 
etc., please refer to the Avaya IP Office product documentation in reference [1]. 
 

1. From the Avaya IP Office Manager PC, go to Start → Programs → IP Office → 
Manager to launch the Manager Application and log into the Manager application using 
the appropriate credentials. 

 
2. On the Manager window that is displayed, select File → Open to search for the IP Office 

system in the network. 
 

3. Log into the appropriate IP Office system using the appropriate login credentials to 
receive its configuration. 

 



4. In the Avaya IP Office Manager window, go to the configuration tree in the left-hand 
panel and right-click Line and select New → IP Line (not shown).  The screen below 
should display. 

 
In this case, the system automatically assigns 15 as the Line Number (and will vary).  
Place the value 15 in the Incoming Group ID and Outgoing Group ID.  Click the VoIP 
Settings tab. 
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5. Set the Gateway IP Address to the IP address of the other Avaya IP Office System.  See 
Figure 1. Check Voice Networking.  The Voice Networking parameter turns on SCN 
capabilities.  Click OK. 

 
Note:  The IP address will be different when administering the other Avaya IP Office 
system. 
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6. On the Avaya IP Office Manager window, double-click on System from the right panel 
configuration tree.  On the right panel, select the CDR tab.  In the CDR window set the 
following; Enable CDRs is checked,  Enable intra-switch CDRs is checked, Record 
Format select Expanded, Record Options select Normal, Date Format select 
Month\Day, IP Address to 192.45.210.24 the IP address of the Shadow CMS PC, and 
IP Port to 9003 the port that Shadow CMS will listen on.   Click OK. 

 

 
 

7. In the Avaya IP Office Manager, select File → Save to push the configuration to the IP 
Office system and wait for the system to update.  This completes configuration of Avaya 
IP Office CDR 

 
8. Log into the Avaya IP406 Office V2 system and perform Steps 4, 5 and 7.  Note the IP 

address is different. 
 

9. This completes configuration of Avaya IP Office CDR. 
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4. Configure Revolution Software International Shadow 
Communication Management System 

For all other provisioning information, such as software installation, installation of optional 
components, configuration of Shadow CMS for call accounting, report generation, etc., please 
refer to the RSI Shadow CMS product documentation in references [2] and [3]. 

4.1. Create the Shadow Communication Management System 
Configuration 

The configuration information provided in this section describes the steps required to configure 
Shadow CMS to listen for CDR records from Avaya IP Office. 
 
The information provided in this section assumes the Shadow CMS has already been 
successfully installed and licensed on the PC. 
 

1. Log into the Shadow CMS PC with the appropriate administrative credentials and 
navigate to Start → Programs → RSI → CMS → Configuration Wizard. 

 
2. On the RSI Call Accounting Configuration Creator window that is displayed, click 

Next > to step through the configuration screens. 
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3. On the Configuration Creator - Customer Information window, fill in the required 
information then click Next >. 
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4. On the Configuration Creator - PBX/Key System Definition window, from the pull-
down menu, select and set Telephone System to G3EXPAND AVAYA DEFINITY 
(Expanded Format), check Telephone System Supports Calling Line Identification 
(CLID), and select and set Collect Call Records Using to Text File.  Click Next >. 
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5. The next several screens (not shown) deal with Directory Assistance, Cost Allocation, 
Taxes, Carrier Information, Comparisons, and Discounts.  Continue to click on the 
Next > button and modify the defaults as needed for a local configuration until the 
Configuration Creator - Setup Completed window is displayed.   Click Finish. 

 

 
 

6. On the Save Configuration File popup that is displayed, select an Entity Number and 
click the Ok button.  The Entity Number selected is required in Section 4.2, Step 2.   

 

 
 

7. The Configuration Wizard will close after the Ok button is pressed. 
 
8. This completes the configuration of Shadow CMS. 
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4.2. Configure CMS Application 
 

1. Launch Shadow CMS by clicking Start → All Programs → RSI → CMS → CMS and 
click the Entity icon 
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2. Select the Entity number created in Section 4.1, Step 6.  Click OK. 
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3. On the SHADOW Voice and Data Management [cms] window, click the Properties 
icon.   Select the Data tab then select the CDR tab.  Select and set Source Input Mode: to 
Winlink IP & Serial Data Storage, select and set Driver Name to G3EXPAND AVAYA 
DEFINITY (Expanded Format).  Click Configure. 
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4. When the Configure button is pressed from the previous properties screen, the winlink 
window should be displayed as below.   Select Configure → Data Source. 

 

 
 

5. On the Data Source popup that is displayed, set Select the Winlink data source: to 
Socket Listener.  Click OK. 

 

 
 

6. On the Warning popup that is displayed, click OK. 
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7. After the application restarts, the Properties window in Step 3 should be displayed. Click 
Configure again to return to the winlink window as in Step 4.   On the winlink window, 
select Configure → Telnet or Socket Settings… from the pull-down menu. 

 

 
 

8. On the IP Configuration window that is displayed, set Name (or IP address) to the IP 
address of the Shadow CMS PC, and Port to the port number configured on the Avaya 
IP412 Office CDR configuration in Section 3, Step 6.  Set Protocol to TCP.   Click OK. 

 

 
 

9. On the winlink window, select Configure → Listen from the pull-down menu to put 
winlink into listen mode (see Step 7).  This completes configuration of Shadow CMS 
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5. Interoperability Compliance Testing 
Interoperability compliance testing evaluated the ability of Shadow CMS to collect and process 
CDR records for various types of calls (inbound, outbound, internal, transfer, conference, etc.).  

5.1. General Test Approach 
The general test approach was to enable Shadow CMS to collect CDR records by or and: 

• Manually place calls:  
1. Between Avaya IP Office extensions.  
2. Inbound and outbound trunk over PRI and Analog trunks. 
3. To and from telephones attached to a remote Avaya IP Office over SCN trunks. 

• Verify that Shadow CMS properly classified the CDR records.  
• Verify that Shadow CMS properly displayed the CDR records in a formatted report.  
Ensure Verify that Shadow CMS properly resumed operation after serviceability testing was 
performed by resetting the Avaya IP412 Office, removing the network connection on Avaya 
IP412 Office, removing the network connection on Shadow CMS PC, and power down/up 
the Shadow CMS PC.   

5.2. Test Results 
All feature and performance test cases that were executed passed. Shadow CMS successfully 
captured and processed call records from Avaya IP Office.  For serviceability testing, Shadow 
CMS was able to resume CDR record collection for outages where Avaya IP Office was reset or 
lost its network link without requiring manual intervention.   In cases where the Shadow CMS 
computer lost power or its network link, Shadow CMS was able to successfully resume 
collecting CDR records once it was back online but not for CDR records for calls that were 
placed during the outage.  Since the current IP Office CDR implementation does not support 
Reliable Session Protocol, there is a chance of CDR record loss if there is a network failure.   
 
The following observations were made during testing: 

 
• CDR records for blind verses supervised transfers are not handled the same by IP Office.  

IP Office blind transfer call splitting behaves correctly.  Hold time for a supervised 
transfer is not factored on the CDR record. 

 
• In a conference scenario where an external call is made to extension 65263 and this 

extension conferences extension 45207 across a SCN trunk, the extension identification 
data is not correct on the CDR record. 

 
• IP Office CDR does not provide DNIS information in CDR records generated. 

6. Verification Steps 
The following steps may be used to verify the configuration: 
 



1. Place a telephone call to the Avaya IP Office, answer the call, and drop the call after a few 
seconds. 

 
2. The raw CDR data such as the one displayed below will appear in the winlink window after 

the call is dropped. 
 

 
 

3. In the SHADOW Voice and Data Management [cms] window, click File → Translate in 
the pull-down menu to manually translate the CDR record. 

 

 
 

4. In the Translate Data window that is displayed, click OK.  Note: Shadow CMS can be 
configured to automatically translate CDR data at user-defined time intervals.  Please refer 
to the Shadow CMS documentation for information on how this is accomplished. 
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5. On the left hand SHADOW Voice and Data Management [cms] navigation panel, click 
Database → Calls Database to view the incoming call parsed by Shadow CMS.  The 
itemized data records are formatted in label-headed columns with various aspects of the 
CDR data within the Calls Database.   For example, records 5, 6, and 7 below represent an 
incoming PSTN call from 732-852-3043 (only 7 digits visible) to extension 55325.  This 
call remains connected for 42 seconds after which a transfer from extension 55325 to 
extension 45207 occurs over trunk number 12.   At this point, extension 45207 and 732-
852-3043 remain connected for an addition 30 seconds.  There are many configurable fields 
that can be used. Refer to Reference [3] 
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6. On the left hand SHADOW Voice and Data Management [cms] navigation panel, click 
Report → Chronological → Chronological Detail to view a report for the incoming call.  
In this report, the Shadow CMS application takes the call information already stored and 
formats the data base on the chronological order of the call events.  Call reporting intervals 
can be altered by the user.  Call reporting can be viewed in many various formats and 
graphs. 
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7. In this report, the Shadow CMS application takes the information already stored and formats 

the data base on an extension number.  In this case, extension 45207 was used. 
 

 

7. Support 
Technical support for Shadow CMS can be obtained by contacting Resource Software 
International Systems, Ltd. at: 

• Phone:   800-891-6014 / 905-576-4575 
• E-mail:  support@telecost.com 
• Web:     www.telecost.com 

8. Conclusion 
These Application Notes describe the steps for configuring the Revolution Software International 
Shadow Communication Management System to retrieve SMDR/CDR data from the Avaya IP 
Office.  All test cases completed successfully.   

9. References 
The following Avaya product documentation can be found at http://support.avaya.com 
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[1] Avaya IP Office 4.0 Installation Manual, Issue 15e (31st January 2007), 15-601042. 
 
The following Resource Software International product documentation is installed during the 
CMS installation process: 
 
[2] CMS Startup Guide. 
[3] CMS User Guide. 
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