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Abstract 
 

  

These Application Notes describe the procedures for configuring 4What Interactive 

VoIPTrainer which was compliance tested with Avaya Aura
TM

 Communication Manager and 

Avaya IP Telephones.   

 

The overall objective of the interoperability compliance testing is to verify 4What Interactive 

VoIPTrainer functionalities in an Avaya H.323 IP telephones (9620, 9630 and 9650 types) 

 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the procedures for configuring 4What Interactive VoIPTrainer 

which was compliance tested with Avaya Aura
TM

 Communication Manager and Avaya IP 

Telephones. 

 

The VoIPTrainer is an end-user training and support tool for Avaya IP phones. It covers the 

basic and advanced features of the phones and can be customized to match the end-users’ exact 

phone environment.  The newest release of the VoIPTrainer gives end-users access to training 

and support directly from the phone. Training is easily accessed with the push of a button, 

displaying the specific steps right on the phone LCD screen. Users also have the option to launch 

a flash based audio/video simulation directly on their desktop computer screens, if they require a 

more in-depth demonstration. 

 

These Application Notes assume that Avaya Communication Manager is already installed and 

basic configuration steps have been performed. Only steps relevant to this compliance test will 

be described in this document. For further details on configuration steps not covered in this 

document, consult [1]. 

1.1. Interoperability Compliance Testing 

The interoperability compliance test included feature.  The focus of the interoperability 

compliance testing was primarily on verifying the menu on the Avaya IP phones (9620, 9630 and 

9650), verifying the button functionalities, and also verifying PUSH feature to the client PC. 

 

1.2. Support  

Technical support for 4What Interactive VoIPTrainer can be obtained by contacting 4What 

Interactive via the support link by logging into http://access.voiptrainer.com or by calling  

(888) 464-9428 (888) GO-4WHAT. 

2. Introduction 
Figure 1 illustrates a sample configuration consisting of an Avaya S8720 Servers, an Avaya 

G650 Media Gateway, 4What Interactive VoIPTrainer, and VoIPTrainer client.  The solution 

described herein is also extensible to other Avaya Media Servers and Media Gateways.  For 

completeness, Avaya 9600 Series H.323 IP Telephones (9620, 9630 and 9650) are included in 

Figure 1 to demonstrate different type of telephones can be programmed for the VoIPTrainer. 

 

 

http://access.voiptrainer.com/
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Figure 1: Test Configuration of 4What Interactive VoIPTrainer 
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3. Equipment and Software Validated 
The following equipment and software were used for the test configuration. 

 
Equipment Software 

Avaya S8720 Servers Avaya Aura™ Communication 

Manager 5.2 (R015x.02.0.947.3) 

Avaya G650 Media Gateway 

 TN2312BP IPSI 

TN799DP CLAN 

TN2302AP MEDPRO 

HW11  FW030 

HW20  FW017 

HW01  FW108 

Avaya S8300 Server Avaya Aura™ Communication 

Manager 5.2 (R015x.02.0.947.3) 

Avaya G450 Media Gateway 28.17 

Avaya 9600 Series IP Telephone 

 9620 

9630 

9650 

3.002 

3.002 

3.002 

Avaya C363T Converged Stackable Switch (Layer 3) 4.5.14 

Extreme Summit 48 Switch (Layer 3) 4.1.21 

4What Interactive VoIPTrainer 1.0 

4. Configure the Avaya Communication Manager 
This section describes the procedure for setting up the Avaya side configuration for 4What 

Interactive VoIPTrainer.  During the compliance test, two servers and a PC were utilized.   

 App Server – 192.45.80.15 (installed VoIPTrainer into the server by 4What Interactive) 

 Server 2 – 192.45.80.90 (TFTP/DHCP server) 

 PC1 – 4What Interactive VoIPTrainer Client 

The Avaya side configuration involves the following files: 

 46xxsettings.txt  

 AvayaMenuAdmin.txt  

 VoIPTrainer Client 

4.1. Configure 46xxsettings.txt 

In the 46xxsettings.txt file set the following parameters: 

 SET TPSLIST 192.45.80.15 

 SET SUBSCRIBELIST http://192.45.80.15/VoIPTrainer/subscribe.php 

 SET AMADMIN http://192.45.80.90 

 
. 

. 

. 

################  PUSH INTERFACE SETTINGS  ################# 

## 

## These settings are used to administer the Push interface. 
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## These parameters are not supported on 16cc SIP phones. 

##  

##   The list of all the Trusted Push Servers. 

##   If set to "/", all servers are allowed. 

##   If set to null or blank, Push is disabled. 

## Note: This parameter is supported on H.323 and R2.2 release 

##       of SIP 96xx telephones. 

## SET TPSLIST 135.20.21.20 

##SET WMLHOME http://192.45.80.15/menu.wml 

SET TPSLIST 192.45.80.15 

SET SUBSCRIBELIST http://192.45.80.15/VoIPTrainer/subscribe.php 

SET AMADMIN http://192.45.80.90 

 

## 

##   The list of all the Subscription Servers. 

## Note: This parameter is supported on H.323 and R2.2 release 

##       of SIP 96xx telephones. 

## SET SUBSCRIBELIST http://135.20.21.21/subscribe 

. 

. 

. 

4.2. Configure AvayaMenuAdmin.txt 

The A (Avaya) Menu is a list of sub-applications the user can select from to invoke the 

corresponding functionality.  The AvayaMenuAdmin file provides the display menu information 

on Avaya IP telephone.  This file must be pointed to by the AMADMIN parameter in the 

46xxsettings.txt file. 

 AMTYPExx – One of six choices. 01=URI, 02=the local “Phone Settings” sub-

application, 03=local Log Off sub-application, 04= the About Avaya one-X screen, 

05=Guest Login application, 06=My Pictures application.  If the AMTYPE for an 

associated administered object is “01”, an additional two parameters must have valid, 

non-null data for the object to be properly administered: 

 AMLBLxx – The label displayed to the user for this object, up to 16 UTF-16 characters, 

shown left-justified unless spaces precede the label value to center the label. 

 AMDATAxx – A URI of up to 255 ASCII characters, without spaces. 

 
############################################################ 

##                                                        ## 

##     AVAYA MENU CONFIGURATION FILE TEMPLATE             ## 

. 

. 

. 

## AMLBLxx=Lable   up to 16 unicode character  

## 

## AMTYPExx=Type   1=WML-Application;  

##             2=local Phone Settings 

##        3=Guest Login Application 

##                 4=local LogOff Application 

##                 5=local About Avaya Screen## 

 

## AMDATAxx        URI of up to 255 ASCII-characters 

##                 e.g. http://yy.yy.yy.yy/*.wml 

## 

## The tags AMLBLxx and AMDATAxx are only used if  

## AMTYPExx = 1 
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## 

## Multiple definitions of local applications (Type 2..4) 

## will be supressed. The last tag is valid. 

## 

## xx describes the sequence in A-Menu and is valid  

## from 01 to 12 

## 

##  

AMTYPE01=1 

AMLBL01=VoIPTrainer-9630 

AMDATA01=http://192.45.80.15/voiptrainer/service.php?Type=9630AV6English 

 

AMTYPE02=1 

AMLBL02=VoIPTrainer-9650 

AMDATA02=http://192.45.80.15/voiptrainer/service.php?Type=9650AV6English 

 

##AMTYPE03= 

##AMLBL03= 

##AMDATA03= 

. 

. 

. 

4.3. Configure VoIPTrainer Client 

Installation and configuration of the VoIPTrainer can be accomplished simply by executing the 

VoIPTrainer.msi file in the VoIPTrainer client PC.   After the installation is completed, run the 

Start  Programs  VoIPTrainer Client  VoIPTrainer.exe.  There are two prompts 

during the configuration steps of the VoIPTrainer. 

 

Provide the VoIPTrainer Server IP address, and click OK 

 

 
 

Provide the phone extension, and click OK. 
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5. Configure 4What Interactive VoIPTrainer 
4What Interactive personnel can prepare the configuration of the VoIPTrainer product on behalf 

of their customers for a fee.  Refer to [2] for installation and configuration of the VoIPTrainer.  

 

VoIPTrainer Installation and Configuration Guide is included in the Appendix. 

6. General Test Approach and Test Results 
The general test approach was to verify the multiple WML applications in the first level of the 

“A” Menu ( ), shown on Avaya H.323 IP telephones. The main objectives were to 

verify that: 

 The AMLBLxx was successfully displayed on Avaya H.323 IP telephones 

 Submenus were able to function correctly. 

 The VoIPTrainer application was able to push to the VoIPTrainer client PC. 

7. Verification Steps 
The following steps may be used to verify the configuration:  

 Verify that 4What Interactive VoIPTrainer label is displayed on Avaya H.323 IP 

telephones. 

 Verify the submenu buttons worked properly. 

 Verify that the VoIPTrainer application can be pushed to a VoIPTrainer client. 

8. Conclusion 
4What Interactive VoIPTrainer were compliance tested with the Avaya H.323 IP telephones 

(9620, 9630 and 9650).  4What Interactive VoIPTrainer functioned properly for the first label 

menu and subsequent submenu. 

9. Additional References  
The following Avaya product documentation can be found at http://support.avaya.com 

[1] Avaya one-X™ Deskphone Edition for 9600 Series IP Telephones Administrator Guide 

Release 3.0, 16-300698, Issue 7, May 2009 

 

The following document was provided by 4What Interactive. 

[2] 4What Interactive VoIPTrainer Installation and Configuration Guide, July 2009. 

http://support.avaya.com/
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Appendix 
 

VoIPTrainer Installation and Configuration Guide 
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VoIPTrainer Installation and Configuration Guide 
 
The following document outlines the installation instruction for installing the VoIPTrainer on your phone system.  
This installation document is divided into 2 sections, Prerequisites and Installation.  
 

 

STEP 1 - Prerequisites 
Installing Prerequisites for VoIPTrainer on Windows Server 2003 and IIS 6  

 
Description:  This step includes preparing the prerequisites before installing the VoIPTrainer.   It includes 
configuring a Microsoft Windows Web Server, acquiring and installing PHP server side scripting software and 
installing the Zend Optimizer which allows prepared PHP scripts to run more efficiently. 
 
Version: 06/30/2009 
 
System Requirements: Internet Connection and a Windows 2003 server with 1 GB of RAM and 2 GB of free space. 
 
Average Installation Time: Approximately 1 to 2 hours depending on level of experience and internet connection 
speed. Internet access is required to download open source php language. 

 
1. Prerequisites 

a. A Windows 2003 Web server with two way communication between the telephones, 
Communications Manager, and Client PCs. 

b. Install, Configure, and test PHP scripting software. 
c. The Group Policy Management Console for Windows Server 2003, a free download from 

Microsoft.  http://www.microsoft.com/downloads/details.aspx?FamilyId=0A6D4C24-8CBD-4B35-
9272-DD3CBFC81887&displaylang=en 

 
2. Install PHP 

a. Download and unzip PHP version 5.2.10 from www.php.net to the folder c:\PHP.   Get the zip file 
version, not the installer. 

 
3. Configure PHP 

a. Create c:\PHP\Session. 
b. Either copy the php.ini from the installation package to c:\PHP\php.ini or follow these steps: 

i. Copy c:\PHP\php.ini-recommended to c:\PHP\php.ini 
ii. Edit php.ini.  You can use notepad or any other editor you prefer, such as WordPad. 

iii. Uncomment (by removing the ; at the beginning of the line) cgi.force_redirect, and set it 
to 0 instead of 1. 

iv. Find the session.save_path line, uncomment it, and set the value to c:\PHP\sessions 
v. Find the extension_dir line and set the value to c:\PHP\ext 

vi. For the following steps, if the line does not exist in your PHP.INI file, add the line near 
the bottom of your php.ini file. 

1. Find extension=php_pdo.dll and remove the “;” at the beginning of the line, if 
there is one. 

2. Find the extension=php_sqlite.dll and remove the “;” at the beginning of the 
line, if there is one. 

3. Find the extension=php_mbstring.dll and remove the “;” at the beginning of 
the line, if there is one. 

http://www.microsoft.com/downloads/details.aspx?FamilyId=0A6D4C24-8CBD-4B35-9272-DD3CBFC81887&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=0A6D4C24-8CBD-4B35-9272-DD3CBFC81887&displaylang=en
http://www.php.net/
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4. Find the extension=php_sockets.dll and remove the “;” at the beginning of the 
line, if there is one. 

5. Find the extension=php_openssl.dll and remove the “;” at the beginning of the 
line, if there is one. 

vii. Save and close the PHP.ini file. 
c. Add c:\PHP to the server’s PATH environment variable. 

i. Right click on “My Computer” and choose properties 
ii. Click on the “Advanced” tab 

iii. Click on the “Environment Variables” button 
iv. Double click the Path variable in the System variables box. 
v. Add “c:\PHP;” to the beginning of the path line 

d. Add the registry key HKEY_LOCAL_MACHINE\SOFTWARE\PHP and create a new string value 
IniFilePath.  Assign the value to “c:\\PHP”.  The double backslash is not a typo. 

i. Click Start then Run and type Regedit and press Enter to access the registry editor. 
e. Copy c:\PHP\ libeay32.dll and c:\PHP\ssleay32.dll to your c:\windows\system32 folder. 

 
4. Configure IIS 

a. Open the IIS Manager by clicking on start->Administrative Tools->Internet Information Services 
(IIS) Manager 

b. Expand to Web Servers Extensions in the left pane and click on it. 
c. In the right plane, click on the “Add a new Web Service extension” link. 
d. Type “PHP ISAPI Extension” as the extension name. 
e. Click the “Add…” button and select “c:\php\php5isapi.dll”. 
f. Make sure the “Set extension status to Allowed” checkbox is set and click OK 
g. Set up the PHP extension to work on all websites on this server 

i. Right click on “Web Sites” in the left pane 
ii. Click on the “Home Directory” tab 

iii. Click “Configuration” 
iv. Click the “Mappings” tab 
v. Click “Add…” 

vi. Enter “C:\php\php5isapi.dll” in the “Executable” textbox. 
vii. Enter “.php” in the “Extension” textbox 

viii. Click “Limit to” and enter “GET,POST,HEAD” 
ix. Click OK twice. 
x. Click “Documents” 

xi. Click “Add…” 
xii. Type “index.php” as a new default content page, and press OK 

h. Turn on scripting permissions for your sites 
i. Right click on “Web Sites” 

ii. Click on “Properties” 
iii. Click “Home Directory” 
iv. Set the “Execute Permissions” to “Scripts Only” 

i. Right click the local computer in the left pain of IIS Manager 
j. Click on All Tasks 
k. Click Restart IIS 
l. Click OK 

 
5. Test 

a. Create a new file named test.php in one of your websites.  Usually c:\inetpub\wwwroot. 
b. Open the test.php in your text editor, and enter this line: 

i. <?php phpinfo(); ?> 
c. Point your browser to that file.   It should list information about your PHP installation. 
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6. Install the Zend Optimizer 

- The Zend Optimizer is included in this installation package.   Double click on the executable and follow 
the onscreen prompts. 

a. If you are running a 64 bit server, you will also need to run this command at a command prompt.  
It allows 32 bit applications to run in your 64bit environment:  cscript 
%SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1 

b. When it asks for the root web folder for your server, it should be c:\inetpub\wwwroot, unless 
you have made it something else. 

 
7. Install the Group Policy Management Console on your Domain server  

- It can be found at http://www.microsoft.com/windowsserver2003/gpmc/gpmcintro.mspx. 
 

 

STEP 2 – VoIPTrainer Installation 
Instructions for installation of VoIPTrainer  

 
Description:  These steps describe installing and configuring the VoIPTrainer on your Windows 2003 server, and 
how to install the service on your Communications Manager.  Finally it discusses how to install the VoIPTrainer 
Client on PC’s so users can use the Show Me button through their phones. 
 
Version: 06/30/2009 
 
System Requirements: Internet Connection, Windows 2003 server with 1 GB of RAM and 2 GB of free space that 
has been through the prerequisites setup.  The requirements for the VoIPTrainer Client are Windows XP or 
Windows Vista with communications ability to both the Communications Manager and the Intranet server.  
 
Average Installation Time: Approximately 1 to 3 hours depending on level of experience and internet connection 
speed. Internet access is required to download open source php language. 

 
1. Installing the VoIPTrainer applications 

a. Install the VoIPTrainer server application to your web server from the installation package. 
i. Copy the VoIPTrainer folder from the installation package to your web server’s 

documents folder.    On IIS the default is c:\inputpub\wwwroot\VoIPTrainer.   Set the 
permissions so that the IUSR_ user has write permissions to the inc\config.php file, as 
well as all files in the directory structure with the extension .sqlite. 

ii. You will also need to create a virtual directory to the application.   
1. Start IIS by clicking Start->Programs->Administrative Tools->Internet 

Information Services (IIS) Manager. 
2. Expand folders until you see “Default Web Site”.  Right click on it and choose 

“New->Virtual Directory”. 
3. Assign “VoIPTrainer” as the alias. 
4. Click Browse, and choose the new VoIPTrainer folder you copied.  Click Next 

and ensure that Execute Permissions:  “Run Scripts” is checked.  Then press 
Next and Finish. 

iii.  Configure the applications for your environment. 
1. Go to http://(YourIntranetServer)/VoIPTrainer/index.php in your web browser.  

Follow the onscreen prompts to setup your installation and acquire your 
license.ini file.  It will ask you for your username; this is the username that you 
use to log into the access.voiptrainer.com web portal. 

http://www.microsoft.com/windowsserver2003/gpmc/gpmcintro.mspx
http://(yourintranetserver)/VoIPTrainer/index.php
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2. Install the service on the Communications Manager 

a. Edit the 46xxsettings.txt file of your Avaya configuration and make the following changes 
(replace 192.168.1.2 with the address of  your VoIPTrainer server): 

i. Find the “SET TPS LIST” and add the VoIPTrainer server’s IP address to the list of 
“Trusted Push Servers”.   SET TPSLIST 192.168.1.2 

ii. Find the “SET SUBSCRIBELIST” line, and add the following service to the subscribe list:  
SET SUBSCRIBELIST http://192.168.1.2/VoIPTrainer/subscribe.php 

iii. In the section for each phone, assign the AMADMIN to appropriate 
AvayaMenuAdmin.txt text, by using a line similar to SET AMADMIN http://192.168.1.2 

b. To make the VoIPTrainer appear in the “A” menu, edit the AvayaMenuAdmin.txt referenced from 
the 46xxsettings.txt file to make one of the line items similar to the following: 

i. AMTYPE05=1 
ii. AMLBL05=VoIPTrainer 

iii. AMDATA05=http://192.168.1.2/voiptrainer/service.php?Type=9650AV6English  
 

3. Install the VoIPTrainer Client to the computers in your domain 
a. Copy the VoIPTrainer.msi file from your installation package to a shared folder on the network, 

to which "Domain Computers" have read access. 
b. Copy the VoIPTrainer Client.adm from the installation package to the "Windows\inf" folder on 

your Windows server. 
c. Go to Start->Programs->Administrative Tools->Active Directory Users and Computers. 
d. Right click your domain, and click "Properties", Group Policy, then "Open". 
e. Create a Group Policy Object (GPO) by right-clicking on your domain, and then clicking "Create 

and Link a GPO here". 
f. Name the policy "VoIPTrainer Client Installation", and press Enter. 
g. Right click the new VoIPTrainer Client Installation GPO and click "Edit".  
h. Under "Computer Configuration", expand "Software Settings". 
i. Right click "Software Installation", point to "New" and click "Package". 
j. In the Open dialog box, put in the full UNC path to the VoIPTrainer.msi file.  For example:  

"\\PUBLICSHARE\installs\VoIPTrainer.msi".  Do NOT browse to the location, type in the path 
directly.  The PUBLICSHARE must be a server name, IP addresses cannot be used in this context. 

k. Click "Open". 
l. Click "Assigned", and then click "OK".   
m. Expand "User Configuration". 
n. Click on "Administrative Templates". 
o. Click on "View->Filtering" and ensure that the checkbox for "Only show policy settings that can 

be fully managed" is cleared. 
p. Right click on "Administrative Templates" and choose "Add/Remove Templates". 
q. Click "Add". 
r. Find the "VoIPTrainer Client.adm" file and click "Open". 
s. Click "Close" to return to the Group Policy Object Editor screen. 
t. Expand "Administrative Templates". 
u. Click on "VoIPTrainer Settings". 
v. In the right pane, double click on "VoIPTrainer Server Location". 
w. Click "Enabled" and enter your VoIPTrainer server's IP address in the "VoIPTrainer Server 

Address" text box. 
x. Click on OK to close the VoIPTrainer Server Location Properties window. 
y. Click on the X to close the Group Policy Object Editor window. 

 
4. Add a firewall Exception  

http://192.168.1.2/VoIPTrainer/subscribe.php
http://192.168.1.2/
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a. If you already have a policy for the windows firewall, add this exception to that policy.  If you do 
not, you can follow the instructions here to add a Program Exception policy for the VoIPTrainer 
Client for your network users. 

b. Go to Start->Programs->Administrative Tools->Active Directory Users and Computers. 
c. Right click your domain, and click "Properties", then "Open". 
d. Right click the Policy to add the firewall settings to.  If you don't already have one, create one 

using the following steps: 
i. Create a Group Policy Object (GPO) by right-clicking on your domain, and then clicking 

"Create and Link a GPO here". 
ii. Name the policy "Windows Firewall Settings", and press Enter. 

e. Right click on the Firewall Policy and choose "Edit". 
f. Expand "Computer Configuration"->"Administrative Templates"->"Network"->"Network 

Connections"->"Windows Firewall". 
g. Click on "Domain Profile". 
h. (Optional) Double click on "Windows Firewall:  Allow local program exceptions".  Make the 

setting "Enabled".  Click "OK".  This will allow local administrators to continue to add programs to 
their local firewall exception list.  If it was not configured the next step would stop this behavior. 

i. Double click on "Windows Firewall:  Define program exceptions".  Click "Enabled".  Click on 
"Show".  Click on "Add".   Enter   

i. %programfiles%\VoIPTrainer\VoIPTrainer 
Client\VoIPTrainer.exe:INTRANETSERVERADDRESS:enabled:VoIPTrainer 

ii. Replace "INTRANETSERVERADDRESS" with the internal address of the Intranet server 
that is hosting VoIPTrainer. 

j. Press OK to all the dialog boxes. 
k. Close the Group Policy Object Editor. 
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