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Abstract 
 
These Application Notes describe the configuration steps required for the iQ NetSolutions 
VistaPoint Enterprise to successfully interoperate with Avaya IP Office.  The iQ NetSolutions 
VistaPoint Enterprise is a complete client/server suite of computer telephony applications 
providing desktop call control for users.  Features and functionality were validated and 
performance testing was conducted in order to verify operation under load.  Information in 
these Application Notes has been obtained through interoperability compliance testing and 
additional technical discussions. Testing was conducted via the DeveloperConnection Program 
at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the compliance-tested configuration utilizing Avaya IP Office 
2.1(24) and iQ NetSolutions VistaPoint Enterprise 3.4.1.5. 
 
iQ NetSolutions VistaPoint (VP) Enterprise is a complete client/server suite of computer 
telephony applications designed to provide end-users with desktop call control.  The following 
VP Enterprise suite components are part of this solution: 
 
VistaPoint Enterprise Server – a Windows based software server application connecting to the 
IP Office through TAPI 3rd party call control and providing IP Office connectivity to the 
VistaPoint companion client software. 
 
VistaPoint Desktop Companion – a Windows based software application providing desktop 
call control.  VP Desktop Companion provides desktop call control, desktop-to-desktop instant 
messaging, system-wide notes, enterprise-wide busy lamp fields (BLFs), calling party 
information, and much more.  With VP Desktop Companion, users can see the real-time 
enterprise-wide BLF status of other IP Office extensions.  When another user is on the phone, 
simply “pop” an instant message to their computer screen to get a message to them. 
 
VistaPoint Console Companion – an application including all the capabilities of VP Desktop 
Companion with additional features designed specifically for system operators and supervisors.  
 
VistaPoint Companion for Outlook – an optional application plug-in for the professional who 
uses Microsoft Outlook as a key tool for conducting day-to-day business.  It provides the ability 
to seamlessly navigate between VP Companion’s functions and Outlook.  A telephony call 
control toolbar within Outlook makes it easy to place calls, transfer, conference, and perform a 
variety of other call control functions from within Outlook.  Users can also configure screen pops 
and place calls from within Outlook Contacts. 
 
The tested configuration is shown in Figure 1. 
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Figure 1: iQ NetSolutions VistaPoint Enterprise and Avaya IP Office Configuration 

 

2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 
Avaya IP 406 System 2.1(24) 
Avaya IP Office Manager 4.1(15) 
Avaya IP Office Feature Key Server 1.0 
Avaya IP Office Voicemail Pro 2.1(10) 
Avaya IP Office TAPI2 Service Provider 1.0.0.21 
Avaya IP Office CTI Link Pro License - 
Avaya 4624 IP Telephones 1.82 
Avaya 6408D+ Telephones - 
iQ NetSolutions VistaPoint Enterprise Server 3.4.1.5 
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Equipment Software 
iQ NetSolutions VistaPoint Desktop Companion 3.4.1.5 
iQ NetSolutions VistaPoint Console Companion 3.4.1.5 
iQ NetSolutions VistaPoint Companion for MS Outlook 3.4.1.5 
Analog telephones - 
PC for use as Microsoft Exchange Server Windows 2000 Server 

Service Pack 4 
PC for Avaya IP Office Manager, Avaya IP Office 
Feature Key Server, and Avaya IP Office Voicemail Pro 

Windows 2000 Professional 
Service Pack 4 

Generic PC for use with iQ NetSolutions VistaPoint 
Server 

Windows 2000 Server 
Service Pack 4 

Generic PCs for use with iQ NetSolutions VistaPoint 
Clients 

Windows 2000 Professional 
Service Pack 4 

 
 

3. Configure Avaya IP Office 
These Application Notes address provisioning of the IP Office as it relates to integration of the 
VistaPoint Server.  For all other provisioning information, such as provisioning of the trunks, 
call coverage, extensions, voicemail, etc. please refer to the IP Office documentation. 
 

Step Description 
 IP Office Feature Key Physical Installation 
1.  Plug the Avaya feature key into the appropriate port (e.g., serial, parallel, USB) on the 

Avaya IP Office Feature Key Server PC. 
 Configure License Key Server IP Address 
2.  Log in to the IP Office Manager PC and go to Start → Programs → IP Office → 

Manager to launch the Manager application. Log in to the Manager application using the 
appropriate credentials. 

3.  In the Manager window that appears, select File → Open to search for the IP Office 
system in the network. 

4.  Log  into the IP Office system using the appropriate login credentials to receive its 
configuration. 
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Step Description 
5.  In the Manager window, go to the Configuration Tree and double-click System.  In the 

System Configuration window that appears, select the System tab and set License Server 
IP Address to the IP address of the machine to which the red Avaya Software Sentinel key 
is connected, e.g., 192.45.70.40.  This is typically the IP Office Manager PC.  Click OK. 
 

 
 

 Setup ‘send to voicemail’ short code 
6.  In the Manager window, go to the Configuration Tree and double-click Shortcode to open 

the list of short codes installed in the IP Office system.   
7.  Right click in the short code list window and select New. In the Shortcode window that 

appears, set Short Code to *60*N#, Telephone Number to #N, Feature to 
VoicemailCollect, and click OK. 
 

 



 
Step Description 

 Install CTI Link Pro License Key 
8.  In the Manager window, go to the Configuration Tree and double-click License to open 

the list of licenses installed in the IP Office system.   
9.  Right click in the license list window and select New. In the License window that appears, 

enter the CTI Link Pro License Key and click OK. 
 

 
10.  In the Manager window, select File → Save to save the licenses to the IP Office system 

and wait for the system to update.  The system reload validates the new license. 
 
 

4. Configure iQ NetSolutions VistaPoint Enterprise Server 
These Application Notes address provisioning of the VP Server as it relates to the Avaya IP 
Office.  For all other provisioning information, please refer to the iQ NetSolutions System Guide 
available on the Installation CD. 
 

4.1. Install and Configure Avaya IP Office TAPI2 Service Provider  
Please refer to the Avaya IP Office CTI Link Installation Manual, 40DHB0002UKAB – Issue 5 
(10/28/2003) for additional information. 
 

Step Description 
1.  Using the Avaya IP Office User CD, install the Avaya IP Office TAPI2 Service Provider 

driver on the VistaPoint server.  Make sure to uncheck all the other installation options 
listed in the Installation Wizard, as they are not required. 

2.  After the system reboots, log into the system again as administrator and go to Start → 
Settings → Control Panel.  In the Control Panel window that appears, double-click 
Phone and Modem Options. 

3.  In the Advanced tab of the Phone and Modem Options window, double-click Avaya IP 
Office TAPI2 Service Provider. 
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Step Description 
4.  In the Avaya TAPI2 configuration window that appears, set Switch IP Address to the IP 

address of the IP Office, e.g., 192.45.70.191, select Third Party, set Switch Password to 
the password of the IP Office, verify WAV Users and ACD Queues are unchecked, and 
click OK. 
 

 
5.  Reboot the VistaPoint server. 

 Verify Connectivity with the IP Office 
6.  After the system reboots, log into the system and go to Start → Programs → Accessories 

→ Communications → Phone Dialer. 
7.  In the Phone Dialer window that appears, select Edit → Options. 
8.  In the Lines tab of the Options window that appears, select the Phone Calls: drop-down 

list.  If one or more “IP Office Phone: XXX” (where XXX is an extension number) entries 
appear, then the IP Office TAPI2 Service Provider Driver is installed and working 
properly. 

 

4.2. Install iQ NetSolutions VistaPoint Enterprise Server 
Step Description 

1.  Insert the VistaPoint Enterprise Installation CD into the VistaPoint server, browse to the 
CD-ROM and run setup.exe. 

2.  In the VistaPoint Enterprise Setup window that appears, click Next. 
3.  In the License Agreement window that appears, review the license agreement.  To accept 

the terms and proceed with the installation, click Yes. 
4.  In the Choose Destination Location window that appears, click Next. 
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Step Description 
5.  In the Select Components window that appears, check Server, Avaya IP Office SIM and 

click Next. 
 

 
6.  In the Review settings before copying files window that appears, click Next. 
7.  In the VistaPoint License Retrieval window that appears, click Cancel.  For the purposes 

of these Application Notes, the thirty-day trial license was used.  This trial license can be 
upgraded later to a permanent license. 

8.  In the VPLicenseAdmin popup that appears, click OK. 
9.  In the VP License Administrator window that appears, click Exit. 
10.  In the VistaPoint Enterprise Setup window that appears, select Yes, I want to restart my 

computer now. and click Finish.  
11.  Remove the installation CD from the server. 

 
 

4.3. Configure VistaPoint Server Components 
Step Description 

1.  Following installation reboot, log into the VistaPoint server using administrative 
privileges. 
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Step Description 
2.  In the Database Server popup that appears, click Yes.  

 

 
3.  In the System Administrator Password popup that appears, set New password and Re-enter 

new password to the password that will be used for accessing VistaPoint Enterprise 
administrator features from VistaPoint Enterprise clients.  Click OK. 
 

 
4.  Verify the Avaya IP Office SIM is running by finding the Avaya IP Office SIM icon in the 

Windows System Tray of the VistaPoint server. 
 

 
5.  Right-click the Avaya IP Office SIM icon and choose Options → SIM startup options. 
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Step Description 
6.  In the VistaPoint Avaya IP Office SIM setup window that appears, click Edit. 

 

 



 
SCR; Reviewed: 
SPOC 3/3/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

11 of 20 
vistapoint-ipo.doc 

 

Step Description 
7.  In the VistaPoint Avaya IP Office SIM startup parameters window that appears, set 

Provider to Avaya, check VMB support and VMB blind support, set Voicemail 
Huntgroup to *60*, clear Voicemail Prefix, set Voicemail Suffix to # and click OK. 

 
 
NOTE:  If the Avaya IP Office CTI Link Pro license is not installed in the Avaya IP 
Office or detected by the Avaya IP Office Feature Key Server, then Avaya will not appear 
as an option in the Provider pull down list.  If this occurs, install the license and verify it is 
properly detected before returning to this window. 
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Step Description 
8.  In the VistaPoint Avaya IP Office SIM setup window, click OK. 

 

 
9.  In the AvayaIPOSIM.exe popup that appears, click Yes. 

 

 
10.  Reboot the VistaPoint server.  This completes the configuration of the VistaPoint 

Enterprise Server. 
 



 

5. Install and configure iQ NetSolutions VistaPoint Enterprise 
Client(s) 

Step Description 
 Install Client Software 
1.  Log into the client PC using administrative privileges. 
2.  Insert the VistaPoint Enterprise Installation CD into the client PC, browse to the CD-ROM 

and run setup.exe. 
3.  In the VistaPoint Enterprise Setup window that appears, click Next. 
4.  In the License Agreement window that appears, review the license agreement.  To accept 

the terms and proceed with the installation, click Yes. 
5.  In the Choose Destination Location window that appears, click Next. 
6.  In the Select Components window that appears, select the VistaPoint Companion client 

desired, e.g., Desktop Companion, Console Companion or Companion for Outlook, 
and click Next. 

7.  In the Review settings before copying files window that appears, click Next. 
8.  In the VistaPoint License Retrieval window that appears, click Cancel.  For the purposes 

of these Application Notes, the thirty-day trial license was used.  This trial license can be 
upgraded later to a permanent license. 

9.  In the VPLicenseAdmin popup that appears, click OK. 
10.  In the VP License Administrator window that appears, click Exit. 
11.  In the VistaPoint Enterprise Setup window that appears, select Yes, I want to restart my 

computer now. and click Finish.  
12.  Remove the installation CD from the computer. 
 Configure VistaPoint Console Companion 
13.  Following installation reboot, log into the client PC. 
14.  Go to Start → Programs → VistaPoint Enterprise → VistaPoint Console Companion 

to launch the VistaPoint Console Companion client.   
15.  In the User Information popup that appears, set My extension number to the extension 

number to be controlled/used from the client PC, e.g., 2510, set My user name to the name 
to be associated with the extension controlled from the client PC, e.g., client1. 
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Step Description 
16.  Once configured, the VistaPoint Console Companion appears as follows. 

 

 



 
Step Description 

 Configure VistaPoint Desktop Companion 
17.  Repeat Steps 1 – 12 to install the VP Desktop Companion client software. 
18.  Following installation reboot, log into the client PC. 
19.  Go to Start → Programs → VistaPoint Enterprise → VistaPoint Desktop Companion 

to launch VistaPoint Desktop Companion. Set My extension number to 2500 and My user 
name to honda to configure the VistaPoint Desktop Companion.  Once provisioned, the 
client appears as follows: 

 
 

 Configure VistaPoint Companion for Outlook 
20.  Repeat Steps 1 – 12 to install the VP Companion for Outlook client software. 
21.  Following installation reboot, log into the client PC. 
22.  Go to Start → Programs → Microsoft Outlook to launch the Microsoft Outlook client 

and log in as usual. 
23.  In the My extension popup that appears, set My extension number to the extension number 

to be controlled/used from the client PC, e.g., 2520, set My user name to the name to be 
associated with the extension controlled from the client PC, e.g., rebel. 
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Step Description 
24.  Once configured, the VistaPoint Companion for Outlook appears as follows within 

Microsoft Outlook: 
 

 
 
 

6. Interoperability Compliance Testing 
This interoperability compliance test included feature, functionality and performance load 
testing1.  Feature and functionality testing examined the ability of iQ NetSolutions VistaPoint 
Enterprise suite (VistaPoint Enterprise Server, VistaPoint Desktop Companion, VistaPoint 
Console Companion, and VistaPoint Companion for Outlook) to work with Avaya IP Office.  
Call control (internal, inbound and outbound calls, supervised transfer, forward, conference, 
drop, hold, park, and send to voicemail) from the VistaPoint Enterprise Clients was verified.  
Performance load tests verified the configuration continued operating under load.  
 
 
 

                                                 
1 Feature and functionality testing was conducted at iQ NetSolutions Test labs and verified during compliance 
testing conducted at the Avaya Solution and Interoperability Test Lab. 
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6.1. General Test Approach 
Feature and functionality testing was performed manually.  Analog loop start and T1/PRI trunks 
from the central office were connected to the IP Office. 
 
Inbound calls were made to the IP Office from analog, T1 and PRI trunks as well as internal 
extensions.  The IP Office routed inbound calls either directly to an extension or to the Main hunt 
group, which was configured to ring all extensions as a group. Calls received at extensions 
configured with VistaPoint clients (VistaPoint Console Companion, VistaPoint Desktop 
Companion, VistaPoint Companion for Outlook) were answered via the client software.  
VistaPoint clients were used to answer inbound calls, place outbound calls, perform supervised 
transfers, forward calls, park calls, send calls to voicemail, and perform conference calls, call 
hold and call drop. 
 
Performance testing was accomplished by utilizing a call generation tool for placing calls from a 
PRI trunk to the IP Office.  The PRI trunk port on the call generation tool was connected to the 
PRI trunk port on the IP Office using a T1 crossover cable. A call generation tool script was 
written to place inbound calls to the IP Office, play .wav files then pause for the call recipient to 
hang up.  The IP Office dial plan routing was set up to route the inbound calls to the appropriate 
destination extensions.  Automated scripts were written to drive the VistaPoint clients on the 
client PCs used for load testing to answer incoming calls, pause a few moments then hang up the 
calls. 
 

6.2. Test Notes 
• VistaPoint clients will not install if Microsoft .NET Framework is installed.  If 

Microsoft .NET Framework was already installed on the client PC or if it was an option 
selected during the VistaPoint client software installation, the VistaPoint client software 
would not install.  To workaround this issue, uninstall Microsoft .NET Framework and 
reboot the PC.  The VistaPoint client software can then be installed.  iQ NetSolutions 
reports a fix will be forthcoming. 

• Support for non-speakerphone devices such as analog phones is limited to call 
monitoring by VistaPoint clients.  When an inbound call rings at an analog station, the 
call can only be answered by lifting the handset.  It cannot be answered from the 
VistaPoint client software.  Additionally, if an outbound call is placed from a VistaPoint 
client associated with an analog station, the analog station will ring because the handset 
must still be lifted for the call to be connected.   

• Inbound CallerID not properly displayed for hunt group recipients by VistaPoint 
clients.  Incoming calls to hunt group Main, which was setup to ring as a group, would 
initially appear in the VistaPoint client display with the hunt group number/name and 
incoming CallerID information for the call.  However, the VistaPoint client display 
would very quickly switch to displaying the incoming call as if it was coming from one 
of the extensions belonging to the hunt group.  When the call was answered, it would 
again properly display the CallerID information about the call.  If the call recipient 
missed the initial information display, there would be no way of knowing the call 
originator before the call is answered.  iQ NetSolutions reports a fix will be forthcoming. 
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• Conference call initiator dropping out of conference calls involving outside caller 
affects VistaPoint client conference display of extensions remaining in call.  
VistaPoint client extensions involved in a multi-party conference call with an outside 
caller lose the outside caller from the conference display if the initiating extension drops 
from the call.  iQ NetSolutions is aware of this problem and a fix will be forthcoming. 

• Instructions for use of the Cpark button on the telephone display in conjunction 
with VistaPoint client.  Calls parked using the Cpark button on the telephone display of 
an IP office extension, e.g., x2500 can be retrieved from the VistaPoint client of another 
extension, e.g., x2510, by entering ‘extension_number + 0’ and clicking unpark on the 
VistaPoint client. 

• Call transfer from VistaPoint clients associated with analog extensions not behaving 
properly.  If a call is transferred from an analog extension, e.g., x2520, through 
VistaPoint client to another extension, e.g., x2500, the receiving extension (x2500) rings 
once and is automatically answered.  This is not the proper behavior for a transfer.  The 
call should ring at x2500 until the recipient answers it.  iQ NetSolutions reports a fix will 
be forthcoming. 

• Conference button provided by VistaPoint Companion for Outlook is permanently 
grayed out.  The conference button on the VistaPoint Companion for Outlook remains 
grayed out while on a call.  The only way available to initiate a conference from this 
client is to right click on the call in the window and choose conference in the popup that 
appears.  iQ NetSolutions reports a fix will be forthcoming. 

6.3. Test Results 
Feature, functionality, and performance testing was successful.  Any issues and/or observations 
noted during testing were presented in Section 6.2.  Overnight performance testing at a rate of 
1489 BHCA (Busy Hour Call Attempts) over eight PRI channels as reported by the call 
generation tool and answered by eight VistaPoint client PCs was conducted.    Performance 
statistics were captured on the VistaPoint server to ensure that it was able to handle the call 
volume. 
 

7. Verification Steps 
The following steps can be used to verify system operation after a field installation: 

• Verify the Avaya IP Office CTI Link Pro license is properly installed and detected  (see 
Section 3). 

• Verify the Avaya IP Office TAPI2 Service Provider is properly installed and IP Office 
extensions can be viewed from the VistaPoint server Phone Dialer application  (see 
Section 4.1). 

• Verify the VistaPoint Avaya IP Office SIM is running on the VistaPoint server (see 
Section 4.3). 

• Verify the VistaPoint clients can display the monitored extensions (see Section 5). 
• Place a test call from one VistaPoint client extension to another, e.g., x2500 to x2511.  

Verify the call rings at the destination extension and there is call connectivity when the 
call is answered at the VistaPoint client of the destination extension. 
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• Place an inbound trunk call to one of the VistaPoint client extensions.  Verify call 
connectivity when the call is answered at the VistaPoint client. 

 

8. Support 
Customers should call the iQ NetSolutions Inc. Customer Service Center when having problems 
related to the VistaPoint Enterprise.  iQ NetSolutions will determine the nature of the problem 
and recommend the best plan to the customer, whether it is to: 
� Fix the problem through remote access. 
� Dispatch, at iQ NetSolutions’ discretion, on-site technical support. 

 
For technical support on VistaPoint Enterprise, contact the iQ NetSolutions Inc. Customer 
Service Center at (508) 870-3228 or support@iqnsi.com.  
 

9. Conclusion 
These Application Notes describe the required configuration steps for iQ NetSolutions 
VistaPoint Enterprise to successfully interoperate with Avaya IP Office.  Features, functionality, 
and performance were validated, subject to the items documented in Section 6.2. 
 

10. Additional References  
Avaya IP Office (R2.1) Installation Manual, 40DHB0002UKCL, Issue 11, 3rd November 2004. 
 
Avaya IP Office CTI Link Installation Manual, 40DHB0002UKAB, Issue 5, (10/28/2003). 
 
iQ NetSolutions VistaPoint Enterprise Install-Admin Guide, Release 3.4.1.5. 
 
iQ NetSolutions VistaPoint Enterprise User Guide, Release 3.4.1.5. 

mailto:support@iqnsi.com
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