Abstract

These Application Notes describe the configuration steps required for Telecorp Wall Display PLUS to interoperate with Avaya Call Management System. Telecorp Wall Display PLUS captures the real-time split/skill call measurement data from Avaya Call Management System to make available for users to display onto high-resolution displays.

Information in these Application Notes has been obtained through compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
1. Introduction
Telecorp Wall Display PLUS captures the real-time split/skill call measurement data from Avaya Call Management System (CMS) to make available for users to display onto high-resolution displays, such as plasma screens, LCD screens, and computer monitors.

The Telecorp Wall Display PLUS system consists of three separate software applications – Wall Display PLUS Client, Wall Display Shub Server, and Wall Display Driver. The compliance testing focused on the interface between the Wall Display Shub Server and Avaya CMS. The Wall Display PLUS Client was used to verify the real-time split/skill call measurement data that were made available by the Wall Display Shub Server.

On Avaya Communication Manager, the split/skill contact center resources are configured to be “measured” by Avaya CMS. When a call travels through a “measured” resource on Avaya Communication Manager, the call measurement data is sent to Avaya CMS.

Contact center users such as supervisors can run the Wall Display PLUS Client software on their desktops, and access the Wall Display Shub Server to review and display the collected split/skill data onto high-resolution displays that can be seen by the agents. For the compliance testing, the Wall Display PLUS Client software was used to verify the collected split/skill call measurement data, and to format and preview the display of such data.

![Figure 1: Telecorp Wall Display PLUS with Avaya Call Management System](image-url)
The integration of the real-time split/skill call measurement data with Avaya CMS is achieved through the Avaya CMS Supervisor interface. The Avaya CMS Supervisor application is installed on the same server hosting the Telecorp Wall Display Shub Server application. Scripts for the Avaya CMS real-time split/skill and the Avaya CMS integrated split/skill comparison reports were created using the Avaya CMS Supervisor, which sets up the necessary parameters and permissions. The Telecorp version of the scripts is then installed to collect the real-time split/skill and integrated split/skill comparison data. The data is parsed by the Telecorp Wall Display Shub Server and made available to the Telecorp Wall Display PLUS Clients for format and display onto high-resolution displays.

These Application Notes assume the configuration and connectivity between Avaya Communication Manager and Avaya CMS is already in place and will not be described.

2. Equipment and Software Validated
The following equipment and software were used for the sample configuration provided:

<table>
<thead>
<tr>
<th>Equipment</th>
<th>Software</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya S8700 Server</td>
<td>Avaya Communication Manager 4.0, R014x.00.0.730.5</td>
</tr>
<tr>
<td>Avaya G650 Media Gateway</td>
<td></td>
</tr>
<tr>
<td>• TN799DP  C-LAN Circuit Pack</td>
<td>HW01 FW024</td>
</tr>
<tr>
<td>Avaya Call Management System Server</td>
<td>r14aa.h</td>
</tr>
<tr>
<td>Avaya C363T-PWR Converged Stackable Switch</td>
<td>4.3.12</td>
</tr>
<tr>
<td>Avaya 4610SW &amp; 4620SW IP Telephones (H.323)</td>
<td>2.8</td>
</tr>
<tr>
<td>Telecorp Wall Display Shub Server and</td>
<td></td>
</tr>
<tr>
<td>Avaya CMS Supervisor running on</td>
<td>1.1.7</td>
</tr>
<tr>
<td>Dell Inspiron E1505</td>
<td>14.0.IA.04</td>
</tr>
<tr>
<td></td>
<td>Windows XP Professional</td>
</tr>
<tr>
<td>Telecorp Wall Display PLUS Client running on</td>
<td>2.2.0</td>
</tr>
<tr>
<td>Dell Precision 380</td>
<td>Windows XP Professional SP2</td>
</tr>
</tbody>
</table>
3. Configure Avaya Communication Manager

The detailed administration of contact center resources and connectivity between Avaya Communication Manager and Avaya CMS are not the focus of these Application Notes and will not be described. For administration of contact center resources and connectivity to Avaya CMS, refer to the appropriate documentation listed in Section 11.

This section provides the procedures for how to enable split/skill measurement data to be sent to Avaya CMS.

3.1. Administer Measured Split/Skill and Agent

Use the “change hunt-group n” command, where “n” is the number of the split/skill group to be measured by Avaya CMS. Navigate to Page 2, and set the measured field to “external” to enable measurement data on the split/skill group to be sent to Avaya CMS. Repeat this step for all split/skill groups that will be measured by Avaya CMS.

```
change hunt-group 510

HUNT GROUP

Skill? y Expected Call Handling Time (sec): 180
AAS? n Service Level Target (% in sec): 80 in 20
Measured: external

Supervisor Extension: none

Timed ACW Interval (sec): none
Multiple Call Handling: none

Redirect on No Answer (rings): none
Redirect to VDN: none
Forced Entry of Stroke Counts or Call Work Codes? N
```

For the compliance testing, two split/skill groups with group numbers 510 and 520 were configured to be measured, as shown below.

```
list hunt-group 510 count 2

HUNT GROUPS

Grp Grp Grp Type MEAS Vec MCH Que Mem Path Ctg Adj Ctrl Center
Grp No. Name/ Ext ACD/ No. Cov Notif/ Dom Message

510 Telecorp Skill 510 34510 ucd-mia y/E SK none y 0 n n
520 Telecorp Skill 520 34520 ucd-mia y/E SK none y 0 n n
```
In the compliance testing, one agent with physical extension 24511 and logical extension 35511 was used as an available agent for skill group 510, and two agents with physical extensions 24513-24514 and logical extensions 35513-35514 were used as available agents for skill group 520.

<table>
<thead>
<tr>
<th>Login ID</th>
<th>Name/Extension</th>
<th>Dir</th>
<th>AAS/AUD</th>
<th>Ag</th>
<th>SO</th>
<th>Skil/Lv</th>
<th>Skil/Lv</th>
<th>Skil/Lv</th>
<th>Skil/Lv</th>
<th>Pr</th>
</tr>
</thead>
<tbody>
<tr>
<td>35511</td>
<td>Telecorp Agent 24511</td>
<td>1</td>
<td>lvl n</td>
<td>510/01</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td></td>
</tr>
<tr>
<td>35513</td>
<td>Telecorp Agent 24513</td>
<td>1</td>
<td>lvl n</td>
<td>520/01</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td></td>
</tr>
<tr>
<td>35514</td>
<td>Telecorp Agent 24514</td>
<td>1</td>
<td>lvl n</td>
<td>520/01</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td>/</td>
<td></td>
</tr>
</tbody>
</table>
4. Configure Avaya Call Management System

The connectivity between Avaya CMS and Avaya Communication Manager is assumed to be in place and will not be described. In addition, these Application Notes assume a user name and password has been created with report access permissions. This section provides the procedures for administering split/skill dictionary names.

4.1. Administer Split/Skill Dictionary Names

Use a terminal emulator to connect to the Avaya CMS server, and log in with the proper credentials. Enter “cms” at the command prompt. The MainMenu screen is displayed. Select Dictionary > Splits/Skills, as shown below.
The **Dictionary: Splits/Skills** dialog box is displayed. Enter a descriptive name for **Split/Skill name**, and a desired description. For the **Split/Skill number** field, enter the first split/skill group number from **Section 3.1**. Tab over to **Add** and press **Enter**.

Repeat this procedure to create dictionary names for all measured splits/skills groups created in **Section 3.1**. Shown below are the split/skill groups used for the compliance testing.
5. Configure Avaya CMS Supervisor

This section provides the procedures for configuring the Avaya CMS Supervisor to create two report scripts. The procedures include the following areas:

- Launch Avaya CMS Supervisor
- Administer real-time split/skill report script
- Administer integrated split/skill comparison report script

5.1. Launch Avaya CMS Supervisor

From the Telecorp server, start the Avaya CMS Supervisor application by selecting Start > All Programs > Avaya > CMS Supervisor R14 > CMS Supervisor 14.0 -- English. The Options screen is displayed, as shown below. Click New to connect to a new CMS server.
The **Server Properties** screen is displayed next. In the **Server Name** field, enter the IP address of the Avaya CMS server, in this case “192.45.120.50”. Retain the default values in the remaining fields, and click **OK**.

![Server Properties Screen](image1)

The **Options** screen is displayed again with the IP address of the Avaya CMS server from above. Click **OK**.

![Options Screen](image2)

The **Avaya CMS Supervisor** screen is displayed next. Retain the default value in the **CMS Server** field, and enter valid credentials for the **Login ID** and **Password** fields. Click **OK**.

![Avaya CMS Supervisor Screen](image3)
5.2. Administer Real-Time Split/Skill Report Script

The Avaya CMS Supervisor screen is displayed next. Click on the Select a Report icon circled below to create a report.

The Select a Report screen is displayed. Select the Real-Time tab, and select Split/Skill and Split/Skill Report as shown below. Click OK.
The **Split/Skill Report** screen is displayed. Click on the **Browse** icon circled below.

![Split/Skill Report Screen](image1.jpg)

The **Browse Split/Skills** screen is displayed. Select the split/skill group dictionary names from **Section 4.1** in the **Choices** pane, and move the selection to the **Selected Splits/Skills** pane by clicking **Add >>**. Click **OK**.

![Browse Splits/Skills Screen](image2.jpg)

The **Split/Skill Report** screen is displayed again with the selected split/skill groups in the **Splits/Skills** field. Click **OK**.

![Split/Skill Report Screen](image3.jpg)
The **Split/Skill Report** screen is updated with a snapshot of the actual report. Select **Edit > Export All Data** from the menu bar.

The **Export All Data** screen is displayed next. Select and enter values into the fields as shown below, and click **Script**.
The **Save as Script** screen is displayed next. Retain the default values, and click **Save**.

![Save as Script](image1)

In the **Save as Script – User Information** screen below, enter valid credentials and click **OK**.

![Save as Script - User Information](image2)

The **Save as Script** dialog box is displayed. Click **OK**.

![Save as Script](image3)
5.3. Administer Integrated Split/Skill Comparison Report Script

From the Avaya CMS Supervisor screen, click on the Select a Report icon circled below to create another report.

The Select a Report screen is displayed. Select the Integrated tab, and select Split/Skill and Comparison Report as shown below. Click OK.
The **Split/Skill Comparison** screen is displayed next, with the **Splits/Skills** field already filled in. Retain the default values, and click **OK**.

![Split/Skill Comparison screen](image)

The **Split/Skill Comparison** screen is displayed with a snapshot of the actual report. Select **Edit > Export All Data** from the menu bar.

![Export All Data screenshot](image)
The Export All Data screen is displayed next. Select and enter values into the fields as shown below, and click Script.

![Export All Data screenshot]

The Save as Script screen is displayed next. Retain the default values, and click Save.

![Save as Script screenshot]

The Save as Script dialog box is displayed. Click OK.

![Save as Script dialog box]
6. Configure Telecorp Wall Display Shub Server

This section provides the procedures for configuring the Telecorp Wall Display Shub Server. The procedures include the following areas:

- Rename script file extensions
- Administer Telecorp report generation

Note that configuration of Telecorp Wall Display Shub Server is typically performed by the Telecorp technicians. The procedural steps are presented in these Application Notes for informational purposes.

6.1. Rename Script File Extensions

From the Telecorp server, open a Windows Explorer window, and navigate to the directory C:\telecorp\avaya, as shown below. Note the two text files with extension “.txt” and the two script files with extension “.acsauto” created from Sections 5.2 and 5.3.
Rename the two script files to use a different file extension, so that the files would not be recognized as script files by the system. In the compliance testing, the two script files were changed to have the file extension “.acsauto.old”, and moved to a manually created folder along with the two text files.

6.2. Administer Telecorp Report Generation

Copy the file Telecorp Export.acsauto from the Telecorp installation CD into the C:\telecorp\avaya directory, as shown below. Open the Telecorp Export.acsauto script file with an application such as Note Pad for editing.
In the **Telecorp Export.acsauto** script file, set the **SERVERNAME** in line 2 to the IP address of the Avaya CMS server, in this case “192.45.120.50” as shown below.

![Image of Notepad++ showing the script file](image)

Search for “Splits/Skills”, and set the split/skill group numbers to the numbers from **Section 3.1**, as shown below. Note the use of semicolon “;” to separate the group numbers. There are a total of four places in the script file that needs this change. The first three places are shown below.

![Image of Notepad++ showing the script file](image)

![Image of Notepad++ showing the script file](image)
After setting the split/skill numbers in all four places, including the one below, select **File > Save** from the menu bar to save the changes.
In the Windows Explorer window, double-click on **AvayaParse.exe** to start the application.

The **Telecorp Products Avaya Parser** dialog box will appear as shown below.
7. **Interoperability Compliance Testing**

The interoperability compliance test included feature and serviceability testing.

The feature testing focused on verifying Telecorp Wall Display PLUS parsing and displaying of split/skill data from Avaya CMS.

The serviceability testing focused on verifying the ability of the Telecorp Wall Display PLUS server to recover from adverse conditions, such as disconnecting the Ethernet cable to the Telecorp Wall Display Shub Server.

### 7.1. General Test Approach

The feature test cases were performed manually. Incoming calls were made to the measured skill groups to enable measurement data to be sent to Avaya CMS. Manual call controls and work mode changes from the agent telephones were exercised to populate specific fields in the skill data.

The serviceability test cases were performed manually by disconnecting/reconnecting the LAN cable to the Telecorp Wall Display Shub Server and to the Avaya CMS server.

The verification of all tests included checking of proper display of data at the Telecorp Wall Display PLUS Client, and of comparing the displayed data with the real-time split/skill and integrated split/skill comparison reports from the Avaya CMS Supervisor.

### 7.2. Test Results

All test cases were executed and passed.

There was one observation from the compliance testing. For data parameters that involved time, such as Average Speed Answer and Average Abandon Time, the Avaya CMS Supervisor rounded the data to the nearest second, whereas the Telecorp Wall Display Shub Server truncated the data to the nearest second.
8. Verification Steps
This section provides the tests that can be performed to verify proper configuration of Avaya CMS Supervisor and Telecorp Wall Display PLUS.

8.1. Verify Avaya CMS Supervisor
From the Avaya CMS Supervisor screen, select Tools > Maintenance from the menu bar.

The Maintenance screen is displayed. Select the Operations tab, and select Connection Status. Click OK.

The Connection Status screen is displayed next. Select the proper system from the ACD(s) field drop-down list, in this case “devcon31”, and click on the Find a Match icon circled below. Verify that the updated screen shows the Session field to be in “data transfer” and “normal”, and that the Connection field to be “operational”.
8.2. Verify Telecorp Wall Display PLUS
Prior to verifying Telecorp Wall Display PLUS, make calls to the measured split/skill groups on Avaya Communication Manager, to enable measurement data to be sent to Avaya CMS.

8.2.1. Launch Telecorp Wall Display PLUS Client
From the Telecorp client PC, start the Telecorp Wall Display PLUS Client application by selecting Start > All Programs > Telecorp > BigClient. The Connect to Software Hub screen is displayed. Enter the IP address of the Telecorp Wall Display Shub Server into the IP Address field. Retain the default values in the remaining fields, and click OK.

The Wall Display PLUS Client screen is displayed. Select (Plasma) Plasma Display.2.2.0 from the Available Displays field drop-down list.
The **Wall Display PLUS Client** screen is updated. Click and drag the **Table** icon from the left pane into the right pane, as shown below. Double-click in the **Win1... Table object Data Source** in the right pane.

![Wall Display PLUS Client screenshot](image)

The **Table Properties** screen is displayed. In the **Data Source** column, select **Avaya Supervisor**.

![Table Properties screenshot](image)
The screen is updated with parameters in the Available Groups column. In the Available Groups column, select the split/skill group dictionary names from Section 4.1.

The screen is updated with parameters in the Source Elements column. Double click on each desired parameter from the Source Elements column, to move the selection to the Selected Elements column. The selected parameters will be displayed onto the plasma display. Click Next.
The **Table Properties** screen is updated, as shown below. Click **Finish**.

The **Wall Display PLUS Client** screen is displayed again. Click on the **Send Display Data** icon toward the top of the screen.
The **Display Viewer** screen is displayed with the actual split/skill data captured via Avaya CMS Supervisor.

Below is a sample screenshot showing additional customization that can be made to the plasma display, including Rich Site Summary (RSS) feed, video feed, table display, graph display, and ticker threshold text display.

<table>
<thead>
<tr>
<th>Data Source</th>
<th>ACD Calls</th>
<th>Abn Calls</th>
<th>Avg ACD Time</th>
<th>Avg Abn Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Telecorp skill 510</td>
<td>10</td>
<td>4</td>
<td>01:35</td>
<td>01:39</td>
</tr>
<tr>
<td>Telecorp skill 520</td>
<td>17</td>
<td>4</td>
<td>02:19</td>
<td>00:15</td>
</tr>
</tbody>
</table>

**XYZ CORPORATE NEWS -- After an excellent first quarter, XYZ antic...**
9. Support
Technical support on Telecorp Wall Display PLUS can be obtained through the following:

- **Web:**  [www.telecorpproducts.com](http://www.telecorpproducts.com)
- **Phone:**  800-634-1012
- **Email:**  support@telecorpproducts.com

10. Conclusion
These Application Notes describe the configuration steps required for Telecorp Wall Display PLUS to interoperate with Avaya CMS, via the Avaya CMS Supervisor interface. All feature and serviceability test cases were completed successfully.

There was one observation from the compliance testing. For data parameters that involved time, such as Average Speed Answer and Average Abandon Time, the Avaya CMS Supervisor rounded the data to the nearest second, whereas the Telecorp Wall Display Shub Server truncated the data to the nearest second.

11. Additional References
This section references the product documentation relevant to these Application Notes.


- *CentrEE Wall Display / PLUS User Guide*, available as part of the Telecorp Wall Display PLUS Client software install.