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Abstract 
 
These Application Notes describe the configuration steps required for the Telephonetics Audio 
File Download Utility to work with Avaya Voicemail Pro.  The Telephonetics Audio File 
Download Utility provides users with a mechanism for managing the replacement of 
Voicemail Pro audio files with audio files professionally recorded by Telephonetics. Features 
and functionality were validated.  Information in these Application Notes has been obtained 
through interoperability compliance testing and additional technical discussions.  Testing was 
conducted via the DeveloperConnection Program at the Avaya Solution and Interoperability 
Test Lab. 
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1. Introduction 
These Application Notes describe the compliance-tested configuration utilizing Avaya 
Voicemail Pro 2.1(10) and Telephonetics Audio File Download Utility 1.0.  
 
Telephonetics Audio Message Management Services provide professionally produced audio files 
for use in the automated attendant and/or interactive voice response modules defined within 
Voicemail Pro. Telephonetics, as part of this service, will work with customers to set up a 
connection (VPN, dial-up, etc) between the Telephonetics Customer Relationship Management 
server and the customer’s Voicemail Pro server for audio file updates.  The Telephonetics Audio 
Messaging Management Services and the connection schemes supported by this service are 
beyond the scope of DevConnect compliance testing.  DevConnect compliance testing for this 
solution focused on the Telephonetics Audio File Download Utility and its ability to update 
locally recorded automated attendant and/or interactive voice response audio files in the Avaya 
Voicemail Pro server.  
 
The Telephonetics Audio File Download Utility is installed on the Avaya Voicemail Pro server.  
The Audio File Download Utility does not directly interoperate with IP Office or Voicemail Pro; 
it works with an exported text file view of the Voicemail Pro configuration.   The Audio File 
Download Utility uses telnet (port 23) to transfer the Voicemail Pro configuration text file to the 
Telephonetics Customer Relationship Management (CRM) server.  Telephonetics references the 
uploaded configuration when an order for new audio files is placed either online or by telephone.  
Once the new audio files are placed in the Telephonetics CRM server, the Audio File Download 
Utility is used to download each audio file sequentially to a temporary directory then transfer the 
file to the appropriate directory and file name on the Voicemail Pro server.  
 
The Telephonetics Audio File Download Utility is used for the following reasons: 
 

1. Upload the latest text file representation of the Voicemail Pro configuration – this 
information is used by Telephonetics services to determine proper placement of the 
replacement audio files ordered for the Voicemail Pro modules provided in the 
configuration. 

 
2. Download replacement audio files to the proper file and directory location on the 

Voicemail Pro server. 
 
The expected User (customer and/or Voicemail Pro administrator)  / Telephonetics interaction is 
as follows: 
 

• User creates a new module in Voicemail Pro and locally records audio file(s) for the 
module. 

• User views configuration as text, saves it to a text file and uploads the saved text file to 
the Telephonetics CRM server using the Utility. 



• User contacts Telephonetics services according to prior arrangement, e.g., online web 
order and/or order by phone to order new audio file(s) for the module. 

• Telephonetics arranges for the production of the newly ordered audio file(s). 
• Once new audio files are ready, Telephonetics places new audio files on CRM server and 

contacts the user to download file(s). 
• User uses the Utility to download new audio files and install them to the appropriate 

location on the Voicemail Pro server. 
 
The Telephonetics Audio File Download Utility by its current design should only be used to 
replace audio files for Voicemail Pro Modules and/or Specific Short Code Start Points.  The 
utility can be used to simplify the replacement of audio files for any module listed in the 
exported text file view of the Voicemail Pro configuration.  All other audio files provided by 
Voicemail Pro, that is, system audio files, locally recorded names and/or greetings, etc., would 
require manual replacement and verification of the replacement.  As such, replacement of these 
files was beyond the scope of DevConnect compliance testing.  Additionally, the ‘Campaigns’ 
feature of Voicemail Pro was not tested with the Telephonetics Audio File Download Utility in 
this solution. 
 
The tested configuration is shown in Figure 1.   
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Figure 1: Telephonetics Audio File Download Utility and Avaya Voicemail Pro 
Configuration  
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The Telephonetics CRM server was placed in the same network as the Voicemail Pro server as 
depicted in Figure 1.  In the real world, the Telephonetics CRM server would reside at the 
Telephonetics site.  Telephonetics, as part of their Audio Message Management Services, will 
work with customers to set up the remote connection scheme desired by the customer (VPN, 
dial-up, etc.).  Testing the various connection schemes supported by the service was beyond the 
scope of DevConnect compliance testing. 
 

2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 
Avaya IP 406 Office System 2.1(24) 
Avaya IP Office Manager 4.1(15) 
Avaya IP Office Voicemail Pro 2.1(10) 
Avaya IP Office Feature Key Server 1.0 
Avaya IP Office Feature Key - 
Avaya IP Office Voicemail Pro License - 
Avaya 6408D+, 6416D+M Telephones - 
Telephonetics Audio File Download Utility 1.0 
PC for Avaya IP Office Manager, Avaya Feature Key 
Server, Avaya IP Office Voicemail Pro Server and 
Telephonetics Audio File Download Utility 

Windows 2000 Professional 
Service Pack 4 

Telephonetics CRM Server Windows 2000 Server 
Service Pack 4 

 
 

3. Configure Avaya Voicemail Pro 
 
There is no direct interaction between Avaya IP Office Voicemail Pro and Telephonetics Audio 
File Download Utility. 
 
For the purposes of these Application Notes, the information provided in this section is to show 
the representation of a simple automated attendant whose locally recorded audio files were 
replaced by those provided by Telephonetics.  This section also provides information on how to 
create a text file representation of the Automated Attendant module created for use with the 
Audio File Download Utility. 
 
For all other provisioning information, such as, installation, module creation, locally recording 
audio files, etc., please refer to the IP Office Voicemail Pro documentation listed in the 
Additional References section of this document. 
 



 

3.1. How to Create New Modules and/or Start Points in Voicemail Pro 
 

Step Description 
 Connect to IP Office Voicemail Pro Client 
1.  Log into the IP Office Voicemail Pro server and go to Start → Programs → IP Office → 

Voicemail Pro to launch the Voicemail Pro client. 
 Define AutoAttend Short Code Start Point 
2.  In the Voicemail Pro Client window that appears, go to the top left pane, right-click on 

Short Codes and select Add. 
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Step Description 
3.  In the Adding a new start point popup that appears, set Name to AutoAttend and click 

OK. 
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Step Description 
4.  On the right hand pane of the Voicemail Pro Client window, the entry Short Codes > 

AutoAttend appears.  The following call flow was defined for this short code:  Test 
business hours, if after hours, go to NightMain module.  If not after hours, transfer the call 
to the desired destination based on caller input, 
 

 
 

5.  Record audio files for the AutoAttend module. 
 Define AutoAttendMod Module 
6.  In the Voicemail Pro Client window, go to the bottom left pane, right-click on Modules 

and select Add. 
7.  In the Adding a new start point popup that appears, set Name to AutoAttendMod and 

click OK. 
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Step Description 
8.  On the right hand pane of the Voicemail Pro Client window, the entry Modules > 

AutoAttendMod appears.  The following call flow was defined for this module:  Go to the 
AutoAttend Short Code start point. 

 
 

 Save and activate the configuration  
9.  In the Voicemail Pro Client window, go to File → Save & Make Live to save the 

configuration and make it accessible to callers. 
 
 

3.2. How to Save the Configuration to Text  
 

Step Description 
 Connect to IP Office Voicemail Pro Client 
1.  Log into the IP Office Voicemail Pro server and go to Start → Programs → IP Office → 

Voicemail Pro to launch the Voicemail Pro client. 
 Export configuration for use with Telephonetics Audio File Download Utility 
2.  In the Voicemail Pro Client window, go to File → View as Text… to view the 

configuration in text format. 
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Step Description 
3.  In the ViewAsText – Notepad window that appears, go to File → Save As… to save the 

file to text. 
 

 
4.  In the Save As popup that appears, save the file to the directory and filename desired.  For 

the purposes of these Application Notes, the configuration was saved to 
D:\members\telephonetics\VMPro-Cfg-120104-1332.txt. 

5.  Exit from Notepad and the Voicemail Pro client. 
 

4. Configure Avaya IP Office 
 
There is no direct interaction between Avaya IP Office and Telephonetics Audio File Download 
Utility. 
 
The configuration information provided in this section describes the basic provisioning required 
to set up IP Office and Voicemail Pro as well as the basic steps needed to call a simple 
automated attendant module defined in Voicemail Pro.  This information has been supplied for 
completeness. 
 
For all other provisioning information, such as provisioning of the trunks for regular inbound and 
outbound dialing, call coverage, extensions, etc., please refer to the IP Office documentation 
listed in the Additional References section of this document. 
 



 
Step Description 

 IP Office Feature Key Physical Installation 
1.  Plug in the Avaya feature key into the appropriate port on the Avaya IP Office Feature Key 

Server PC, e.g., serial, parallel, USB. 
 Connect to IP Office 
2.  Log into the IP Office Manager PC and go to Start → Programs → IP Office → 

Manager to launch the Manager application. Log into the Manager application using the 
appropriate credentials. 

3.  In the Manager window that appears, select File → Open to search for the IP Office 
system in the network. 

4.  Log into the IP Office system using the appropriate login credentials to receive its 
configuration. 

 Configure License Key Server IP Address 
5.  In the Manager window, go to the Configuration Tree and double-click System.  In the 

System Configuration window that appears, select the System tab and set License Server 
IP Address to the IP address of the machine to which the red Avaya Software Sentinel key 
is connected, e.g., 192.45.70.36.  This is typically the IP Office Manager PC. 
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Step Description 
6.  In the Voicemail tab of the System Configuration window, select the PC radio button for 

Voicemail Type, set Voicemail IP Address to the IP address of the Voicemail Pro server, 
e.g., 192.45.70.36 and click OK.  
 

 
 

 Setup Auto Attendant short code (dial this short code to access auto attendant) 
7.  In the Manager window, go to the Configuration Tree and double-click Shortcode to open 

the list of short codes installed in the IP Office system.   
8.  Right click in the short code list window and select New. In the Shortcode window that 

appears, set Short Code to *90, Telephone Number to AutoAttend, Feature to 
VoiceMailNode, and click OK. 
 

 



 
Step Description 

 Route incoming calls to the Automated Attendant Module 
9.  In the Manager window, go to the Configuration Tree and double-click Incoming Call 

Route to open the list of incoming call routes in the IP Office system.   
10.  Right click in the incoming call route window and select New.  In the Incoming Call Route 

window that appears, set Line group ID to the ID used for all trunks that are to be directed 
to the Automated Attendant module, e.g., 0, set Destination to the module defined in 
Voicemail Pro for the automated attendant, e.g., VM:AutoAttendMod.  Click OK. 
 

 
NOTE 1: An alternate approach could have been to set Destination to *90 which would 
have directed incoming calls to the AutoAttend short code rather than the AutoAttendMod 
module in Voicemail Pro.  These are two distinct start points in Voicemail Pro.  For further 
information and/or examples, please refer to the Voicemail Pro documentation listed in the 
Additional References section of this document.  
 
NOTE 2: Do not define conflicting incoming call routes.  If Line group ID 0 is already in 
use, redundant entries will prevent calls from being routed as desired. 

 Install Voicemail Pro License Key  
11.  In the Manager window, go to the Configuration Tree and double-click License to open 

the list of licenses installed in the IP Office system.   
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Step Description 
12.  Right click in the license list window and select New. In the License window that appears, 

enter the Voicemail Pro License Key and click OK. 
 

 
13.  In the Manager window, select File → Save to save the licenses to the IP Office system 

and wait for the system to update.  The system reload validates the new license. 
 

5. Use the Telephonetics Audio File Download Utility 
This section addresses use of the Audio File Download Utility as it relates to using the text file 
representation of the Voicemail Pro configuration. 
 
For all other provisioning information, such as installation of the Audio File Download Utility 
and/or setting up the remote connection between the Telephonetics CRM server and the 
Voicemail Pro server, please contact Telephonetics services and technical support. 
 

5.1. How to Send Configuration to Telephonetics CRM server 
 

Step Description 
 Launch the Utility 
1.  Log into the Voicemail Pro server with the appropriate administrative privileges.  Go to 

Start → Programs → Telephonetics → Telephonetics Audio File Download Utility.  



 
Step Description 

 Set up session with Telephonetics CRM server 
2.  In the Telephonetics Phone System File Download Utility window that appears, set Server 

to the CRM server name provided by Telephonetics, e.g., REM-SERVER, set User Name 
to the ID provided by Telephonetics, e.g., fpalacio@telephonetics.com, and set Password 
to the password provided by Telephonetics. Click Connect.  The connection to the CRM 
server is successfully established when the CRM server populates Select Phone System 
with AVAYA IP403. This is a label that is assigned by Telephonetics to identify the 
system.  
 

  
3.  In the Telephonetics Phone System File Download Utility window, go to Upload → 

Configuration. 
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Step Description 
4.  In the Open window that appears, browse to the text file view of the Voicemail Pro 

configuration saved and click Open. 
 

 
5.  In the Telephonetics Phone System File Download Utility window, go to View → Log 

File to verify the configuration was successfully sent to the CRM server. 
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Step Description 
6.  In the View Log window that appears, verify the entry Successful Configuration Upload 

appears to confirm the configuration was successfully sent to the CRM server. 
 

 
7. TThis completes the steps necessary to send the configuration to the CRM server. 

 



 

5.2. How to Download Ordered Audio Files 
This section addresses how to download ordered audio files once they are made available on the 
CRM server.   Audio files may be ordered from Telephonetics by Telephone or online based on 
prior arrangement. 
 

Step Description 
 Launch the Utility 
1.  Log into the Voicemail Pro server with the appropriate administrative privileges.  Go to 

Start → Programs → Telephonetics → Telephonetics Audio File Download Utility.  
 Set up session with Telephonetics CRM server 
2.  In the Telephonetics Phone System File Download Utility window that appears, set Server 

to the CRM server name provided by Telephonetics, e.g., REM-SERVER, set User Name 
to the id provided by Telephonetics, e.g., fpalacio@telephonetics.com, and set Password 
to the password provided by Telephonetics. Click Connect.   
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Step Description 
3.  In the Telephonetics Phone System File Download Utility window, verify the connection 

to the CRM server is successfully established by confirming the CRM server populates 
Select Phone System with AVAYA IP403 and the File View pane is populated with the 
replacement audio files that are available for download.  Click Browse. 
 

 
4.  In the Browse for Folder popup that appears, browse to the root directory where the locally 

recorded audio files are located, e.g., C:\Program Files\Avaya\IP Office\Voicemail 
Pro\VM\WAVS, and click OK. 
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Step Description 
5.  In the Telephonetics Phone System File Download Utility window, click Compare Phone 

System Files. 
 

 
NOTE:  If Download were clicked instead of Compare Phone System Files, all the audio 
files would simply be downloaded. 



 
SCR; Reviewed: 
SPOC 3/10/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

20 of 24 
telphntcs-ipo.doc 

 

Step Description 
6.  In the Download Files window that appears, all files selected for download appear in the 

bottom half of the window.  To remove files from the download list, highlight them and 
click Remove Selected.  The rejected files would then be moved to the top half of the 
window.  Once the final selection is made for file download, click Download Files to 
download the files.  To close the window, click Cancel. 
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Step Description 
7.  In the Telephonetics Phone System File Download Utility window, go to View → Log 

File to verify the files were downloaded successfully and moved to the appropriate 
location in the Voicemail Pro server. 
 

 
 

6. Interoperability Compliance Testing 
This Interoperability Compliance Test included feature and functionality testing.  Feature and 
functionality testing examined the Telephonetics Audio File Download Utility’s ability to work 
with the text file view of the Avaya IP Office Voicemail Pro configuration. Audio file 
replacement was verified both visually through Microsoft Windows Explorer and audibly by 
calling the appropriate module and listening to the audio prompt.   
 

6.1. General Test Approach 
Feature and functionality testing was performed manually.  The IP Office was setup with 
Voicemail Pro and a short code was defined to access the Voicemail Pro automated attendant 
module defined for testing.  The Voicemail Pro client was used to create a simple automated 
attendant with locally recorded audio files.  The configuration was saved as a text file, which was 
accessible to the Audio File Download Utility.  The Audio File Download Utility was used to 
upload the configuration to the CRM server as well as download replacement audio files.  The 
audio files were downloaded both while calls were in progress and navigating through the 
defined Voicemail Pro modules and while there was no call activity.   
 
Performance and load testing was beyond the scope of DevConnect compliance testing for this 
solution because Telephonetics recommends customers limit audio file replacements during 
system down times and the Audio File Download Utility is meant for usage in short durations. 
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6.2. Test Results 
Most feature and functionality test cases passed.  All issues and/or observations noted during 
testing are presented in Section 6.2.1 of these Application Notes. 

6.2.1. Compliance Test Notes / Observations 
• Utility released mouse too soon during a slow configuration upload.  The Utility 

released the mouse before the configuration file upload was complete.  To prevent issues 
requiring assistance at the CRM server, users should refrain from other activity on the 
Utility including exiting the program until confirmation that the ‘Successful 
Configuration Upload’ message appears in the Log File. 

• Utility meant for incremental audio file replacement.  If the customer requires the 
initially provided set of audio files to be replaced, e.g., for server replacement scenarios, 
Telephonetics usually provides the complete set via other means, e.g., CD or zip.  The 
Utility is meant for incremental audio file replacements. 

7. Verification Steps 
The following steps can be used to verify system operation after a field installation and the 
connection to the CRM server is setup in conjunction with Telephonetics Technical Support. 

• Create a new module in Voicemail Pro, locally record audio files for it, and make it live. 
(Section 3.1) 

• Generate a text file view of the Voicemail Pro configuration (Section 3.2) 
• Define a short code in IP Office to access the new module and listen to the audio files. 

(Section 4) 
• Send the Voicemail Pro configuration to the Telephonetics CRM server. (Section 5.1) 
• Download replacement audio files from the Telephonetics CRM server. (Section 5.2) 
• From an internal extension, dial the short code defined to access the module and verify 

Voicemail Pro plays the new audio files rather than the locally recorded ones. 
 

8. Support 
Customers should call the Telephonetics Customer Service Center when having network 
connectivity problems to the Telephonetics CRM server and/or problems related to the Audio 
File Download Utility product.  Telephonetics will determine the nature of the problem and 
recommend the best plan to the customer, whether it is to: 
 Fix the problem through remote access. 
 Dispatch, at Telephonetics’ discretion, on-site technical support. 

 
For technical support on the Audio File Download Utility software, contact the Telephonetics 
Customer Service Center at (800) 446-5366 x5995.  Technical support email can be sent to 
avaya@telephonetics.com.  
 

mailto:avaya@telephonetics.com
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9. Conclusion 
These Application Notes describe the required steps for Telephonetics Audio File Download 
Utility to successfully replace locally recorded audio files in locally defined Avaya Voicemail 
Pro modules.  Features and functionality were successfully validated. 
 

10. Additional References  
Avaya IP Office Installation Manual, 40DHB0002USCL, Issue 10c (5/11/2004) 
 
Avaya IP Office 2.1 Voicemail Pro 2.1 Installation and Maintenance, 40DHB0002USAW, Issue 
12mk (11/23/2004) 
 
Avaya IP Office – Job Aid Voicemail Pro (2.0) Example Exercises, 048, Issue 3 (10/30/2003) 
 
Telephonetics Audio File Download Utility Installation documentation can be found at 
http://avaya.telephonetics.com  

http://avaya.telephonetics.com/
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