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Abstract 
 

  
These Application Notes describe the configuration steps required for Resource Software 
International Shadow Call Management Software (CMS) to work with Avaya IP Office.  
Shadow CMS is an application that captures Simple Message Detail Records (SMDR) / Call 
Detail Records (CDR) from Avaya IP Office. Call activity can be reported by extension, trunk, 
and account code.  Information in these Application Notes was obtained through compliance 
testing and additional technical discussions.  Testing was conducted via the 
DeveloperConnection Program at the Avaya Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes describe the configuration steps required for RSI Shadow CMS to work 
with Avaya IP Office. This call accounting product is distributed under the brand name Shadow 
within the United States and TeleCOST outside of the United States.  This software can price 
calls using most commercially available carrier rate plans subscribed to by customers.  The 
Report Generator provides users with access to both detail and summary reports.  Shadow CMS 
is multi-site ready, supporting up to 10,000 unique locations, each with up to 10,000 extensions.  
The software can price calls using up to five different carriers or rate plans.  A built-in Job 
Scheduler permits automatic, unattended generation of reports at scheduled intervals (i.e., daily, 
weekly, monthly, etc.).  Most environments can install this application on an existing non-
dedicated computer.  
 
Shadow CMS is an application that listens for CDR/SMDR records from Avaya IP Office.  The 
Shadow CMS winlink data collection module is used to listen for CDR/SMDR information from 
Avaya IP Office.  This module is normally installed on the same computer as the Shadow CMS 
Administration/Reporting module, but can be deployed on a different computer.  Call activity 
can be reported by extension, trunk, and account code. 
 
The configuration in Figure 1 shows a network consisting of an Avaya IP Office 412, Avaya IP 
Office Manager/Voicemail Pro PC, RSI Shadow CMS, and Avaya 4600 Series IP Telephones 
connected to an Avaya C363T-PWR Converged Stackable Switch.  Avaya 6400 Series Digital 
Telephones are connected to an Avaya IP400 Digital Station Module that connects to Avaya IP 
Office. 
 
Avaya IP Office 412 has T1, PRI and analog trunks to the central office.  Avaya IP Office is 
configured to generate CDR data for all inbound, outbound, and internal calls. 
 
Avaya IP Office CDR is configured to send the CDR records to a user-configured IP address and 
port.  The Shadow CMS winlink module is configured to listen on the port configured on IP 
Office for CDR data.  Once winlink receives the raw CDR data from IP Office, Shadow CMS 
translates the CDR record, and then stores the record for later retrieval and/or reporting by the 
end user. 
  
The tested configuration is shown in Figure 1.   
 



 
Figure 1 – Network Configuration Diagram 

 

2. Equipment and Software Validated 
The following products and software were used for the configuration in Figure 1: 
 

Product Software/Version 
Avaya IP Office 412 3.1(48) 
Avaya IP400 Office Analog Trunk Module 5.1(48) 
Avaya IP400 Office Digital Station Module 5.1(48) 
Avaya IP400 Office Phone Module 5.1(48) 
Avaya IP Office Manager 5.1(48) 
Avaya Voicemail Pro 3.1(16) 
Avaya Feature Key Server 1.0 
Avaya 4602SW IP Telephones 1.8 
Avaya 4620SW IP Telephones 2.3 
Avaya 6408D+ Digital Telephones - 
Avaya C363T-PWR Converged Stackable Switch 4.3.12 
RSI Shadow Call Management Software 4.1.0 
PCs for Avaya IP Office Manager, Avaya Voicemail 
Pro, and RSI Shadow CMS 

Windows 2000 Professional 
Service Pack 4 

 
Table 1 – Product and Software Version  
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3. Configure Avaya IP Office 
The configuration information provided in this section describes the steps required to set up 
Avaya IP Office to generate CDR data to a user-defined destination IP address and port. 
 
For all other provisioning information, such as Avaya IP Office installation and configuration, 
etc., please refer to Avaya IP Office product documentation in reference [1]. 
 
Step Description 

 Login 
1.  Log into the IP Office Manager PC and go to Start → Programs → IP Office → Manager 

to launch the Manager application. Log into the Manager application using the appropriate 
credentials. 

2.  In the Manager window that appears, select File → Open to search for the IP Office system 
in the network. 

3.  Log into IP Office using the appropriate login credentials to receive its configuration. 
 Enable CDR 
4.  In the Manager window, go to the Configuration Tree and double-click System.  In the CDR 

tab of the System Configuration window that appears, check Enable CDRs, set IP Address 
to the IP address of the RSI Shadow CMS PC, set IP Port to the port that the RSI Shadow 
CMS will listen on, check Enable intra-switch CDRs, select Expanded for Record Format, 
select Month\Day for Date Format, select Normal for Record Options and click OK. 
 

 
 

5.  In the Manager window, select File → Save to push the configuration to IP Office and wait 
for the system to update.  This completes configuration of Avaya IP Office CDR. 
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4. Configure RSI Shadow CMS 
The configuration information provided in this section describes the steps required to configure 
RSI Shadow CMS to listen for CDR records from Avaya IP Office. 
 
For all other provisioning information, such as software installation, installation of optional 
components, configuration of Shadow CMS for call accounting, report generation, etc., please 
refer to the RSI Shadow CMS product documentation in references [2] and [3]. 
 
The information provided in this section assumes the Shadow CMS has already been 
successfully installed and licensed on the PC. 
 

Step Description 
 Run Configuration Wizard 
1.  Log into the Shadow CMS PC with the appropriate administrative credentials and navigate to 

Start → Programs → RSI → CMS → Configuration Wizard. 
2.  In the RSI Call Accounting Configuration Creator window that appears, click Next to step 

through the configuration screens. 
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Step Description 
3.  In the Configuration Creator - Customer Information window, fill in the required information 

and click Next. 
 

 
 

4.  In the Configuration Creator - PBX/Key System Definition window, select G3EXPAND 
AVAYA DEFINITY (Expanded Format) for Telephone System, check Telephone System 
Supports Calling Line Identification (CLID), select Text File for Collect Call Records 
Using and click Next. 
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Step Description 
5.  Continue to click on the Next button in the screens that follow modifying defaults as needed 

for local configuration until the Configuration Creator - Setup Completed window appears, 
then click Finish. 
 

 
6.  In the Save Configuration File popup that appears, save the configuration to the entity 

number for this configuration such as Entity 0001 and click Ok.  The Configuration Wizard 
will close after the Ok button is pressed. 
 

 
 



 
Step Description 

 Configure CMS application 
7.  Launch Shadow CMS by clicking Start → Programs → CMS → CMS. 
8.  In the Entity popup that appears, select the entity number created in Step 6 and click OK. 

 

 
 

9.  In the SHADOW Voice and Data Management CMS window that appears, select File → 
Properties in the pull-down menu. 
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Step Description 
10.  In the Properties window that appears, select the Data → CDR tab.  Select Winlink IP & 

Serial Data Storage for Source Input Mode and select G3EXPAND AVAYA DEFINITY 
(Expanded Format) for Driver Name, and then click Configure. 

 
11.  In the winlink window that appears, select Configure → Data Source. 
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Step Description 
12.  In the Data Source popup that appears, select Socket Listener for Select the Winlink data 

source and click OK. 
 

 
 

13.  In the Warning popup that appears, click OK. 
 

 
 

14.  In the Properties window, click Configure again to return to the winlink window. 
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Step Description 
15.  In the winlink window, select Configure → Telnet or Socket Settings… from the pull-

down menu. 
 

 
 

16.  
 

In the IP Configuration window that appears, set Name (or IP address) to the IP address of 
the Shadow CMS PC, Port to the port number configured in the IP Office CDR configuration 
form in Section 3, Step 4, and select TCP for Protocol. Click OK. 
 

 
 

17.  In the winlink window, select Configure → Listen from the pull-down menu to put winlink 
into listen mode.  This completes configuration of Shadow CMS. 
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5. Interoperability Compliance Testing 
Interoperability compliance testing evaluated the ability of Shadow CMS to collect and process 
CDR records for various types of calls (inbound, outbound, internal, transfer, conference, etc.).  
A load test involving a high volume of calls was executed for one to two hours.  Shadow CMS 
was configured to automatically retrieve, process, and store the CDR records for later report 
generation. 
 

5.1. General Test Approach 
The general test approach was to manually place intra-switch calls, inbound trunk and outbound 
trunk calls to and from telephones attached to Avaya IP Office and verify that Shadow CMS 
collects the CDR records and properly classifies and reports the attributes of the call.  For the 
load test, a call generator was used to place 6080 calls over a two hour period with Shadow CMS 
configured to automatically retrieve, translate and store the CDR records for later report 
generation.  Upon completion of the load test, the number of calls placed by the call generator 
matched the number of CDR records processed and reported by Shadow CMS. 
 

5.2. Test Results 
All feature and performance test cases that were executed passed. Shadow CMS successfully 
captured and processed call records from Avaya IP Office.  For serviceability testing, Shadow 
CMS was able to resume CDR record collection for outages where Avaya IP Office was reset or 
lost network connectivity without requiring manual intervention.   In cases where the Shadow 
CMS computer lost power or its network link, Shadow CMS was able to successfully resume 
collecting CDR records once it was back online but not for CDR records for calls that were 
placed during the outage.  Since the current IP Office CDR implementation does not support 
Reliable Session Protocol, there is a chance of CDR record loss if there is a network failure.   
 
The following observations were made during testing: 

• Note1 - Shadow CMS reports calls as Inbound, Outbound, or Internal.  It does not 
identify calls participating in either a conference call, transfer or going to voicemail. 

 
• Note2 – CDR records for internal call transfer do not match call-splitting behavior 

described in IP Office documentation.  For example, when A (x6501) calls B (x6502), B 
transfers the call to C (x6504), the IP Office call splitting documentation states that two 
CDR records will be generated with the first one listing A as the calling number and B as 
the dialed number, and the second one listing A as the calling number and C as the dialed 
number.  The CDR records generated list A as the calling number and B as the dialed 
number for the first record (correct), and B as the calling number and C as the dialed 
number (incorrect) for the second record. 
Status: Issue #BugDB00027272 was filed with the IP Office team. 

 
 



• Note3 – CDR records for calls answered by Voicemail show Voicemail as the answering 
extension.  Shadow CMS translates and reports calls answered by Voicemail as answered 
by extension 0000000. 
Status: RSI has been informed of this behavior. 
 

• Note4 – CDR records for calls to retrieve voicemail shows ‘?<vm extension number>’ as 
destination number, e.g., ‘?6501’.  Shadow CMS strips non-numeric values from the 
calling/destination number so that the report for this CDR record will show extension 
x6501 calling x6501. 
Status: RSI has been informed of this behavior. 
 

• Note5: IP Office CDR does not provide DNIS information in generated CDR records. 
 

6. Verification Steps 
The following steps may be used to verify the configuration: 
 

Step Description 
1.  Place a call to a telephone attached to Avaya IP Office, answer the call, and drop the call after 

a few seconds. 
 To view raw CDR record received by Shadow CMS, look at the winlink window: 
2.  A CDR record such as the one listed below will appear in the winlink window after the call is 

dropped. 
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Step Description 

 To manually translate the CDR record into the CMS call records database: 
3.  In the SHADOW Voice and Data Management CMS window, select File → Translate in the 

pull-down menu to manually translate the CDR record. 
 

 
 

4.  In the Translate Data window that appears, click OK.  Note: Shadow CMS can be configured 
to automatically translate CDR data at user-defined time intervals. Please refer to the Shadow 
CMS documentation for information on how to configure this. 

 To view CDR record parsed and stored by Shadow CMS into its database: 
5.  In the SHADOW Voice and Data Management CMS window, select Database → Calls 

Database to view the incoming call parsed by Shadow CMS. 
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Step Description 

 To view CDR record in a sample Shadow CMS report: 
6.  In the SHADOW Voice and Data Management CMS window, select Report → 

Chronological → Chronological Detail to view a report for the incoming call. 
 

 
 

 

7. Support 
Technical support for Shadow CMS can be obtained by contacting Resource Software 
International Systems, Ltd. at: 

• Phone:   800.891.6014 / 905.576.4575 
• E-mail:  support@telecost.com 
• Web:     www.telecost.com 

 

8. Conclusion 
These Application Notes describe the steps for configuring the RSI Shadow CMS to retrieve 
SMDR/CDR data from Avaya IP Office.  All test cases completed successfully.   
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http://www.telecost.com/
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9. References 
The following Avaya product documentation can be found at http://support.avaya.com: 
 
[1] Avaya IP Office 3.1 Installation Manual, Issue 13l (23rd January 2006) 
 
The following Resource Software International product documentation is installed to the hard-
drive during the CMS installation process: 
 
[2] CMS Startup Guide 
[3] CMS User Guide 
 
 
 
 

http://support.avaya.com/
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