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Abstract 
 

  
Resource Software International Visual Rapport is a visual communication console application 
that provides telephone features, telephone status, and screen pop capabilities at the extension 
user’s client computer.  These Application Notes describe the configuration steps required for 
Visual Rapport features such as Answer, Hang Up, Hold, Transfer, Park, and screen pop, to 
interoperate with Avaya IP Office systems. 
 
Information in these Application Notes has been obtained through DevConnect compliance 
testing and additional technical discussions.  Testing was conducted via the DevConnect 
Program at the Avaya Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes describe the configuration steps required for Resource Software 
International (RSI) Visual Rapport to work with Avaya IP Office.  Visual Rapport is an 
integrated visual communication console application that provides real-time telephone status, 
telephone feature dialing, and screen pop capabilities, under one application.   
 
Visual Rapport makes call handling simple.  Visual Rapport can perform time-consuming 
telephony functions (including Call, Answer, Hold, Park, and Transfer) with a few mouse-clicks.  
When an incoming call arrives, Visual Rapport can unobtrusively display the incoming Caller ID 
information and allows for a decision to be made about the call. 
 
Using Visual Rapport, incoming calls can be linked with information that exists in a database or 
contact management applications, such as Access, Outlook, Act!, Maximizer, Goldmine or a 
custom application.  As an example, a travel agency with a proprietary customer database could 
use Visual Rapport to receive screen pops at every agent’s desktop and access the details of each 
customer’s travel plans from the Visual Rapport database. 
 
Visual Rapport consists of a server module and a client module.  Each Visual Rapport client 
interfaces with Avaya IP Office via TAPI 1st party call control, and in this case connects a 
telephone directly to a PC.  The Avaya IP Office TAPI driver must be installed on the Visual 
Rapport client PC to establish the connection to Avaya IP Office for the extension to be 
controlled by the Visual Rapport client. 
 
The Visual Rapport clients also connect to the Visual Rapport server.  The Visual Rapport 
server, with its Directory Services facilities, authenticates each Visual Rapport client and 
manages the data exchange between the Visual Rapport clients on the network.  Communication 
between the Visual Rapport clients and server can be accomplished by multicasting or 
broadcasting.  For the purposes of these Application Notes, the Visual Rapport clients and server 
were configured with broadcasting.  
 
The configuration in Figure 1 shows a network consisting of Avaya IP412 Office, Avaya IP406 
Office V2, Avaya IP Office Manager PC, Visual Rapport server and clients connected to the 
various networks.  Avaya IP412 Office has PRI and Analog trunks to the central office.  Avaya 
IP406 Office V2 can also access the central office facilities over the Small Community Network 
(SCN).  Avaya IP Office SCN networks allow dial plan information to be share between Avaya 
IP Office systems.  SCN networks are also used to collectively ring extensions across two (or 
more) Avaya IP Office systems by dialing a single hunt group extension.  For example, an 
incoming PRI call was routed to ring hunt group extension 55440 in this configuration.  As a 
result, all three Visual Rapport clients described in Figure 1 are alerted. 
 



Each of the Visual Rapport clients in Figure 1 is configured with TAPI 1st party call control 
connectivity to Avaya IP Office and is registered to a distinct Avaya IP Office extension.  Refer 
to Table 1 for the mapping of extensions to Visual Rapport clients and to Visual Rapport login 
user IDs.  
 

Client Avaya IP Office 
Extension 

Visual Rapport 
Client User ID 

Visual Rapport Client 1 55262 John Smith 
Visual Rapport Client 2 55263 Tim Smith 
Visual Rapport Client 3 45320 John Adams 

 
Table 1 – Client/Extension/User ID Mapping 

 
The tested configuration is shown in Figure 1.   

 
Figure 1 – Network Configuration Diagram 
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Avaya IP412 Office system was configured to route incoming calls to hunt groups or specific 
extensions, based on the test case being executed.  For an incoming trunk call, Avaya IP412 
Office routed the call to the destination extension.  While this event occurred, Avaya IP Office 
also sent TAPI 1st party call control signaling to the Visual Rapport client associated with the 
destination extension.  The user then received visual notification of the incoming call from the 
Visual Rapport client in addition to the audible notification from the telephone.  The Visual 
Rapport client could be configured to take different actions during an incoming call.  For the 
purposes of compliance testing, one of the three Visual Rapport clients was configured to 
generate a screen pop after two seconds, when an incoming call was answered at that extension.  
For example, when receiving an incoming call, the Visual Rapport client assigned to extension 
55263 was setup to launch Microsoft Notepad and immediately display the caller’s information 
(Section 5.2.1).  

2. Equipment and Software Validated 
The following products and software were used for the configuration in Figure 1 

Figure 1: 
 

Product Software/Version 
Avaya IP412 Office 4.0.10 
Avaya IP406 Office V2 4.0.10 
Avaya IP400 Phone Module 6.0.10 
Avaya IP400 Digital Station Module 6.0.10 
Avaya IP Office Manager 6.0.10 
Avaya 4620SW IP Telephone 2.3 
Avaya 5620SW IP Telephone 2.3 
Avaya 2420 Digital Telephone 5.0 
Avaya 5420 Digital Telephone 5.0 
Visual Rapport server 2.08 
Visual Rapport client 2.08 
Avaya C364T – PWR Converged Stackable Switch 4.5.14 
PCs for Avaya IP Office Manager and Resource 

Source International Visual Rapport server and 
clients 

Windows 2003 XP 
Professional Service Pack 2 

 
Table 2 – Product and Software Version  

3. Configure Avaya IP Office 
The configuration information provided in this section describes the steps required to set up user 
extensions and passwords on Avaya IP Office.  While this is part of a typical Avaya IP Office 
configuration, the information is needed for the TAPI driver configuration on the Visual Rapport 
clients. 
 



For other information, such as Avaya IP Office installation and configuration, etc., please refer to 
the Avaya IP Office product documentation in Reference [1].  Except where noted, similar 
configurations are performed on each Avaya IP Office systems. 
 

1. From the Avaya IP Office Manager PC, go to Start → Programs → IP Office → 
Manager to launch the Avaya IP Office Manager application. Log into the Avaya IP 
Office Manager application using the appropriate credentials. 

 
2. In the Avaya IP Office Manager window that is displayed (not shown), select File → 

Open to search for the IP Office system in the network.  Select Avaya IP412 Office. 
 

3. Log into the Avaya IP412 Office system using the appropriate login credentials to receive 
its configuration. 

 
4. In the Avaya IP Office Manager window, go to the configuration tree in the left-hand 

panel and right-click Line and select New → IP Line (not shown).   The screen below 
should display. 

 
In this case, the system automatically assigns 15 as the Line Number (this will vary).  
Place the value 15 in the Incoming Group ID and Outgoing Group ID fields.  Click the 
VoIP Settings tab. 
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5. Set the Gateway IP Address to the IP address of the other Avaya IP Office System (see 
Figure 1).  Check the Voice Networking check-box.  The Voice Networking parameter 
turns on SCN capabilities.  Click OK. 

 
Note: The IP address will be different when administering the other Avaya IP Office 
system. 
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6. Select User on the left-hand panel configuration tree.  In the User list displayed, scroll 
down and select the user and extension name mapped to the first Visual Rapport client 
listed in Table 1.  Assign a password to the Password field for this extension.  Record 
the name and password associated with this extension as this information will be required 
in Section 5.2.  Click OK. 

 
Note:  Extension numbers will be different when administering the other Avaya IP Office 
system 

 

 
 

7. Repeat Step 4 for the remaining extensions listed in Table 1.   
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8. Select License on the left-hand panel configuration tree.  Check that License Type is set 
to Advanced Small Community Networking license is installed and License Status is 
set to Valid.   Note:  This license is required for multiple system hunt group capabilities 
and needs to be installed on all participating Avaya IP Office systems. 

 
Note:  The compliance tests were performed using SCN trunks, where the dial plans and 
hunt groups were shared.  If SCN hunt group functionality is not required, or where only 
one Avaya IP Office system is available, this license is not necessary. 
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9. Create a hunt group by right-clicking on HuntGroup on the left-hand panel 
configuration tree and select New (not shown).  On the right-hand panel, enter a Name 
for the hunt group.  In the Extension field, enter the extension assigned to the hunt group.  
Click on the Add… button and select the extension members from the extension list (not 
shown).  In this case, the name of the hunt group is VRapport, the hunt group extension 
is 55440 and the member extensions are 55262, 55263, and 45320.  Click OK.   

 
Note:  Hunt group administration does not need to be performed on the other Avaya IP 
Office system. 

 

 
 
10. In the Avaya IP Office Manager window, select File → Save to push the configuration 

to the Avaya IP Office system and wait for the system to update.   
 
11. Repeat Steps 1 – 8 and 10 on the Avaya IP406 Office V2 system. This completes 

configuration of Avaya IP Office. 
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4. Configure Resource Software International Visual Rapport 
Server 

The configuration information provided in this section describes the steps required to configure 
user accounts in the Visual Rapport server.  Only one Visual Rapport server is required within 
the infrastructure and the Visual Rapport client can be co-located as illustrated in Figure 1. This 
information is provided for completeness since the Visual Rapport server does not interface with 
Avaya IP Office. 
 
For all other provisioning information, such as software installation, installation of optional 
components, general configuration of Visual Rapport server, please refer to the Visual Rapport 
product documentation in References [2] and [3]. 
 
The information provided in this section assumes the Visual Rapport server has already been 
successfully installed and licensed on the PC. 
 

1. Log into the Visual Rapport server PC with the appropriate administrative credentials. 
 

2. Launch the RSI Visual Rapport Server application from the short-cut installed on the 
Windows desktop.  In the RSI Visual Rapport Server window, click the switch icon to 
turn off the Communication Services. 

 

 
 

3. In the RSI Visual Rapport Server window, select Tools → Directory Services… 
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4. In the RSI Visual Rapport Server – Directory Services window that is displayed, click 
the  in the left-hand panel, enter a Group Name (in the top left corner of the window), 
and then click  to save the information.  In this case, the group name created is Tools.    
Click the  in the right-hand panel, set the Extension to 55262, User Id to JohnSmith, 
and the Password to the password defined in Avaya IP Office Manager.  The 
Administrative Group name is the same as Group Name defined above. 

 

 
 

5. Repeat Step 4 for the remaining clients listed in Table 1.  When done, close the window. 
 

6. In the RSI Visual Rapport Server window, select Tools → Options… (see Step 3). 
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7. In the Options window that is displayed, make a note of the Server Port(s) and Client 
Port(s) settings on the Communications tab as it will be referenced in Section 5.2.   
Check the Use Broadcast Communications check box.  Select the Server 
Identification tab. 

   

 
 

8. In the Server Identification tab window that is displayed, make a note of the Name, 
Description and Network information entered as it will be referenced in Section 5.2.  
Click OK.  This completes configuration of the Visual Rapport server. 
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5. Configure Resource Software International Visual Rapport 
Client PC 

The configuration information provided in this section describes the steps required to configure 
the Visual Rapport client PC. 
 
For all other provisioning information, such as software installation, installation of optional 
components, configuration of the Visual Rapport client software to integrate with other 3rd party 
products, etc., please refer to the Visual Rapport product documentation in References [2] and 
[3]. 

5.1. Install and Configure Avaya TAPI Driver 
1. Log into the Visual Rapport client PC with administrative privileges and launch the 

Avaya IP Office User Suite installer. 
 

2. Click Next in the InstallShield wizard until the Select Components window is displayed.  
Check TAPI to install the Avaya IP Office TAPI driver on the PC. Click Next >. 

 

 
 

3. Click Finish (not shown).  This completes the installation of the Avaya IP Office User 
Suite.   

 
4. Go to Start → Control Panel and double-click Phone and Modem Options in the 

Control Panel window that is displayed. 
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5. In the Phone and Modem Options window that is displayed, select the Advanced tab. 
 

      
 

6. In the Advanced tab window that is displayed, highlight Avaya IP Office TAPI2 
Service Provider and click Configure… 
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7. On the Avaya TAPI2 configuration window that is displayed, set Switch IP Address to 
the IP address of Avaya IP Office, select Single User, set User Name to the name 
associated with the extension that will be controlled by this Visual Rapport client PC, 
e.g., John Smith and set User Password to the password set for the user in Section 3 
Step 4.  Click OK. 

 

 
 

8. In the Phone and Modem Options window, click OK. 
 

9. This completes configuration of the Avaya TAPI Driver on one client PC.   Repeat Steps 
1 – 8 for the remaining Visual Rapport clients listed in Table 1. 
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5.2. Configure Resource Software International Visual Rapport Client 
The information provided in this section assumes that the Visual Rapport client has already been 
successfully installed and licensed on the PC. 
 

1. From the Visual Rapport PC, navigate to Start → Programs → RSI → Visual Rapport 
for TAPI → Desktop Console. 

 
2. Click through the initial screens that appear, responding to prompts as appropriate for the 

local configuration (not shown). 
 

3. In the RSI Visual Rapport Client wizard window that is displayed, click Next >. 
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4. In the Messaging Configuration window that is displayed, set Visual Rapport Server 
Address to the IP address of the Visual Rapport server as listed in Figure 1, verify 
Service Port(s), and Client Port(s) match the settings made on the Visual Rapport server 
configuration in Section 4 Step 7.  Click Test Insta-Message Configuration…   

 
Note: By default, LOCALHOST is placed in the Visual Rapport Server Address field.  
In this case, LOCALHOST has an IP address of 192.45.210.24 and does not need to be 
changed since server and client are running on the same PC.  Change as appropriate. 

 

 
 
5. If a popup window such as the one below is displayed, the connection between the Visual 

Rapport client and server is fine.  Close the popup window. 
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6. In the Messaging Configuration window (Step 4), click Next >. 

 
7. In the TAPI Configuration window that is displayed, select Avaya IP Office TAPI2 

Service Provider from the pull-down menu for Telephony Service Provider (TSP), 
make sure that Callable and Owner are checked and click Next >. 
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8. On the Sign In window that is displayed, select the first Visual Rapport client extension 
number listed in Table 1 and enter the password defined for the Visual Rapport client in 
Section 4 Step 4.  Click Finish. 

 

 
 

9. In the RSI Visual Rapport Client window that is displayed, confirm the bottom right 
corner shows the logged-in extension with a green background. 

 

 
 

10. Repeat Steps 1 – 9 for the remaining clients listed in Table 1.  This completes initial 
configuration of the Visual Rapport client. 
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5.2.1. Configure Visual Rapport Client for Generic Screen Pop 
 

1. Go to Start → Programs → RSI → Visual Rapport for TAPI → Desktop Console to 
launch the Visual Rapport client. 

 
2. On the RSI Visual Rapport Client window that is displayed, select Tools → Call-Pop 

Script Editor… 
 

 
 

3. On the Call-Pop Script Editor window that is displayed, for Inbound 1 under Menu 
Caption, check Enabled and Auto and click Edit Script… 
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4. On the Microsoft® Visual Basic® Scripting Edition – Editor window that is displayed, 
select File → Import Script. 

 

 
 

5. On the Open window that is displayed, select NotepadDump.vbs and click Open. 
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6. On the Microsoft® Visual Basic® Scripting Edition – Editor window, select File → 
Save. 

 

 
 

7. On the Microsoft® Visual Basic Scripting Edition – Editor window (Step 6), select 
File → Exit. 

 
8. On the Call-Pop Script Editor window (Step 3), click Close. 

 
9. On the RSI Visual Rapport Client window, select Tools → Customize… 
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10. On the Customize window that is displayed, check Auto-pop inbound calls, select 
After a delay of 2 seconds and click OK.  This completes configuration of Visual 
Rapport client to generate screen pop for inbound calls. 

 

 
 

11. Repeat Steps 1 – 10 for the remaining clients listed in Table 1. 

6. Interoperability Compliance Testing 
Interoperability compliance testing evaluated the ability of Visual Rapport to successfully 
generate screen pops for inbound calls.  Answer, Hang Up, Hold, Transfer, and Park of inbound, 
outbound and internal calls were verified successfully using the Visual Rapport clients.  

6.1. General Test Approach  
The general test approach was to verify:  
 

• The telephone status capabilities of the Visual Rapport application. 
• The telephone feature capabilities of the Visual Rapport application including Answer, 

Hang Up, Hold, Transfer, and Park of inbound, outbound and internal calls. 
• The capability of Visual Rapport to dial Avaya IP Office shortcodes (for example, *17, 

*07*55262#).  For more information on shortcodes, see Reference [1]. 
• The screen pop capabilities of the Visual Rapport application when the client extension 

detects an incoming call. 
• The serviceability of Visual Rapport. 
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6.2. Test Results 
Visual Rapport successfully passed all test cases.  As a result of the testing, the following 
observations were noted: 
 

• Avaya IP Office does not provide Caller ID Name via TAPI for incoming PRI trunk calls.  
• Avaya IP Office is does not send the correct Call Display Trunk information to the Visual 

Rapport client for both incoming and outgoing trunk calls. 
• The Visual Rapport client requires a restart if the client’s associated extension is involved 

in a conference call.  Visual Rapport does not support Conference; however, the 
associated extension’s involvement in a conference is not affected by the reset.  

• The Visual Rapport client does not support Message Waiting Indication (MWI). 
• The Visual Rapport client does not support Do Not Disturb, Call Forwarding, or 

Voicemail; however, this should not prevent the ability to dial the Do Not Disturb, Call 
Forwarding, or Voicemail shortcodes from the client (or any programmed shortcode). 

7. Verification Steps 
The following steps may be used to verify the configuration: 
 

• Verify each Visual Rapport client PC successfully pings each Avaya IP Office as well as 
the Visual Rapport server in the test network. 

• Place a call between two Visual Rapport client extensions and verify that each Visual 
Rapport client can be used to display, answer and hang up the call. 

• Verify each Visual Rapport client can be used to initiate and/or drop an inbound or 
outbound call.  

• Verify each Visual Rapport client can be used to Hold, Transfer, and Park inbound, 
outbound and internal calls. 

• Verify incoming calls to extension 55263 activate screen pop of Microsoft NotePad after 
two seconds as described in Section 5.2.1, and the information is correct. 

• Verify each Visual Rapport client can be removed and connected from the network 
without issues. 



7.1. Visual Rapport Client 
1. The Visual Rapport client is activated by clicking on the appearance button or by picking 

up the associated ringing telephone extension.  The screen below displays an inbound call 
that has been answered at extension 55263.  A right-click on the active appearance pops a 
call operation menu, where Visual Rapport call features are performed. 
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2. Click the Telephone tab from the above window.  The Number pad was used to for 
Avaya IP Office shortcode dialing, and for any other dialing requirement. 

 

 
 

3. Screen pop presentation was in the format presented below. 
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8. Support 
Technical support for Visual Rapport can be obtained by contacting Resource Software 
International Systems, Ltd. at: 

• Phone:   800.891.6014 / 905.576.4575 
• E-mail:  support@telecost.com  
• Web:     http://www.telecost.com 

9. Conclusion 
These Application Notes describe the steps for configuring the Resource Software International 
Visual Rapport clients to interoperate with Avaya IP Office systems.  All test cases completed 
successfully.   

10. References 
The following Avaya product documentation can be found at http://support.avaya.com: 
 
[1] Avaya IP Office 4.0 Installation Manual, Issue 15e (31st January 2007), 15-601042. 
 
The following Resource Software International product documentation is installed during the 
Visual Rapport installation process: 
 
[2] Visual Rapport Startup Guide  
[3] Visual Rapport User Guide 
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