Abstract

These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) Trunking between service provider Megapath and Avaya IP Office 8.1.

Megapath SIP Trunking provides PSTN access via a SIP trunk between the enterprise and the Megapath network as an alternative to legacy analog or digital trunks. This approach generally results in lower cost for the enterprise.

Megapath is a member of the Avaya DevConnect Service Provider program. Information in these Application Notes has been obtained through DevConnect compliance testing and additional technical discussions. Testing was conducted via the DevConnect Program at the Avaya Solution and Interoperability Test Lab.
1. Introduction

These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) Trunking between service provider Megapath and an Avaya IP Office solution via an EdgeMarc SIP ALG (Application Layer Gateway). In the sample configuration, the Avaya IP Office solution consists of an Avaya IP Office 500v2 Release 8.1, Avaya embedded Voicemail, Avaya IP Office Softphone, Avaya H.323, Avaya SIP, digital and analog endpoints.

The Megapath SIP Trunking service referenced within these Application Notes is designed for business customers. The service enables local and long distance PSTN calling via standards-based SIP trunks as an alternative to legacy analog or digital trunks, without the need for additional TDM enterprise gateways and the associated maintenance costs.

2. General Test Approach and Test Results

The general test approach was to configure a simulated enterprise site using Avaya IP Office connecting to the EdgeMarc SIP ALG (Application Layer Gateway) which is delivered as part of service provider. Then, the EdgeMarc SIP ALG connects to Megapath SIP Trunking service. This configuration (shown in Figure 1) was used to exercise the features and functionality tests listed in Section 2.1. Note that: NAT devices added between EdgeMarc SIP ALG and the Megapath network should be transparent to the SIP signaling.

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to the interoperability of the tested products and their functionalities. DevConnect Compliance Testing is not intended to substitute full product performance or feature testing performed by DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of a DevConnect member’s solution.

2.1. Interoperability Compliance Testing

A simulated enterprise site with Avaya IP Office and EdgeMarc SIP ALG was connected to Megapath SIP Trunking service. To verify SIP trunking interoperability, the following features and functionality were exercised during the interoperability compliance test:

- Incoming PSTN calls to various phone types. Phone types included H.323, SIP, digital, and analog telephones at the enterprise. All inbound PSTN calls were routed to the enterprise across the SIP trunk from the service provider.
- Outgoing PSTN calls from various phone types. Phone types included H.323, SIP, digital, and analog telephones at the enterprise. All outbound PSTN calls were routed from the enterprise across the SIP trunk to the service provider.
- Inbound and outbound PSTN calls to/from the Avaya IP Office Softphone.
- Inbound and outbound long hold time call stability.
- Various call types including: local, long distance, international, inbound toll-free, outbound toll-free, operator assisted, 411, and 911 services.
- Codec G.711U and G.729A.
- Caller number/ID presentation.
• Privacy requests (i.e., caller anonymity) and Caller ID restriction for inbound and outbound calls.
• DTMF transmission using RFC 2833.
• Voicemail navigation for inbound and outbound calls.
• Telephony features such as hold and resume, terminator declined, do not disturb, call waiting, call park and pickup, transfer, and conference.
• Use of SIP re-INVITE for call transfer to PSTN.
• FAX using G.711.
• Off-net call forwarding (Megapath supports Diversion Header).
• Registration and Authentication.
• Twinning to mobile phones on inbound calls.

2.2. Test Results
All the applicable test cases were executed. Megapath SIP Trunking passed compliance testing.

2.3. Support
For technical support on the Avaya products described in these Application Notes visit: http://support.avaya.com

For technical support on the Megapath system, please contact customer service or visit: http://www.megapath.com/voice/sip-trunking/

3. Reference Configuration
Figure 1 below illustrates the test configuration. The test configuration shows an enterprise site connected to Megapath SIP Trunking service through the public IP network. For confidentiality and privacy purposes, actual public IP addresses used in this testing have been masked out and replaced with fictitious IP addresses throughout the document.

Located at the enterprise site are an EdgeMarc SIP ALG and an Avaya IP Office 500v2 with the MOD DGTL STA16 expansion module which provides connections for 16 digital stations to the PSTN, and the extension PHONE 8 card which provides connections for 8 analog stations to the PSTN as well as 64-channel VCM (Voice Compression Module) for supporting VoIP codecs. The voicemail service is embedded on Avaya IP Office. The LAN2 port of Avaya IP Office is connected to LAN port of EdgeMarc SIP ALG while the WAN port of EdgeMarc SIP ALG is connected to the public IP network. Endpoints include an Avaya 9600 Series IP Telephone (with H.323 firmware), Avaya 1408D Digital Telephones, an Avaya Symphony 2000 Analog Telephone and an Avaya IP Office Softphone H323/SIP. A separate Windows XP PC runs Avaya IP Office Manager to configure and administer Avaya IP Office.

Mobility Twinning is configured for some of the Avaya IP Office users so that calls to these user’s phones will also ring and can be answered at the configured mobile phones.
For the purposes of the compliance test, Avaya IP Office users dialed a short code of $6 + N$ digits to send digits across the SIP trunk to Megapath. The short code of 6 was stripped off by Avaya IP Office but the remaining N digits were sent unaltered to Megapath. For calls within the North American Numbering Plan (NANP), the user would dial 11 ($1 + 10$) digits. Thus for these NANP calls, Avaya IP Office would send 11 digits in the Request URI and the To field of an outbound SIP INVITE message. It was configured to send 10 digits in the From field. For inbound calls, Megapath SIP Trunking sent 10 digits in the Request URI and the To field of inbound SIP INVITE messages.

In an actual customer configuration, the enterprise site may also include additional network components between the service provider and the Avaya IP Office such as a session border controller or data firewall. A complete discussion of the configuration of these devices is beyond the scope of these Application Notes. However, it should be noted that SIP and RTP traffic between the service provider and the Avaya IP Office must be allowed to pass through these devices.
4. Equipment and Software Validated

The following equipment and software/firmware were used for the sample configuration provided:

<table>
<thead>
<tr>
<th>Avaya Telephony Components</th>
<th>Release</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avaya IP Office 500v2</td>
<td>8.1 (43)</td>
</tr>
<tr>
<td>Avaya IP Office DIG DCP*16 V2</td>
<td>8.1 (43)</td>
</tr>
<tr>
<td>Avaya IP Office Ext Card Phone 8</td>
<td>8.1</td>
</tr>
<tr>
<td>Avaya IP Office Manager</td>
<td>10.1 (43)</td>
</tr>
<tr>
<td>Avaya 9640 IP Telephone (H.323)</td>
<td>Avaya one-X Deskphone Edition S3.110b</td>
</tr>
<tr>
<td>Avaya Digital Telephones (1408D)</td>
<td>N/A</td>
</tr>
<tr>
<td>Avaya Symphony 2000 Analog Telephone</td>
<td>N/A</td>
</tr>
<tr>
<td>Avaya IP Office Softphone</td>
<td>3.2.3.15 64595</td>
</tr>
<tr>
<td>HP Officejet 4500</td>
<td>N/A</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Megapath Components</th>
<th>Release</th>
</tr>
</thead>
<tbody>
<tr>
<td>SBC Acme Packet SBC Net-Net</td>
<td>C51.1.1 Patch 21</td>
</tr>
<tr>
<td>Broadsoft</td>
<td>R17 SP4</td>
</tr>
</tbody>
</table>

Note: Testing was performed with IP Office 500 R8.1, but it also applies to IP Office Server Edition R8.1. Note that IP Office Server Edition requires an Expansion IP Office 500 v2 R8.1 to support analog or digital endpoints or trunks.

5. Configure IP Office

This section describes the Avaya IP Office configuration to support connectivity to Megapath SIP Trunking service. Avaya IP Office is configured through the Avaya IP Office Manager PC application. From a PC running the Avaya IP Office Manager application, select Start → Programs → IP Office → Manager to launch the application. Navigate to File → Open Configuration, select the proper Avaya IP Office system from the pop-up window, and log in with the appropriate credentials. A management window will appear similar to the one shown in the next section. The appearance of the IP Office Manager can be customized using the View menu. In the screens presented in this section, the View menu was configured to show the Navigation pane on the left side, the Group pane in the center, and the Details pane on the right side. These panes will be referenced throughout the Avaya IP Office configuration. Proper licensing as well as standard feature configurations that are not directly related to the interface with the service provider (such as the LAN interface to the enterprise site and IP Office Softphone support) is assumed to be already in place.
5.1. LAN2 Settings

In the sample configuration, the **IPOffice_1** was used as the system name and the LAN2 port was used to connect to LAN port of the EdgeMarc SIP ALG. To access the LAN2 settings, first navigate to **System (1) → IPOffice_1** in the Navigation and Group Panes and then navigate to the **LAN2 → LAN Settings** tab in the Details Pane. Set the **IP Address** field to the IP address assigned to the Avaya IP Office LAN port. Set the **IP Mask** field to the mask used on the public network. All other parameters should be set according to customer requirements.
Select the **VoIP** tab as shown in the following screen. The **H323 Gatekeeper Enable** box is checked to allow the use of Avaya IP Telephones using the H.323 protocol, such as the 9600-Series IP Telephones used in the sample configuration. The **SIP Trunks Enable** box must be checked to enable the configuration of SIP trunks to Megapath. The **SIP Registrar Enable** box is checked to allow Avaya IP Office Softphone usage. The **RTP Port Number Range** can be customized to a specific range of receive ports for the RTP media. Based on this setting, Avaya IP Office would request RTP media be sent to a UDP port in the configurable range for calls using **LAN2**. The **Enable RTCP Monitoring On Port 5005** is checked. Avaya IP Office can also be configured to mark the Differentiated Services Code Point (DSCP) in the IP Header with specific values to support Quality of Service policies for both signaling and media. The DSCP field is the value used for media and the SIG DSCP is the value used for signaling. The specific values used for the compliance test are shown in the example below. All other parameters should be set according to customer requirements.
On the **Network Topology** tab in the Details Pane, configure the following parameters:

- Select the **Firewall/NAT Type** from the pull-down menu that matches the network configuration. No firewall or network address translation (NAT) device was used in the compliance test as shown in Figure 1, so the parameter was set to **Open Internet**. With this configuration, STUN will not be used.
- Set the **Binding Refresh Time (seconds)** to **60**. This value is used as one input to determine the frequency at which Avaya IP Office will send SIP OPTIONS messages to the service provider. (Refer to **Section 5.10**)
- Set **Public IP Address** to the IP address of the Avaya IP Office LAN2 port. **Public Port** is set to **5060**.
- All other parameters should be set according to customer requirements.

In the compliance test, the LAN1 interface was used to connect the Avaya IP Office to the enterprise site IP network. The LAN1 interface configuration is not directly relevant to the interface with Megapath SIP Trunking service, and therefore is not described in these Application Notes.
5.2. System Telephony Settings

Navigate to the Telephony → Telephony Tab in the Details Pane. Choose the Companding Law typical for the enterprise location. For North America, U-Law is used. Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and call transfers to the PSTN via the service provider across the SIP trunk. Set Hold Timeout (secs) to 600.
5.3. Twinning Calling Party Settings

When using twinning, the calling party number displayed on the twinned phone is controlled by two parameters. These parameters only affect twinning and do not impact the messaging or operation of other redirected calls such as forwarded calls. The first parameter is the **Send original calling party information for Mobile Twinning** box on the System→Twinning tab, as shown below. The second parameter is the **Send Caller ID** parameter on the SIP Line form (shown in Section 5.4).

If **Send original calling party information for Mobile Twinning** on the System→Twinning tab is optioned, the setting of the second parameter is ignored and Avaya IP Office will send the following in the SIP From Header:

- On calls from an internal extension to a twinned phone, Avaya IP Office will send the calling party number of the originating extension.
- On calls from the PSTN to a twinned phone, Avaya IP Office will send the calling party number of the host phone associated with the twinned destination (instead of the number of the originating caller).

If this option is unchecked, the value sent in the SIP From header is determined by the setting of the second parameter mentioned above.

For the compliance test, the **Send original calling party information for Mobile Twinning** box in the System→Twinning tab was checked which overrides any setting of the **Send Caller ID** parameter on the SIP Line form.
5.4. Administer SIP Line

A SIP line is needed to establish the SIP connection between Avaya IP Office and Megapath SIP Trunking service. To create a SIP line, begin by navigating to Line in the left Navigation Pane, then right-click in the Group Pane and select New → SIP Line. On the SIP Line tab in the Details Pane, configure the parameters as shown below:

- Set ITSP Domain Name to the enterprise domain so that IP Office uses this domain as the host portion of the SIP URI in SIP headers such as the From header.
- Check the In Service box.
- Check the Check OOS box. With this option selected, IP Office will use the SIP OPTIONS method to periodically check the SIP Line.
- Set Call Routing Method to Request URI.
- Check Caller ID from From header box.
- Set Send Caller ID to Diversion Header. For the compliance test, this parameter was used for call forwarding and it was ignored in Mobility Twinning since Send original calling party information for Mobile Twinning is optioned in Section 5.3.
- Set Association Method to By Source IP address.
- The area of the screen entitled REFER Support is used to enable/disable SIP REFER for call transfers. The default values of “Auto” for Incoming and Outgoing effectively disable the use of SIP REFER.
- Set UPDATE Supported to Never. This method is not supported by Megapath SIP Trunk Interface at this time.
- Default values may be used for all other parameters.
Select the **Transport** tab. The **ITSP Proxy Address** is set to the EdgeMarc SIP ALG LAN IP address. As shown in **Figure 1**, this IP Address is **192.168.1.1**. In the **Network Configuration** area, **UDP** is selected as the **Layer 4 Protocol**, and the **Send Port** is set to the port number provided by Megapath, in this case the well known SIP port of **5060** was used. The **Use Network Topology Info** parameter is set to **LAN 2**. This associates the SIP Line with the parameters in the **System → LAN2 → Network Topology** tab. Other parameters retain default values in the screen below.
A SIP Credentials entry must be created for Digest Authentication used by Megapath SIP trunking service to authenticate calls from the enterprise to the PSTN. To create a SIP Credentials entry, first select the **SIP Credentials** tab. Click the Add button and the New Channel area will appear at the bottom of the pane (not shown). To edit an existing entry, click an entry in the list at the top, and click the **Edit…** button. In the bottom of the screen, the **Edit Channel** area will be opened. In the example screen below, a previously configured entry is edited. The entry was created with the parameters shown below:

- Set **User name/ Authentication Name/Contact/Password** to the values provided by the service provider.
- **Expiry (mins)** is set to **60**.
- Check the **Registration required** option (Megapath requires registration for Digest Authentication).
A SIP URI entry must be created to match each incoming number that Avaya IP Office will accept on this line. Select the SIP URI tab; click the Add button and the New Channel area will appear at the bottom of the pane (not shown). To edit an existing entry, click an entry in the list at the top, and click the Edit… button. In the example screen below, a previously configured entry is edited. For the compliance test, a single SIP URI entry was created that matched any DID number assigned to an Avaya IP Office user. The entry was created with the parameters shown below:

- Set Local URI, Contact and Display Name to Use Internal Data. This setting allows calls on this line whose SIP URI matches the number set in the SIP tab of any User as shown in Section 5.6.
- Set PAI to None.
- Associate this line with an incoming line group in the Incoming Group field. This line group number will be used in defining incoming call routes for this line. Similarly, associate the line to an outgoing line group using the Outgoing Group field. For the compliance test, a new incoming and outgoing group 17 was defined that only contains this line (line 17).
- Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed using this SIP URI pattern.
- Set Registration to 1:7039399245. This is the account credentials previously configured on the line's SIP Credentials tab.
Select the **VoIP** tab to set the Voice over Internet Protocol parameters of the SIP line. Set the parameters as shown below:

- The **Codec Selection** can be selected by choosing **Custom** from the pull-down menu, allowing an explicit ordered list of codecs to be specified. Selecting **G.711 ULAW 64K** and **G.729(a) 8K CS –ACELP** codecs causes Avaya IP Office to include these codecs, which are supported by the Megapath SIP Trunking service, in the Session Description Protocol (SDP) offer, in that order.
- Set **Fax Transport Support** to **G.711** from the pull-down menu.
- Set the **DTMF Support** field to **RFC2833** from the pull-down menu. This directs Avaya IP Office to send DTMF tones using RTP events messages as defined in RFC2833.
- Uncheck the **VoIP Silence Suppression** box.
- Check the **Re-invite Supported** box.
- Check **Use Offerer’s Preferred Codec**.
- Default values may be used for all other parameters.

### 5.5. Short Code

Define a short code to route outbound traffic to the SIP line. To create a short code, select **Short Code** in the left Navigation Pane, then right-click in the Group Pane and select **New**. On the **Short Code** tab in the Details Pane, configure the parameters for the new short code to be created. The screen below shows the details of the previously administered “6N;” short code used in the test configuration.

- In the **Code** field, enter the dial string which will trigger this short code, followed by a semi-colon. In this case, **6N;**, this short code will be invoked when the user dials 6 followed by any number.
- Set **Feature** to **Dial**. This is the action that the short code will perform.
- Set **Telephone Number** to **N”megapathvoice.com”**. This field is used to construct the Request URI and To headers in the outgoing SIP INVITE message. The value **N** represents the number dialed by the user. The host part following the “@” is the domain of the service provider network.
- Set the **Line Group Id** to the outgoing line group number defined on the **SIP URI** tab on the **SIP Line** in **Section 5.4**. This short code will use this line group when placing the outbound call.
Set Locale to United States (US English).

The simple “6N;” short codes illustrated above does not provide a means of alternate routing if the configured SIP Line is out of service or temporarily not responding. When alternate routing options and/or more customized analysis of the digits following the short code are desired, the Automatic Route Selection (ARS) feature may be used. In the following example screen, the short code 7N is illustrated for access to ARS. When the Avaya IP Office user dials 7 plus any number N, rather than being directed to a specific Line Group Id, the call is directed to Line Group ID 50: Main, configurable via ARS. See Section 5.8 for example ARS route configuration for 50: Main as well as a backup route.
5.6. User

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP line defined in Section 5.4. To configure these settings, first select User in the left Navigation Pane, then select the name of the user to be modified in the center Group Pane. In the example below, the name of the user is H323 9246. Select the SIP tab in the Details Pane.

The values entered for the SIP Name and Contact fields are used as the user part of the SIP URI in the From header for outgoing SIP trunk calls. They also allow matching of the SIP URI for incoming calls without having to enter this number as an explicit SIP URI for the SIP line (Section 5.4). The example below shows the settings for user H323 9246. The SIP Name and Contact are set to one of the DID numbers assigned to the enterprise from Megapath. The SIP Display Name (Alias) parameter can optionally be configured with a descriptive name. If all calls involving this user and a SIP Line should be considered private, then the Anonymous box may be checked to withhold the user’s information from the network.
One of the H.323 IP Phones at the enterprise site uses the Mobile Twinning feature. The following screen shows the Mobility tab for User H323 9246. The Mobility Features and Mobile Twinning boxes are checked. The Twinned Mobile Number field is configured with the number to dial to reach the twinned mobile telephone, in this case 616139675205. Other options can be set according to customer requirements.
5.7. Incoming Call Route

An Incoming Call Route maps an inbound DID number on a specific line to an internal extension. This procedure should be repeated for each DID number provided by the service provider. To create an incoming call route, select **Incoming Call Route** in the left Navigation Pane, then right-click in the center Group Pane and select **New**. On the **Standard** tab of the Details Pane, enter the parameters as shown below:

- Set the **Bearer Capacity** to **Any Voice**.
- Set the **Line Group ID** to the incoming line group of the SIP line defined in **Section 5.4**.
- Set the **Incoming Number** to the incoming number on which this route should match.
- Set **Locale** to **United States (US English)**.
- Default values can be used for all other fields.

On the **Destinations** tab, select the destination extension from the pull-down menu of the **Destination** field. In this example, incoming calls to 703-939-9246 on line 17 are routed to extension **9246 H323 9246**.
5.8. ARS and Alternate Routing

While detailed coverage of Automatic Route Selection (ARS) is beyond the scope of these Application Notes, this section includes basic ARS screen illustrations and considerations. ARS is shown here mainly to illustrate alternate routing should the SIP Line be out of service or temporarily not responding.

Optionally, ARS can be used rather than the simple 6N; short code approach documented in Section 5.5. With ARS, a secondary dial tone can be provided after the access code, time-based routing criteria can be introduced, and alternate routing can be specified so that a call can re-route automatically if the primary route or outgoing line group is not available. Although not shown in this section, ARS also facilitates more specific dialed telephone number matching, enabling immediate routing and alternate treatment for different types of numbers following the access code. For example, if all 1+10 digit calls following an access code should use the SIP Line preferentially, but other local or service numbers following the access code should prefer a different outgoing line group, ARS can be used to distinguish these call behaviors.

To add a new ARS route, right-click ARS in the Navigation pane, and select New. To view or edit an existing ARS route, select ARS in the Navigation pane, and select the appropriate route name in the Group pane.

The following screen shows an example ARS configuration for the route named Main. The In Service parameter refers to the ARS form itself, not the Line Groups that may be referenced in the form. If the In Service box is un-checked, calls are routed to the ARS route name specified in the Out of Service Route parameter. IP Office short codes may also be defined to allow an ARS route to be disabled or enabled from a telephone. The configurable provisioning of an Out of Service Route, and the means to manually activate the Out of Service Route can be helpful for scheduled maintenance or other known service-affecting events for the primary route.
Assuming the primary route is in-service, the number passed from the short code used to access ARS (e.g., 7N in Section 5.5) can be further analyzed to direct the call to a specific Line Group ID. Per the example screen above, if the user dialed 7-1-613-967-5205, the call would be directed to Line Group 17, the SIP Line configured and described in these Application Notes. If Line Group 17 cannot be used, the call can automatically route to the route name configured in the Additional Route parameter in the lower right of the screen. Since alternate routing can be considered a privilege not available to all callers, IP Office can control access to the alternate route by comparing the calling user’s priority to the value in the Alternate Route Priority Level field.

The following screen shows an example ARS configuration for the route named backup with ARS Route ID 51. Continuing the example, if the user dialed 7-1-613-967-5205, and the call could not be routed via the primary route 50: Main described above, the call will be delivered to this backup route. Per the configuration shown below, the call will be delivered to Line Group 1, using an analog trunk connecting the Avaya IP Office to the PSTN as a backup connection. In this case, the originally dialed number (sans the short code 7) will be dialed as is through the analog/PRI trunk to the PSTN.

In the testing associated with the configuration, calls were successfully delivered to SIP Line 17 via the primary ARS route 50: Main or to the analog/PRI trunk via the backup ARS route shown above. When the primary route experiences a network outage, Avaya IP Office successfully routed the call via the backup route.
5.9. Privacy/Anonymous Calls

For outbound calls with privacy (anonymous) enabled, Avaya IP Office will replace the calling party number in the From and Contact headers of the SIP INVITE message with “restricted” and “anonymous” respectively and enable privacy:id. On the other hand, by default Avaya IP Office will send the P-Preferred-Identity (PPI) or can be configured to use the P-Asserted-Identity (PAI) header to pass the actual calling party information for authentication and billing. For the compliance test, Megapath does not use either PPI or PAI for the purposes of privacy.

5.10. SIP OPTIONS

Avaya IP Office sends SIP OPTIONS messages periodically to determine if the SIP connection is active. The rate at which the messages are sent is determined by the combination of the Binding Refresh Time (in seconds) set on the Network Topology tab in Section 5.1 and the SIP_OPTIONS_PERIOD parameter (in minutes) that can be set on the Source Number tab of the noUser user. The OPTIONS period is determined in the following manner:

- If no SIP_OPTIONS_PERIOD parameter is defined and the Binding Refresh Time is 0, then the default value of 44 seconds is used.
- To establish a period less than 42 seconds, do not define a SIP_OPTIONS_PERIOD parameter and set the Binding Refresh Time to a value less than 42 secs. The OPTIONS message period will be equal to the Binding Refresh Time.
- To establish a period greater than 42 seconds, a SIP_OPTIONS_PERIOD parameter must be defined. The Binding Refresh Time must be set to a value greater than 42 secs. The OPTIONS message period will be the smaller of the Binding Refresh Time and the SIP_OPTIONS_PERIOD.

To configure the SIP_OPTIONS_PERIOD parameter, navigate to User → NoUser in the Navigation / Group Panes. Select the Source Numbers tab in the Details Pane. Click the Add button.

![SIP OPTIONS Configuration](image)
At the bottom of the Details Pane, the **Source Number** field will appear. Enter **SIP_OPTIONS_PERIOD=X**, where X is the desired value in minutes. Click **OK**.

![Image of Details Pane showing Source Number field]

The **SIP_OPTIONS_PERIOD** parameter will appear in the list of Source Numbers as shown below. For the compliance test, an OPTIONS period of 1 minute was desired. The **Binding Refresh Time** was set to **60** seconds (1 minute) in **Section 5.1**. The **SIP_OPTIONS_PERIOD** was set to **2** minutes. Avaya IP Office chose the OPTIONS period as the smaller of these two values (1 minute).

![Image of Source Number list with SIP_OPTIONS_PERIOD entry]

### 5.11. Save Configuration

Navigate to **File → Save Configuration** in the menu bar at the top of the screen to save the configuration performed in the preceding sections.
6. **EdgeMarc SIP ALG Configuration**

The EdgeMarc SIP ALG gateway is configured to manage all SIP signaling and provides voice quality management. All data traffic also traverses the EdgeMarc SIP ALG. It is part of the Megapath SIP trunk service and Megapath will provide it to the customer when the customer orders the Megapath SIP trunk service. Megapath manages it and the end-customer does not manage it.

6.1. **EdgeMarc SIP ALG Login**

The EdgeMarc SIP ALG was configured with a local LAN address of 192.168.1.1 and a subnet mask of 255.255.255.0. A personal computer is configured with Ethernet IP address assigned to any address other than 192.168.1.1 in the same subnet mask, for example 192.168.1.2.

Launch a web browser on personal computer and enter the following URL: [http://192.168.1.1](http://192.168.1.1) and hit enter.

The following login window should appear:

![Login Window](image)

Enter **User name** and **Password** field.

Click OK and the system page should be appeared next.
6.2. EdgeMarc SIP ALG Network Configuration

From the Configuration Menu, select Network menu option. Under Network, input the public and private networks as followings:

- **LAN Interface Settings**:
  - IP Address: 192.168.1.1.
  - Subnet Mask: 255.255.255.0.

- **WAN Interface Settings: Static IP**.
  - IP Address: 10.10.98.14 (Provide this IP Address to service provider to set up the connectivity).
  - Subnet Mask: 255.255.255.192.

- **Network Settings**:
  - Default Gateway: 10.10.98.1.

Submit the changes.
6.3. EdgeMarc SIP ALG SIP Settings

From the Configuration Menu, select VoIP ALG menu option → SIP option.

Under SIP Settings, input the parameters as followings:

- **SIP Server Address**: `lab-2-siptrunk-a.voice.speakeasy.net` (This is fully-qualified domain name or IP address of the SIP gateway or session border controller provided by service provider).
- **SIP Server Port**: 5060.
- **Check Use Custom Domain**.
- **SIP Server Domain**: `megapathvoice.com`.

Submit the changes.

![SIP Settings](image_url)
6.4. EdgeMarc SIP ALG SIP Trunking Configuration

From the Configuration Menu, select VoIP ALG menu option → SIP → Trunking.

In the Add a trunking device menu box:

- Set the Action to Add new trunking device.
- Input a recognizable Name for the trunking device: Avaya IP Office.
- Input the SIP Port number of the Avaya IP Office server: 5060.

Select the Commit button to create the SIP trunking device.
In the **Add a rule** menu box:
- Set the **Action** to **Add new rule**.
- Set **Type** to **Inbound**.
- Input **Pattern-match (if not default):** 703.
- Set **Trunking device** to **Avaya IP Office (192.168.1.200:5060)**.

Select the **Commit** button to create the rule.
Rules

Rules are used to forward and/or modify incoming and outgoing calls. There are 3 types of rules:
- Inbound: from server to trunking device
- Outbound: from trunking device to server
- Redirect: from local phone to trunking device (w/o routing to server)

Outbound rules can match against and/or modify either the calling or called number. Inbound and redirect rules operate on the called number only. Stripped and added digits always apply to the left-most digits of the DID.

<table>
<thead>
<tr>
<th>Type</th>
<th>Party</th>
<th>PRIQ</th>
<th>Pattern-match</th>
<th>Strip</th>
<th>Add</th>
<th>b2bua</th>
<th>ss</th>
<th>Trunking device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inbound</td>
<td>703</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Avaya IP Office (192.168.1.200:5060)</td>
<td></td>
</tr>
<tr>
<td>Inbound</td>
<td>206</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Avaya IP Office (192.168.1.200:5060)</td>
<td></td>
</tr>
<tr>
<td>Inbound</td>
<td>312</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Avaya IP Office (192.168.1.200:5060)</td>
<td></td>
</tr>
<tr>
<td>Inbound</td>
<td>408</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>Avaya IP Office (192.168.1.200:5060)</td>
<td></td>
</tr>
</tbody>
</table>

7. Megapath SIP Trunking Configuration

Megapath is responsible for the configuration of Megapath SIP Trunking service. The customer must provide the EdgeMarc WAN interface IP address (Session 6.2) used to reach Megapath SIP Trunking service. Megapath will provide the customer the necessary information to configure the SIP connection between Avaya IP Office and Megapath. The provided information from Megapath includes:

- Fully Qualified Domain Name, IP address and port number of Acme Packet Session Border Controller used for signaling or media through any security.
- DID numbers.
- Megapath SIP trunking Specification.
8. Verification Steps

The following steps may be used to verify the configuration:

- Use the Avaya IP Office System Status application to verify the state of the SIP connection. Launch the application from **Start → Programs → IP Office → System Status** on the PC where Avaya IP Office Manager was installed. Select the SIP line of interest from the left pane. On the **Status** tab in the right pane, verify that the **Current State** for each channel (The below screen shot showed an active call at present time).
Select the **Alarms** tab and verify that no alarms are active on the SIP line.

- Verify that a phone connected to the PSTN can successfully place a call to Avaya IP Office with two-way audio.
- Verify that a phone connected to Avaya IP Office can successfully place a call to the PSTN with two-way audio.

9. **Conclusion**

Megapath SIP Trunking passed compliance testing. These Application Notes describe the procedures required to configure the SIP connection between Avaya IP Office and the Megapath SIP Trunking service via EdgeMarc SIP ALG as shown in **Figure 1**.

10. **Additional References**


Product documentation for Avaya products may be found at: [http://support.avaya.com](http://support.avaya.com). Additional IP Office documentation can be found at:  

Product documentation for Megapath SIP Trunking may be found at:  