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Abstract 
 

  
These Application Notes describe the procedures for configuring CyTrack Unified 
Communications Suite (UCS) with Avaya IP Office. CyTrack UCS is an enabling modular 
suite of products that provide business benefits and functionalities such as call control, call 
recording, queue management, call detail record reporting, interactive voice response and 
telemarketing call management. 
 
Information in these Application Notes has been obtained through DevConnect compliance 
testing and additional technical discussions.  Testing was conducted via the DevConnect 
Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the configuration steps required for CyTrack Unified 
Communications Suite (UCS) to successfully interoperate with Avaya IP Office. 
 
The following CyTrack UCS products were tested: 
 

• CyTrack® CyDesk™  - Telephone Unified Communications & CTI 
• CyTrack® CyRecord™  - On Demand Voice Recording from the Desktop 
• CyTrack® CyCall™  - TeleMarketing Campaign Management 
• CyTrack® CyReport™  - Telephone Accounting, Billing, Directory and Reporting 
• CyTrack® CyQ™  - Intelligent Inbound Call and Queue Management 
• CyTrack® CyLive™  - Intelligent IVR 

 
CyTrack UCS integrated with Avaya IP Office using the Microsoft Telephony Application 
Programmer Interface (TAPI).  
 
Figure 1 illustrates the test configuration used to verify the CyTrack UCS solution. The Main 
Site is comprised of an Avaya IP Office 500, and has connections to the following: Avaya 
4621SW IP Telephones, Avaya 2420 Digital Telephone, Avaya analog telephone and an ISDN-
PRI trunk to the PSTN. CyTrack UCS is installed on a server running Microsoft Windows Server 
2003 with Service Pack 2. It has connections to the IP Office 500 via four analog extensions for 
queuing of calls and playing announcements. CyTrack CyDesk is installed on three desktop PCs 
running Microsoft Windows XP Professional Service Pack 2 and is used to control the IP, Digital 
and analog telephones respectively. Branch Site A was only used to generate IP trunk Call Detail 
Records (CDR). The Avaya C363T-PWR Converged Stackable Switches provide Ethernet 
connectivity to the servers and IP telephones and Layer 3 IP routing between the two sites. 



 
Figure 1: Test Configuration 

2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 
 

Equipment Software 
Avaya IP Office 500 4.1(12) 
Avaya IP Office IP412 4.1(12) 
Avaya 4621SW IP Telephones 2.8.8.7 (H.323) 
Avaya 2420 Digital Telephone - 
Avaya Analog Telephone - 
Avaya C363T-PWR Converged Stackable Switches 4.5.18 
CyTrack UCS 5.2.2.1 
Dell PowerEdge 750 Server Microsoft Windows Server 2003 

with Service Pack 2 
Desktop PCs Microsoft Windows XP Professional 

with Service Pack 2 
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3. Configure Avaya Office 
This section provides the procedures for configuring Avaya IP Office. The procedures include 
the following areas: 
 

• Licensing Avaya IP Office 
• Configuring Call Detail Record (CDR) settings 
• Saving the Avaya IP Office configuration 

 
It is expected that the installer is familiar with configuring users, hunt groups, short codes, etc. 
on Avaya IP Office as the focus of these Application Notes is on the configuration of the TAPI 
interface only. For all other provisioning information, such as software installation, installation 
of optional components, basic configuration of Avaya IP Office, etc., refer to the Avaya IP 
Office product documentation in reference [1] of Section 10. 

3.1. License Avaya IP Office 
 
Step Description 

1. Log into the IP Office Manager PC and go to Start > Programs > IP Office > Manager 
to launch the Avaya IP Office Manager application. Go to File > Open Configuration to 
bring up the Select IP Office dialog box. Select the IP Office system by checking the 
system name as seen below and click OK. 
 

 
 

Log into the Avaya IP Office Manager application by using the appropriate user name and 
password (not shown). 
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Step Description 
2. The CTI Link Pro license is required for CyTrack UCS to connect to Avaya IP Office via 

TAPI. To add a license, in the Avaya IP Office Manager window, go to the Configuration 
Tree, right-click License and select New from the drop-down menu (not shown). Enter 
the license code into the License Key field and click OK. 
 

 
 



3.2. Configuring Call Detail Record (CDR) settings 
 
Step Description 

1. In the Avaya IP Office Manager window, expand System on the left navigation menu. 
Click the CDR tab on the right panel and configure the settings as follows: 
 

• Enable CDRs: Checked 
• Enable intra-switch CDRs: Checked 
• Record Format: Unformatted 
• Record Options: Normal 
• Date Format: Select the format which corresponds to your region 
• IP Address: IP address of the CyTrack UCS Server 
• IP Port: 9035 
• Max CDRs: 500 
• Use UDP: Unchecked 

 

 
 

3.3. Save the Avaya IP Office Configuration 
In the Avaya IP Office Manager window select File > Save Configuration. The configuration is 
saved to Avaya IP Office at this point and will require a reboot of Avaya IP Office. This 
completes the configuration of Avaya IP Office. 
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4. Configure Avaya TAPI Driver 
This section provides the procedures for configuring the Avaya TAPI Driver on the CyTrack 
UCS Server. The procedures include the following areas: 
 

• Install Avaya TAPI driver 
• Configure Avaya TAPI driver 

4.1. Install Avaya TAPI Driver 
 
Step Description 

1. Log into the CyTrack UCS Server with administrative privileges and start the IP Office 
User Suite installation. Check TAPI to install the Avaya IP Office TAPI driver on the 
server. Click Next to complete the installation of the Avaya IP Office User Suite. At the 
InstallShield Wizard Complete window, click Finish (not shown).  
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4.2. Configure Avaya TAPI Driver 
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Step Description 
1. Go to the Windows Control Panel and open Phone and Modem Options. Click the 

Advanced tab, select Avaya IP Office TAPI2 Service Provider and click Configure….  
 

 
 

2. In the Avaya TAPI2 configuration window that is displayed, set Switch IP Address to the 
IP address of Avaya IP Office, select Third Party and set Switch Password to the IP 
Office password. Click OK. 
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Step Description 
3. In the Phone and Modem Options window, click OK. Reboot the server for the new 

changes to take effect. 
 

5. Configure CyTrack UCS 
This section provides the procedures for configuring the CyTrack UCS Server. The procedures 
include the following areas: 
 

• Configure CyTrack UCS Server 
• Configure CyTrack CyDesk on the PCs 

5.1. Configure CyTrack UCS Server 
The initial configuration of the CyTrack UCS Server is done using the configuration wizard. The 
complete steps required to configure CyTrack UCS Server for service is beyond the scope of this 
document. Refer to CyTrack documentation in Section 10 for details. 
 
Step Description 

1. Log into the CyTrack UCS Server with administrative privileges. Browse to the folder 
C:\Program Files\CyTrack\CyDesk\ and double-click CyPhoneConfigurationWizard.exe 
to launch the configuration wizard. Click Next to continue. 
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Step Description 
2. Select 3rd Party TAPI as the type of integration and click Next to continue. 

 

 
 

3. To define the range of extensions that CyTrack UCS Server will use, click Add an 
extension range. 
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Step Description 
4. Enter the range of extensions by entering the appropriate values for Start and Finish. 

Note that for both the Avaya IP and Digital telephones, the Type field should be set to 
Digital Extension. Click OK. 
 
Repeat Steps 3 and 4 to add another extension with the Type set to Analog Extension. 
 

 
 

5. In this configuration, four extensions are defined. Click Next to continue. 
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Step Description 
6. Enter the values for the fields International Dialling Code and Digit to get an outside 

line.  Consult the Avaya IP Office administrator for the appropriate values.  Click Next to 
continue. 
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Step Description 
7. For the configuration of CyRecord, accept the default path for the storing of recording 

files and click Next to continue. 
 

 
 

8. Select the extensions that will be used for CyRecord. Click Next to continue. 
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Step Description 
9. CyTrack UCS supports integration with several CRM applications out of the box. As this 

is not the focus of the testing, we select None. Click Next to continue. 
 

 
 

10. Click Next to continue. 
 

 
 



 
JC; Reviewed: 
SPOC 8/14/2008 

Solution & Interoperability Test Lab Application Notes 
©2008 Avaya Inc. All Rights Reserved. 

15 of 22 
CyTrack-IPO 

 

Step Description 
11. To configure the agents that will log in to CyTrack UCS, click Add an agent. 

 

 
 

12. In the Add agents window, enter the name of each agent on a separate line. In this 
configuration, Agent 1 and Agent 2 are created. Select Use CyRecord ‘Record on 
Demand’ to configure the agents for on-demand recording. Click OK. 
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Step Description 
13. Click Next to continue. 

 

 
 

14. Accept the default Break Types to be created and click Next to continue. 
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Step Description 
15. Click Finish to accept the configuration and allow the wizard to save the changes. 
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Step Description 
16. Click Start > All Programs > CyTrack > CyDesk Manager to launch the CyDesk 

Manager program. Click Options > Configure (not shown) to open the CyDesk Manager 
Configuration window. Click the PABXs tab and then double-click TAPI PABX to 
configure additional options required for Avaya IP Office. 
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Step Description 
17. In the PABX Settings window, check the option Use ‘Connected’ call for drop in 

conference. Click OK to close the window. This completes the initial configuration of 
CyTrack Server.  
 

 
 



5.2. Configure CyTrack CyDesk on the PCs 
 
Step Description 

1. Log into the PC running CyTrack CyDesk with administrative privileges. Click Start > 
All Programs > CyTrack > CyDesk Config to configure CyDesk. Enter the IP address of 
the CyTrack UCS Server for CyServer Address and click Connect. Click OK. 
 

 
 

6. Interoperability Compliance Testing 
The interoperability compliance test included both feature and serviceability testing.  
 
The feature testing focused on verifying CyTrack UCS’s handling of TAPI messages to request 
and respond to Avaya IP Office features. The feature testing also evaluated the ability of 
CyTrack UCS to collect and process CDR records for various types of calls. 
 
The serviceability testing introduced failure scenarios to verify CyTrack UCS could resume 
operation after failure recovery. 

6.1. General Test Approach 
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For feature testing, the general test approach was to use CyTrack CyQ to queue incoming calls to 
the agents and use CyTrack CyCall to place outgoing campaign calls. To manage the calls, the 
agents used CyTrack CyDesk on the agent PCs. CyTrack CyRecord was also configured to 
record the agent’s incoming and outgoing calls. At the same time, a script was also deployed in 
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CyTrack CyLive to provide IVR features. Finally, CyTrack CyReport was used to collect CDR 
records for various types of calls which include intra-switch calls, inter-switch calls, inbound and 
outbound PSTN trunk calls. For serviceability testing, failures such as reboot of the CyTrack 
UCS Server and the Avaya IP Office were applied. 

6.2. Test Results 
All feature and serviceability tests passed. 

7. Verification Steps 
The following steps may be used to verify the configuration. 
 

• Verify the CTI Link Pro license is enabled on Avaya IP Office (see Section 3.1). 
• Assign an agent to an inbound queue. Log in and make the agent available. Place an 

incoming call to the inbound queue. Verify that the agent’s phone rings and the agent is 
able to answer the call using CyTrack CyDesk. 

• Assign an agent to an outbound campaign.  Log in and make the agent available. Verify 
that an outbound call is placed. When the call is delivered to the agent, verify that the 
agent’s phone rings and the agent is able to answer the call using CyTrack CyDesk. 

• Using the System Monitor provided by Avaya IP Office, verify that Call Detail Records 
were generated after call completion and sent to CyTrack UCS. 

8. Support 
For technical support on CyTrack UCS, contact the CyTrack support team at: 
 

• Phone:  +61 1300 CYHELP (1300 294357) 
• Fax:   +61 1300 788791 
• Email:  support@cytrack.com 

9. Conclusion 
These Application Notes describe the compliance-tested configuration used to validate Avaya IP 
Office 4.1 with CyTrack UCS 5.2.2.1. All test cases were completed successfully. 

10. Additional References  
The following documents are available at http://support.avaya.com. 
 
[1] Avaya IP Office Release 4.1, Manager: 01, Using Manager, Issue 20(i), November 2007 
[2] Avaya IP Office Release 4.1, Manager: 02, Configuration Settings, Issue 20(h), October 2007 
 
The following documents are available from CyTrack upon request: 
 
[1] CyDesk™ Telephony Suite Administration and User guide 
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