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Abstract 
 

 

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking between service provider Gold Line Telemanagement using Registration and 

Avaya IP Office Server Edition Release 11.0. 

 

Gold Line Telemanagement SIP Trunking Service provides PSTN access via a SIP trunk 

between the enterprise and the Gold Line Telemanagement network as an alternative to legacy 

analog or digital trunks. This approach generally results in lower cost for the enterprise. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 

 

Gold Line Telemanagement is a member of the Avaya DevConnect Service Provider program. 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) 

Trunking between Gold Line Telemanagement using SIP Registration and Avaya IP Office Server 

Edition solution. In the sample configuration, the Avaya IP Office Server Edition solution consists of 

the Primary Server running the Avaya IP Office Server Edition Linux software Release 11.0, Avaya 

IP Office Server Edition Expansion System (IP500 V2), Avaya Voicemail Pro, WebRTC and one-X 

Portal services enabled, Avaya Communicator for Web, Avaya Equinox for Windows, Avaya H.323 

and Avaya SIP Deskphones, digital and analog endpoints. 

 

The Gold Line Telemanagement service referenced within these Application Notes is designed for 

business customers. The service enables local and long distance PSTN calling via standards-based 

SIP trunks as an alternative to legacy analog or digital trunks, without the need for additional TDM 

enterprise gateways and the associated maintenance costs. 

2. General Test Approach and Test Results 
The general test approach was to simulate an enterprise site in the Solution & Interoperability Test 

Lab by connecting IP Office to Gold Line Telemanagement’s SIP Trunking service across the public 

internet. The configuration in Figure 1 was used to exercise the features and functionality tests listed 

in Section 2.1. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to 

the interoperability of the tested products and their functionalities. DevConnect Compliance Testing 

is not intended to substitute full product performance or feature testing performed by DevConnect 

members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of 

a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

                                                                                                     

Support for these security and encryption capabilities in any non-Avaya solution component is the 

responsibility of each individual vendor.  Readers should consult the appropriate vendor-supplied 

product documentation for more information regarding those products. 
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2.1. Interoperability Compliance Testing 

To verify SIP trunking interoperability, the following features and functionality were exercised 

during the interoperability compliance test: 

• SIP Trunk registration with authentication 

• SIP OPTIONS queries and responses 

• Incoming PSTN calls to various phone types. Phone types included Avaya H.323, Avaya 

SIP, digital, and analog telephones at the enterprise. All inbound PSTN calls were routed to 

the enterprise across the SIP trunk from the service provider 

• Outgoing PSTN calls from various phone types. Phone types included Avaya H.323, Avaya 

SIP, digital, and analog telephones at the enterprise. All outbound PSTN calls were routed 

from the enterprise across the SIP trunk to the service provider 

• Inbound and outbound PSTN calls from/to the Avaya Communicator for Web with basic 

telephony transfer feature 

• Inbound and outbound PSTN calls from/to the Avaya Equinox for Windows (SIP) 

• Inbound and outbound long hold time call stability 

• Various call types including: local, long distance, international call, inbound toll-free, 

outbound toll-free and 911 services  

• Codec G.711MU and G.729A 

• Caller number/ID presentation  

• Privacy requests (i.e., caller anonymity) and Caller ID restriction for inbound and outbound 

calls 

• DTMF transmission using RFC 2833 

• Voicemail navigation for inbound and outbound calls 

• Telephony features such as hold and resume, transfer, and conference 

• G.711 pass-through and T.38 fax 

• Off-net call forwarding 

• Twinning to mobile phones on inbound calls 

 

Items are not supported including the following: 

• Outbound calls to Local Directory Assistance 411 

• Outbound calls to assisted operator 

2.2. Test Results 

Interoperability testing of Gold Line Telemanagement was completed with successful results for all 

test cases. 
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2.3. Support 

For technical support on the Avaya products described in these Application Notes visit: 

http://support.avaya.com. 

 

For technical support on Gold Line Telemanagement SIP Trunking, contact Gold Line 

Telemanagement at http://glcloudconnect.com/Pages/GLSIP.aspx  

http://support.avaya.com/
http://glcloudconnect.com/Pages/GLSIP.aspx
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3. Reference Configuration 
Figure 1 illustrates the test configuration. The test configuration shows an enterprise site connected 

to Gold Line Telemanagement network through the public internet. For confidentiality and privacy 

purposes, actual public IP addresses used in this testing have been masked out and replaced with 

fictitious IP addresses throughout the document.  

 

The Avaya components used to create the simulated customer site includes: 

• IP Office Server Edition Primary Server 

• IP Office Voicemail Pro  

• IP Office Server Edition Expansion System (IP500 V2) 

• WebRTC and one-X Portal services   

• Avaya 96x1 Series IP Deskphones (H.323) 

• Avaya 11x0 Series IP Deskphones (SIP) 

• Avaya J129 IP Deskphones (SIP) 

• Avaya 1408 Digital phones 

• Avaya Analog phones 

• Avaya Communicator for Web 

• Avaya Equinox for Windows 

 

The Primary Server consists of a Dell PowerEdge R640 server, running the Avaya IP Office Server 

Edition Linux software Release 11.0.  Avaya Voicemail Pro runs as a service on the Primary Server. 

The LAN1 port of the Primary Server (Eth0) is connected to the enterprise LAN (Private network) 

while the LAN2 port is connected to the public network. The SIP trunk to the Gold Line 

Telemanagement system is connected to LAN2 port of the Avaya IP Office Server Edition. 

 

The optional Expansion System (IP500 V2) is used for the support of digital, analog, fax, and 

additional IP stations. It consists of an Avaya IP Office IP500 V2 with the MOD DGTL STA16 

expansion module which provides connections for 16 digital stations to the PSTN, and the extension 

PHONE 8 card which provides connections for 8 analog stations to the PSTN as well as 64-channel 

VCM (Voice Compression Module) for supporting VoIP codecs.  

 

A separate Windows 10 Enterprise PC runs Avaya IP Office Server Edition Manager to configure 

and administer Avaya IP Office Server Edition system. 

 

Mobility Twinning is configured for some of the Avaya IP Office Server Edition users so that calls 

to these user’s phones will also ring and can be answered at configured mobile phones. 
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Internet Simulated 

PSTN

DevConnect Test LAB

Enterprise site

Gold Line 

Telemanagement

Network
Signaling Server IP address: 

192.168.168.250. 

Media Server IP address: 

192.168.168.0/24 (Markham 

Complex) & 192.168.212.228-250 

(Montreal Complex)

Avaya IP Office Server Edition

Voicemail Pro

IPO-Media Server

Web RTC Gateway

One-X Portal

Analog, Fax 

and Digital Endpoints

IP Office Manager for 

Server Edition

SIP Trunk

Mobile Twining with 

Cell phone, Digital 

phone and FAX

SIP Trunk

Avaya IP Office SE internal IP address: 

10.33.10.56 

Avaya IP Office SE external IP address:

10.10.80.104 

DID numbers: 647XXX0110, 

647XXX0111, 647XXX0112, 

647XXX0113 and 647XXX0114 

SIP trunk registration with authentication

PortaOne

Avaya IP Office Expansion System (V2) – IP 500 V2

PHONE 8 

DIG DCPx16 V2

H.323 Endpoints 

SIP Endpoints 

and Soft Clients

Avaya IP Office Expansion IP address: 

172.16.199.60 

 
 

Figure 1 - Test Configuration for Avaya IP Office Server Edition with Gold Line 

Telemanagement SIP Trunk Service 

 

Inbound calls from the service provider via the SIP trunk arrive to the Server Edition Primary 

Server, where Incoming Call Routes are checked to determine the call destination. In the event that 

the destination of the incoming call is an endpoint in the Expansion System (IP500 V2), the call is 

sent via the Small Community Network (SCN) H.323 trunk (IP Office Line) to the expansion 

IP500V2 for routing to the final endpoint. This SCN H.323 trunk is automatically created during the 

initial process of addition of the Expansion System to the IP Office Server Edition solution.  
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Similarly, outbound calls from the enterprise to the PSTN are routed via the SIP trunk to the Gold 

Line Telemanagement network. Calls originated from extensions registered to the Primary Server 

are routed directly to Gold Line Telemanagement, while calls originated from extensions on the 

Expansion System are sent to the Primary Server via SCN H.323 trunk, before being routed to Gold 

Line Telemanagement via the SIP trunk.  

 

For the purposes of the compliance test, Avaya IP Office Server Edition users dialed a short code of 

9 + N digits to send digits across the SIP trunk to Gold Line Telemanagement. The short code of 9 

was stripped off by Avaya IP Office Server Edition but the remaining N digits were sent unaltered to 

Gold Line Telemanagement. For calls within the North American Numbering Plan (NANP), the user 

would dial 11 (1 + 10) digits. Thus, for these NANP calls, Avaya IP Office Server Edition would 

send 11 digits in the Request URI and the To header of an outbound SIP INVITE request, and it was 

configured to send 11 digits in the From field. For inbound calls, Gold Line Telemanagement sent 11 

digits in the Request URI and the To header of an inbound SIP INVITE request. 

 

In an actual customer configuration, the enterprise site may also include additional network 

components between the service provider and Avaya IP Office Server Edition, such as a data 

firewall. A complete discussion of the configuration of these devices is beyond the scope of these 

Application Notes. However, it should be noted that SIP and RTP traffic between the service 

provider and Avaya IP Office Server Edition must be allowed to pass through these devices.  
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4. Equipment and Software Validated 
The following equipment and software/firmware were used for the sample configuration provided: 

 

Component Version 

Avaya 

Avaya IP Office Server Edition solution  

▪ Primary Server Dell PowerEdge R640 – IPO-

Linux-PC 

▪ IPO-Media Server 

▪ Voicemail Pro  

▪ Web RTC Gateway 

▪ one-X Portal 

▪ IP Office Manager for Server Edition 

▪ IP Office Expansion System (V2) – IP 500 V2 

▪ IP Office Analogue - PHONE 8  

▪ IP Office Digital - DIG DCPx16 V2 

 

11.0.4.0.0 Build 74 

 

11.0.4.0.0 Build 74 

11.0.4.0.0 Build 5 

11.0.4.0.0 Build 59 

11.0.4.0.0 Build 38 

11.0.4.0.0 Build 74 

11.0.4.0.0 Build 74 

11.0.4.0.0 Build 74 

11.0.4.0.0 Build 74 

Avaya 1140E IP Deskphone (SIP) 04.04.23 

Avaya 9641G IP Deskphone (H323) 6.8003 

Avaya 9621G IP Deskphone (H323) 6.8003 

Avaya J129 IP Deskphone (SIP) 4.0.2.1.3 

Avaya Communicator for Web 1.0.16.2220 

Avaya Equinox for Windows (SIP) 3.6.0.153.36 

Avaya 1408D Digital Deskphone R48 

Avaya Analog Deskphone N/A 

HP Officejet 4500 (fax) N/A 

Gold Line Telemanagement 

PortaOne MR70-1 

 

Table 1: Equipment and Software Tested 
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5. Configure Avaya IP Office Server Edition Solution 
This section describes the Avaya IP Office Server Edition solution configuration necessary to 

support connectivity to the Gold Line Telemanagement. It is assumed that the initial installation and 

provisioning of the Server Edition Primary Server and Expansion System has been previously 

completed and therefore is not covered in these Application Notes. For information on these 

installation tasks refer to [2] in the Additional References Section 9.  

 

This section describes the Avaya IP Office Server Edition configuration to support connectivity to 

Gold Line Telemanagement system. Avaya IP Office Server Edition is configured through the 

Avaya IP Office Server Edition Manager PC application. From a PC running the Avaya IP Office 

Server Edition Manager application, select Start → Programs → IP Office → Manager to launch 

the application. Navigate to File → Open Configuration, select the proper Avaya IP Office Server 

Edition system from the pop-up window. Log in using appropriate credentials.  

 

 
 

Figure 2 – Avaya IP Office Server Edition Selection 
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The appearance of the Avaya IP Office Server Edition Manager can be customized using the View 

menu. In the screens presented in this section, it includes the system inventory of the servers and 

links for administration and configuration tasks. 

 

 
 

Figure 3 – Avaya IP Office Server Edition View Menu 
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5.1. Licensing 

The configuration and features described in these Application Notes require the Avaya IP Office 

Server Edition system to be licensed appropriately. If a desired feature is not enabled or there is 

insufficient capacity, contact an authorized Avaya sales representative.  

 

Licenses for an Avaya IP Office Server Edition solution are based on a combination of centralized 

licensing done through the Avaya IP Office Server Edition Primary Server, and server specific 

licenses that are entered into the configuration of the system requiring the feature. SIP Trunk 

Channels are centralized licenses, and they are entered into the configuration of the Primary Server. 

Note that when centralized licenses are used to enable features on other systems, such as SIP trunk 

channels, the Primary Server allocates those licenses to the other systems only after it has met its 

own license needs. To verify that there is a SIP Trunk Channels license with sufficient capacity, 

select Solution → IPO-SE → License on the Navigation pane and SIP Trunk Channels in the 

Group pane. Confirm that there is a valid license with sufficient “Instances” (trunk channels) in the 

Details pane. Note that the actual License Key in the screen below was edited for security purposes. 

 

 
 

Figure 4 – Avaya IP Office Server Edition License 
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5.2. System Tab 

Navigate to System (1) under the IPO-SE on the left pane and select the System tab in the Details 

pane. The Name field can be used to enter a descriptive name for the system. In the reference 

configuration, IPO-SE was used as the name in the Primary Server.  

 

 
 

Figure 5 - Avaya IP Office Primary Server System Configuration 
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5.3. LAN Settings 

In the sample configuration, LAN2 on the Primary Server was used, and LAN1 on the Expansion 

System was used. Note: The LAN1 port of the Primary Server (Eth0) is connected to the enterprise 

LAN (Private network) and will not be discussed in this document. The IPO-SE was used as the 

Primary Server name and IPOffice_1 was used as the Expansion System name. 

 

To configure the LAN2 settings on the Primary Server, complete the following steps. Navigate to 

IPO-SE → System (1) in the Navigation and Group Panes and then navigate to the LAN2 → LAN 

Settings tab in the Details Pane. Set the IP Address field to the IP address assigned to the Avaya IP 

Office Server Edition LAN2 port. Set the IP Mask field to the mask used on the public network. All 

other parameters should be set according to customer requirements. Click OK to submit the change. 

 

 
 

Figure 6 - Avaya IP Office Primary Server LAN2 Settings 
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The VoIP tab as shown in the screenshot below was configured with following settings: 

• Check the H323 Gatekeeper Enable to allow Avaya IP Deskphones/Softphones using the 

H.323 protocol to register 

• Check the SIP Trunks Enable to enable the configuration of SIP Trunk connecting to Gold 

Line Telemanagement system 

• Verify Keepalives to select Scope as RTP-RTCP with Periodic timeout 60 and select 

Initial keepalives as Enabled 

• All other parameters should be set according to customer requirements 

• Click OK to submit the changes 

 

 
 

Figure 7 - Avaya IP Office Primary Server LAN2 VoIP 
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To configure the LAN1 settings tab for the Expansion System, navigate to Solution → IPOffice_1 

→ System (1) in the Navigation and Group Panes and then navigate to the LAN1 → LAN Settings 

tab in the Details Pane. The IP Address and IP Mask fields should be populated with the values 

assigned during the Expansion System initial installation process. Verify the configuration or modify 

the values if needed. While DHCP was disabled during the compliance test, this parameter should be 

set according to customer requirements. Other settings were left at their default values. Click OK to 

submit the change. 

 

 
 

Figure 8 - Avaya IP Office Expansion Server Settings 

 

The VoIP tab for LAN1 in the Expansion System (not shown) can be configured using the same 

values previously described for the VoIP tab in the Primary Server.  
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5.4.  System Telephony Settings 

Navigate to Solution → IPO-SE → System (1) in the Navigation and Group Panes (not shown) and 

then navigate to the Telephony → Telephony tab in the Details Pane. Choose the Companding 

Law typical for the enterprise location. For North America, U-Law is used. Uncheck the Inhibit 

Off-Switch Forward/Transfer box to allow call forwarding and call transfers to the PSTN via the 

service provider across the SIP trunk. The Hold Timeout (sec) field controls how long calls remain 

on hold before being alerted to the user and should be set based on the customer’s requirement. Set 

Default Name Priority to Favor Trunk to have IP Office display the name provided in the Caller 

ID from the SIP trunk. Defaults were used for all other settings. Click OK to submit the changes. 

 

 
 

Figure 9 - Avaya IP Office Primary Server Telephony 

 

Navigate to Solution → IPOffice_1 → System (1) (not shown) and repeat the steps above to 

configure the Telephony settings for the Expansion System.  



 
HV; Reviewed: 

SPOC 10/8/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

17 of 43 

                         GLRIPO11 

 

5.5.  System VoIP Settings 

Navigate to Solution → IPO-SE → System (1) in the Navigation and Group Panes and then 

navigate to the VoIP tab in the Details Pane. Leave the RFC2833 Default Payload as the default 

value of 101. Select codecs G.711 ULAW 64K and G.729(a) 8K CS-ACELP that Gold Line 

Telemanagement supports. Click OK to submit the changes. 

 

 

Figure 10 - Avaya IP Office Primary Server VoIP 
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5.6. Administer SIP Line 

A SIP Line is needed to establish the SIP connection between Avaya IP Office Server Edition and 

Gold Line Telemanagement system. The recommended method for configuring a SIP Line is to use 

the template associated with these Application Notes. The template is an .xml file that can be used 

by Avaya IP Office Server Edition Manager to create a SIP Line. Follow the steps in Section 5.6.1 

to create the SIP Line from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

• Setting of the Use Network Topology Info field on the Transport tab 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after 

the SIP Line is created via the template. The resulting SIP Line data can be verified against the 

manual configuration shown in Section 5.6.2. 

 

Also, the following SIP Line settings are not supported on Basic Edition: 

• SIP Line – Originator number for forwarded and twinning calls 

• Transport – Second Explicit DNS Server 

• SIP Credentials – Registration Required 

• SIP Advanced Engineering 

 

Alternatively, a SIP Line can be created manually. To do so, right-click Line in the Navigation Pane 

and select New → SIP Line. Then, follow the steps outlined in Section 5.6.2. 

For the compliance test, SIP Line 17 was used as trunk for both outgoing and incoming calls. 
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5.6.1. Create SIP Line from Template 

1. Create a new folder in computer where Avaya IP Office Server Edition Manager is installed 

(e.g., C:\Gold Line Telemanagement\Template). Copy the template file to this folder and 

rename the template file to GLRIPO11.xml (for SIP Line 17). 

2. Import the template into Avaya IP Office Server Edition Manager: From Avaya IP Office 

Server Edition Manager, select Tools → Import Templates in Manager. This action will 

copy the template file from step 1 into the IP Office template directory. 

  

 
 

Figure 11 – Import Template for SIP Line 

 

In the pop-up window (not shown) that appears, select the folder where the template file was 

copied in Step 1. After the import is complete, a final import status pop-up window below 

will appear stating success (or failure). Then click OK to continue. 

 

 
 

Figure 12 – Import Template for SIP Line successfully 
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3. Create the SIP Trunk from the template: Right-click on Line in the Navigation Pane, then 

navigate to New from Template → Open from file.  

 

 

 

Figure 13 – Create SIP Line from Template 
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4. Select the Template Files (*.xml) and select the imported template from step2 at IP Office 

template directory C:\Program Files\Avaya\IP Office\Manager\Templates\. Click Open 

button to create a SIP line from template.  

 

 
 

Figure 14 – Create SIP Line from IP Office Template directory 
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A pop-up window below will appear stating success (or failure). Then click OK to continue. 

 

 
 

Figure 15 – Create SIP Line from Template successfully  

 

5. Once the SIP Line is created, verify the configuration of the SIP Line with the configuration 

shown in Section 5.6.2. 
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5.6.2. Create SIP Line Manually 

To create a SIP line, begin by navigating to Line in the left Navigation Pane, then right-click in the 

Group Pane and select New → SIP Line (not shown).  

On the SIP Line tab in the Details Pane, configure the parameters as shown below: 

• Select available Line Number: 17 

• Check the In Service and Check OOS boxes 

• Set URI Type to SIP URI 

• For Session Timers, set Refresh Method to Re-invite with Timer (sec) to On Demand 

• Set Name Priority to Favor Trunk. As described in Section 5.4, the Default Name 

Priority parameter may retain the default Favor Trunk setting or can be configured to 

Favor Directory. As shown below, the default Favor Trunk setting was used in the 

reference configuration 

• For Redirect and Transfer, set Incoming Supervised REFER and Outgoing Supervised 

REFER to Auto. Note: Gold Line Telemanagement supports SIP Refer during the 

compliance testing 

• Select the Outgoing Blind REFER option 

• Default values may be used for all other parameters 

• Click OK to commit then press Ctrl + S to save 

 

 
 

Figure 16 – SIP Line Configuration  
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On the Transport tab in the Details Pane, configure the parameters as shown below: 

• The ITSP Proxy Address was set to the IP addresses of Gold Line Telemanagement signaling 

servers: 192.168.168.250 as shown in Figure 1. This is the SIP Proxy address used for 

outgoing SIP calls  

• In the Network Configuration area, UDP was selected as the Layer 4 Protocol and the Send 

Port was set to 5060 

• The Use Network Topology Info parameter was set to None. The Listen Port was set to 

5060. Note: For the compliance testing, the Use Network Topology Info field was set to 

None, since no NAT was using in the test configuration.  In addition, it was not necessary to 

configure the System → LAN2 → Network Topology tab for the purposes of SIP trunking. If 

a NAT is used between Avaya IP Office and the other end of the trunk, then the Use Network 

Topology Info field should be set to the LAN interface (LAN2) used by the trunk and the 

System → LAN2 → Network Topology tab needs to be configured with the details of the 

NAT device 

• The Calls Route via Registrar was unchecked as Gold Line Telemanagement did not support 

the dynamic Registration on the SIP Trunk 

• Other parameters retain default values 

• Click OK to commit then press Ctrl + S to save 

 

 
 

Figure 17 – SIP Line Transport Configuration  
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On the SIP Credentials tab in the Details Pane, click Add button to configure the parameters as 

shown below: 

• User name: 05XXXXXXXXX (Gold Line Telemanagement provided this information) 

• Authentication Name: 05XXXXXXXXX (Gold Line Telemanagement provided this 

information) 

• Password: ********* (Gold Line Telemanagement provided this information) 

• Confirm Password: ********* (Gold Line Telemanagement provided this information) 

• Expiration (mins): 60 

• Check Registration required option 

• Other parameters retain default values 

• Click OK to commit then press Ctrl + S to save 

 

 
 

Figure 18 – SIP Line SIP Credentials Configuration 
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Select the Call Details tab; click the Add button and the New Channel area will appear at the 

bottom of the pane (not shown). To edit an existing entry, click an entry in the list at the top, and 

click Edit… button. In the example screen below, a previously configured entry is edited 

 

A SIP URI entry was created that matched any DID number assigned to an Avaya IP Office user. 

The entry was created with the parameters shown below: 

• Associate this SIP line with an incoming line group in the Incoming Group field and an 

outgoing line group in the Outgoing Group field. This line group number will be used in 

defining incoming and outgoing call routes for this line. For the compliance test, a new line 

group 17 was defined that only contains this line (line 17) 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern 

• Select Credentials to 1: 05XXXXXXXXX 

• Check P Asserted ID and Diversion Header options 

• Set the Display and Content of Local URI, Contact, P Asserted ID and Diversion Header 

to Use Internal Data 

• In Field meaning: Set Forwarding/Twinning of Local URI, P Asserted ID and Diversion 

Header to Original Caller 

• Click OK to submit the changes 

 

 
 

Figure 19 – SIP Line Call Details Configuration  
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Another SIP URI entry was created for the inbound toll-free call testing purpose. In this case, set the 

Display and Content of Local URI, Contact, P Asserted ID and Diversion Header to Auto so that 

SIP trunk will accept inbound toll-free call. The entry was created with the parameters shown below: 

• Associate this line with an incoming line group in the Incoming Group field. This line group 

number will be used in defining incoming call routes for this line. For the compliance test, a 

new line group 17 was defined that only contains this line (line 17) 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern 

• Leave the parameters retain default values.  

• Click OK to submit the changes. 

 

 
 

Figure 20 – SIP Line Call Details Configuration for Inbound Toll-Free 

 

Select the VoIP tab to set the Voice over Internet Protocol parameters of the SIP line. Set the 

parameters as shown below: 

• The Codec Selection can be selected by choosing Custom from the pull-down menu, 

allowing an explicit ordered list of codecs to be specified. The G.711 ULAW 64K and 

G.729(a) 8K CS –ACELP codecs are selected. Avaya IP Office Server Edition supports 

these codecs, which are sent to the Gold Line Telemanagement, in the Session Description 

Protocol (SDP) offer, in that order 

• Check the Re-invite Supported box 

• Set Fax Transport Support to G.711 or T38 from the pull-down menu. Note: Gold Line 

Telemanagement supports both G.711 pass through and T.38 FAX during the compliance 

testing  
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• Set the DTMF Support to RFC2833/RFC4733 from the pull-down menu. This directs 

Avaya IP Office Server Edition to send DTMF tones using RTP events messages as defined 

in RFC2833 and RFC4733 

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

 

Figure 21 – SIP Line VoIP Configuration 
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5.7. Outgoing Call Routing 

The following section describes the Short Code for outgoing calls to Gold Line Telemanagement. 

5.7.1. Short Code in Primary Server and IP Office Line in Primary System 

Define a short code to route outbound traffic on the SIP line to Gold Line Telemanagement. To 

create a short code, select Short Code in the left Navigation Pane, then right-click in the Group Pane 

and select New (not shown). On the Short Code tab in the Details Pane, configure the parameters 

for the new short code to be created. The screen below shows the details of the previously 

administered “9N;” short code used in the test configuration. 

 

• In the Code field, enter the dial string which will trigger this short code, followed by a semi-

colon. In this case, 9N;, this short code will be invoked when the user dials 9 followed by 

any number 

• Set Feature to Dial. This is the action that the short code will perform 

• Set Telephone Number to N. The value N represents the number dialed by the user 

• Set the Line Group ID to the Outgoing Group 17 defined on the Call Details tab on the 

SIP Line in Section 5.6.2. This short code will use this line group when placing the 

outbound call  

• Set the Locale to United States (US English) 

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

 

Figure 22 – Short Code 9N for Primary Server 
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The feature of incoming calls from mobility extension to idle-appearance FNE (Feature Name 

Extension) is hosted by Avaya IP Office Server Edition. The Short Code FNE00 was configured 

with following parameters: 

• For Code field, enter FNE feature code as FNE00 for dial tone  

• Set Feature to FNE Service 

• Set Telephone Number to 00 

• Set Line Group ID to 0 

• Set the Locale to United States (US English) 

• Default values may be used for other parameters  

• Click OK to submit the changes 

 

 
 

Figure 23 – Short Code FNE 

 

Verify the ID of the IP Office line connecting the Primary Server to the Expansion Server. To do 

this, select Line on the navigation pane and select the IP Office Line on the Group pane (line 2 on 

the screen below). Make note of the Outgoing Group ID 99999 on the Details pane. The Address is 

Avaya IP Office Expansion Server LAN1 IP address 172.16.199.60 

 

 

Figure 24 – IP Office Line for Primary Server 
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Verify the VoIP Settings of the IP Office line connecting the Primary System to the Expansion 

Server. Select Fax Transport Support to G.711 or T38 (This setting should be as same as the VoIP 

settings in SIP line). Default values may be used for all other parameters. Click OK to submit the 

changes. 

 

 
 

Figure 25 – IP Office Line for Primary Server VoIP Settings 
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5.7.2. Short Code and IP Office Line in Expansion System 

Define a short code to route outbound traffic on the SIP line to Gold Line Telemanagement. This 

short code is used for analog and digital phones which are connected to Expansion System. To create 

a short code, select Short Code in the left Navigation Pane, then right-click in the Group Pane and 

select New (not shown). On the Short Code tab in the Details Pane, configure the parameters for the 

new short code to be created. The screen below shows the details of the previously administered 

“9N;” short code used in the test configuration. 

 

• In the Code field, enter the dial string which will trigger this short code, followed by a semi-

colon. In this case, 9N;, this short code will be invoked when the user (using Avaya analog or 

digital phones) dials 9 followed by any number 

• Set Feature to Dial. This is the action that the short code will perform 

• Set Telephone Number to 9N 

• Set the Line Group ID to 99999 defined on the Outgoing Group ID of the IP Office line 

connecting the Expansion System to the Primary Server. This short code will use this line 

group when placing the outbound call via Avaya IP Office Server Edition Primary Server  

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

 
 

Figure 26 – Short Code 9N for Expansion Server 
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Verify the ID of the IP Office line connecting the Expansion System to the Primary Server. To do 

this, select Expansion Line on the navigation pane and select the IP Office Line on the Group pane 

(line 17 on the screen below). Make note of the Outgoing Group ID 99999 on the Details pane. The 

Address is Avaya IP Office Server Edition LAN1 IP address 10.33.10.56 

 

 
 

Figure 27 – IP Office Line for Expansion Server 

 

Verify the VoIP Settings of the IP Office line connecting the Expansion System to the Primary 

Server. Select Fax Transport Support to G.711 or T38 (This setting should be as same as the VoIP 

settings in SIP line on Primary Server). Default values may be used for all other parameters. Click 

OK to submit the changes. 

 

Figure 28 – IP Office Line for Expansion Server VoIP Settings 
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5.8. User  

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP Line 

defined in Section 5.6. To configure these settings, first select User in the left Navigation Pane, then 

select the name of the user to be modified in the center Group Pane. In the example below, the name 

of the user is 647XXX0110. Select the SIP tab in the Details pane.   

 

The values entered for the SIP Name and Contact fields are used as the user part of the SIP URI in 

the From header for outgoing SIP trunk calls. They also allow matching of the SIP URI for incoming 

calls without having to enter this number as an explicit SIP URI for the SIP line. The example below 

shows the settings for user 647XXX0110. The SIP Name and Contact are set to one of the DID 

numbers assigned to the enterprise provided by Gold Line Telemanagement. The SIP Display Name 

(Alias) parameter can optionally be configured with a descriptive name. If all calls involving this 

user and a SIP Line should be considered private, then the Anonymous box may be checked to 

withhold the user’s information from the network. 

 

 

Figure 29 – User Configuration 
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One of the H.323 IP Deskphones at the enterprise site uses the Mobile Twinning feature. The 

following screen shows the Mobility tab for User 647XXX0110. The Mobility Features and 

Mobile Twinning boxes are checked. The Twinned Mobile Number field is configured with the 

number to dial to reach the twinned mobile telephone, in this case 91613XXX5096. Check Mobile 

Call Control to allow incoming calls from mobility extension to access FNE00 (defined in Section 

5.7.1). Other options can be set according to customer requirements. 

 

 
 

Figure 30 – Mobility Configuration for User 
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5.9. Incoming Call Route 

An Incoming Call Route maps an inbound DID number on a specific line to an internal extension.  

This procedure should be repeated for each DID number provided by service provider. To create an 

incoming call route, select Incoming Call Route in the left Navigation Pane, then right-click in the 

center Group Pane and select New (not shown). On the Standard tab of the Details Pane, enter the 

parameters as shown below:  

• Set the Bearer Capability to Any Voice 

• Set the Line Group ID to the Incoming Group 17 defined on the Call Details tab on the 

SIP Line in Section 5.6.2 

• Set the Incoming Number to the incoming DID number on which this route should match 

• Default values can be used for all other fields  

 

 
 

Figure 31 – Incoming Call Route Configuration 

 

On the Destination tab, select the destination extension from the pull-down menu of the Destination 

field. In this example, incoming calls to 1647XXX0110 on line 17 are routed to Destination 

associated to extension 0110 as below screenshot: 

 

 
 

Figure 32 – Incoming Call Route for Destination 1647XXX0110  
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For Feature Name Extension Service testing purpose, the incoming calls to DID number 

1647XXX0113 were configured to access FNE00. The Destination was appropriately defined as 

FNE00 as below screenshot: 

 

 

Figure 33 – Incoming Call Route for Destination FNE  

 

For Voice Mail testing purpose, the incoming calls to DID number 1647XXX0114 were configured 

to access VoiceMail. The Destination was appropriately defined as VoiceMail as below screenshot: 

 

 
 

Figure 34 – Incoming Call Route for Destination VoiceMail 
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For Inbound Toll-Free testing purpose, the incoming calls to toll-free number 1800XXX8145 were 

configured to route to Destination associated to extension 0110 as below screenshot: 

 

Figure 35 – Incoming Call Route for inbound toll-free  

5.10. Save Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections.  
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6. Gold Line Telemanagement SIP Trunk Configuration 
Gold Line Telemanagement is responsible for the configuration of Gold Line Telemanagement SIP 

Trunk Service. The customer must provide the IP address used to reach the Avaya IP Office Server 

Edition LAN2 port at the enterprise. Gold Line Telemanagement will provide the customer 

necessary information to configure the SIP connection between Avaya IP Office Server Edition and 

Gold Line Telemanagement. The provided information from Gold Line Telemanagement includes: 

• SIP Proxy IP address and port number used for signaling and media 

• DID numbers 

• The credentials for the trunk registration 

• Gold Line Telemanagement SIP Trunk Specification 
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7. Verification Steps 
The following steps may be used to verify the configuration: 
 

• Use the Avaya IP Office System Status application to verify the state of the SIP connection.  

Launch the application from Start → Programs → IP Office → System Status on the PC 

where Avaya IP Office Server Edition Manager was installed. Select the SIP Line of interest 

from the left pane. On the Status tab in the right pane, verify that the Current State for each 

channel (The below screen shot showed 2 active calls at present time) 

 

 
 

Figure 36 – SIP Trunk status 
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• Use the Avaya IP Office System Status application to verify that no alarms are active on the 

SIP line. Launch the application from Start → Programs → IP Office → System Status on 

the PC where Avaya IP Office Manager was installed. Select Alarm → Trunks to verify that 

no alarms are active on the SIP line 
 

 
 

Figure 37 – SIP Trunk alarm 

 

• Verify that a phone connected to the PSTN can successfully place a call to Avaya IP Office 

Server Edition with two-way audio 

• Verify that a phone connected to Avaya IP Office Server Edition can successfully place a call 

to the PSTN with two-way audio  

• Use a network sniffing tool e.g., Wireshark to monitor the SIP signaling between the 

enterprise and Gold Line Telemanagement. The sniffer traces are captured at the LAN2 port 

interface of the Avaya IP Office Server Edition 
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8. Conclusion 
Gold Line Telemanagement passed compliance testing excepting the limitation in Section 2.2. These 

Application Notes describe the procedures required to configure the SIP connections between Avaya 

IP Office Server Edition and the Gold Line Telemanagement system as shown in Figure 1. 

9. Additional References 
 

[1] Administering Avaya IP Office Platform with Manager, Release 11.0, Issue 17a, August 2018. 

[2] Deploying IP Office Essential Edition IP Office™ Platform 11.0, 15-601042 Issue 33j - 

(Thursday, September 13, 2018). 

[3] Avaya IP Office™ Platform Release 11.0 – Release Notes / Technical Bulletin General 

Availability 

 

Product documentation for Avaya products may be found at: http://support.avaya.com.    

 

Product documentation for Gold Line Telemanagement SIP Trunking may be found at: 

http://glcloudconnect.com/Pages/GLSIP.aspx 

 

   

http://support.avaya.com/
http://glcloudconnect.com/Pages/GLSIP.aspx
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