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Abstract 

 
  

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking on an enterprise solution consisting of Avaya IP Office Release 11 and Avaya 

Session Border Controller for Enterprise Release 8.0, to interoperate with the Masergy SIP 

Trunking service. 

 

Masergy SIP Trunking provides PSTN access via a SIP trunk between the enterprise and the 

service provider’s  network, as an alternative to legacy analog or digital trunks. This approach 

generally results in lower cost for the enterprise 
 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as any observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 
 

Masergy is a member of the Avaya DevConnect Service Provider program. Information in 

these Application Notes has been obtained through DevConnect compliance testing and 

additional technical discussions.  Testing was conducted via the DevConnect Program at the 

Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking on an enterprise solution consisting of Avaya IP Office 11.0 and Avaya Session 

Border Controller for Enterprise to interoperate with the Masergy SIP Trunking service. 

 

Avaya IP Office is a versatile communications solution that combines the reliability and ease 

of a traditional telephony system with the applications and advantages of an IP telephony 

solution. This converged communications solution can help businesses reduce costs, increase 

productivity, and improve customer service. 

 

In the sample configuration, the Avaya IP Office solution consists of an Avaya IP Office Server 

Edition Primary Server release 11.0, an Avaya IP Office 500 V2 Expansion System release 11.0 

and Avaya IP Office softclients and deskphones, including SIP, H.323, digital, and analog 

endpoints, listed in Section 4. 

 

The Avaya Session Border Controller for Enterprise is the point of connection between Avaya 

IP Office and the Masergy SIP trunk. It is used to not only secure the SIP trunk, but also to make 

adjustments to the SIP signaling and media for interoperability. 

 

The SIP trunking service provided by Masergy referenced within these Application Notes is 

designed for business customers. Customers using this service with this Avaya enterprise 

solution are able to place and receive PSTN calls via a broadband WAN connection using the 

SIP protocol. This converged network solution is an alternative to traditional PSTN trunks such 

as analog and/or ISDN-PRI trunks.  

 

Note that the terms “service provider” or “Masergy” will be used interchangeably throughout 

these Application Notes. 
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2. General Test Approach and Test Results  
A simulated enterprise site containing all the Avaya equipment for the SIP-enabled solution was 

installed at the Avaya Solution and Interoperability Lab. The enterprise site was configured to 

connect to Masergy SIP Trunking Services via a broadband connection.  

 

The configuration shown in Figure 1 was used to exercise the features and functionality tests 

listed in Section 2.1.   

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent 

to the interoperability of the tested products and their functionalities. DevConnect Compliance 

Testing is not intended to substitute full product performance or feature testing performed by 

DevConnect members, nor is it to be construed as an endorsement by Avaya of the suitability or 

completeness of a DevConnect member’s solution. 
 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

Support for these security and encryption capabilities in any non-Avaya solution component is 

the responsibility of each individual vendor.  Readers should consult the appropriate vendor-

supplied product documentation for more information regarding those products.  

 

For the testing associated with this Application Notes, the interface between the Avaya systems 

and the Masergy service did not include use of any specific encryption features as requested by 

Masergy. Encryption (TLS/SRTP) was enabled between Avaya products internally on the 

enterprise. 
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2.1. Interoperability Compliance Testing 

To verify SIP trunking interoperability, the following features and functionality were covered 

during the interoperability compliance test:  

• Response to SIP OPTIONS queries. 

• Incoming PSTN calls to various phone types. Phone types included SIP, H.323, digital 

and analog telephones at the enterprise. All inbound PSTN calls were routed to the 

enterprise across the SIP trunk from the service provider. 

• Outgoing PSTN calls from various phone types. Phone types included SIP, H.323, 

digital, and analog telephones at the enterprise. All outbound PSTN calls were routed 

from the enterprise across the SIP trunk to the service provider. 

• Inbound and outbound PSTN calls to/from Avaya Equinox for Windows softphones. 

• Various call types including: local, long distance national, outbound toll free and 

international calls. 

• Proper disconnect when the call is abandoned by the caller before it is answered. 

• Proper disconnect via normal call termination by the caller or the called parties. 

• Proper disconnect for calls that are not answered. 

• Proper response to busy endpoints. 

• Proper response/error treatment when dialing invalid numbers.  

• Proper codec negotiation and two-way speech path. Testing was performed using codec 

G.711MU, G711A and G,729A. 

• Proper response to no matching codecs condition. 

• Caller ID presentation and Caller ID restriction.  

• DTMF transmission using RFC 2833. Voicemail navigation for inbound and outbound 

calls.  

• Fax T.38 and G.711 pass-through modes. 

• Call Hold/Resume (long and short duration). 

• Call Forward (unconditional, busy, no answer).  

• Blind Call Transfers. 

• Consultative Call Transfers. 

• Station Conference. 

• Mobility twinning of incoming calls to mobile phones. 

• Long duration calls. 

• Proper response/error treatment to all trunks busy conditions. 

• Proper response/error treatment for signaling failure conditions. 

• Avaya Remote Worker configuration (Avaya Equinox SIP softphone) via Avaya SBCE. 

 

Items not supported or not tested included the following: 

• Local directory assistant (411) calls are not supported. 

• 0, 0+10 digits calls are not supported. 

• 911 Emergency calls were not tested 
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2.2. Test Results 

All the test objectives stated in Section 2.1, with the limitation noted below, were verified.  

 

• Outbound Anonymous Calls – When privacy is enabled at the IP Office station 

(Withhold Number enabled), the SIP INVITE toward Masergy does not include the 

“Privacy: id” header. This can cause the far-end to still see the number presented in the P-

Asserted Identity header. This is currently being investigated by the Avaya IP Office 

development team. The recommended workaround is described in Section 7.7, where a 

script file is used on the Avaya SBCE to insert the “Privacy: id” header on calls where 

privacy is enabled by the IP Office user. 

2.3. Support 

For more information on the Masergy SIP Trunking service, visit Masergy at 

https://www.masergy.com/cloud-communications/intelligent-sip-trunking/ 

 

For technical support on the Avaya products described in these Application Notes, visit 

http://support.avaya.com. Alternatively, in the United States, (866) GO-AVAYA (866-462-8292) 

provides access to overall sales and service support menus. 

  

https://www.masergy.com/cloud-communications/intelligent-sip-trunking/
http://support.avaya.com/
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3. Reference Configuration 
The reference configuration used in these Application Notes is shown in Figure 1 below and 

consists of the following components: 

• Avaya IP Office provides the voice communications services for the enterprise. In the 

reference configuration, Avaya IP Office runs on the Avaya IP Office Server Edition 

platform. Note that this solution is extensible to deployments using the standalone IP500 V2 

platform as well.  

• In the sample configuration, the Primary server runs the Avaya IP Office Server Edition 

Linux software. Avaya Voicemail Pro runs as a service on the Primary Server. The LAN1 

port of the Primary Server is connected to the enterprise LAN. The LAN2 port was not used.  

• The Expansion System (V2) is used for the support of digital, analog and additional IP 

stations. It consists of an Avaya IP Office 500v2 with analog and digital extension expansion 

modules, as well as a VCM64 (Voice Compression Module). The LAN1 port of the Avaya IP 

Office IP500V2 is connected to the enterprise LAN, while the LAN2 port was not used.  

• Avaya endpoints are represented with an Avaya 9608 H.323 deskphone, Avaya J129 and 

J169 SIP Deskphones, an Avaya 1140E SIP Deskphone, an Avaya 9508 Digital Deskphone, 

as well as Avaya Equinox for Windows (SIP) softphone. Fax endpoints are represented by 

PCs running Ventafax emulation software connected by modem to an Avaya IP Office 

analog port. 

• Voicemail Pro (running on the Primary server) provided the voice messaging capabilities in 

the reference configuration. This solution is extensible to the Avaya IP Office embedded 

voice mail as well. 

• In the reference configuration, Avaya IP Office interface “LAN 1” is connected to the private 

CPE network. The “LAN 2” interface was not used. 

• Avaya Session Border Controller for Enterprise (Avaya SBCE) running on VMware 

platform. This solution is extensible to other Avaya Session Border Controller for Enterprise 

platforms as well. 

• TLS/5061 is the recommended transport protocol/port to use on the Avaya IP Office LAN1 

connection to the Avaya SBCE A1 interface. However, TCP/5060 may be used for this 

connection if desired. 

• UDP/5060 was the transport protocol/port used to connect the Avaya SBCE B2 interface to 

the Masergy SIP trunk, across the public Internet.  

• Avaya IP Office was configured to send and receive calls using the E.164 numbering format, 

as requested by Masergy.  

• An Avaya Remote Worker endpoint (Avaya Equinox for Windows softphone) was used in 

the reference configuration. The Remote Worker endpoint resides on the public side of an 

Avaya SBCE (via a TLS connection), and registers/communicates with IP Office as though it 

was an endpoint residing in the private CPE space.  

 

Note – The configuration of the Remote Worker environment is beyond the scope of this 

document. Refer to [8] on the Additional References section for information on Remote Worker 

deployments. 
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Note – For security reasons, public IP addresses used in the reference configuration for the 

Avaya SBCE and the SBCs on the service provider’s network are not included in this document. 

However, as placeholders in the following configuration sections, the IP addresses 192.168.80.50 

(Avaya SBCE “Outside” interface B2), and 192.168.11.97 /192.168.9.97(Masergy SBCs IP 

addresses), are specified. In addition, DID numbers shown in this document are masked as well.  

 

 
 

Figure 1: Test Configuration 

 

In an actual customer configuration, the enterprise site may include additional network 

components between the service provider and the IP Office system, such as a router or data 
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firewall. A complete discussion of the configuration of these devices is beyond the scope of these 

Application Notes. However, it should be noted that all SIP and RTP traffic between the service 

provider and the IP Office system must be allowed to pass through these devices. 

4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment/Software Release/Version 

Avaya 

Avaya IP Office Server Edition 

Avaya IP Office Voicemail Pro 

Release 11.0.4.0.0 Build 74 

Release 11.0.4.0.0 Build 5 

Avaya IP Office 500 V2 Expansion System Release 11.0.4.0.0 Build 74 

Avaya IP Office Manager Release 11.0.4.0.0 Build 74 

Avaya Session Border Controller for Enterprise Release 8.0.0.0-19-16991 

Avaya 96x1 Series IP Deskphone (H.323) Release 6.8002 

Avaya 1140E IP Deskphone (SIP) Release 04.04.23.00 

Avaya J129 IP Deskphone (SIP) Release 4.0.0.21 

Avaya J169 IP Deskphone (SIP) Release 4.0.0.21 

Avaya 9508 Digital Deskphone Release 0.60 

Avaya Equinox for Windows Release 3.5.5.113.24 

Fax Device Ventafax 7.10 

Masergy 

Broadsoft Softswitch R21sp1 

Oracle SBC scz7.2.0M6P2 

 

Table 1: Equipment and Software Versions 

 

Note – Compliance Testing is applicable when the tested solution is deployed with a standalone 

IP Office 500 V2, and also when deployed with all configurations of IP Office Server Edition. IP 

Office Server Edition requires an Expansion IP Office 500 V2 to support analog or digital 

endpoints or trunks. 
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5. Avaya IP Office Primary Server Configuration 
Avaya IP Office is configured through the Avaya IP Office Manager application. From the PC 

running the IP Office Manager application, select Start →  Programs → IP Office → Manager 

to launch the Manager application. Log in using the appropriate credentials. 

 

 
 
On Server Edition systems, the Solution View screen will appear, similar to the one shown below. 

All the Avaya IP Office configurable components are shown in the left pane, known as the 

Navigation Pane. Clicking the “plus” sign next to the Primary server system name, e.g., IPOSE-

Primary, on the navigation pane will expand the menu on this server. 
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In the screens presented in the following sections, the View menu was configured to show the 

Navigation pane on the left side, the Group pane in the center and the Details pane on the right 

side. These panes will be referenced throughout the rest of this document.  

 

Standard feature configurations that are not directly related to the interfacing with the service 

provider are assumed to be already in place, and they are not part of these Application Notes. 

5.1. Licensing  

The configuration and features described in these Application Notes require the IP Office system 

to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, 

contact an authorized Avaya sales representative. 

 

In the reference configuration, IPOSE-Primary was used as the system name of the Primary 

Server and IP500 Expansion was used as the system name of the Expansion System. All 

navigation described in the following sections (e.g., License) appears as submenus underneath 

the system name in the Navigation Pane.  

 

Navigate to License in the Navigation Pane. In the Details Pane verify that the License Status 

for SIP Trunk Channels is Valid and that the number of Instances is sufficient to support the 

number of channels provisioned for the SIP trunk. 
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5.2. TLS Management 

For the compliance test, the signaling on the SIP trunk between IP Office and the Avaya SBCE 

was secured using TLS. Testing was done using identity certificates signed by a local certificate 

authority SystemManager CA. The generation and installation of these certificates are beyond 

the scope of these Application Notes. However, once the certificates are available they can be 

viewed on IP Office in the following manner. 

 

To view the certificates currently installed on IP Office, navigate to File → Advanced → 

Security Settings. Log in with the appropriate security credentials (not shown). In the Security 

Settings window, navigate to Security → System and select the Certificates tab. 

 

To verify the identity certificate, locate the Identity Certificate section and click View to see the 

details of the certificate. 
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5.3. System Settings  

This section illustrates the configuration of system settings. Select System on the Navigation 

pane to configure these settings. The subsection order corresponds to a left to right navigation of 

the tabs in the Details pane for System settings. For all the following configuration sections, the 

OK button (not shown) must be selected in order for any changes to be saved. 

5.3.1. LAN1 Tab 

In the sample configuration, LAN1 is used to connect the Primary Server to the enterprise private 

network. 

 

To view or configure the LAN 1 IP address and subnet mask, select the LAN1 → LAN Settings 

tab and enter the information as needed, according to customer specific requirements: 

• IP Address: 10.64.19.170 was used in the reference configuration. 

• IP Mask: 255.255.255.0 was used in the reference configuration. 

• Click the OK button (not shown). 
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Select the LAN1 → VoIP tab as shown in the following screen. The following settings were 

used in the reference configuration:  

• The H323 Gatekeeper Enable box is checked to allow the use of Avaya IP Telephones 

using the H.323 protocol, such as the Avaya 96x1-Series Deskphones used in the 

reference configuration.  

• The H.323 Signaling over TLS should be set based on customer needs. In the reference 

configuration it was set to Preferred.  

• The SIP Trunks Enable parameter must be checked to enable the configuration of SIP 

trunks on this interface. 

• The SIP Registrar Enable box was checked to allow Avaya J100-Series Deskphones, 

Avaya 1100-Series Deskphones and Avaya Equinox usage.  

• The Domain Name and SIP Registrar FQDN may be set according to customer 

requirements. The values used in the reference configuration are shown.  

• Set the Layer 4 Protocol section based on customer needs. In the reference configuration 

TCP/5055 and TLS/5056 were configured.  
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Scroll down the page: 

• Verify the RTP Port Number Range. Based on this setting, Avaya IP Office will 

request RTP media to be sent to a UDP port in the configurable range for calls using 

LAN1. The Minimum and Maximum port numbers were kept at their default values in 

the reference configuration. 

• In the Keepalives section, set the Scope to RTP-RTCP. Set the Periodic timeout to 30 

and the Initial keepalives parameter to Enabled. This is done to prevent possible issues 

with network firewalls closing idle RTP channels.  

• In the DiffServ Settings section, IP Office can be configured to mark the Differentiated 

Services Code Point (DSCP) in the IP Header with specific values to support Quality of 

Services (QoS) policies for both signaling and media. The DSCP field is the value used 

for media, while the SIG DSCP is the value used for signaling. These settings should be 

set according to the customer’s QoS policies in place. The default values used during the 

compliance test are shown. 

• Click OK to commit (not shown). 
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Select the LAN1 → Network Topology tab as shown in the following screen, and enter the 

following:  

• Firewall/NAT Type was set to Unknown in the reference configuration. 

• Public IP Address: The 0.0.0.0 default value was used. This means Avaya IP Office will 

use the LAN1 IP address specified on the LAN1 LAN Settings tab described above 

(10.64.19.170).  

• Click the OK button (not shown).  
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5.3.2. Voicemail Tab 

As described in Section 3, Voicemail Pro was used in the reference configuration. 

• Set Voicemail Type to Voicemail Lite/Pro. 

• Set Voicemail IP Address to the IP address of the server hosting voicemail. In the 

reference configuration, this is the Primary server, 10.64.19.170. 

• Other parameters on this screen are default. Click the OK button (not shown). 

 

 

5.3.3. Telephony Tab 

To view or change telephony settings, select the Telephony tab and Telephony sub-tab as 

shown in the following screen. The settings presented here simply illustrate the values used in 

the reference configuration and are not intended to be prescriptive.  
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• Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and 

call transfers to the PSTN via the SIP trunk to the service provider. If for security reasons 

incoming calls should not be allowed to transfer back to the PSTN, then leave this setting 

checked. 

• Set the Companding Law parameters to U-Law as is typical in North America.  

• Default values are used in the other fields.  

• Click the OK button (not shown).  
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5.3.4. VoIP Tab 

Navigate to the VoIP tab in the Details pane to view or change the system codecs and VoIP 

security settings. 

 

Select the VoIP → VoIP tab. Configure the following parameters: 

• The RFC2833 Default Payload field allows for the manual configuration of the payload 

type used on SIP calls that are initiated by the IP Office. During the compliance test, this 

was set to 101, the value preferred by Masergy.  

• For codec selection, select the codecs and codec order of preference on the right, under 

the Selected column. The Default Codec Selection area enables the codec preference 

order to be configured on a system-wide basis. The buttons between the two lists can be 

used to move codecs between the Unused and Selected lists, and to change the order of 

the codecs in the Selected codecs list. By default, all IP lines and phones (SIP and H.323) 

will use the system default codec selection shown here, unless configured otherwise for a 

specific line or extension. The screen below shows the settings used in the compliance 

test. 

• Click OK to commit (not shown). 
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During the compliance test, SRTP was used internal to the enterprise wherever possible. To view 

or configure the media encryption settings, select the VoIP → VoIP Security tab on the Details 

pane.  

• Set the Media Security drop-down menu to Preferred to have IP Office attempt use 

encrypted RTP for devices that support it and fall back to RTP for devices that do not 

support encryption.  

• Under Media Security Options, select RTP for the Encryptions and Authentication 

fields.  

• Under Crypto Suites, select SRTP_AES_CM_128_SHA1_80.  

• Click OK to commit (not shown). 
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5.4. IP Route 

In the sample configuration, the IP Office LAN1 port is physically connected to the local area 

network switch at the IP Office customer site. The Avaya SBCE resides on a different subnet and 

requires an IP route to allow SIP traffic between the two devices.  

 

To create a new IP route, right-click on IP Route on the left navigation pane. Select New (not 

shown). 

• Set the IP Address and IP Mask of the subnet of the private side of the Avaya SBCE, or 

enter 0.0.0.0 to make this the default route. 

• Set Gateway IP Address to the IP Address of the router in the IP Office subnet. The 

default gateway for this network is 10.64.19.1. 

• Set Destination to LAN1 from the pull-down menu. 

• Click OK to commit (not shown). 

 

 
  



 
MAA; Reviewed: 

SPOC 6/12/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

 

23 of 79 

Msrgy-IPO11SBC8 

 

5.5. SIP Line 

The following sections describe the configuration of a SIP Line. The IP Office SIP Line 

terminates the CPE end of the SIP trunk to the Masergy SIP Trunking service. 

 

The recommended method for creating/configuring a SIP Line is to use the template associated 

with the provisioning described in these Application Notes. The template is an .xml file that can 

be used by Avaya IP Office Manager to create a new SIP Line. Follow the steps in Section 5.5.1 

to create a SIP Trunk from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses. 

• SIP trunk registration credentials (if applicable). 

• SIP URI entries. 

• Setting of the Use Network Topology Info field on the Transport tab. 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary 

after the SIP Line is created via the template. The resulting SIP Line data can be verified against 

the manual configuration shown in Sections 5.5.2 to 5.5.6. 

 

In addition, the following SIP Line settings are not supported on Basic Edition: 
 

• SIP Line – Originator number for forwarded and twinning calls. 

• Transport – Second Explicit DNS Server. 

• SIP Credentials – Registration Requirement. 

• SIP Advanced Engineering. 

 

Alternatively, a SIP Line can be created manually. To do so, right-click on Line in the 

Navigation pane and select New → SIP Line. Then, follow the steps outlined in Sections 5.5.2 

to 5.5.6. 
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5.5.1. Creating a SIP Line from an XML Template 

Note – DevConnect generated SIP Line templates are always exported in an XML format. 

These XML templates do not include sensitive customer specific information and are 

therefore suitable for distribution. The XML format templates can be used to create SIP 

trunks on both IP Office Standard Edition (IP500 V2) and IP Office Server Edition systems. 

Alternatively, binary templates may be generated. However, binary templates include all the 

configuration parameters of the Trunk, including sensitive customer specific information. 

Therefore, binary templates should only be used for cloning trunks within a specific 

customer’s environment. 

 

Copy a previously created template file to the computer where IP Office Manager is installed. To 

create the SIP Trunk from the template, right-click on Line in the Navigation Pane, then navigate 

to New →New from Template. Select Open from file.  

 

 
 

Navigate to the directory where the template was copied on the local computer (e.g., \temp) and 

select it. Click Open (not shown). 

 

 
 

The new SIP Line is created, and it will appear on the Navigation pane (e.g., SIP Line 25). The 

resulting SIP Line data can be verified against the manual configuration shown in Sections 5.5.2 

to 5.5.6. 
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5.5.2. SIP Line – SIP Line tab 

On the SIP Line tab in the Details pane, configure or verify the parameters as shown below: 

• ITSP Domain Name: leave as the default (blank) to have IP Office send the ITSP Proxy 

Address as the domain name. See Section 5.5.3. 

• Local Domain Name: Set to the public IP address of the Avaya IP Office LAN1 

interface (e.g., 10.64.19.170).  

• Verify that In Service box is checked, the default value. This makes the trunk available 

to incoming and outgoing calls. 

• Verify that Check OOS box is checked, the default value. IP Office will use the SIP 

OPTIONS method to periodically check the SIP Line. 

• Refresh Method: Set to Re-Invite. 

• Clear any digits on the National Prefix and International Prefix fields. 

• Incoming Supervised Refer: Set this field to Always to enable Avaya IP Office to 

accept REFER sent by the network during a transfer scenario. 

• Outgoing Supervised Refer: Set this field to Always to enable Avaya IP Office to use 

REFER for station-initiated call transfer scenarios back to PSTN. 

• Use the default values for the other fields. 

• Click OK (not shown). 
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5.5.3. SIP Line - Transport Tab 

Select the SIP Line → Transport tab and configure the following: 

• ITSP Proxy Address: Set to the Avaya SBCE A1 IP address (e.g., 10.64.91.101). 

• Network Configuration → Layer 4 Protocol:  Set to TLS. 

• Network Configuration → Send Port: Set to 5061. 

• Network Configuration → Use Network Topology Info: Set to None. 

• Network Configuration → Listen Port: Set to 5061. 

• Verify Calls Route via Registrar: Enabled (default) 

• Click OK (not shown). 
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5.5.4. SIP Line – Call Details tab 

Select the Call Details tab. To add a new SIP URI, click the Add… button. To review an 

existing SIP URI, select it and click the Edit button.  
 

 
 

The SIP URI window will open. Configure the following:  

• Incoming Group: Set to 25 (SIP Line 25). This value references the Line Group ID set 

on the Incoming Call Routes in Section 5.7.  

• Max Sessions: In the reference configuration this was set to 10. This sets the maximum 

number of simultaneous calls that can use the URI before Avaya IP Office returns busy to 

any further calls.  

• Outgoing Group: Set to 25 (SIP Line 25). This will be used for routing outbound calls to 

Masergy via the ARS configuration (Section 5.9).  

• Check the P-Asserted ID and Diversion Header.  

• For the Local URI, Contact and Diversion Header leave the selections under the 

Display and Content columns to the default Auto. With this setting, IP Office will use 

the information on the Incoming Call Routes (Section 5.7) to populate the From and 

Contact headers on outbound calls, and also to determine which inbound calls will be 

allowed on the SIP line.  

• On the Field meaning section, set the values under the Outgoing Calls, Forwarding/ 

Twinning and Incoming Calls columns as shown on the screenshot below.  

• Click OK.  
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5.5.5. SIP Line - VoIP tab 

Select the SIP Line → VoIP tab. Set the parameters as shown below: 

• The Codec Selection drop-down box → System Default will list all available codecs. In 

the reference configuration, Custom was selected with G.711 ULAW 64K,  G.711 

ALAW 64K and  G729(a) 8K CS-ACELP specified. This causes Avaya IP Office to 

include these codecs in the Session Description Protocol (SDP) offer, and in the order 

specified. Note that this was set to match the codec order of preference offered by 

Masergy on incoming calls from the network. 

• T.38 fax was used in the reference configuration. Set the Fax Transport Support drop-

down menu to T.38. G.711 fax also tested successfully in the reference configuration 

(T.38 option disabled); however, T.38 is the preferred method.  

• Set the DTMF Support field to RFC2833/RFC4733. This directs IP Office to send 

DTMF tones using RTP events messages as defined in RFC2833. 

• Set the Media Security drop-down menu to Same as System (Preferred) to have IP 

Office use the system setting for media security set in Section 5.3.4 to encrypted RTP 

toward Avaya SBCE. 

• Check the Re-invite Supported parameter to allow for codec re-negotiation in cases 

where the target of an incoming call or transfer does not support the codec originally 

negotiated on the trunk. 

• Default values may be used for all other parameters. 

• Click the OK to commit (not shown). 

 

 
  



 
MAA; Reviewed: 

SPOC 6/12/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

 

29 of 79 

Msrgy-IPO11SBC8 

 

5.5.6. SIP Line – SIP Advanced Tab 

Select the SIP Advanced tab. Set the parameters as shown below:  

• Check the box for Use PAI for Privacy.  

• Select Indicate HOLD. IP Office can be configured to signal when a call is placed on 

hold by sending an INVITE with media attribute “sendonly”. The service provider in turn 

will respond with media attribute “recvonly” or “inactive”, and will stop sending RTP 

media for the duration the call is on hold. When the call is taken off of hold, IP Office 

will send another INVITE removing the media attribute “sendonly”, indicating to 

Masergy to start sending RTP again. 

• Select Emulate NOTIFY for Refer. Some Avaya endpoints (e.g., Avaya 1140E 

Deskphone) require receipt of a NOTIFY when Refer based call transfers are performed. 

This option will send a NOTIFY to these endpoints. 

• Default values may be used for all other parameters. 

• Click OK to commit (not shown). 
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5.6. IP Office Line 

In IP Office Server Edition systems, IP Office Lines are automatically created on each server 

when a Secondary server or Expansion System is added to the solution. To edit an existing IP 

Office Line, select Line in the Navigation pane, and select the appropriate line to be configured 

in the Group pane. The screen below shows the IP Office Line to the IP500 V2 Expansion 

System. 

 

 
 

The screen below shows the IP Office Line, VoIP Settings tab. In the reference configuration, a 

fax machine is connected to one of the analog ports on the Expansion System. Fax Transport 

Support is set to T.38. Default values were used for all other parameters. 
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5.7. Incoming Call Route 

Incoming call routes map inbound DID numbers on a specific line to internal extensions, hunt 

groups, short codes, etc., within the IP Office system. To add an incoming call route, right click 

on Incoming Call Route in the Navigation pane and select New (not shown).  On the Details 

Pane, under the Standard tab, set the parameters as show below: 

• Set Bearer Capacity to Any Voice.  

• The Line Group ID is set to 25. This matches the Incoming Group field configured in 

the Call Details tab for the SIP Line on Section 5.5.4. 

• On the Incoming Number, enter the DID number for this route. Note that since Masergy 

uses the E.164 numbering format the “+1” prefix is added to the 10 digit DID number. 

 

Note - When the destination is a user’s extension, the Incoming Number can be used to 

construct the From and Contact headers to be used in place of the extension number in the 

outgoing SIP INVITE for that user. 

 

• Default values may be used for all other parameters. 

 

 
 

Select the Destinations tab. From the Destination drop-down menu, select the endpoint 

associated with this DID number.  In the reference configuration, DID number +14241234567 is 

associated with the Avaya IP Office user at extension 6241. 

 

 
 

Repeat this process to route the rest of the service provider assigned DID numbers to additional 

users, as well as other Avaya IP Office destinations (Hunt Group, Voicemail, Short Codes, etc.).  
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5.8. Short Codes 

Avaya IP Office uses Automatic Route Selection (ARS) to route outbound traffic to the SIP line. 

A short code is needed to send the outbound traffic to the ARS route. To create the short code 

used for ARS, right-click on Short Code in the Navigation Pane and select New (not shown). 

The screen below shows the creation of the short code 9N used in the reference configuration. 

When the Avaya IP Office users dialed 9 plus any number N, calls were directed to Line Group 

65, configurable via ARS and defined next in Section 5.8. 

 

On the Short Code tab in the Details Pane, configure the parameters as shown below.  

• In the Code field, enter the dial string which will trigger this short code, in this case 9N. 

This short code will be invoked when the user dials 9 followed by any number.  

• Set Feature to Dial. This is the action that the short code will perform. 

• Set Telephone Number to N.  The value N represents the number dialed by the user after 

removing the 9 prefix.   

• Set the Line Group ID to the ARS route to be used. In the example shown, the call is 

directed to Line Group 65: Route to Masergy 
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5.9. Automatic Route Selection (ARS) 

While detailed coverage of ARS is beyond the scope of these Application Notes, this section  

includes some basic screen illustrations of the ARS settings used during the compliance test. 

 

As described in Section 5.8, Short Code 9N was defined for ARS access. Therefore, outbound 

calls via ARS are dialed as 9 plus the number. ARS will strip off the 9, and it will process the 

call based on the remaining digits.  

 

To add a new ARS route, right-click ARS in the Navigation pane, and select New (not shown).  

The following screen shows the ARS Route ID 65, created in the sample configuration. 
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To add a new ARS table entry, click on the Add button. To change an existing entry, select the 

entry and click on the Edit button.  

 

The example below shows the entry for 10 digit dialed calls to numbers within the North 

American Numbering Plan (NANP). 

 

 
 

• Set Code to xxxxxxxxxx  

This means that any 10 digit dialed string will be routed to the specified Line Group.  

•  Feature = Dial  

• Telephone Number = +1N  

With this setting, the 10 digit dialed number, preceded by prefix +1 will be sent to the 

SIP trunk, in E.164 format as requested by Masergy. 

• Line Group ID = 25 (SIP Line 25).  
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5.10. Outbound Calling Party Information 

In accordance to the SIP URI configuration on Section 5.5.4, Avaya IP Office will use the 

information on the Incoming Number field on the Incoming Call Routes (Section 5.7) to 

populate the From and Contact headers on outbound calls from the IP Office users. These 

headers are used by the service provider to deliver Caller ID information to the receiving end of 

the call. 

 

There are cases where the IP Office user may not be associated with an Incoming Call Route.  

In other situations, it may be desired to send the same outbound caller ID for all the users in the 

enterprise. Short Codes can be created to construct the From and Contact headers in the outgoing 

SIP INVITE message. 

5.10.1. Short Code- User 

In cases where a user does not have an associated Incoming Call Route with a DID number 

assigned to it, a Short Code can be created for that user to set the outbound caller ID.  

 

To set a Short Code for an existing user, select User in the Navigation pane, and select the 

appropriate user to be configured in the Group pane. Select the Short Code tab on the Details 

pane and click Add (not shown). 

 

The following screen shows the Short Codes tab for user 6240. This user does not have an 

associated Incoming Call Route.  

 

 
 

• Set Code to 9N 

• In the example, the Telephone Number is set to “Ns+14241234500”. The number after  

the “s” will be sent on the From and Contact headers in the outgoing SIP INVITE on 

calls from this user. 

• Feature = Dial 

• Line Group ID = 65, the ARS route to be used for Masergy SIP Trunking.  
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5.10.2. Short Code - ARS 

In some specific cases, the customer may prefer to send on outbound calls the same caller ID for 

all the users in the enterprise, for example, the published main number for the location.  

 

Short Code entries on the ARS table (Section 5.9) can be created or edited, to modify the From 

and Contact headers in the outgoing SIP INVITE messages for all outbound calls.  

 

On the screen below, an existing ARS Short Code entry was modified. The Telephone Number 

is set to “Ns+14241230000”. The number after the “s” will be sent on the From and Contact 

headers in the outgoing SIP INVITE on calls from all users in the Avaya IP Office using this 

ARS route. 
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5.11. Save IP Office Primary Server Configuration 

The provisioning changes made in Avaya IP Office Manager must be applied to the Avaya IP 

Office server in order for the changes to take effect. At the top of the Avaya IP Office Manager 

page, click File → Save Configuration (if that option is grayed out, no changes are pending).  

 

A screen similar to the one below will appear, with either Merge or Immediate automatically 

selected, based on the nature of the configuration changes. The Merge option will save the 

configuration change with no impact to the current system operation. The Immediate option will 

save the configuration and cause the Avaya IP Office server to reboot.  

 

Click OK to execute the save. 
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6. Avaya IP Office Expansion System Configuration 
Navigate to File → Open Configuration (not shown), select the proper Avaya IP Office system 

from the pop-up window, and log in using the appropriate credentials. Clicking the “plus” sign 

next to IP500 Expansion on the left navigation pane will expand the menu on this server. 

 

 

6.1. Expansion System - Physical Hardware 

In the sample configuration, the IP500 V2 Expansion System contained a PHONE8 analog card 

and a COMBO6210 card, for the support of analog and digital stations. Also included is a 

VCM64 (Voice Compression Module). Both the VCM64 and the COMBO6210 cards provide 

voice compression channels to the control unit. Voice compression channels are needed to 

support VoIP calls, including IP extensions and or IP trunks. 
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6.2. Expansion System - LAN Settings 

In the sample configuration, LAN1 is used to connect the Expansion System to the enterprise 

network. To view or configure the LAN1 IP address, select System on the Navigation pane. 

Select the LAN1 → LAN Settings tab on the Details pane, and enter the following:  

• IP Address: 10.5.5.180 was used in the reference configuration.  

• IP Mask: 255.255.255.0 was used in the reference configuration  

• Click the OK button (not shown).  

 

 
 

Defaults were used on the VoIP and Network Topology tabs (not shown). 

6.3. Expansion System - IP Route 

To create an IP route for the Expansion system, right-click on IP Route on the left Navigation 

pane. Select New (not shown). 

• Enter 0.0.0.0 on the IP Address and IP Mask fields to make this the default route. 

• Set Gateway IP Address to the IP Address of the default router in the IP Office subnet. 

The default gateway in the reference configuration was 10.5.5.2 

• Set Destination to LAN1 from the pull-down menu. 
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6.4. Expansion System - IP Office Line 

The IP Office Line was automatically created on each server when the Expansion System is 

added to the solution. Below is the IP Office Line to the Primary server. 

 

 
 

In the reference configuration, a fax machine is connected to one of the analog ports on the 

Expansion System. To accommodate T.38 fax, select the VoIP Settings tab and set Fax 

Transport Support to T38.  
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Select the T38 Fax tab. The Use Default Values box is unchecked, and the T38 Fax Version is 

set to “0”. All other values are left at default. 

 

 

6.5. Expansion System - Short Codes 

Similar to the configuration of the Primary server in Section 5.8, create a Short Code to access 

ARS. In the reference configuration, the Line Group ID is set to the ARS route illustrated in the 

next section. 
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6.6. Expansion System - Automatic Route Selection – ARS 

The following screen shows an example ARS configuration for the route named “To-Primary” 

on the Expansion System. The Telephone Number is set to 9N. The Line Group ID is set to 

“99999” matching the number of the Outgoing Group configured on the IP Office Line 17 to 

the Primary server (Section 6.4). 
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6.7. Save IP Office Expansion System Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections 

 

The following will appear, with either Merge or Reboot selected, based on the nature of the 

configuration changes made since the last save. Note that clicking OK may cause a service 

disruption. Click OK to proceed. 
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7. Configure Avaya Session Border Controller for Enterprise 

This section covers the configuration of the Avaya SBCE. It is assumed that the initial 

provisioning of the Avaya SBCE, including the assignment of the management interface IP 

Address and license installation have already been completed; hence these tasks are not covered 

in these Application Notes. For more information on the installation and provisioning of the 

Avaya SBCE consult the Avaya SBCE documentation in the Additional References section. 

 

Use a WEB browser to access the Element Management Server (EMS) web interface, and enter 

https://ipaddress/sbc in the address field of the web browser, where ipaddress is the management 

LAN IP address of the Avaya SBCE. 

 

Enter the Username and click on Continue. 

 

 
 

Enter the password and click on Log In. 
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The EMS Dashboard page of the Avaya SBCE will appear. Note that the installed software 

version is displayed. Verify that the License State is OK. The SBCE will only operate for a 

short time without a valid license. Contact your Avaya representative to obtain a license. 

 

 

7.1. Device Management – Status 

Select Device Management and verify that the Status column says Commissioned. If not, 

contact your Avaya representative. To view system information that was configured during 

installation, navigate to System Management. A list of installed devices is shown in the right 

pane. In the case of the sample configuration, a single device named SBCE8-100 is shown. To 

view the configuration of this device, click View on the screen below. 

 

Note – Certain Avaya SBCE configuration changes require that the underlying 

application be restarted. To do so, click on Restart Application shown below. 
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The System Information screen shows the Network Configuration, DNS Configuration and  

Management IP(s) information provided during installation and corresponds to Figure 1. In the 

shared test environment, the highlighted A1 and B2 IP addresses are the ones relevant to the 

configuration of the SIP trunk to Masergy. 
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7.2. TLS Management 

Note – Testing was done using identity certificates signed by a local certificate authority. The 

procedure to create and obtain these certificates is outside the scope of these Application Notes. 

 

In the reference configuration, TLS transport is used for the communication between IP Office 

and Avaya SBCE. The following procedures show how to view the certificates and configure the 

profiles to support the TLS connection. 

7.2.1. Verify TLS Certificates – Avaya Session Border Controller for 
Enterprise 

To access the SBCE configuration menus, select the SBCE device from the top navigation menu. 

 

 
 

Select TLS Management → Certificates from the left-hand menu. Verify the following: 

• The root CA certificate is present in the Installed CA Certificates area. 

• The signed identity certificate is present in the Installed Certificates area. 

• The private key associated with the identity certificate is present in the Installed Keys 

area. 
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7.2.2. Server Profiles 

Select TLS Management → Server Profiles and click on Add. Enter the following: 

• Profile Name: enter descriptive name. 

• Certificate: select the identity certificate, e.g., sbce8_100.pem, from pull down menu. 

• Peer Verification = None. 

• Click Next. 

 

 Accept default values for the next screen (not shown) and click Finish. 
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The following screen shows the completed TLS Server Profile form: 
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7.2.3. Client Profiles 

Select TLS Management → Client Profiles and click on Add. Enter the following: 

• Profile Name: enter descriptive name. 

• Certificate: select the identity certificate, e.g., sbce8_100.pem, from pull down menu. 

• Peer Verification = Required. 

• Peer Certificate Authorities: select the CA certificate used to verify the certificate 

received from Session Manager, e.g., SystemManager8CA.pem. 

• Verification Depth: enter 1. 

• Click Next. 

 

Accept default values for the next screen (not shown) and click Finish. 
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The following screen shows the completed TLS Client Profile form: 
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7.3. Network Management 

The Network Management screen is where the network interface settings are configured and 

enabled. During the installation process of Avaya SBCE, certain network-specific information is 

defined such as device IP address(es), public IP address(es), netmask, gateway, etc., to interface 

the device to the network. It is this information that populates the various Network Management 

tab displays, which can be edited as needed to optimize device performance and network 

efficiency. Navigate to Networks & Flows → Network Management and verify the IP 

addresses assigned to the interfaces and that the interfaces are enabled. The following screen 

shows the enterprise interface is assigned to A1 and the interface towards Masergy is assigned to 

B2. 

 

The following Avaya SBCE IP addresses and associated interfaces were used in the sample 

configuration for the Masergy SIP Trunking service: 
 

• A1: 10.64.91.101 – “Inside” IP address, towards the IP Office. 

• B2: 192.168.80.50 – “Outside” IP address towards the Masergy SIP trunk. This address 

is known to Masergy. 

 

 
 

The following screen shows interface A1, and B2 are Enabled. To enable an interface, click the 

corresponding Disabled Status link to change it to Enabled. 
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7.4. Media Interface 

The Media Interface screen is where the SIP media ports are defined. Avaya SBCE will send SIP 

media on the defined ports. Create a SIP Media Interface for the inside and outside IP interfaces. 

 

To add the Media Interface in the enterprise direction, select Network & Flows → Media 

Interface from the menu on the left-hand side, and click the Add button (not shown). On the 

Add Media Interface screen, enter an appropriate Name for the Media Interface. Select the 

Avaya SBCE private IP Address from the IP Address drop-down menu. The Port Range was 

left at the default values of 35000-40000. Click Finish. 

 

The screen below shows the Inside-Media-101 media interface created in the reference 

configuration. 

 

 
 

A second Media Interface facing the public network side was similarly created with the name 

Outside-med_B2, as shown below. The outside IP Address of the Avaya SBCE was selected 

from the drop-down menu. The Port Range was left at the default values. Click Finish. 
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7.5. Signaling Interface 

The Signaling Interface screen is where the SIP signaling ports are defined. Avaya SBCE will 

listen for SIP requests on the defined ports. Create a Signaling Interface for the inside and 

outside IP interfaces. 

 

To create a new Signaling Interface on the enterprise direction, navigate to Network and Flows 

→ Signaling Interface and click Add. On the Add Signaling Interface screen, enter an 

appropriate Name for the interface. Select the private IP Address for the Avaya SBCE from the 

IP Address drop-down menu. Since TLS is used in the sample configuration to listen for 

signaling traffic from the IP Office, 5061 is entered under TLS Port. The TLS Profile is set to 

the TLS server profile sbce8_100Server shown on Section 7.2.2. Click Finish. 

 

 
 

A second Signaling Interface with the name Outside-sig_B2 was similarly created in the 

network direction. The B2 interface IP Address of the Avaya SBCE was selected from the drop-

down menu. Under UDP Port, enter 5060 as specified by Masergy. Click Finish. 
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7.6. Server Interworking Profile 

The Server Internetworking Profile includes parameters to make the Avaya SBCE function in an 

enterprise VoIP network using different implementations of the SIP protocol. There are default 

profiles available that may be used as is, or modified, or new profiles can be configured as 

described below. 

 

In the sample configuration, separate Server Interworking Profiles were created for IP Office and 

the service provider. 

7.6.1. Server Interworking Profile – IP Office 

In the sample configuration, the IP Office Server Interworking profile was cloned from the 

default avaya-ru profile. To clone a Server Interworking Profile for IP Office, navigate to 

Configuration Profiles → Server Interworking, select the avayu-ru profile and click the 

Clone button. Enter a Clone Name and click Finish to continue. 

 

 
 

The following screen shows the Enterprise Interwork profile used in the sample configuration, 

with T.38 Support set to Yes. To modify the profile, scroll down to the bottom of the screen and 

click Edit. Select the T.38 Support parameter and then click Next and then Finish (not shown). 

Default values can be used for all other fields. 
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7.6.2. Server Interworking Profile – Service Provider 

To create a new Server Interworking Profile for Masergy, navigate to Configuration Profiles → 

Server Interworking and click Add as shown below. Enter a Profile Name and click Next. 

 

 
 

The following screens show the SIP Provider Interw profile used in the sample configuration. 

On the General tab, default values are used with the exception of T.38 Support set to Yes. 
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The Timers tab shows the values used for compliance testing for the Trans Expire field. The 

Trans Expire timer sets the allotted time the Avaya SBCE will try the first primary server 

before trying the secondary server, if it exists. See Sections 7.8.2 and 7.9.2 for the configuration 

for redundant SBCs on the Masergy’s network. 

 

 
 

Default parameters are used for the Privacy, URI Manipulation, and Header Manipulation 

tabs (not shown). On the Advanced tab, verify Record Routes is set to Both Sides. Default 

values can be used for all other fields. 
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7.7. Signaling Manipulation 

Signaling Manipulations are SigMa scripts the Avaya SBCE can use to manipulate SIP 

headers/messages. In the reference configuration, one signaling manipulation script is used. 

 

Note – Use of the Signaling Manipulation scripts require higher processing requirements on the 

Avaya SBCE. Therefore, this method of header manipulation should only be used in cases where 

the use of Server Interworking Profiles (Section 7.6) or Signaling Rules (Section 7.13) does not 

meet the desired result. Refer to [10] on the Additional References section for information on 

the Avaya SBCE scripting language. 

 

As described in Section 2.2, when privacy is enabled at an IP Office station, the SIP INVITE on 

the outbound call to the network does not include the “Privacy: id” header. This can cause the 

far-end to still see the number presented in the P-Asserted Identity header. To address this issue, 

a script file is used to insert the “Privacy: id” header on calls where privacy is enabled by the IP 

Office user. 

 

1. Select Configuration Profiles from the menu on the left-hand side. 

2. Select Signaling Manipulation. 

3. Click Add Script (not shown) and the script editor window will open. 

4. Enter a name for the script in the Title box (e.g., Add Privacy id header). The 

following script is defined: 

 

 
 

Click on Save. The script editor will test for any errors, and the window will close. This script 

will later be applied to the Masergy Server Configuration profile in Section 7.8.2.  
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7.8. SIP Server Profiles 

The SIP Server Profile contains parameters to configure and manage various SIP call server-

specific parameters such as TLS, TCP and UDP port assignments, heartbeat signaling 

parameters, DoS security statistics, and trusted domains. 

 

In the sample configuration, separate SIP Server Profiles were created for the IP Office and the 

service provider. 

7.8.1. SIP Server Profile – IP Office 

To add a SIP Server Profile for IP Office, navigate to Services → SIP Servers and click Add. 

Enter a descriptive name for the new profile and click Next. 

 

 
 

The following screens illustrate the SIP Server Profile named IPOSE Call Server. In the 

General parameters, the Server Type is set to Call Server. In the IP Address / FQDN field, the 

IP Address of IP Office LAN 1 interface in the sample configuration is entered. This IP address 

is 10.64.19.170. Under Port, 5061 is entered, and the Transport parameter is set to TLS. The 

TLS profile sbce8_100Client created in Section 7.2.3 is selected for TLS Client Profile. If 

adding the profile, click Next (not shown) to proceed. If editing an existing profile, click Finish. 
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Default values can be used on the Authentication tab, click Next (not shown) to proceed to the 

Heartbeat tab. The Avaya SBCE can be optionally configured to source “heartbeats” towards IP 

Office. Check the Enable Heartbeat box and select OPTIONS from the Method drop-down 

menu. Select the desired frequency that the SBCE will source OPTIONS towards IP Office. 

 

 
 

On the Advanced tab, Enable Grooming is checked and the Interworking Profile is set to 

Enterprise Interwork created in Section 7.6.1 for IP Office. 
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7.8.2. SIP Server Profile – Service Provider 

To add a SIP server profile for the service provider, navigate to Services → SIP Servers and 

click Add. Enter a descriptive name for the new profile and click Next. 

 

 
 

In the reference configuration, Masergy provided two SBCs, 192.168.11.97 (Primary) and 

192.168.9.97 (Secondary), for redundancy purposes. The Avaya SBCE can be provisioned to 

support this redundant configuration. 

 

The following screens illustrate the SIP Server Profile Masergy. In the General parameters, the 

Server Type is set to Trunk Server. In the IP Address / FQDN fields, the Masergy-provided 

SBCs IP addresses are entered. This is 192.168.11.97 (Primary) and 192.168.9.97 (Secondary). 

Under Port, 5060 is entered, and the Transport parameter is set to UDP. If adding the profile, 

click Next (not shown) to proceed. If editing an existing profile, click Finish. 

 

 
 

Default values can be used on the Authentication tab, click Next (not shown) to proceed to the 

Heartbeats tab.  
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On the Heartbeat tab, check the Enable Heartbeat box. Select OPTIONS from the Method 

drop-down menu. Select the desired frequency that the SBCE will source OPTIONS. The From 

URI and To URI may be filled in to configure easily identifiable URIs to appear in SIP 

OPTIONS sourced by the Avaya SBCE. If adding a new profile, click Next to continuing to the 

Advanced settings. 

 

 
 

Note – The Avaya SBCE will issue OPTIONS messages to both Masergy SBC, primary 

(192.168.11.97) and secondary (192.168.9.97). If the SBCE fails to get a response to the 

OPTIONS sent to 192.168.11.97, the SBCE will redirect outbound calls to 192.168.9.97. 

 

On the Advanced tab, Enable Grooming is not used for UDP connections and is left 

unchecked. The Interworking Profile is set to the SIP Provider Interw created in Section 7.6.2 

for Masergy. The Signaling Manipulation Script is set to the script created in Section 7.7. 
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7.9. Routing Profile 

Routing Profiles define a specific set of packet routing criteria that are used in conjunction with 

other types of domain policies to identify a particular call flow and thereby ascertain which 

security features will be applied to those packets. Parameters defined by Routing Profiles include 

packet transport settings, name server addresses and resolution methods, next hop routing 

information, and packet transport types. Separate Routing Profiles were created in the reference 

configuration for IP Office and the Masergy SIP Trunking service. 

7.9.1. Routing Profile – IP Office 

To add the Routing Profile for the IP Office, navigate to Configuration Profiles → Routing and 

select Add. Enter a Profile Name and click Next to continue. 

 

 
 

The following screen shows the Routing Profile To IPOSE created in the sample configuration. 

The parameters in the top portion of the profile are left at their default settings. Clicking the Add 

button on this screen allows to enter the routing rule at the bottom of the profile. The Priority / 

Weight parameter is set to 1, and the IP Office SIP Server Profile, created in Section 7.8.1, is 

selected from the drop-down menu. The Next Hop Address is automatically populated with the  

values from the IP Office SIP Server Profile, and Transport becomes grayed out. Click Finish. 
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7.9.2. Routing Profile – Service Provider 

Similarly, add a Routing Profile to the Masergy SIP trunk. The following screen shows the 

Routing Profile Route to Masergy created in the sample configuration. The parameters in the 

top portion of the profile are left at their default settings.  

 

For the first routing rule (Masergy Primary SBC), set the following: 

• Set Priority / Weight to 1  

• SIP Server Profile: select the Masergy profile created in Section 7.8.2 from the drop-

down menu.  

• On the Next Hop Address select 192.168.11.97:5060 (UDP) from the drop-down menu. 

 

For the second routing rule (Masergy Secondary SBC): 

• Set Priority / Weight to 2  

• Server Configuration: select the Masergy profile created in Section 7.8.2 from the 

drop-down menu.  

• On the Next Hop Address select 192.168.9.97:5060 (UDP) from the drop-down menu. 

• Click Finish. 

 

 
 

Note – If desired, the Load Balancing parameter may be used to modify how the traffic is 

handed to the service provider’s SBCs. Priority was used in the Reference Configuration. 
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7.10. Topology Hiding Profile 

The Topology Hiding profile manages how various source, destination and routing information 

in SIP and SDP message headers are substituted or changed to maintain the integrity of the 

network. It hides the topology of the enterprise network from external networks. These profiles 

will later be applied to the Server Flows in Section 7.155. 

 

To create the Topology Hiding profiles for IP Office and the service provider, navigate to 

Configuration Profiles → Topology Hiding. Click the Add button to add a new profile, or 

select an existing topology hiding profile to clone or edit. In the sample configuration, the 

default profile was cloned to create the profiles.  

 

In the Replace Action column an action of Auto will replace the header field with the IP address 

of the Avaya SBCE interface and the Overwrite will use the value in the Overwrite Value. 

 

The example below shows the IPOSE_Topology profile created in the reference configuration. 

The profile was  cloned from the default. The Request-Line, To and From headers were 

overwritten with the domain of the enterprise. 

 

 
  



 
MAA; Reviewed: 

SPOC 6/12/2019 

Solution & Interoperability Test Lab Application Notes 

©2019 Avaya Inc. All Rights Reserved. 

 

66 of 79 

Msrgy-IPO11SBC8 

 

A second profile, Masergy-Topology was similarly cloned from the default. The Request-Line, 

To and From headers were overwritten with the domain used by Masergy. 

 

 

7.11. Application Rule 

Application Rules define which types of SIP-based Unified Communications (UC) applications 

the Avaya SBCE security device will protect: voice, video, and/or Instant Messaging (IM). In 

addition, you can determine the maximum number of concurrent voice and video sessions the 

network will process in order to prevent resource exhaustion. 

 

Select Domain Policies → Application Rules from the left-side menu as shown below. Click 

the Add button to add a new profile, or select an existing application rule to edit. In the sample 

configuration, a sip-trunk rule was created for IP Office and Masergy. In an actual customer 

installation, set the Maximum Concurrent Sessions for the Audio and Video applications to a 

value slightly larger than the licensed sessions. For example, if licensed for 150 session set the 

values to 200. The Maximum Session Per Endpoint should match the Maximum Concurrent 

Sessions. 
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7.12. Media Rule 

Media Rules define RTP media packet parameters such as prioritizing encryption techniques and 

packet encryption techniques. Together these media-related parameters define a strict profile that 

is associated with other SIP-specific policies to determine how media packets matching these 

criteria will be handled by the Avaya SBCE security product. 

 

Select Domain Policies → Media Rules from the left-side menu as shown below. In the sample 

configuration, the default Media Rule avaya-low-med-enc was cloned to create the IP Office 

enterprise med rule, and modified as shown below. With the avaya-low-med-enc rule chosen, 

click Clone. Enter a descriptive name for the new rule and click Finish (not shown). 

 

The media rule enterprise med rule was used for IP Office as shown below. 
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To create the Media Rule to be used for the service provider, the default media rule default-low-

med was cloned in this case to create the Masergy-med-rule, shown below. 
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7.13. Signaling Rule 

Signaling Rules define the action to be taken (Allow, Block, Block with Response, etc.) for each 

type of SIP-specific signaling request and response message. When SIP signaling packets are 

received by Avaya SBCE, they are parsed and “pattern-matched” against the particular signaling 

criteria defined by these rules. Packets matching the criteria defined by the Signaling Rules are 

tagged for further policy matching. 

 

Clone and modify the default Signaling Rule to add the proper quality of service to the SIP 

signaling. To clone a Signaling Rule, navigate to Domain Policies → Signaling Rules. With the 

default rule chosen, click Clone. Enter a descriptive name for the new rule and click Finish (not 

shown). In the sample configuration, Signaling Rule enterprise-sig-rule for the IP Office was 

unchanged from the default rule. 

 

 
 

Similarly, the Masergy-sig-rule (not shown) for Masergy was also cloned from the default rule 

and left unchanged from the default values. 
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7.14. Endpoint Policy Groups 

The rules created within the Domain Policy section are assigned to an Endpoint Policy Group. 

The Endpoint Policy Group is then applied to a Server Flow in Section 7.15. 

 

To create a new policy group, navigate to Domain Policies → Endpoint Policy Groups and 

click on Add as shown below. The following screen shows the enterprise-policy-gr created for 

IP Office. The details of the non-default rules chosen are shown in previous sections. 

 

 
 

The following screen shows the Masergy-policy-grp created for Masergy. The details of the 

non-default rules chosen are shown in previous sections. 
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7.15. End Point Flows - Server Flow 

When a packet is received by Avaya SBCE, the content of the packet (IP addresses, URIs, etc.) 

is used to determine which flow it matches. Once the flow is determined, the flow points to a 

policy which contains several rules concerning processing, privileges, authentication, routing, 

etc. Once routing is applied and the destination endpoint is determined, the policies for this 

destination endpoint are applied. The context is maintained, so as to be applied to future packets 

in the same flow.  

 

Create Server Flows for IP Office and the service provider. To create a Server Flow, navigate to 

Network and Flows → End Point Flows. Select the Server Flows tab and click Add (not 

shown).  

 

The following screen shows the flow named IPOSE Flow viewed from the sample 

configuration. This flow uses the interfaces, polices, and profiles defined in previous sections. 
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Once again, select the Server Flows tab and click Add. The following screen shows the flow 

named Masergy Flow viewed from the sample configuration. This flow uses the interfaces, 

polices, and profiles defined in previous sections. 
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8. Masergy SIP Trunking Service Configuration 
To use the Masergy SIP Trunking Service, a customer must request the service from Masergy 

using the established sales processes. The process can be started by contacting Masergy via the 

corporate web site at https://www.masergy.com/ 

  

Masergy is responsible for the configuration of Masergy SIP Trunking service. The customer 

will need to provide the IP address used to reach the IP Office at the enterprise. In the reference 

configuration, this address will be the outside interface of the Avaya SBCE. Masergy will 

provide the customer the necessary information to configure the Avaya IP Office SIP connection 

to Masergy. The provided information from Masergy includes: 

 

• IP address of the Masergy SIP proxy or proxies. 

• Supported codecs. 

• DID numbers. 

• IP addresses and port numbers used for signaling or media through any security devices. 

9. Verification Steps 
This section provides example verifications of the Avaya configuration with the Masergy SIP 

Trunking service. 

9.1. Avaya SBCE 

This section provides verification steps that may be performed with the Avaya SBCE. 

9.1.1. Incidents 

The Incident Viewer can be accessed from the Avaya top navigation menu as highlighted in the 

screenshot below. 

 

 
  

https://www.masergy.com/
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Use the Incident Viewer to verify Server Heartbeat and to troubleshoot routing failures. 

 

 

9.1.2. Server Status 

The Server Status can be access from the Avaya SBCE top navigation menu by selecting the 

Status menu, and then Server Status. 

 

 

9.1.3. Tracing  

To take a call trace, navigate to Monitoring & Logging → Trace and select the Packet 

Capture tab. Populate the fields for the capture parameters and click Start Capture as shown 

below. 
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When tracing has reached the desired number of packets the trace will stop automatically, or 

alternatively, hit the Stop Capture button at the bottom. 

 

 
 

Select the Captures tab to view the files created during the packet capture. 

 

 
 

The packet capture file can be downloaded and then viewed using a Network Protocol Analyzer 

like WireShark.  
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9.2. IP Office 

This section provides verification steps that may be performed with the IP Office. 

9.2.1. System Status 

The Avaya IP Office System Status application can be used to verify the service state of the SIP 

line. From the IP Office Manager application, select File → Advanced → System Status.  

Under Control Unit IP Address select the IP address of the IP Office system under verification. 

Log in using the appropriate credentials. 

 

 
 

Select the SIP line from the left pane (Line 25 in the reference configuration). On the Status tab 

in the right pane, verify that the Current State is Idle for each channel (assuming no active calls 

at present time). 
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In the lower part of the screen, the Trace All button may be pressed to display real time tracing 

information as calls are made using this SIP Line. The Ping button can be used to ping the other 

end of the SIP trunk (e.g., Avaya SBCE). 

 

Select the Alarms tab and verify that no alarms are active on the SIP line. 

 

 

9.3. System Monitor 

The Avaya IP Office Monitor application can be used to monitor and troubleshoot signaling 

messaging on the SIP trunk. Launch the application from Start → Programs → IP Office → 

Monitor on the PC where IP Office Manager was installed. Click the Select Unit icon on the 

taskbar and Select the IP address of the IP Office system under verification.  
 

 
 

Clicking the Trace Options icon on the taskbar and selecting the SIP tab allows modifying the 

threshold used for capturing events, types of packets to be captured, filters, etc. Additionally, the 

color used to represent the packets in the trace can be customized by right clicking on the type of 

packet and selecting to the desired color. 
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10. Conclusion 
As illustrated in these Application Notes, Avaya IP Office Release 11.0 and the Avaya Session 

Border Controller for Enterprise 8.0 can be configured to interoperate successfully with the 

Masergy SIP Trunking Service, with the observations/limitations described in Section 2.2. 

 

The reference configuration shown in these Application Notes is representative of a basic 

enterprise customer configuration and is intended to provide configuration guidance to 

supplement other Avaya product documentation. It is based upon formal interoperability 

compliance testing as part of the Avaya DevConnect Service Provider program. 

11. Additional References  
This section references the documentation relevant to these Application Notes. Product 

documentation for Avaya IP Office, including the following, is available at: 

http://support.avaya.com/ 
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[2] IP Office Platform 11.0, Deploying Avaya IP Office Servers as Virtual Machines, January 

2019 

[3] IP Office Platform 11.0, Deploying Avaya IP Office Essential Edition (IP500 V2), February 

2019. 

[4] Administering Avaya IP Office Platform with Manager, Release 11.0 FP4, February 2019. 

[5] Administering Avaya IP Office™ Platform with Web Manager, Release 11.0 FP4, February 

2019. 

[6] Planning for and Administering Avaya Equinox for Android, iOS, Mac and Windows, 

Release 3.4.8, November 2018 

[7] Using Avaya Equinox for IP Office, Release 11.0 FP4, February 2019 
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Additional Avaya IP Office information can be found at:  

http://marketingtools.avaya.com/knowledgebase/  

http://support.avaya.com/
https://www.ietf.org/rfc/rfc3261.txt
http://marketingtools.avaya.com/knowledgebase/
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