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Abstract 
 

  
These Application Notes describe the procedure for configuring SpeechSwitch Speech 
Enabled Automated Attendant – analog integration to work with Avaya IP Office.  
Information in these Application Notes has been obtained through compliance testing and 
additional technical discussions.  Testing was conducted via the DeveloperConnection 
Program at the Avaya Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes focus on the steps required for configuring SpeechSwitch Speech 
Enabled Automated Attendant to work with Avaya IP Office. 
 
The SpeechSwitch Speech-Enabled Auto Attendant (SEAA) is a stand-alone auto attendant that 
enables businesses to incorporate speech recognition into their current communication systems 
without duplicating voice mail applications.  Features provided by SEAA include: 
 

• Recognizing any name or word in the English language 
• Allowing callers to barge-in on the Auto Attendant at any time 
• GUI Configurable User/Extension Dictionary 

 
Upon initial configuration, the SEAA goes through a tuning period where it adapts to the speech 
levels, noise levels, and line clarity of the phone system it is using.  After the initial tuning 
period, the success rate for recognizing names increases.  The SEAA has the ability to speed up 
tuning, but this requires experienced SEAA operators and is not left to the end-user to configure.  
After three failed attempts by the caller, the SEAA will route the call to an extension defined in 
the SEAA as the Operator extension.  
 
The configuration in Figure 1 shows a network consisting of an Avaya IP Office 406v2 with 
Avaya IP400 Phone Expansion Module, Avaya IP Office Manager/Voicemail Pro PC, 
SpeechSwitch SEAA, Avaya 2420, 5420 and 6408D+ digital telephones, Avaya 4600-series IP 
telephones and analog telephones. Avaya IP Office has T1/PRI and analog trunks to the central 
office. 
 
The SEAA interfaces with IP Office via station trunking interface using a Dialogic card.  The 
Dialogic card is connected to analog station ports on Avaya IP Office and/or the Avaya IP400 
Phone Expansion Module.  IP Office is configured to route inbound calls to a hunt group made 
up of the analog station ports connected to the SEAA.  Upon receipt of the inbound calls, the 
SEAA determines the destination extension via voice recognition or by the caller DTMF digits 
entered.  The SEAA then transfers the call to the destination extension by performing a hook 
flash transfer – TAPI is not used in this solution.   The SEAA is not a voice mail system.    
 
The tested configuration is shown in Figure 1.   
 
Note:  For security purposes, Avaya IP Office does not support nested forwarding.  In the event 
SEAA becomes unavailable, calls to extensions, which are forwarded to the SEAA hunt group as 
coverage calls, will not be routed to the SEAA hunt group’s overflow or fallback path.  If such a 
scenario occurs, the administrator must make alternate call routing arrangements until the SEAA 
becomes available.  
 



 
Figure 1 – Network Configuration Diagram 

 
Table 1 lists all users and associated extension numbers for Figure 1. 
 

End User Name Extension 
Khoa Bui 6501 
John Yaya 6502 
Marketing 6503 
Kit Tankhiwale 6510 
Tech Support 6511 
John Finnegan 6512 
John Bigbootei 6513 
Returns 6517 
SEAA Operator 206 
  
Hunt Group  
SEAA HG 6570 
  
SEAA port Extensions  
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seaa 1 235 
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End User Name Extension 
seaa 2 236 
seaa 3 237 
seaa 4 238 

 
Table 1 – User to Extension Mapping 

 

2. Equipment and Software Validated 
or the sample configuration The following equipment and software/firmware were used f

provided in Figure 1: 
 

Equipment Software/Firmware 
Avaya IP Office 406v2 4.0(5) 
Avaya IP400 Office Phone Expansion Module 6.0(5) 
Avaya IP Office Manager 6.0(5) 
Avaya IP Office Voicemail Pro 4.0(15) 
Avaya 4600-series IP Telephones 
(4610SW, 4620SW) 

2.3 

Avaya 2420, 5420, and 6408D+ Digital Telephones - 
Avaya Analog Telephone - 
SpeechSwitch Speech Enabled Auto Attendant 3.2.0 

 
Table 2 – Equipment and Softwa are Versions Validated  

 

3. Configure Avaya IP Office 
 section describes the steps required to set up 

or all other provisioning information, such as Avaya IP Office installation and configuration, 

re / Firmw

The configuration information provided in this
Avaya IP Office for this solution. 
 
F
please refer to Avaya IP Office product documentation in reference [1]. 
 
Step Description 

1.  P Office Manager PC with the appropriate administrative privileges and go to Log into the I
Start → All Programs → IP Office → Manager to launch the Manager application. 

2.  in the In the Manager window, select File → Open Configuration… to search for IP Office 
network. 



 
Step Description 

3.  Log into IP Office using the appropriate login credentials to receive its configuration. 
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Step Description 
 Configure SEAA port extensions 

4.  In the Manager window, go to the Configuration Tree in the left pane and double-click 
Extension to open the list of extensions on IP Office. 

5.  In the extension list that appears, click the extension number that matches the first SEAA port 
extension in Table 1.  Select the Analogue tab.  
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Step Description 
6.  In the Analogue tab, select IVR Port and click OK.   
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Step Description 
7.  In the Manager window, go to the Configuration Tree and double-click User to open the list 

of users on IP Office. In the list of users that appears, select the extension number that 
matches the first SEAA port extension number in Table 1.  In the User window that appears, 
set Name to the name of the first SEAA port extension listed in Table 1.  Select the 
Voicemail tab. 
 

 
8.  

 

In the Voicemail tab, uncheck Voicemail On.  Select the Telephony tab. 
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Step Description 
9.  In the Telephony tab, uncheck Call Waiting On, uncheck Answer Call Waiting On Hold 

(Analogue), uncheck Cannot be Intruded and click OK. 
 

 
10.  Repeat Steps 5 – 9 for each SEAA port extension listed in Table 1.  For the purposes of these 

Application Notes, extensions 235 – 238 were configured in this manner. 



 
Step Description 
 Configure SEAA hunt group 

11.  In the Manager window, go to the Configuration Tree, right-click Hunt Group and select 
New in the popup that appears. 

12.  In the hunt group window that appears, set Name to the name of the SEAA hunt group listed 
in Table 1, set Extension to the extension number listed for the SEAA hunt group in Table 
1. Add all the SEAA port extensions listed in Table 1 to the Extension List. Select Rotary 
for Ring Mode.  Select the Voicemail tab. 
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Step Description 
13.  In the Voicemail tab, uncheck Voicemail On.  Select the Queuing tab. 

 

 
14.  In the Queuing tab, uncheck Queuing On.  Click OK. 

 



 
Step Description 
 Configure incoming call route to route calls to SEAA hunt group 

15.  In the Manager window, go to the Configuration Tree, right-click Incoming Call Route and 
select New in the popup that appears. 

16.  In the Incoming Call Route window that appears, set Line Group Id to a unique number and 
Destination to 6570 SEAA HG.  Click OK.  Note:  Make sure no other incoming call route 
is configured with the same Line Group Id. 
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Step Description 
 Assign incoming call route to inbound trunks being used 

17.  In the Manager window, go to the Configuration Tree and click Line.  In the list of lines that 
appear, click the line (analog or digital) whose incoming calls are to be routed to the SEAA 
hunt group extension.  For the purposes of these Application Notes, analog line 1 is selected. 

18.  In the window that appears, set Incoming Group ID to the value used for Line Group Id in 
Step 16.  A similar procedure is used on the T1/PRI lines.  Click OK. 
 

 
19.  Repeat Steps 17 – 18 for each line (trunk) assigned to the Incoming Call Route. 
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Step Description 
 Configure user extensions 

20.  In the Manager window, go to the Configuration Tree and click Extension.  In the list of 
extensions that appear, click the Extension Id that will be assigned to the first end user listed 
in Table 1.   

21.  In the Extension window that appears, set Base Extension to the extension number of the 
first end user in Table 1.  Click OK. 
 

 
22.  In the Manager window, go to the Configuration Tree, right-click User and select New in the 

popup that appears. 
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Step Description 
23.  In the User window that appears, set Name to the name of the first end user listed in Table 1, 

set Extension to the extension number associated with the first end user in Table 1.  
Click OK. 

 
24.  Repeat Steps 20 – 23 for each end user extension listed in Table 1.  For the purposes of these 

Application Notes, end user extensions 6501 – 6503, 6510 – 6513, and 6517 were created. 
25.  In the Manager window, select File → Save to push the configuration to IP Office.  In the 

Send Configuration popup that appears, select Immediate for Configuration Reboot Mode 
and click OK.  Wait for the system to update.  This completes configuration of Avaya IP 
Office for this solution. 

 

4. Configure SpeechSwitch Speech Enabled Automated 
Attendant 

The configuration information provided in this section describes the steps required to configure 
SpeechSwitch SEAA to work with Avaya IP Office for this solution. 
 
For all other provisioning information, such as software installation, installation of optional 
components, and/or the configuration of SEAA, please refer to the SpeechSwitch SEAA product 
documentation in reference [2]. 
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Step Description 
1.  Log into the SEAA PC with the appropriate administrative privileges and go to Start → All 

Programs → iVoice → iVoice Media Center to launch the SEAA application.  Note:  
SpeechSwitch was formerly known as iVoice. 

2.  In the iVoice Media Center window that appears, select Auto Attendant → Settings. 
 

 
3.  In the Settings window that appears, select the Extensions tab. 
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Step Description 
4.  In the Extensions tab, set Mailbox/Extension Digits to 4, set Operator Extension Day to 

the SEAA Operator extension number defined in Table 1, set Operator Extension Night to 
the SEAA Operator extension number defined in Table 1, and check Set variable extension 
numbers.  Click OK.   Note:  The Mailbox/Extension Digits field becomes grayed out 
when Set variable extension numbers is checked. 

 
5.  In the Media Center popup that appears, click OK. 

 

 
 Recording Prompts 

6.  Place an internal call to the SEAA hunt group.  When the welcome greeting plays, dial the 
supervisor extension as defined in Step 4.  When prompted, enter the supervisor password as 
defined in Step 4. 

7.  To record the day greeting, press 1.  Press 2 to record the night greeting.  For both the day 
and night greeting, press 1 to record, 2 to review the recording and  # to exit. 

8.  Hang up when finished. 



 
Step Description 
 Adding User Names to the SEAA Telephone Directory 

9.  In the iVoice Media Center window, select Auto Attendant → Telephone Directory. 
 

 
10.  In the Telephone Directory window that appears, click Add Row to add a new row to the 

directory listing.  In the new row that appears, set First Name and Last Name to the name of 
the first user listed in Table 1, set Tel. Ext. to the extension number of the first user listed in 
Table 1, and set Password to the extension number of the first user listed in Table 1.  Click 
the More>> button. 
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Step Description 
11.  The Telephone Directory window expands to show the Dictionary entry form on the right 

with the name (word) that is not in the dictionary as well as a phonetically generated 
pronunciation for it.  Click Add Name to add the name to the dictionary. 

 
If the name is added successfully to the dictionary, the following popup appears.  Click OK. 
 

 
12.  In the Telephone Directory window, click Apply to save the entry. 
13.  Repeat Steps 10 – 12 for each end user listed in Table 1.  For the purposes of these 

Application Notes, entries were made for the names associated with extensions 6501 – 6503, 
6510 – 6513, and 6517. This completes configuration of the SEAA.   

 

5. Interoperability Compliance Testing 
Interoperability compliance testing examined the ability of SpeechSwitch SEAA to properly 
transfer inbound and internal calls to the appropriate destination extension (digital, analog, IP 
telephone) on IP Office regardless of whether the caller used spoken or DTMF input.  
Performance load testing verified the configuration to continue operating when under load. 
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5.1. General Test Approach 
Feature functionality testing was performed manually.  Inbound calls were made to Avaya IP 
Office through analog and T1/PRI trunks, as well as from internal extensions (analog, digital and 
IP Telephone).  IP Office routed inbound calls to the SEAA hunt group.  Upon receipt of a call at 
an SEAA port extension, SEAA would play the automated attendant greeting and transfer calls 
according to the caller’s spoken input.   
 
A load test was performed using a call generator to generate inbound calls over four channels on 
a PRI trunk to Avaya IP Office.  Four call generator analog ports were connected to four Avaya 
IP Office analog station ports.  Four call generator scripts were written to place calls over the 
PRI trunk to Avaya IP Office and select transfer to a destination extension by playing a wave 
file.  Each wave file played the name of a different end user listed in Table 1.  Each call 
generator script played a different wave file. 
 

5.2. Test Results 
Except for the load test issues described below, all test cases were completed successfully.  
Observations and/or issues made during testing are noted below. 
 
• Hook flash transfer– When SEAA performs hook flash transfer (using its Intel Dialogic 

card), the caller will hear the hook flash followed by 2 beeps. 
 
• SEAA does not support *17 as valid DTMF input – The *17 is the default short code for 

voicemail retrieval on IP Office. SEAA does not recognize *17 as valid DTMF input. 
However, SEAA can be programmed with a user entry in its Telephone Directory called 
Voicemail so when the caller speaks ‘Voicemail’, the caller is transferred to voicemail. 

 
• Pause prior to hearing SEAA welcome greeting issue – When a call is answered by the 

SEAA, there is a noticeable pause, between 2 – 5 seconds, before the caller will hear the 
Welcome greeting play.  This can be confusing to callers who will think the call did not go 
through. 
Status: SpeechSwitch is aware of this issue and will incorporate changes in their next release 
to reduce this pause interval. 
 

• Load Test Issue (SEAA periodically did not recognize call generator wave file) – During 
the first couple of load test attempts, there were instances where SEAA did not recognize the 
wave file played by the call generator script.  In those instances, SEAA asked the caller to 
repeat the spoken input.   
Workaround: The call generator scripts were modified to first play a wave file, pause for 1 
– 2 seconds, and then automatically generate the DTMF digits of the desired destination 
extension.  This was meant to obtain a successful call transfer using DTMF input if spoken 
input was not successful.  
Status: This issue is under investigation by SpeechSwitch.  
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• Load Test – A load test with a call rate of ~532 call attempts per hour using 4 PRI trunk 
channels and calls averaging 18.91 seconds in length was run for one and a half hours.   The 
call generator reported placing 793 calls, SEAA reported placing 743 blind transfers, and IP 
Office System Monitor reported completing 712 transfers.  

 
o Issue 1: Mixed length extensions – There were instances where the SEAA failed 

to transfer a call even though according to the logs, SEAA recognized the DTMF 
input.  SpeechSwitch suspects that modifications introduced to support mixed 
length extensions may have contributed to the disparity in the numbers reported 
by the call generator and SEAA. 

o Status: This issue is under investigation by SpeechSwitch.  
 

o Issue 2 (Blind transfers not always successful) – There were some blind 
transfers performed by SEAA that were not completed successfully. Of the 743 
blind transfers reported by SEAA, IP Office System Monitor reported 712 were 
completed. 
Status: This issue is under investigation by SpeechSwitch. 

 

6. Verification Steps 
The following steps may be used to verify the configuration: 
 
� To verify the SEAA hunt group is operating properly: connect analog phones to all 

analog station ports assigned to the hunt group and call the hunt group.  Verify one of the 
phones rings. 

 
� To verify the SEAA is operating properly for internal calls:  place a call to the SEAA 

hunt group.  Verify the SEAA Welcome greeting plays and either speak a name or 
department, or enter the DTMF of a valid extension on IP Office.  Verify the call is 
transferred to the correct extension. 

 
� To verify the SEAA is operating properly for external calls:  place a call to IP Office 

through one of the trunks assigned to the SEAA hunt group.  Verify the SEAA Welcome 
greeting plays and either speak a name or department, or enter the DTMF of a valid 
extension on IP Office.  Verify the call is transferred to the correct extension. 

 

7. Support 
For technical support on Speech Enabled Automated Attendant, consult SpeechSwitch at 
www.speechswitch.com or contact the SpeechSwitch Technical Support at: 

• Phone: (732) 441-7700 x129 or say “Tech Support” 
• E-mail: techsupport@ivoice.com  
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8. Conclusion 
These Application Notes describe the steps for configuring SpeechSwitch Speech Enabled 
Automated Attendant to work with Avaya IP Office.  Except for the load test issues described in 
Section 5.2, all test cases completed successfully. 
 

9. Additional References  
Product documentation for Avaya products may be found at http://support.avaya.com. 
 
[1] Avaya IP Office 4.0 Manager: 02. Configuration Settings, Issue 19k, 22nd January 2007 
 
The following SpeechSwitch documentation is provided in the Installation CD: 
 
[2] SpeechSwitch Speech Enabled Automated Attendant System Guide, Version 3.1.0 
 



 
SCR; Reviewed: 
SPOC 3/20/2007 

Solution & Interoperability Test Lab Application Notes 
©2007 Avaya Inc. All Rights Reserved. 

23 of 23 
ipo-seaa 

 

 
 
©2007 Avaya Inc. All Rights Reserved. 
Avaya and the Avaya Logo are trademarks of Avaya Inc.  All trademarks identified by ® and ™ 
are registered trademarks or trademarks, respectively, of Avaya Inc.  All other trademarks are the 
property of their respective owners.  The information provided in these Application Notes is 
subject to change without notice.  The configurations, technical data, and recommendations 
provided in these Application Notes are believed to be accurate and dependable, but are 
presented without express or implied warranty.  Users are responsible for their application of any 
products specified in these Application Notes. 
 
Please e-mail any questions or comments pertaining to these Application Notes along with the 
full title name and filename, located in the lower right corner, directly to the Avaya 
DeveloperConnection Program at devconnect@avaya.com. 
 
 

 
 


