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Abstract 
 

  
These Application Notes describe the procedures for configuring eWings Technologies 
Communication Assistant (ComAssistant) to successfully interoperate with Avaya IP Office 
3.0. 
 
ComAssistant is a value-added total solution providing multiple speech-based services in one 
box.  It enhances users’ business efficiency and productivity by self-service and automation. 
 
In the configuration described in these Application Notes, ComAssistant used Microsoft 
TAPI3 to communication with IP Office 3.0.  During compliance testing, ComAssistant 
features – Auto Attendant, Auto Dialer, Personal Dialer and Voice Mail – were verified to be 
working. 
 
Testing was conducted via the DeveloperConnection Program at the Avaya Solution and 
Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe a compliance-tested configuration comprised of Avaya IP 
Office IP403 with the Digital Station Module, and eWings Technologies ComAssistant.   
 
ComAssistant 1.3.0 is a Windows 2000-based voice application providing enterprise-wide 
comprehensive voice applications.  It uses speech-recognition technology to provide Auto 
Dialer, Personal Dialer, Auto Attendant and Voice Mail services. 
 
For the Auto Attendant service, the IP Office is configured to route incoming calls to a hunt 
group that consists of the “virtual” TAPI Wave extensions configured on the ComAssistant.  
When ComAssistant receives a call, it determines the destination through speech-recognition or 
DTMF digits entered.  It then transfers the call to the destination extension by performing a 
TAPI-based transfer.  More hunt groups are configured in the same way for the other 
ComAssistant services such as Auto Dialer, Personal Dialer and Voice Mail.   
 
The Interoperability Compliance Testing included basic TAPI interworking and feature 
functionality testing only.  For Voice Mail service, the ComAssistant was tested for dial in voice 
recording/playback only (no voicemail call coverage testing or message waiting lamp update). 
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Figure 1: eWings ComAssistant Compliance Test Sample Configuration 
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2. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 
Equipment Software 
Avaya IP 403 Office System 3.0 (59) 
Avaya IP 400 Phone 30 Expansion Module 5.0 (59) 
Avaya 6408D+ - 
Avaya 4610SW, 4620SW IP Telephones 2.2.3 
Avaya IP Office Manager PC Windows XP Professional 
eWings ComAssistant Server 1.3.0 

 

3. Configure the Avaya IP Office 
These Application Notes address provisioning of the IP Office as it relates to integration of the 
eWings ComAssistant. For all other provisioning information such as provisioning of the trunks 
for inbound routing, outbound dialing, call coverage, extensions, etc., please refer to the IP 
Office documentation. 

Step Description 
 IP Office License Key Physical Installation 

1. Plug in the red Avaya Software Sentinel key into the parallel port of the IP Office 
Manager PC. 

 Configure License Key Server IP Address 
2. Log in to the IP Office Manager PC and go to Start → Programs → IP Office → 

Manager to launch the Manager application. Log in to the Manager application using the 
appropriate credentials. 

3. In the Manager window that appears, select File → Open to search for the IP Office 
system in the network. 

4. Log in to the IP Office system using the appropriate login credentials to receive its 
configuration. 
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Step Description 
5. In the Manager window, go to the Configuration Tree and double-click System. In the 

System Configuration window that appears, select the System tab and set License Server 
IP Address to the IP address of the machine to which the red Avaya Software Sentinel key 
is connected. This is typically the IP Office Manager PC.  Click OK. 
 

 
 

 Install Licenses 
6. In the Manager window, go to the Configuration Tree and double-click License to open 

the list of licenses installed in the IP Office system. 
7. Right click in the license list window and select New. In the License window that appears, 

enter the CTI Link Pro License Key and click OK. 
 

 
 

8. Repeat Step 7 to install the Wave User license. 
9. In the Manager window, select File → Save to save the licenses to the IP Office system 

and wait for the system to update. 
 
Note 1: Before the system reloads, the new licenses will be listed with an Unknown 
status.  After the system reloads, the new licenses will list as Valid. 
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Step Description 
 Configure TAPI Extensions 

10. In the Manager window, select File → Open to search for the IP Office system in the 
network. 

11. Log in to the IP Office system using the appropriate login credentials to receive its 
configuration. 

12. In the Manager window, go to the Configuration Tree and double-click User to open the 
list of users on the IP Office system. 

13. Right click in the User list window and select New. In the User window that appears, set 
Name to TAPI:eWingsX where X is the number of the TAPI Wave extension desired, 
(e.g., 1, 2). and Extension to the extension number to be used. 
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Step Description 
14. In the Voicemail tab of the User window, verify that Voicemail On and Voicemail 

Ringback are not checked. 
 

 
 

15. In the Telephony tab of the User window, verify Call Waiting On is unchecked, Offhook 
Station and Forced Login are checked and click OK. 
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Step Description 
16. In the Manager popup that appears, click No. 

 

 
 

17. Repeat Steps 13 - 16 for each TAPI Wave extension needed. For the purposes of these 
Application Notes, five TAPI Wave extensions were created (extensions 32001 – 32005). 
The number of eWings licenses and Avaya TAPI Wave licenses purchased limits the 
number of TAPI extensions that can be created. 

 Configure Main Hunt Group for Auto Attendant 
18. In the Manager window, go to the Configuration Tree and double-click Hunt Group to 

open the list of hunt groups on the IP Office system. 
19. Select the Main hunt group by double-clicking. 
20. In the Hunt Group window that appears, add the TAPI extensions created in Steps 13 to 

17 to the Extension List by right-clicking in the Extension List section and selecting Add.  
Then, set Extension to 32000 (or the extension number desired for the hunt group), Hunt 
Type to Circular, and Call Waiting On to unchecked. 
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Step Description 
21. In the Voicemail tab of the Hunt Group window, verify Voicemail On is not checked. 
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Step Description 
 Create New Hunt Groups for Other ComAssistant Services 

22. Right click in the Hunt Group list window and select New.  In the Hunt Group window 
that appears, set Name to AD Internal and Extension to the extension number to be used.  
Add the TAPI extensions created in Steps 13 to 17 to the Extension List by right-clicking 
in the Extension List section and selecting Add.  Then, set Hunt Type to Circular, and 
Call Waiting On to unchecked. 
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Step Description 
23. In the Voicemail tab of the HuntGroup window, verify Voicemail On is not checked. 

 

 
 

24. Repeat Steps 22 - 23 for each Hunt Group needed.  Altogether, six Hunt Groups were 
created (extensions 32100, 32200, 32300, 32400, 32500, 32600), corresponding to the 
different services of ComAssistant. 
 

 
 

25. In the Manager window, select File → Save to save the configuration to the IP Office 
system and wait for the unit to reboot with the saved configuration. 
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Step Description 
26. Log in to the IP Office system using the appropriate login credentials to receive its 

configuration. 
 Select Inbound Call Route 

27. In the Manager window, go to the Configuration Tree and double-click Incoming Call 
Route to open the list of incoming call routes on the IP Office system. Select the route 
with the destination set to Main and double-click.  In the Incoming Call Route window 
that appears, record the Line group ID. Click OK. 
 

 
 

 Assign Trunks to the Incoming Call Route 
28. In the Manager window, go to the Configuration Tree and double-click Line to open the 

list of lines (trunks) available on the IP Office system. Double-click the PRI 30 Line 
whose incoming calls are to be routed to the ComAssistant. 
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Step Description 
29. In the Line window that appears, double-click on every channel and edit the Incoming 

Group field in the Edit Channel pop up that appears. Click OK. 
 

 
 

30. In the Manager window, select File → Save to push the configuration to the IP Office 
system and wait for the unit to reboot. 

31. Verify the incoming call route is properly operating by temporarily assigning a telephone 
extension to the hunt group and placing calls through the selected inbound line (trunk).  
The telephone extension assigned to the hunt group will ring. The TAPI Wave extensions 
will not answer until ComAssistant is configured. 

 

4. Configure the eWings ComAssistant 
These Application Notes address provisioning of the eWings ComAssistant as it relates to TAPI3 
integration with the Avaya IP Office System. For all other provisioning information such as 
eWings ComAssistant software installation, Speech Recognition assignment, Telephone 
Directory creation and License Key installation, please refer to the eWings ComAssistant 
Administrator Guide available on the eWings Software Installation CD. 
 
 
 
 



4.1. Installing and Configuring Avaya IP Office TAPI3 Service Provider 
 
Step Description 

1. From the Avaya IP Office CTI SDK 2.0.1 CDROM, run the program TAPI3Install.exe to 
install the Avaya IP Office TAPI3 Service Provider driver on the ComAssistant Server. 

2. After the system reboots, log in to the system again as administrator and go to Start → 
Settings → Control Panel. In the Control Panel window that appears, double-click 
Phone and Modem Options. 

3. In the Advanced tab of the Phone and Modem Options window, double-click Avaya IP 
Office TAPI3 Service Provider. 

4. In the Avaya TAPI3 configuration window that appears, set Switch IP Address to the IP 
Address of the IP Office System, check Third Party, set Switch Password to the IP Office 
System password, check WAV Users, and click OK. 
 

 
 

5. Reboot the system. 
 Verify Connectivity with the IP Office 

6. After the system reboots, log in to the system and go to Start → Programs → 
Accessories → Communications → Phone Dialer. 

7. In the Phone Dialer Window that appears, select Edit → Options. 
8. In the Lines tab of the Options window that appears, select the Phone Calls: drop-down 

list. If one or more “IP Office Phone: XXX” (where XXX is an extension number) entries 
appear, then the IP Office TAPI Driver is installed and working properly. 
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4.2. Installing and Configuring Avaya IP Office TAPI Wave Driver 
 
The steps that follow are for a Windows 2000 installation; please refer to the Avaya IP Office 
CTI Link Installation Manual, 40DHB0002UKAB – Issue 5 (28th October 2003) for additional 
information. 
 
Step Description 

 Install TAPI Wave Driver 
1. Log in to the ComAssistant server as administrator and go to Start → Settings → 

Control Panel.  In the Control Panel window that appears, double-click Add/Remove 
Hardware. 

2. In the Add/Remove Hardware Wizard Welcome window that appears, click Next. 
3. In the Choose a Hardware Task window that appears, select ‘Add/Troubleshoot a device’ 

and click Next. 
4. In the New Hardware Detection window that appears, wait while the PC searches for a 

new device. 
5. In the Choose a Hardware Device window, select ‘Add a new device’ and click Next. 
6. In the Find New Hardware window, select ‘No, I want to select the hardware from a list’ 

and click Next. 
7. In the Hardware Type window that appears, select ‘Sound, video and game controllers’ 

and click Next. 
8. In the Select a Device Driver window that appears, click Have Disk…. 
9. In the Install from Disk popup that appears, click Browse… to navigate to the Wave32 

directory on the Avaya IP Office User Applications CD, select the oemsetup.inf file, and 
click Open. 

10. In the Install From Disk popup that appears, verify the pull-down field lists the path to the 
Wave32 directory on the CD and click OK. 

11. In the Select a Device Driver window that appears, verify Avaya IP400 WIDWOD driver 
is listed in the Models field and click Next. 

12. In the Start Hardware Installation window that appears, click Next. 
13. In the Completing the Add/Remove Hardware Wizard window that appears, click Finish. 
14. In the Systems Settings Change popup that appears, click Yes to reboot the system. 

 Ensure Avaya TAPI Wave Driver is only used by TAPI 
15. Login to the ComAssistant server as administrator and go to Start → Settings → Control 

Panel.  In the Control Panel window that appears, double-click Sounds and Multimedia 
Properties. 
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Step Description 
16. In the Hardware tab of the Sounds and Multimedia Properties window, double-click 

Avaya IP400 WIDWOD driver. 
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Step Description 
17. In the Avaya IP400 WIDWOD driver Properties window that appears, click the 

Properties tab. 
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Step Description 
18. In the Properties tab of the Avaya IP400 WIDWOD driver Properties window, double-

click Audio Devices to reveal the Avaya IP400 WIDWOD driver and double-click Avaya 
IP400 WIDWOD driver. 
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Step Description 
19. In the Avaya IP400 WIDWOD driver Properties window that appears, check Do not map 

through this device and click OK. 
 

 
 

20. In the Changes Saved popup that appears, click OK and reboot the ComAssistant server 
so that the changes can take effect. 
 

 
 

 

4.3. Configuring the eWings ComAssistant 
 
Step Description 

 Configuring PBX Connection 
1. Log in to the ComAssistant server as administrator and go to Start → Run.  In the Run 

window that appears, type D:\NetVoice\ConfigTool.exe to execute the configuration tool.
2. Click on TEL CFG and expand the node Configure. 
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Step Description 
3. Expand the node General and click on VenderType.  Click Modify to set PBX 

connection interface.  In the Modify Entry window that appears, select TAPI from the 
drop-down list and click OK. 
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Step Description 
4. To set the number of ports that ComAssistant will use, expand the node General and click 

on NumOfLines.  Click Modify and in the Modify Entry window that appears, enter 5 (or 
a number corresponding to the number of TAPI Wave Extensions used by ComAssistant) 
and click OK. 
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Step Description 
5. Expand the node TapiDevice and click on TSPName.  Click Modify and in the Modify 

Entry window that appears, select Avaya from the drop-down list and click OK.  In the 
same way, set SendSessionId to FALSE and PauseTime to 100.  Set AgentExtRange to 
32001-32005, which is the range of TAPI Wave Extensions created on IP Office. 
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Step Description 
 Configuring TTS and ASR Audio Format  

6. Expand VAD to set voice activity detection and speech recognition parameters. 
7. Click VADSelection and then click Modify.  In the Modify Entry window that appears, 

select NuanceVADWithASR from the drop-down list and click OK. 
  

 
 

8. Expand the node NuanceVADWithASR and click on EnableDynamicResource.  Click 
Modify and select TRUE. 

9. Click on NumberOfEngines.  Click Modify and type the number of ASR port purchased 
for the system. 
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Step Description 
10. Click on AudioFormat. Click Modify and in the Modify Entry window that appears, 

select linear-8k-16bit from the drop-down list and click OK. 
 

 
 
Note 2:  IP Office supports only linear-8k-16bit audio format. 
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Step Description 
11. Click on TTS CFG and expand the node Configure.  Expand the node General and click 

on AudioFormat. Click Modify and in the Modify Entry window that appears, select 
linear-8k-16bit from the drop-down list and click OK. 
 

 
 
Note 3:  IP Office supports only linear-8k-16bit audio format. 

12. Click Commit to apply and save all configurations.  Restart the ComAssistant system 
services to activate the changes. 

 Configuring Call Route Rules 
13. Log in to the ComAssistant server as administrator and go to Start → Run.  In the Run 

window that appears, type D:\NetVoice\ConfigTool.exe to execute configuration tool. 
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Step Description 
14. Click on RM CFG and click on the tab Dispatch Configure.  Select StartURL in the 

Dispatch Type list.  eWings ComAssistant is a VoiceXML platform and uses the web 
technology to provide service.  The VoiceXML start URL for each service is as follows: 
• Auto Attendant Service URL 

http://localhost:8000/aa/vxml/incoming/incoming_welcome.php  
• Auto Dialer Internal Service URL 

http://localhost:8000/ad/vxml/inner_welcome.php
• Auto Dialer External Service URL 

http://localhost:8000/ad/vxml/outbound_welcome.php
• Personal Dialer Internal Service URL 

http://localhost:8000/pd/vxml/flow/inner_welcome.php
• Personal Dialer External Service URL 

http://localhost:8000/pd/vxml/flow/welcome.php  
• Voice Message Recording Service URL 

http://localhost:8000/vm/vxml/Record/vmstart.php
• Voice Message Retrieval Service URL 

http://localhost:8000/vm/vxml/ManageRecord/vmstart.php
 

 
 
 

http://localhost:8000/aa/vxml/incoming/incoming_welcome.php
http://localhost:8000/ad/vxml/inner_welcome.php
http://localhost/ad/vxml/outbound_welcome.php
http://localhost/pd/vxml/flow/inner_welcome.php
http://localhost/pd/vxml/flow/welcome.php
http://localhost/vm/vxml/Record/vmstart.php
http://localhost/vm/vxml/ManageRecord/vmstart.php


 
JC; Reviewed: 
SPOC 10/24/2005 

Solution & Interoperability Test Lab Application Notes 
©2005 Avaya Inc. All Rights Reserved. 

26 of 30 
eWingsCA-IPO.doc 

 

Step Description 
15. In the Exist Rules list, select the rule for Auto Attendant Service and click Modify.  Set 

Keyword to DNIS, Operator to = and Value to 32000.  This must correspond to the 
extension assigned to the Hunt Group Main on IP Office.  Then click on Update. 
 

 
 

16. Repeat Step 15 for the rest of the ComAssistant services. 
17. Click Commit to apply and save all configurations. 
18. Click Basic Configure to check the DNIS number table.  Expand the node DNIS1 and 

select Callee.  Click Modify to change the value to * (star) and click Commit to save the 
setting. 
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Step Description 
19. Using Internet Explorer, login to the ComAssistant Administration Interface.  Set 

Integration PBX Type to Avaya Media Server.  Set the Transfer Type to Supervised 
Transfer.  Click Submit. 
 

 
 

 

5. Interoperability Compliance Testing 
The Interoperability Compliance Testing included basic TAPI interworking and feature 
functionality testing only.  Performance load testing was not performed.  Feature functionality 
testing examined the ComAssistant’s ability to properly transfer inbound and internal calls to the 
appropriate destination extension (digital, IP Telephone).  For Voice Mail service, the 
ComAssistant was tested for dial in voice recording/playback only (no voicemail call coverage 
testing or message waiting lamp update). 
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5.1. General Test Approach 
Feature functionality testing was performed manually. Inbound calls were made to the IP Office 
system from ISDN-PRI trunks connected to the central office as well as internal extensions.  The 
following call scenarios were tested using the test configuration diagram shown in Figure 1: 
 

• Auto Dialer service - ability to make calls to other user extensions using speech and 
DTMF. 

• Personal Dialer service - ability to make calls to other user extensions using speech 
and DTMF. 

• Auto Attendant service - ability to serve incoming calls and transfer them to user 
extensions using speech and DTMF. 

• Voice Mail service - ability to record and play back voice messages. 
 
Results were tabulated based on whether the call was being transferred successfully to the correct 
extension.  Voice Mail service was tested by leaving voice messages on different voice 
mailboxes.  The voice messages were then played back and verified if they were correct.  

5.2. Test Results 
All test cases passed successfully.     

6. Verification Steps 
The following steps can be used to verify system operation after a field installation: 
 

• Place a call to the Auto Attendant service hunt group from an IP Office extension. Verify 
that the Auto Attendant Welcome greeting plays and either speak a name or department, 
or enter a valid extension number on the IP Office system. Verify the call is transferred to 
the correct extension. 

• Place a call to the Auto Dialer service hunt group from an IP Office extension.  Verify 
that the Auto Dialer Welcome greeting plays and either speak a name or department, or 
enter a valid extension number on the IP Office system. Verify the call is transferred to 
the correct extension. 

• Place a call to the Voice Message Recording service hunt group from an IP Office 
extension.  Verify that the Voice Message Recording Welcome greeting plays and enter a 
valid mailbox extension to leave a voice message. 

• Place a call to the Voice Message Retrieval service hunt group from an IP Office 
extension.  Verify that the Voice Message Retrieval Welcome greeting plays and follow 
the prompts to retrieve the voice message. 

7. Support 
For technical support on eWings ComAssistant, contact eWings Support Team at: 

• Phone:  +886 (2) 27973088 Extension 1133 
• Fax:  +886 (2) 27973800 
• Email:  etac@ewingstech.com 
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8. Conclusion 
These Application Notes describe the required configuration steps for eWings Communication 
Assistant to successfully interoperate with Avaya IP Office System.  All test cases were 
completed successfully. 

9. Additional References  
The following documents can be found at http://support.avaya.com: 
 

• Avaya IP Office CTI Link Installation Manual, 40DHB0002UKAB – Issue 5 (28th 
October 2003) 

• Avaya IP Office 3.0 Installation Manual, 40DHB0002UKCL Issue 12c (24th February 
2005) 

• Avaya IP Office Manager 3.0 Manual, Issue 16f (8th February 2005) 
 
The following documents are available from eWings: 
 

• eWings ComAssistant 1.3 Installation Guide 
• eWings ComAssistant 1.3 Administration Guide 
• eWings ComAssistant 1.3 User Guide 

http://support.avaya.com/
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