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Abstract 
 

  

These Application Notes describes the steps to configure Session Initiation Protocol (SIP) 

Trunking between Level 3 and Avaya IP Office Release 8.1. 

 

Level 3 SIP Trunking provides PSTN access via a SIP trunk between the enterprise and the 

Level 3 network as an alternative to legacy analog or digital trunks.  This approach generally 

results in lower cost for the enterprise. 

 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions.  Testing was conducted in the Avaya Solution and 

Interoperability Test Lab, utilizing Level 3 SIP Trunk Services. 
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1. Introduction 
These Application Notes describe the steps to configure Session Initiation Protocol (SIP) 

Trunking between Level 3 and Avaya IP Office Release 8.1. 

 

The Level 3 SIP Trunking service referenced within these Application Notes is positioned for 

customers that have an IP-PBX or IP-based network equipment with SIP functionality, but need 

a form of IP transport and local services to complete their solution. 

 

Level 3 SIP Trunking will enable delivery of origination and termination of local, long-distance 

and toll-free traffic across a single broadband connection.  A SIP signaling interface will be 

enabled to the Customer Premises Equipment (CPE).  

 

The Level 3 SIP Trunking service uses Digest Authentication for outbound calls from the 

enterprise, using challenge-response authentication for each call to the Level 3 network based on 

a configured user name and password (provided by Level 3 and configured in IP Office).  This 

call authentication scheme as specified in SIP RFC 3261 provides security and integrity 

protection for SIP signaling. 

2. General Test Approach and Test Results  
The general test approach was to connect a simulated enterprise site to the Level 3 SIP Trunking 

service via the public Internet and exercise the features and functionality listed in Section 2.1.  

The simulated enterprise site was comprised of Avaya IP Office and various Avaya endpoints. 

 

The Level 3 SIP Trunk Service passed compliance testing with any observations or limitations 

described in Section 2.2.   

2.1. Interoperability Compliance Testing 

To verify SIP trunking interoperability, the following features and functionality were covered 

during the interoperability compliance test: 

 

 Response to SIP OPTIONS queries from the provider 

 Incoming PSTN calls to various phone types including H.323, digital, and analog 

telephones at the enterprise.  All inbound PSTN calls were routed to the enterprise across 

the SIP trunk from the service provider. 

 Outgoing PSTN calls from various phone types including H.323, digital, and analog 

telephones at the enterprise.  All outgoing PSTN calls were routed from the enterprise 

across the SIP trunk to the service provider. 

 Inbound and outbound PSTN calls to/from soft clients.  Avaya IP Office supports two 

soft clients: Avaya IP Office Phone Manager and Avaya IP Office Softphone.   Avaya IP 

Office Phone Manager supports two modes (PC softphone and telecommuter). Both 

clients in each supported mode were tested. 

 Various call types including: local, long distance, outbound toll-free, operator services 

and local directory assistance. 
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 Codec G.711MU and G.729A. 

 T.38 Fax 

 Caller ID presentation and Caller ID restriction 

 DTMF transmission using RFC 2833 

 Voicemail navigation using DTMF for inbound and outbound calls. 

 User features such as hold and resume, transfer, and conference. 

 Off-net call forwarding and twinning. 

 REFER method for call redirection   

2.2. Test Results 

Interoperability testing of Level 3 SIP Trunking was completed with successful results for all test 

cases with the exception of the observations/limitations described below. 

 

 Inbound toll-free and outbound emergency calls (911) are supported but were not tested 

as part of the compliance test. 

 SIP OPTIONS from IP Office: During the compliance test, no SIP OPTIONS messages 

were sent from IP Office to Level 3 even though IP Office was configured to send them.  

The reason for this is still under investigation.  SIP OPTIONS messages were tested in 

the opposite direction from Level 3 to IP Office.  Level 3 does not require IP Office to 

initiate OPTIONS so this behavior had no user impact. The configuration relating to the 

sending of OPTIONS is described in Sections 5.2, 5.6.1 and 5.11. 

 Ring No Answer: Outbound call from IP Office is allowed to ring without answer until 

the call times out (approximately three minutes).  At this time, Level 3 sends a “401 

Unauthorized” response with parameter stale=yes.  IP Office resends the INVITE with 

proper credentials.  Level 3 sends a “481 Unknown Dialog” response.  Even with the 

error response, the call is properly disconnected.  There is no user impact to this behavior. 

 No Matching Codec Offered: If the IP Office SIP trunk is improperly configured to 

have no matching codec with the service provider and an outbound call is placed, Level 3 

returns a “480 Temporarily Unavailable” response instead of a “488 Not Acceptable 

Here” response.  The user hears fast busy.  There is no user impact to this behavior. 

 Off-net Call Forward with REFER: If REFER is enabled, IP Office will send a REFER 

message to Level 3 when an inbound call is forwarded back to the PSTN.  Level 3 

responds with a 603 Decline response even though the call is properly forwarded. There 

is no user impact to this behavior. 

 Blind Transfer with REFER: If REFER is enabled, IP Office will send a REFER 

message to Level 3 when an inbound call is transferred to the PSTN.  If the transfer is 

completed before the transfer destination answers (blind transfer), then IP Office sends an 

unexpected re-INVITE to Level 3 after the call has been transferred resulting in a “481 

Unknown Dialog” response from Level 3.  However, the call is properly transferred so 

there is no user impact to this behavior. 

2.3. Support 

For technical support on Level 3 SIP Trunking, contact Level 3 using the Customer Service links 

at www.Level3.com or by calling 1-877-4LEVEL3. 
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3. Reference Configuration 
Figure 1 illustrates the sample configuration used for the DevConnect compliance testing.  The 

sample configuration shows an enterprise site connected to Level 3 SIP Trunking.  

 

Located at the enterprise site is an Avaya IP Office 500 V2.  The LAN port of Avaya IP Office is 

connected to the enterprise LAN while the WAN port is connected to the public network.  

Endpoints include an Avaya 1608 IP Telephone (with H.323 firmware), an Avaya 9641G IP 

Telephone (with H.323 firmware), an Avaya 9640G IP Telephone (with H.323 firmware), an 

Avaya IP Office Phone Manager, an Avaya IP Office Softphone, an Avaya 5420 Digital 

Telephone, and an Avaya 6210 Analog Telephone.  The site also has a Windows 2003 Server 

running Avaya Voicemail Pro for voicemail and running Avaya IP Office Manager to configure 

the Avaya IP Office. 

 

 
 

Figure 1: Avaya Interoperability Test Lab Configuration 
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For security purposes, any public IP addresses or PSTN routable phone numbers used in the 

compliance test are not shown in these Application Notes.  Instead, public IP addresses have 

been replaced with private addresses and all phone numbers have been replaced with numbers 

that cannot be routed over the PSTN. 

 

For the purposes of the compliance test, users dialed a short code of 9 + N digits to send digits 

across the SIP trunk to Level 3. The short code of 9 is stripped off by Avaya IP Office but the 

remaining N digits were sent unaltered to Level 3.  For calls within the North American  

Numbering Plan (NANP), the user dialed 11 (1 + 10) digits for long distance calls and 10 digits 

for local calls. Avaya IP Office sent either 11 digits or 10 digits, depending on the type of NANP 

call, in the Request URI and the To field of an outbound SIP INVITE message.  It was 

configured to send 10 digits in the From field.  For inbound calls, Level 3 SIP Trunking sent 10 

digits in the Request URI and the To field of inbound SIP INVITE messages.   

 

In an actual customer configuration, the enterprise site may also include additional network 

components between the service provider and the Avaya IP Office such as a session border 

controller or data firewall.  A complete discussion of the configuration of these devices is beyond 

the scope of these Application Notes.  However, it should be noted that SIP and RTP traffic 

between the service provider and the Avaya IP Office must be allowed to pass through these 

devices. 

4. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Avaya Telephony Components 

Equipment Software 

Avaya IP Office 500 v2 8.1 (63) 

Avaya Voicemail Pro 8.1 (Build 8.1.9016.0) 

Avaya IP Office Manager 10.1 (63) 

Avaya 16xx Series IP Telephones (H.323) 

running Avaya one-X® Deskphone Value 

Edition 

1.3 SP2 (1.3.2) 

Avaya 56xx Series IP Telephones (H.323) 2.9.1 

Avaya 96x0 Series IP Telephones (H.323) 

running Avaya one-X® Deskphone Edition 

3.1 SP5 (3.1.05S) 

Avaya 96x1 Series IP Telephones (H.323) 

running Avaya one-X® Deskphone Edition 

6.2 SP2 (6.2209) 

Avaya IP Office Video Softphone (SIP) 3.2.3 (64595) 

Avaya IP Office Phone Manager (H.323) 4.2.36 

Avaya Digital Telephones (5420) - 

Avaya Analog Telephones - 
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Level 3 Components 

Equipment Software 

Level 3 Enterprise Edge Version 1 

5. Configure Avaya IP Office 
Avaya IP Office is configured through the Avaya IP Office Manager PC application.  From the 

Avaya IP Office Manager PC, select Start → Programs → IP Office → Manager to launch the 

application.  A screen that includes the following in the center may be displayed: 

 
Select Open Configuration from System.  If the above screen does not appear, the 

configuration may be alternatively opened by navigating to File → Open Configuration at the 

top of the Avaya IP Office Manager window.  Select the proper Avaya IP Office system from the 

pop-up window and log in with the appropriate credentials.  The appearance of the IP Office 

Manager can be customized using the View menu. In the screens presented in this section, the 

View menu was configured to show the Navigation pane on the left side, omit the Group pane in 

the center, and the Details pane on the right side. Since the Group Pane has been omitted, its 

content is shown as submenus in the Navigation pane.  These panes (Navigation, Group and 

Details) will be referenced throughout the Avaya IP Office configuration.  All licensing and 

feature configuration that is not directly related to the interface with the service provider (such as 

twinning and IP Office Softphone support) is assumed to already be in place. 
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5.1. Licensing and Physical Hardware 

The configuration and features described in these Application Notes require the IP Office system 

to be licensed appropriately. If a desired feature is not enabled or there is insufficient capacity, 

contact an authorized Avaya sales representative.  
 

To verify that there is a SIP Trunk Channels License with sufficient capacity; click License → 

SIP Trunk Channels in the Navigation pane. Confirm a valid license with sufficient Instances 

(trunk channels) in the Details pane.  
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If Avaya IP Telephones will be used as is the case in these Application Notes, verify the Avaya 

IP endpoints license. Click License → Avaya IP endpoints in the Navigation pane. Confirm a 

valid license with sufficient Instances in the Details pane. 
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To view the physical hardware comprising the IP Office system, expand the components under 

the Control Unit in the Navigation pane. In the sample configuration, the second component 

listed is a Combination Card.  This module has 6 digital stations ports, two analog extension 

ports, 4 analog trunk ports and 10 VCM channels. The VCM is a Voice Compression Module 

supporting VoIP codecs. An IP Office hardware configuration with a VCM component is 

necessary to support SIP trunking. 

 

To view the details of the component, select the component in the Navigation pane. The 

following screen shows the details of the IP 500 V2. 

 

 



 
CTM; Reviewed: 

SPOC 5/1/2013 

Solution & Interoperability Test Lab Application Notes 

©2013 Avaya Inc. All Rights Reserved. 

10 of 37 

Lev3SipTrkIPO81 

 

5.2. LAN2 Settings 

In the sample configuration, the WAN port was used to connect the Avaya IP Office to the 

public network.  The LAN2 settings correspond to the WAN port on the Avaya IP Office 500.  

To access the LAN2 settings, first navigate to System → <Name>, where <Name> is the system 

name assigned to the IP Office.  In the case of the compliance test, the system name is Atlantic 

City. Next, navigate to the LAN2 → LAN Settings tab in the Details Pane.  Set the IP Address 

field to the IP address assigned to the Avaya IP Office WAN port. Set the IP Mask field to the 

mask used on the public network.  All other parameters should be set according to customer 

requirements. 
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On the VoIP tab in the Details Pane, check the SIP Trunks Enable box to enable the 

configuration of SIP trunks.  The RTP Port Number Range can be customized to a specific 

range of receive ports for the RTP media.  Based on this setting, Avaya IP Office would request 

RTP media be sent to a UDP port in the configurable range for calls using LAN2.  Avaya IP 

Office can also be configured to mark the Differentiated Services Code Point (DSCP) in the IP 

Header with specific values to support Quality of Services policies for both signaling and media.  

The DSCP field is the value used for media and the SIG DSCP is the value used for signaling.  

The specific values used for the compliance test are shown in the example below and are also the 

default values.  For a customer installation, if the default values are not sufficient, appropriate 

values will be provided by Level 3.  All other parameters should be set according to customer 

requirements. 
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On the Network Topology tab in the Details Pane, configure the following parameters:  

 Select the Firewall/NAT Type from the pull-down menu that matches the network 

configuration.  No firewall or network address translation (NAT) device was used in the 

compliance test as shown in Figure 1, so the parameter was set to Open Internet.  

 Set Binding Refresh Time (seconds) to 30.  This value is used to determine the 

frequency at which Avaya IP Office will send SIP OPTIONS messages to the service 

provider.  

 Set Public IP Address to the IP address of the Avaya IP Office WAN port.  

 Set the Public Port to the port Avaya IP Office will listen on. 

 All other parameters should be set according to customer requirements. 
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5.3. System Telephony Settings 

To access the System Telephony settings, first navigate to System → Atlantic City in the 

Navigation Pane and then navigate to the Telephony → Telephony tab in the Details Pane.  

Uncheck the Inhibit Off-Switch Forward/Transfer box to allow call forwarding and call 

transfer to the PSTN via the service provider across the SIP trunk.  If for security reasons 

incoming calls should not be allowed to transfer back to the PSTN then leave this setting 

checked. 
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5.4. Twinning Calling Party Settings 

To view or change the System Twinning settings, first navigate to System → Atlantic City in 

the Navigation Pane and then navigate to the Twinning tab in the Details Pane as shown in the 

following screen. The Send original calling party information for Mobile Twinning box is 

not checked in the sample configuration, and the Calling party information for Mobile 

Twinning is left blank.  Click the OK button at the bottom of the page (not shown). 

 

 
 

5.5. IP Route 

Navigate to IP Route → 0.0.0.0 in the left Navigation Pane if a default route already exists. 

Otherwise, to create the default route, right-click on IP Route and select New.  Create/verify a 

default route with the following parameters: 

 

 Set IP Address and IP Mask to 0.0.0.0. 

 Set Gateway IP Address to the IP Address of the default router to reach Level 3. 

 Set Destination to LAN2 from the drop-down list. 

 

Click the OK button at the bottom of the page (not shown). 
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5.6. SIP Line 

A SIP line is needed to establish the SIP connection between Avaya IP Office and Level 3 SIP 

Trunking.  To create a SIP line, right-click Line in the Navigation Pane and select New → SIP 

Line.   

5.6.1. SIP Line – SIP Line Tab 

On the SIP Line tab in the Details Pane, configure the parameters as shown below.  

 

 Set ITSP Domain Name to the IP address of the Level 3 SIP proxy.  

 Set Send Caller ID to Diversion Header. With this setting and the related configuration 

in Section 5.4, IP Office will include the Diversion Header for calls that are directed via 

Mobile Twinning out the SIP Line to Level 3. It will also include the Diversion Header 

for calls that are call forwarded out the SIP Line.   

 Check REFER Support. 

 Set Incoming and Outgoing to Always. In the compliance test, this feature was enabled 

to test transfers of a call between a PSTN phone and an enterprise phone to a second 

PSTN phone. 

 Check the In Service box. This makes the trunk available to incoming and outgoing calls. 

 Check the Check OOS box. IP Office will use the SIP OPTIONS method to periodically 

check the SIP Line. The time between SIP OPTIONS sent by IP Office will use the 

Binding Refresh Time for LAN2, as shown in Section 5.2. 

 Default values may be used for all other parameters. 
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5.6.2. SIP Line - Transport Tab 

Select the Transport tab. Set the parameters as shown below.  

 Set ITSP Proxy Address to the IP address of the Level 3 SIP proxy.  

 Set Layer 4 Protocol to UDP.    

 Set Use Network Topology Info to the network port configured in Section 5.2.  

 Set the Send Port to 5070.  

 Default values may be used for all other parameters. 
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5.6.3. SIP Line - SIP Credentials Tab 

A SIP Credentials entry must be created for Digest Authentication used by Level 3 SIP Trunking 

service to authenticate calls from the enterprise to the PSTN.  To create a SIP Credentials entry, 

first select the SIP Credentials tab.  Click the Add button and the New SIP Credentials area 

will appear at the bottom of the pane.  To edit an existing entry, click an entry in the list at the 

top, and click the Edit button.  In the bottom of the screen, the Edit Channel area will be opened.  

In the example screen below, a new entry was added.  The entry was created with the parameters 

shown below:  

  

 Set User name and Authentication Name to the value provided by the service provider.    

 Set Password to the value provided by the service provider.    

 Uncheck the Registration required option.  Level 3 does not require registration for 

Digest Authentication. 

 

Click OK. 

 

 
 



 
CTM; Reviewed: 

SPOC 5/1/2013 

Solution & Interoperability Test Lab Application Notes 

©2013 Avaya Inc. All Rights Reserved. 

18 of 37 

Lev3SipTrkIPO81 

 

5.6.4. SIP Line - SIP URI Tab 

A SIP URI entry must be created to match each incoming number that Avaya IP Office will 

accept on this line.  Select the SIP URI tab, then click the Add button and the New Channel 

area will appear at the bottom of the pane.  To edit an existing entry, click an entry in the list at 

the top, and click the Edit button.  In the example screen below, a new entry is created.  The 

entry was created with the parameters shown below: 

 Set Local URI, Contact and Display Name to Use Internal Data.  This setting allows 

calls on this line whose SIP URI matches the number set in the SIP tab of any User as 

shown in Section 5.8.  

 For Registration, select the account credentials previously configured on the line’s SIP 

Credentials tab in Section 5.6.3. 

 Associate this line with an incoming line group by entering a line group number in the 

Incoming Group field.  This line group number will be used in defining incoming call 

routes for this line.  Similarly, associate the line to an outgoing line group using the 

Outgoing Group field. The outgoing line group number is used in defining short codes 

for routing outbound traffic to this line.  For the compliance test, a new incoming and 

outgoing group 20 was defined that only contains this line (line 20).  

 Set Max Calls per Channel to the number of simultaneous SIP calls that are allowed 

using this SIP URI pattern. 

 

Click OK. 
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In the sample configuration, the single SIP URI shown above was sufficient to allow incoming  

calls for Level 3 DID numbers destined for specific IP Office users or IP Office hunt groups.  

The calls are accepted by IP Office since the incoming number will match the SIP Name 

configured for the user or hunt group that is the destination for the call.  For service numbers, 

such as a DID number routed directly to voicemail, or DID numbers routed to Short Codes, the 

DID numbers that IP Office should admit can be entered into the Local URI and Contact fields 

instead of Use Internal Data. 

 

The following shows the SIP URI tab for SIP Line 20 after the SIP URIs corresponding to Voice 

mail Auto Attendant (720-555-0014) and FNE00 (720-555-0082) has been added. 
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5.6.5. SIP Line - VoIP Tab 

Select the VoIP tab, to set the Voice over Internet Protocol parameters of the SIP line.  Set the 

parameters as shown below. 

 For Codec Selection, select System Default from the pull-down menu. A list of the 

codecs in their current order of preference is shown on the right in the Selected column. 

The compliance test used the default codec list. To use a custom list of codecs, select 

Custom for Codec Selection. Next, move unwanted codecs from the Selected Column to 

the Unused column. Lastly, move the codecs up or down the list in the Selected column 

to achieve the desired order of preference.   

 Uncheck the VoIP Silence Suppression box. 

 Set the Fax Transport Support to T.38. 

 Set the DTMF Support field to RFC2833.  This directs Avaya IP Office to send DTMF 

tones using RTP events messages as defined in RFC2833. 

 Check the Re-invite Supported box. 

 Default values may be used for all other parameters. 

  

Click the OK button at the bottom of the page (not shown). 
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5.7. Short Codes 

Define a short code to route outbound traffic to the SIP line.  To create a short code, right-click 

on Short Code in the Navigation Pane and select New.  On the Short Code tab in the Details 

Pane, configure the parameters as shown below.  

 

 In the Code field, enter the dial string which will trigger this short code, followed by a 

semi-colon.  In this case, 9N;.  This short code will be invoked when the user dials 9 

followed by any number. 

 Set Feature to Dial.  This is the action that the short code will perform. 

 Set Telephone Number to N”@192.168.35.86”.  This field is used to construct the 

Request URI and To headers in the outgoing SIP INVITE message.  The value N 

represents the number dialed by the user.  The IP address 192.168.35.86 is the IP address 

of the Level 3 SIP proxy. 

 Set the Line Group Id to the outgoing line group number defined on the SIP URI tab on 

the SIP Line in Section 5.6.4.  This short code will use this line group when placing the 

outbound call. 

  

Click the OK button (not shown). 
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Optionally, add or edit a short code that can be used to access the SIP Line anonymously.  In the 

screen shown below, the short code *67N; is illustrated.  This short code is similar to the 9N; 

short code except that the Telephone Number field begins with the letter W, which means 

“withhold the outgoing calling line identification”.  In the case of the SIP Line to Level 3 

documented in these Application Notes, when a user dials *67 plus the number, IP Office will 

include the user’s telephone number in the P-Asserted-Identity (PAI) header along with 

“Privacy: Id”.  Level 3 will allow the call due to the presence of a valid DID in the PAI header, 

but will prevent presentation of the caller id to the called PSTN destination.   

 

 
 

The following screen illustrates a short code that acts like a feature access code rather than a 

means to access a SIP Line.  In this case, the Code FNE00 is defined for Feature FNE Service 

to Telephone Number 00.  This short code will be used as means to allow a Level 3 DID to be 

programmed to route directly to this feature, via inclusion of this short code as the destination of 

an Incoming Call Route.  See Section 5.9.  This feature is used to provide dial tone to twinned 

mobile devices (e.g. cell phone) directly from IP Office; once dial tone is received the user can 

perform dialing actions including making calls and activating Short Codes.  
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5.8. User 

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP 

line defined in Section 5.6.  To configure these settings, first navigate to User → Name in the 

Navigation Pane where Name is the name of the user to be modified.  In the example below, the 

name of the user is Extn243.  Select the SIP tab in the Details Pane.  The values entered for the 

SIP Name and Contact fields are used as the user part of the SIP URI in the From and Contact 

headers for outgoing SIP trunk calls and allow matching of the SIP URI for incoming calls 

without having to enter this number as an explicit SIP URI for the SIP line (Section 5.6.4). The 

example below shows the settings for User Extn243.  The SIP Name and Contact are set to one 

of the DID numbers assigned to the enterprise from Level 3.  The SIP Display Name (Alias) 

parameter can optionally be configured with a descriptive name.  If all calls involving this user 

and a SIP Line should be considered private, then the Anonymous box may be checked to 

withhold the user’s information from the network.  Click the OK button (not shown). 
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The following screen shows the Mobility tab for User Extn243.  The Mobility Features and 

Mobile Twinning boxes are checked.  The Twinned Mobile Number field is configured with 

the number to dial to reach the twinned mobile telephone, in this case 917325551234.   Other 

options can be set according to customer requirements. 
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5.9. Incoming Call Route 

An incoming call route maps an inbound DID number on a specific line to an internal extension.   

This procedure should be repeated for each DID number provided by the service provider.  To 

create an incoming call route, right-click Incoming Call Routes in the Navigation Pane and 

select New.  On the Standard tab of the Details Pane, enter the parameters as shown below.   

 Set the Bearer Capacity to Any Voice.  

 Set the Line Group Id to the incoming line group of the SIP line defined in Section 

5.6.4.  

 Set the Incoming Number to the incoming number on which this route should match.   

 Default values can be used for all other fields. 

 

 
 

On the Destinations tab, select the destination extension from the pull-down menu of the 

Destination field.  Click the OK button (not shown).  In this example, incoming calls to  

7205550023 on line 20 are routed to extension 243. 

 

 
 

Incoming Call Routes for other direct mappings of DID numbers to IP Office users listed in 

Figure 1 are omitted here, but can be configured in the same fashion.  
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In the screen shown below, the incoming call route for Incoming Number 7205550082 is 

illustrated.  The Line Group Id is 20, matching the Incoming Group field configured in the SIP 

URI tab in Section 5.6.4.  

 

 
 

When configuring an Incoming Call Route, the Destination field can be manually configured 

with a number such as a short code, or certain keywords available from the drop-down list.  For 

example, the following Destinations tab for an incoming call route contains the Destination  

FNE00 entered manually.  FNE00 is the short code for FNE Service, as shown in Section 5.7.  

An incoming call to 720-555-0082 will be delivered directly to internal dial tone from the IP 

Office, allowing the caller to perform dialing actions including making calls and activating Short 

Codes. The incoming caller ID must match the Twinned Mobile Number entered in the User 

Mobility tab (Section 5.8); otherwise, the IP Office responds with a 486 Busy Here and the caller 

will hear a busy tone.  
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5.10. Privacy/Anonymous Calls 

For outbound calls with privacy (anonymous) enabled, Avaya IP Office will replace the calling 

party number in the From and Contact headers of the SIP INVITE message with “restricted” and  

“anonymous” respectively.  Avaya IP Office can be configured to use the P-Preferred-Identity 

(PPI) or P-Asserted-Identity (PAI) header to pass the actual calling party information for 

authentication and billing.  By default, Avaya IP Office will use PPI for privacy.  For the 

compliance test, PAI was used for the purposes of privacy.    

 

To configure Avaya IP Office to use PAI for privacy calls, navigate to User → NoUser in the 

Navigation Pane.  Select the Source Numbers tab in the Details Pane.  Click the Add button. 

 

 
  

At the bottom of the Details Pane, the Source Number field will appear.  Enter  

SIP_USE_PAI_FOR_PRIVACY.  Click OK. 

 

 
 

The SIP_USE_PAI_FOR_PRIVACY parameter will appear in the list of Source Numbers as 

shown below.  Click OK at the bottom of the screen (not shown). 
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5.11. SIP Options Frequency 

Avaya IP Office sends SIP OPTIONS messages periodically to determine if the SIP connection 

is active.  Avaya IP Office will send a SIP OPTIONS message only if an OPTIONS request is 

not received from the far-end during the defined interval.  The rate at which the messages are 

sent is determined by the combination of the Binding Refresh Time (in seconds) set on the 

Network Topology tab in Section 5.2 and the SIP_OPTIONS_PERIOD parameter (in 

minutes) that can be set on the Source Number tab of the NoUser user.  The OPTIONS period 

is determined in the following manner: 

 If no SIP_OPTIONS_PERIOD parameter is defined and the Binding Refresh Time is 

0, then the default value of 300 seconds is used. 

 To establish a period less than 300 seconds, do not define a SIP_OPTIONS_PERIOD 

parameter and set the Binding Refresh Time to a value less than 300 seconds.  The 

OPTIONS message period will be equal to the Binding Refresh Time. 

 To establish a period greater than 300 seconds, a SIP_OPTIONS_PERIOD parameter 

must be defined.  The Binding Refresh Time must be set to a value greater than 300 

seconds.  The OPTIONS message period will be the smaller of the Binding Refresh 

Time and the SIP_OPTIONS_PERIOD. 

 

For the compliance test, a SIP OPTIONS frequency of 30 seconds was defined by setting the 

Binding Refresh Time to 30 seconds in Section 5.2 and not defining a 

SIP_OPTIONS_PERIOD parameter.   

 

If a SIP_OPTIONS_PERIOD parameter is needed to define a longer interval, the required 

NoUser Source Number can be defined in the same manner as the 

SIP_USE_PAI_FOR_PRIVACY parameter in Section 5.10. 
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5.12. Save Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. 

 

The following will appear, with either Merge or Immediate selected, based on the nature of the 

configuration changes made since the last save.  Note that clicking OK may cause a service 

disruption.  Click OK if desired. 
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6. Level 3 SIP Trunking Configuration 
Level 3 is responsible for the configuration of Level 3 SIP Trunking.  The customer will need to 

provide the IP address used to reach the Avaya IP Office at the enterprise.  Level 3 will provide 

the customer the necessary information to configure the Avaya IP Office SIP connection to Level 

3 including:  

 IP address of the Level 3 SIP proxy  

 Supported codecs  

 DID numbers  

 All IP addresses and port numbers used for signaling or media that will need access to the 

enterprise network through any security devices 

 Username and Password for Digest Authentication. 

7. Verification Steps 
This section provides verification steps that may be performed in the field to verify that the 

solution is configured properly. 

7.1. System Status 

The System Status application is used to monitor and troubleshoot IP Office.  Use the System 

Status application to verify the state of the SIP trunk.  System Status can be accessed from Start 

→ Programs → IP Office → System Status.   

 

The following screen shows an example Logon screen. Enter the IP Office IP address in the 

Control Unit IP Address field, and enter an appropriate User Name and Password. Click 

Logon. 
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Select the SIP line under Trunks from the left pane.  On the Status tab in the right pane, verify 

the Current State is Idle for each channel. 

 

 
 

Select the Alarms tab and verify that no alarms are active on the SIP line. 

 

 
 

7.2. Monitor 

The Monitor application can also be used to monitor and troubleshoot IP Office.  Monitor can be 

accessed from Start → Programs → IP Office → Monitor.  The application allows the 

monitored information to be customized. To customize, select Filters → Trace Options.  
 

The following screen shows the SIP tab, allowing configuration of SIP monitoring. In this 

example, the SIP Rx and SIP Tx boxes are checked.  
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As an example, the following shows a portion of the monitoring window for an outbound call 

from extension 240, whose DID is 720-555-0021, calling out to the PSTN via the Level 3 IP 

Trunking Service. The telephone user dialed 9-1-908-555-5506. 
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8. Conclusion 
These Application Notes describe the configuration necessary to connect Avaya IP Office 8.1 to 

Level 3 SIP Trunking service.  Level 3 SIP Trunking is a SIP-based Voice over IP solution for 

customers ranging from small businesses to large enterprises.  It provides a flexible, cost-saving 

alternative to traditional hardwired telephony trunks. Level 3 SIP Trunking passed compliance 

testing.  Please refer to Section 2.2 for any exceptions. 

9. Additional References  
This section references documentation relevant to these Application Notes. In general, Avaya 

product documentation is available at http://support.avaya.com.  

 

[1] IP Office 8.1 IP500/IP500 V2 Installation, Document Number 15-601042, Issue 27f, March 

04, 2013  

 

[2] IP Office Release 8.1 Manager 10.1, Document Number 15-601011, Issue 29t, February 20, 

2013  

 

[3] IP Office System Status Application, Document Number 15-601758 Issue 07a, November 26, 

2012  

 

[4] IP Office Release 8.1 Administering Voicemail Pro, Document Number 15-601063, Issue 8b, 

December 11, 2012 

 

[5] IP Office System Monitor, Document Number 15-601019, Issue 03b, February 28, 2013 

 

Additional IP Office documentation can be found at:  

http://marketingtools.avaya.com/knowledgebase/ 

 

http://support.avaya.com/
http://marketingtools.avaya.com/knowledgebase/
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10. Appendix A: SIP Line Template 
Avaya IP Office supports a SIP Line Template (in xml format) that can be created from an 

existing configuration and imported into a new installation to simplify configuration procedures 

as well as to reduce potential configuration errors.    

  

Note that not all of the configuration information, particularly items relevant to a specific 

installation environment, is included in the SIP Line Template.  Therefore, it is critical that the 

SIP Line configuration be verified/updated after a template has been imported and additional 

configuration be supplemented using Section 5.6 in these Application Notes as a reference. 

 

The SIP Line Template created from the configuration as documented in these Application Notes 

is as follows: 

 
<?xml version="1.0" encoding="utf-8"?> 

<Template xmlns="urn:SIPTrunk-schema"> 

  <TemplateType>SIPTrunk</TemplateType> 

  <Version>20130307</Version> 

  <SystemLocale>enu</SystemLocale> 

  <DescriptiveName>Level3</DescriptiveName> 

  <ITSPDomainName>192.168.35.86</ITSPDomainName> 

  <SendCallerID>CallerIDDIV</SendCallerID> 

  <ReferSupport>true</ReferSupport> 

  <ReferSupportIncoming>1</ReferSupportIncoming> 

  <ReferSupportOutgoing>1</ReferSupportOutgoing> 

  <RegistrationRequired>false</RegistrationRequired> 

  <UseTelURI>false</UseTelURI> 

  <CheckOOS>true</CheckOOS> 

  <CallRoutingMethod>1</CallRoutingMethod> 

  <OriginatorNumber /> 

  <AssociationMethod>SourceIP</AssociationMethod> 

  <LineNamePriority>SystemDefault</LineNamePriority> 

  <UpdateSupport>UpdateNever</UpdateSupport> 

  <UserAgentServerHeader /> 

  <CallerIDfromFromheader>false</CallerIDfromFromheader> 

  <PerformUserLevelPrivacy>false</PerformUserLevelPrivacy> 

  <ITSPProxy>192.168.35.86</ITSPProxy> 

  <LayerFourProtocol>SipUDP</LayerFourProtocol> 

  <SendPort>5070</SendPort> 

  <ListenPort>5060</ListenPort> 

  <DNSServerOne>0.0.0.0</DNSServerOne> 

  <DNSServerTwo>0.0.0.0</DNSServerTwo> 

  <CallsRouteViaRegistrar>true</CallsRouteViaRegistrar> 

  <SeparateRegistrar /> 

  <CompressionMode>AUTOSELECT</CompressionMode> 

  <UseAdvVoiceCodecPrefs>false</UseAdvVoiceCodecPrefs> 

  <CallInitiationTimeout>4</CallInitiationTimeout> 

  <DTMFSupport>DTMF_SUPPORT_RFC2833</DTMFSupport> 

  <VoipSilenceSupression>false</VoipSilenceSupression> 

  <ReinviteSupported>true</ReinviteSupported> 

  <FaxTransportSupport>FOIP_T38</FaxTransportSupport> 

  <UseOffererPrefferedCodec>false</UseOffererPrefferedCodec> 
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  <CodecLockdown>false</CodecLockdown> 

  <Rel100Supported>false</Rel100Supported> 

  <T38FaxVersion>3</T38FaxVersion> 

  <Transport>UDPTL</Transport> 

  <LowSpeed>0</LowSpeed> 

  <HighSpeed>0</HighSpeed> 

  <TCFMethod>Trans_TCF</TCFMethod> 

  <MaxBitRate>FaxRate_14400</MaxBitRate> 

  <EflagStartTimer>2600</EflagStartTimer> 

  <EflagStopTimer>2300</EflagStopTimer> 

  <UseDefaultValues>true</UseDefaultValues> 

  <ScanLineFixup>true</ScanLineFixup> 

  <TFOPEnhancement>true</TFOPEnhancement> 

  <DisableT30ECM>false</DisableT30ECM> 

  <DisableEflagsForFirstDIS>false</DisableEflagsForFirstDIS> 

  <DisableT30MRCompression>false</DisableT30MRCompression> 

  <NSFOverride>false</NSFOverride> 

  <SIPCredentials> 

    <Expiry>60</Expiry> 

    <RegistrationRequired>false</RegistrationRequired> 

  </SIPCredentials> 

</Template> 

 

To import the above template into a new installation:  

  

1. On the PC where IP Office Manager was installed, copy and paste the above template 

into a text document named US_Level3_SIPTrunk.xml.  Move the .xml file to the IP 

Office Manager template directory (C:\Program Files\Avaya\IP 

Office\Manager\Templates). It may be necessary to create this directory. 

 

2. Import the template into an IP Office installation by creating a new SIP Line as shown in 

the screenshot below.  In the Navigation Pane on the left, right-click on Line then 

navigate to New → New SIP Trunk From Template: 
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3. Verify that United States is automatically populated for Country and Level3 is 

automatically populated for Service Provider in the resulting Template Type Selection 

screen as shown below.  Click Create new SIP Trunk to finish the importing process. 
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