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Abstract 
 
 
These Application Notes describe the configuration steps required for the Callmedia Contact 
Centre Suite to successfully interoperate with Avaya IP Office. 
 
The Callmedia contact centre suite is designed to handle inbound and outbound telephone 
calls, emails, web interactions, SMS messages and faxes. The Telephony API (TAPI) interface 
is used to monitor and control agent stations, and handle routing of external calls. The 
Callmedia contact centre suite comprises of three core components: Callmedia Enterprise, 
Callmedia Advance and Callmedia Professional. An additional component called Callmedia 
Express was not compliance tested. 
 
Information in these Application Notes has been obtained through compliance testing and 
additional technical discussions.  Testing was conducted via the DeveloperConnection 
Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
These Application Notes describe a compliance-tested configuration using a Callmedia 4.0.1 
contact centre server and an Avaya IP Office 3.1. 
 
The Callmedia suite comprises three core components: 
• Callmedia Professional – Callmedia Professional is the foundation layer for the rest of the 

Callmedia contact centre suite. 
• Callmedia Enterprise – Only inbound and outbound calls were tested during compliance 

testing, although the application is also designed to handle, emails, web interactions, SMS 
messages and faxes.  

• Callmedia Advance – Provides preview, progressive and predictive dialling. It is not possible 
to do predictive dialling with Avaya IP Office. 

 
Callmedia agents log on to Callmedia with a username and password configured within the 
Callmedia application. This logon is linked to a phone extension configured on Avaya IP Office.  
 
Callmedia Inbound call routing and allocating to users. 
Users (Agents) and their teams have skills on Callmedia Enterprise Queues. Inbound calls queue 
on the Avaya IP Office hunt group. The hunt group is mapped to a Callmedia Enterprise queue. 
When Callmedia Enterprise has an available skilled user, Callmedia will route the call to the 
user’s phone. 
 
Callmedia Outbound. 
Preview and Progressive Callmedia outbound users are given customer telephone numbers, 
contained in the Callmedia calling list (in the Callmedia database), to dial. These calls are 
launched from the user’s extensions using TAPI MakeCall. The call progress is monitored and 
controlled using TAPI. 
 
Callmedia is composed of four Windows Services: 

 Callmedia Log   - Manages logging for Callmedia Applications 
 Callmedia Server  - Client connections and CTI link 
 Callmedia Enterprise  - Task Allocation Engine 
 Callmedia Scheduler  - Outbound Engine and Calls List management 

 
An additional component called Callmedia Express that allows the agent to transfer and 
conference calls was not compliance tested as part of the Callmedia contact centre suite. 
 
 
 



 
 
 

Figure 1: Avaya IP Office System with Callmedia Contact Centre Suite 

 

2. Equipment and Software Validated 

 
Equipment Software 
Avaya IP Office 412 3.1(56) 
Avaya TAPI 1.0.0.27 
Avaya IP Office Manager software 5.1(56) 
Avaya C364T-PWR Converged Stackable Switch 4.3.12 
Avaya 4600 Series IP Telephones 2.2.3 (4620SW) 
Callmedia contact centre suite 4.0.1 
Callmedia Server 3.4.13  (running on 

Windows Server 2003 SP 
1) 

Callmedia Log 2.4.1.1 
Callmedia Enterprise 2.1.0.781 
Callmedia Scheduler 2.5.1.22 
Callmedia IP Office Switch Driver 1.2.4.78 
Microsoft SQL Server 2000 SQL 2000 SP3 
Operating System for Callmedia Agent PC’s Windows XP 
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3. Configure Avaya IP Office 
These Application Notes address the provisioning of Avaya IP Office as it relates to integration 
of the Callmedia application.  For all other provisioning information, such as provisioning of the 
trunks for outbound dialling, call coverage, extensions, etc., refer to the Avaya IP Office 
documentation in Section 9. 

3.1. Verify IP Office CTI Licences 
On the IP Office Manager PC, click on Start → Programs → IP Office → Manager to launch 
the Manager application. Log in to the Manager application using the appropriate credentials. 
 
In the Manager window, select File → Open to search for the IP Office system in the network. 
Log in to the IP Office system using the appropriate login credentials. In the Manager window, 
go to the Configuration Tree and double-click Licence to open the list of licences installed in the 
IP Office system. Verify that enough CTI Link Pro Instances are available. 
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3.2. Configure Callmedia Hunt group 
In the Manager window, go to the Configuration Tree and double-click Hunt Group to open the 
list of hunt groups on Avaya IP Office. Right-click in the right pane of the Manager window and 
click on New. Enter an appropriate name for the hunt group in the Name field and the hunt 
group extension in the Extension field. Ensure that no extensions are listed in the Extension List 
section as the Callmedia application controls the allocation of inbound calls to agent stations.  
Set the Ring Mode to Group, and ensure that Call Waiting On is unchecked.  
 

 
 
In the Queuing tab of the Hunt Group window, check Queuing On and click OK. 
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3.3. Configure Extensions to be Used by Callmedia 
Please refer to Avaya IP Office documentation referenced in Section 9 for information on 
configuring Avaya IP Office extensions. During compliance testing, several extensions in the 
“20000” range were created as shown below. Extension 20002 was used for alternative routes in 
Section 4.1 
 

 
 

3.4. Assign Trunks to the Incoming Call Route 
In the Manager window, go to the Configuration Tree and double-click Line to open the list of 
lines (trunks) available on Avaya IP Office. Double-click the PRI 30 Line whose incoming calls 
are to be routed to the Hunt Group Callmedia (22222), created earlier in Step 3.2. By default the 
Incoming and Outgoing Group are set to “0” in the Line window that appears. It is possible to 
edit the Incoming Group by double-clicking on every channel and editing the Incoming Group 
field in the Edit Channel dialog box. Make a note of the Incoming Group and click OK. 
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3.5. Configure Incoming call Route 
In the Manager window, go to the Configuration Tree and double-click Incoming Call Route to 
open the list of incoming call routes on Avaya IP Office. Right click in the Incoming Call Route 
window and select New. From the Destination drop down list, select Callmedia.  For Line 
group ID, enter the Incoming Group value noted in Step 3.4. Click OK. 
 

 
 
In the Manager window, select File → Save to write the configuration to Avaya IP Office and 
select the option to reboot immediately. 
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4. Configure the Callmedia Contact Centre Server 
The Callmedia Server and SQL database were pre-installed on the same machine for 
convenience during the compliance testing. The standard practice would be to install the SQL 
database on a separate machine. Note the Callmedia Enterprise Database and Callmedia Advance 
Database are preconfigured during the installation stage of the Callmedia server. Refer to 
Callmedia Advance Book 2 and Callmedia Enterprise Book 2 documentation referenced in 
Section 9 for information related to Callmedia database configuration.  

4.1. Callmedia Server Configuration 
Launch the Callmedia Console by clicking Start  Programs  Callmedia  Callmedia 
Console and log in with the appropriate User Name and Password. 

 

 
 
Expand the tree view in the Callmedia Console by clicking on Callmedia Server Management 

 Servers and expand the node for the preinstalled Callmedia Server (callmaed-coih4d). Click 
on Licences to ensure that the AVAYA IP Office under the Switch Drivers section is licensed 
by having a tick in the check box.   
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Under the same preinstalled Callmedia Server options, click on Switch Driver and click Change 
in the Current Driver section. 
 

 
 
 
Select AVAYA IP Office from the drop-down list of the Select switch driver field. Click OK. 
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In the Current Driver section, click on the Load button to load the switch driver. The Loaded 
field changes to Yes and the Load button changes to Unload. Once the switch driver has loaded, 
its console snap-in should load into the Callmedia Console. 
 

 
 
 
In the Callmedia AVAYA IP Office Switch Driver window, click on the Compatibility tab in 
the left panel and tick the 3.1 Compatibility check box option.  
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Click on Enterprise in the left pane and tick the Enabled check box. By default, the Callmedia 
switch driver will not attempt to connect to Callmedia Enterprise. The Enterprise IP Address, 
Connecter ID and Port are populated by default. Click OK. 
 

 
 
In the Switch Driver screen in the main Callmedia Console, click on the Trigger Points button. 
Click the Add button in the Enterprise Trigger Points tab of the Callmedia AVAYA IP Office 
Switch Driver window below. 
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The Trigger Point Wizard is launched, and the three queues present are configured as part of the 
Callmedia Server installation. Select the Inbound Voice Queue and click Next. 
 

 
 
 
 
In the Managed Queue Queuing Hunt Group section, enter 22222 in the Queuing Hunt Group 
field. Click Next. 
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Alternative Routes are used in situations where Callmedia Enterprise cannot handle the call.  For 
example, when the Enterprise Queue is outside of its working hours, or there are no skilled users 
logged on, the call can be routed elsewhere. During compliance testing, one of the extensions 
“20002” configured on Avaya IP Office (see Section 3.3) was used for Alternative Routes, 
although Alternative Routes can be interactive voice response systems or a voice mail number. 
Click Next.   
 

 
 
 
The final screen is the Trigger Point Summary. Click Finish. 
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4.2. Create Callmedia Teams and Users  
Three sets of teams and users were created for the compliance testing.  This section shows the 
setup for the blended team and blended user only.  For compliance testing, inbound and 
outbound teams and users were also configured. 
 
Expand the tree view in the Callmedia Console by clicking on Callmedia User Manager 
Console  CallmediaEnterprise and right-clicking on Teams. Click on New Team 
 

 
 
In the Edit Team dialog box, click on the Team Details tab, and enter a team name in the Team 
Name field. From the Team Type drop-down list, select Advance Preview/Progressive. The 
Call Selection Rules can be left with the default choice. 
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Click on the Team Skills tab and tick the Callmedia Outbound Queue and Inbound Voice 
Queue check boxes. Click OK. 
 

 
 
The Teams page in the main Callmedia Console shows a summary of all teams. Ensure that the 
three teams are correctly set up. In this setup there are three teams: “inbound_team”, 
“outbound_team” and “blended_team”. 
 

 
 

Expand the tree view in the Callmedia Console by clicking on Callmedia User Manager 
Console  CallmediaEnterprise, and right-click on Users. Click on New User. 
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In the User form, click on the User Details tab and complete the agent user information. The 
Logon ID and Password will be used during agent logon. Select the appropriate team from the 
drop-down list in the Team field. 
 

 
 
The Users page in the main Callmedia Console shows a summary of all users configured. Ensure 
that the three users are correctly set up. In this setup, there are three users: “user_inbound”, 
“user_outbound” and “user_blend”. 
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4.3. Check Inbound Voice Queues 
To check that the necessary skills for the teams have been set up correctly, expand the tree view 
in the Callmedia Console. Click on Callmedia Enterprise Console  CallmediaEnterprise  
Managed Queues  Inbound Voice Queue  Skill Deployment. The configured teams that 
will be used for inbound calls will be listed. 
 

 
 

4.4. Check Outbound Call List 
For Preview and Progressive outbound dialling a call list was pre-configured. Refer to the 
Callmedia documentation in Section 9. Click on Callmedia Advance Console  Callmedia 
Advance  Campaigns  Outbound Campaign  Calls Lists  Calls List Summary. The 
outbound call list is displayed. 
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4.5. Callmedia Agent Application Configuration  
Insert the Callmedia installation CD, and in the Main item selection section, select Callmedia 
Core Products.  In the Sub item selection section, select User Components. Click Install 
Selection. 
 

 
 
  
The type of user components must be selected; choose the Callmedia Enterprise or Blended 
Contact Centre option. Click Next. 
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Tick the Hot Desking checkbox, to allow the user to enter an extension during login. The Socket 
Number appears as “4605” by default. Tick Specify IP Address and enter the IP Address of 
the Callmedia server. Click Next. 
 

 
 
The Callmedia Desktops Configuration screen allows the desktops to start a browser which can 
be used as a link into the client’s application. Ensure that Enable Browser is unchecked (this is 
the default). Click Next. 
 

 
 
Click Install to start the installation. 
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4.6. Install and Configure Avaya IP Office TAPI2 Service Provider  
Using the Avaya IP Office User CD, install the Avaya IP Office TAPI Service Provider driver on 
the Callmedia client machine. 
 
After the Callmedia client machine reboots, log in to the system again as administrator and go to 
Start → Settings → Control Panel.  In the Control Panel window that appears, double-click 
Phone and Modem Options. In the Advanced tab of the Phone and Modem Options window, 
double-click Avaya IP Office TAPI2 Service Provider. 

 

 
 
In the Avaya TAPI2 configuration window, set Switch IP Address to the IP Address of Avaya 
IP Office, select Third Party, and set Switch Password to the password set for Avaya IP 
Office. 

 
 
Reboot the Callmedia client machine. 
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4.7. Callmedia Agent Application 
The Callmedia Client will automatically start when Windows starts, and may also be started by 
selecting Start  Programs  Callmedia  Callmedia Client. 
 
When Hot Desking is enabled (as in this installation), enter the user’s extension and click OK. 
This can be any station configured on Avaya IP Office. 
 

 

 

The user must log in, and enter a valid Login ID and Password with the user name and 
password configured in Section 4.2. Click OK. 

 
When the user logs on, the desktop will display the user in the “Not Available” state.  

 
 
When the user clicks Available, the desktop display will change, showing the “Waiting” state.  
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5. Interoperability Compliance Testing 
The interoperability compliance testing included basic TAPI interoperability, functionality and 
serviceability testing. Performance load testing was not performed. The testing examined the 
Callmedia contact centre suite interoperability with Avaya IP Office 3.1. The majority of the 
testing focused on the ability of the Callmedia agent application to perform the following 
operations: Place/receive calls, Hold, and Retrieve. The serviceability testing focused on 
verifying the ability of the Callmedia contact centre to recover from adverse conditions, such as 
an Avaya IP Office reboot and disconnecting the Ethernet cable from the Callmedia server. 
 

5.1. General Test Approach 
Testing included validation of correct operation of typical call centre functions including 
inbound voice calls and outbound campaign calls both in preview and progressive modes. 
Functionality testing included basic telephony operations such as answer, hangup and 
hold/retrieve, exercised from both the agent telephones and the agent softphones for the inbound 
and outbound campaign calls. The serviceability test cases were performed manually by 
rebooting Avaya IP Office from Avaya IP Office Manager and by physically disconnecting and 
reconnecting the LAN cables.  
 

5.2. Test Results 
All test cases passed successfully. Callmedia does not support transfers and conference from the 
Callmedia agent bar. Predictive dialling is not supported with Avaya IP Office. A separate 
application called Callmedia Express allows more control functionality over the agent phones, 
such as transfer and conference although this was not compliance tested.   
 
 



6. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of Avaya IP 
Office and Callmedia contact centre. 

6.1. Verify Avaya IP Office TAPI 
Verify connectivity with Avaya IP Office as follows: 

• Log in to the Callmedia client machine and go to Start → Programs → Accessories → 
Communications → Phone Dialer. 

• In the Phone Dialer window, select Edit → Options. 
• In the Lines tab of the Options window, select the Phone Calls: drop-down list.  If one or 

more “IP Office Phone: XXX” (where XXX is an extension number) entries appear, then 
the IP Office TAPI Driver is installed and working properly. 

 

6.2. Callmedia Contact Centre 
• List all TAPI Lines, and verify that all expected phones are listed in the log. 
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• Check that the trigger points are set up and active. In the Callmedia Switch Driver screen, 
click on the Trigger Points button. Ensure that the correct Hunt Group numbers are 
entered (in this example “22222”) and that the state is shown as ACTIVE.  
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7. Support 
For technical support on Callmedia, contact Callmedia Support at +44 (0)1489 553525 or via e-
mail at support@callmedia.co.uk. 
 

8. Conclusion 
These Application Notes describe the configuration steps required for the Callmedia 4.0.1 
contact centre suite to successfully interoperate with Avaya IP Office 3.1.  All feature 
functionality, performance and serviceability test cases were completed successfully. 
 

9. Additional References 
This section references the Avaya and Callmedia contact centre product documentation that are 
relevant to these Application Notes. 
 
Avaya product documentation can be found at http://support.avaya.com. 

• Avaya IP Office CTI Link Installation Manual, 40DHB0002UKAB – Issue 11a (June 
2005) 

• Avaya IP Office 3.1 Installation Manual, Issue 13j (Dec 2005) 
• Avaya IP Office 3.1 Manager Manual, Issue 17d (Sept 2005) 

 
 

The following documents can be found on the Callmedia Installation CD: 
 

• Callmedia Enterprise Book 1 
• Callmedia Enterprise Book 2 
• Callmedia Advance Book 1 
• Callmedia Advance Book 2 
• Callmedia IP Office Switch Driver Guide  
• Callmedia Planning Guide 

 
 
 

http://support.avaya.com/
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