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Abstract 
 

 

These Application Notes describe the procedures for configuring Session Initiation Protocol 

(SIP) Trunking service between service provider Cox Communications and Avaya IP Office 

Release 11.0 and Avaya Session Border Controller for Enterprise Release 7.2.2 using UDP/RTP. 

 

Cox Communications SIP Trunk Service provides PSTN access via a SIP trunk between the 

enterprise and the Cox Communications network as an alternative to legacy analog or digital 

trunks. This approach generally results in lower cost for the enterprise. 

 

Readers should pay attention to Section 2, in particular the scope of testing as outlined in 

Section 2.1 as well as the observations noted in Section 2.2, to ensure that their own use cases 

are adequately covered by this scope and results. 

 

Cox Communications is a member of the Avaya DevConnect Service Provider program. 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions. Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 

 

Avaya DevConnect Confidential & Restricted. For benefit of Cox Communications only. These 

Application Notes may not be distributed further without written permission from DevConnect. 
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 Introduction 
These Application Notes describe the procedures for configuring Session Initiation Protocol (SIP) 

Trunking service between Cox Communications and an Avaya IP Office solution. In the sample 

configuration, the Avaya IP Office solution consists of Avaya IP Office Server Edition Release 11.0, 

Avaya embedded Voicemail, Avaya IP Office Application Server (with WebRTC and one-X Portal 

services enabled), Avaya IXTM Workplace (SIP mode), Avaya Communicator for Web, Avaya 

H.323, Avaya SIP, digital and analog deskphones. The enterprise solution connects to the Cox 

Communications network via the Avaya Session Border Controller for Enterprise (Avaya SBCE). 

 

The Cox Communications referenced within these Application Notes is designed for business 

customers. The service enables local and long distance PSTN calling via standards-based SIP trunks 

as an alternative to legacy analog or digital trunks, without the need for additional TDM enterprise 

gateways and the associated maintenance costs. 

 General Test Approach and Test Results 
The general test approach was to configure a simulated enterprise site using Avaya IP Office 

connecting to Cox Communications via the Avaya SBCE. 

 

This configuration (shown in Figure 1) was used to exercise the features and functionality tests 

listed in Section 2.1. Note: NAT devices added between Avaya SBCE and the Cox Communications 

network should be transparent to the SIP signaling. 

 

DevConnect Compliance Testing is conducted jointly by Avaya and DevConnect members. The 

jointly-defined test plan focuses on exercising APIs and/or standards-based interfaces pertinent to 

the interoperability of the tested products and their functionalities. DevConnect Compliance Testing 

is not intended to substitute full product performance or feature testing performed by DevConnect 

members, nor is it to be construed as an endorsement by Avaya of the suitability or completeness of 

a DevConnect member’s solution. 

 

Avaya recommends our customers implement Avaya solutions using appropriate security and 

encryption capabilities enabled by our products. The testing referenced in this DevConnect 

Application Note included the enablement of supported encryption capabilities in the Avaya 

products.  Readers should consult the appropriate Avaya product documentation for further 

information regarding security and encryption capabilities supported by those Avaya products. 

                                                                                                     

Support for these security and encryption capabilities in any non-Avaya solution component is the 

responsibility of each individual vendor.  Readers should consult the appropriate vendor-supplied 

product documentation for more information regarding those products. 
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 Interoperability Compliance Testing 

A simulated enterprise site with Avaya IP Office and Avaya SBCE was connected to Cox 

Communications. To verify SIP trunking interoperability, the following features and functionality 

were exercised during the interoperability compliance test: 

• Incoming PSTN calls to various phone types. Phone types included H.323, SIP, digital, and 

analog phones at the enterprise. All inbound PSTN calls were routed to the enterprise across 

the SIP trunk from the service provider 

• Outgoing PSTN calls from various phone types. Phone types included H.323, SIP, digital, 

and analog phones at the enterprise. All outbound PSTN calls were routed from the 

enterprise across the SIP trunk to the service provider 

• Inbound and outbound PSTN calls from/to the Avaya IXTM Workplace (SIP)  

• Inbound and outbound PSTN calls from/to the Avaya Communicator for Web (WebRTC) 

with basic telephony transfer feature 

• Inbound and outbound long hold time call stability 

• Various call types including: local, long distance, international call, inbound toll-free, 

outbound toll-free, outbound call to assistant operator, outbound call to 411 and 911 services 

• SIP transport UDP/RTP between Cox Communications and the simulated Avaya enterprise 

site   

• Codec G.711MU 

• Caller number/ID presentation  

• Privacy requests (i.e., caller anonymity) and Caller ID restriction for inbound and outbound 

calls 

• DTMF transmission using RFC 2833 

• Registration and Authentication 

• Voicemail navigation for inbound and outbound calls 

• Telephony features such as hold and resume, transfer, and conference 

• Fax G.711 pass-through and Fax T.38 modes 

• Off-net call forwarding 

• Off-net call transfer 

• Twinning to mobile phones on inbound calls  

• Remote Worker. Avaya IXTM Workplace (SIP) was used to test remote worker functionality  

 

Item not supported or not tested include the following: 

• Cox Communications does not support TLS/SRTP SIP Transport 

• The SIP REFER in the off-net call redirection was not tested during the compliance testing 

because Cox Communications did not fully support it. Cox Communications confirmed that 

SIP REFER is only supported without sending a NOTIFY message. Therefore, the SIP RE-

INVITE was tested in the off-net call redirection instead 
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 Test Results 

Interoperability testing of Cox Communications was completed with successful results for all test 

cases with the exception of the observation described below: 

 

• The EdgeMarc did not forward Diversion header (or PAI header) to Cox Communications 

network in off-net call forward - Although the EdgeMarc did not forward Diversion header 

(or PAI header) to Cox Communications network in off-net call forward, the off-net call 

forward still worked successfully. As far as Cox Communications is aware, this issue should 

be fixed in new EdgeMarc firmware load (Potentially 15.7.0 and higher firmware)   
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 Support 

For technical support on the Avaya products described in these Application Notes visit: 

http://support.avaya.com. 

 

For technical support on Cox Communications SIP Trunking, contact Cox Communications at 

http://www.cox.com 

http://support.avaya.com/
http://www.cox.com/
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 Reference Configuration 
Figure 1 below illustrates the test configuration. The test configuration shows an enterprise site 

connected to Cox Communications through the public internet. For confidentiality and privacy 

purposes, actual public IP addresses and DID numbers used in this testing have been masked out and 

replaced with fictitious IP addresses throughout the document.  

 

The Avaya components used to create the simulated customer site included: 

• IP Office Server Edition Primary Server 

• IP Office Voicemail Pro  

• IP Office Server Edition Expansion System (IP500 V2) 

• WebRTC and one-X Portal services 

• Avaya Session Border Controller for Enterprise   

• Avaya 96x1 Series IP Deskphones (H.323) 

• Avaya 11x0 Series IP Deskphones (SIP) 

• Avaya J129 IP Deskphones (SIP) 

• Avaya 1408 Digital phones 

• Avaya Analog phones 

• Avaya Communicator for Web 

• Avaya IXTM Workplace (SIP) 

• Avaya IXTM Workplace (SIP) for remote worker 

 

The Primary Server consists of a Dell PowerEdge R640 server, running the Avaya IP Office Server 

Edition Linux software Release 11.0.  Avaya Voicemail Pro runs as a service on the Primary Server.  

The LAN2 port of Avaya IP Office is connected to Avaya SBCE internal interface. The Avaya 

SBCE external interface is connected to LAN port of the Cox managed CPE (This device is included 

as part of the Service Provider service and not as part of the CPE solution – See Section 12 

Appendix B in details). The WAN port of Cox managed CPE is connected to Cox Communications’ 

network via public network. 

 

The optional Expansion System (IP500 V2) is used for the support of digital, analog, fax, and 

additional IP stations. It consists of an Avaya IP Office IP500 V2 with the MOD DGTL STA16 

expansion module which provides connections for 16 digital stations to the PSTN, and the extension 

PHONE 8 card which provides connections for 8 analog stations to the PSTN as well as 64-channel 

VCM (Voice Compression Module) for supporting VoIP codecs 

 

A separate Windows 10 Enterprise PC runs Avaya IP Office Manager to configure and administer 

Avaya IP Office system. 

 

Mobility Twinning is configured for some of the Avaya IP Office users so that calls to these user’s 

phones will also ring and can be answered at configured mobile phones. 
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Internet Simulated 

PSTN

DevConnect Test LAB

Enterprise site

Cox Communications

Network

Domain: DUKEBWSSCM-MTC1-

SA-XXXX.TC.AT.COX.NET

IP addresses: 192.168.205.194; 

192.168.206.194; 192.168.205.75 & 

192.168.206.75

Avaya IP Office Server Edition

Voicemail Pro

IPO-Media Server

Web RTC Gateway

One-X Portal

Analog, Fax 

and Digital Endpoints

IP Office Manager for 

Server Edition

SIP Trunk

Mobile Twining with 

Cell phone, Digital 

phone and FAX

SIP Trunk

MetaSwitch GW

Avaya IP Office Expansion System (V2) – IP 500 V2

PHONE 8 

DIG DCPx16 V2

H.323 Endpoints 

SIP Endpoints 

and Soft Clients

Avaya IP Office Expansion IP address: 172.16.199.60 

Avaya Session Border Controller for Enterprise

Cox Managed CPE

Avaya IP Office SE internal IP address: 10.33.10.56 

Avaya IP Office SE external IP address: 10.33.80.104 

DID numbers: 402XXX5730, 402XXX6581, 

402XXX7903, 402XXX8145, 402XXX8367

Avaya SBCE internal IP address: 10.33.80.88 

Avaya SBCE external IP address: 10.33.80.89 

Avaya SBCE RW internal IP address: 10.33.80.106 

Avaya SBCE RW external IP address: 10.33.80.105

LAN IP address: 10.33.80.87

WAN IP address: 10.33.80.103

Remote Worker

 
 

Figure 1 - Test Configuration for Avaya IP Office with Cox Communications SIP Trunk 

Service 

 

For the purposes of the compliance test, Avaya IP Office users dialed a short code of 9 + N digits to 

send digits across the SIP trunk to Cox Communications. The short code of 9 was stripped off by 

Avaya IP Office but the remaining N digits were sent unaltered to Cox Communications. For calls 

within the North American Numbering Plan (NANP), the user would dial 11 (1 + 10) digits. Thus, 

for these NANP calls, Avaya IP Office would send 11 digits in the Request URI and the To field of 
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an outbound SIP INVITE message. It was configured to send 10 digits in the From field. For 

inbound calls, Cox Communications sent 10 digits in the Request URI and the To field of inbound 

SIP INVITE messages. 

 

In an actual customer configuration, the enterprise site may also include additional network 

components between the service provider and Avaya SBCE, such as a data firewall. A complete 

discussion of the configuration of these devices is beyond the scope of these Application Notes. 

However, it should be noted that SIP and RTP traffic between the service provider and Avaya SBCE 

must be allowed to pass through these devices.  
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 Equipment and Software Validated 
The following equipment and software/firmware were used for the sample configuration provided: 

 

Component Version 

Avaya 

Avaya IP Office Server Edition solution  

▪ Primary Server Dell PowerEdge R640 – IPO-

Linux-PC 

▪ IPO-Media Server 

▪ Voicemail Pro  

▪ Web RTC Gateway 

▪ one-X Portal 

▪ IP Office Manager for Server Edition 

▪ IP Office Expansion System (V2) – IP 500 V2 

▪ IP Office Analogue - PHONE 8  

▪ IP Office Digital - DIG DCPx16 V2 

 

11.0.4.2.0 Build 58 

 

11.0.4.2.0 Build 58 

11.0.4.2.0 Build 1 

11.0.4.2.0 Build 69 

11.0.4.2.0 Build 2 

11.0.4.2.0 Build 58 

11.0.4.2.0 Build 58 

11.0.4.2.0 Build 58 

11.0.4.2.0 Build 58 

Avaya Session Border Controller for Enterprise 

running on VMware®-based Avaya appliance 

7.2.2.3-12-17892 

Avaya 1140E IP Deskphone (SIP) 04.04.26 

Avaya 9641G IP Deskphone (H323) 6.8003 

Avaya 9621G IP Deskphone (H323) 6.8003 

Avaya J129 IP Deskphone (SIP) 4.0.3.1.4 

Avaya Communicator for Web 1.0.18.1422 

Avaya IXTM Workplace 3.8.0.86.49 

Avaya 1408D Digital Deskphone R48 

Avaya Analog Deskphone N/A 

HP Officejet 4500 (fax) N/A 

Cox Communications  

Cox managed CPE  14.9.7 

MetaSwitch GW 4.3.40 
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 Configure Avaya IP Office Solution 
This section describes the Avaya IP Office Server Edition solution configuration necessary to 

support connectivity to the Cox Communications. It is assumed that the initial installation and 

provisioning of the Server Edition Primary Server and Expansion System has been previously 

completed and therefore is not covered in these Application Notes. For information on these 

installation tasks refer to Error! Reference source not found. in the Additional References Section 

 REF _Ref33542749 \r \h 10.  

 

This section describes the Avaya IP Office Server Edition configuration to support connectivity to 

Cox Communications system. Avaya IP Office Server Edition is configured through the Avaya IP 

Office Server Edition Manager PC application. From a PC running the Avaya IP Office Server 

Edition Manager application, select Start → Programs → IP Office → Manager to launch the 

application. Navigate to File → Open Configuration, select the proper Avaya IP Office Server 

Edition system from the pop-up window. Log in using appropriate credentials.  

 

 
 

Figure 2 – Avaya IP Office Server Edition Selection 
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The appearance of the Avaya IP Office Server Edition Manager can be customized using the View 

menu. In the screens presented in this section, it includes the system inventory of the servers and 

links for administration and configuration tasks. 

 

 
 

Figure 3 – Avaya IP Office Server Edition View Menu 
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 Licensing 

The configuration and features described in these Application Notes require the Avaya IP Office 

Server Edition system to be licensed appropriately. If a desired feature is not enabled or there is 

insufficient capacity, contact an authorized Avaya sales representative.  

 

Licenses for an Avaya IP Office Server Edition solution are based on a combination of centralized 

licensing done through the Avaya IP Office Server Edition Primary Server, and server specific 

licenses that are entered into the configuration of the system requiring the feature. SIP Trunk 

Channels are centralized licenses, and they are entered into the configuration of the Primary Server. 

Note that when centralized licenses are used to enable features on other systems, such as SIP trunk 

channels, the Primary Server allocates those licenses to the other systems only after it has met its 

own license needs. To verify that there is a SIP Trunk Channels license with sufficient capacity, 

select Solution → IPO-SE → License on the Navigation pane and SIP Trunk Channels in the 

Group pane. Confirm that there is a valid license with sufficient “Instances” (trunk channels) in the 

Details pane. Note that the actual License Key in the screen below was edited for security purposes. 

 

 
 

Figure 4 – Avaya IP Office Server Edition License 
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 System Tab 

Navigate to System (1) under the IPO-SE on the left pane and select the System tab in the Details 

pane. The Name field can be used to enter a descriptive name for the system. In the reference 

configuration, IPO-SE was used as the name in the Primary Server.  

 

 
 

Figure 5 - Avaya IP Office Primary Server System Configuration 
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 LAN Settings 

In the sample configuration, LAN2 on the Primary Server was used, and LAN1 on the Expansion 

System was used. Note: The LAN1 port of the Primary Server (Eth0) is connected to the enterprise 

LAN (Private network) and will not be discussed in this document. The IPO-SE was used as the 

Primary Server name and IPOffice_1 was used as the Expansion System name. 

 

To configure the LAN2 settings on the Primary Server, complete the following steps. Navigate to 

IPO-SE → System (1) in the Navigation and Group Panes and then navigate to the LAN2 → LAN 

Settings tab in the Details Pane. Set the IP Address field to the IP address assigned to the Avaya IP 

Office Server Edition LAN2 port. Set the IP Mask field to the mask used on the public network. All 

other parameters should be set according to customer requirements. Click OK to submit the change. 

 

 
 

Figure 6 - Avaya IP Office Primary Server LAN2 Settings 
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The VoIP tab as shown in the screenshot below was configured with following settings: 

• Check the H323 Gatekeeper Enable to allow Avaya IP Deskphones/Softphones using the 

H.323 protocol to register 

• Check the SIP Trunks Enable to enable the configuration of SIP Trunk connecting to Avaya 

SBCE 

• Verify Keepalives to select Scope as RTP-RTCP with Periodic timeout 60 and select 

Initial keepalives as Enabled 

• All other parameters should be set according to customer requirements 

• Click OK to submit the changes 

 

 
 

Figure 7 - Avaya IP Office Primary Server LAN2 VoIP 
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To configure the LAN1 settings tab for the Expansion System, navigate to Solution → IPOffice_1 

→ System (1) in the Navigation and Group Panes and then navigate to the LAN1 → LAN Settings 

tab in the Details Pane. The IP Address and IP Mask fields should be populated with the values 

assigned during the Expansion System initial installation process. Verify the configuration or modify 

the values if needed. While DHCP was disabled during the compliance test, this parameter should be 

set according to customer requirements. Other settings were left at their default values. Click OK to 

submit the change. 

 

 
 

Figure 8 - Avaya IP Office Expansion Server Settings 

 

The VoIP tab for LAN1 in the Expansion System (not shown) can be configured using the same 

values previously described for the VoIP tab in the Primary Server.  
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  System Telephony Settings 

Navigate to Solution → IPO-SE → System (1) in the Navigation and Group Panes (not shown) and 

then navigate to the Telephony → Telephony tab in the Details Pane. Choose the Companding 

Law typical for the enterprise location. For North America, U-Law is used. Uncheck the Inhibit 

Off-Switch Forward/Transfer box to allow call forwarding and call transfers to the PSTN via the 

service provider across the SIP trunk. The Hold Timeout (sec) field controls how long calls remain 

on hold before being alerted to the user and should be set based on the customer’s requirement. Set 

Default Name Priority to Favor Trunk to have IP Office display the name provided in the Caller 

ID from the SIP trunk. Defaults were used for all other settings. Click OK to submit the changes. 

 

 
 

Figure 9 - Avaya IP Office Primary Server Telephony 

 

Navigate to Solution → IPOffice_1 → System (1) (not shown) and repeat the steps above to 

configure the Telephony settings for the Expansion System.  
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  System VoIP Settings 

Navigate to Solution → IPO-SE → System (1) in the Navigation and Group Panes and then 

navigate to the VoIP tab in the Details Pane. Leave the RFC2833 Default Payload as the default 

value of 101. Select codec G.711 ULAW 64K that Cox Communications supports. Click OK to 

submit the changes. 

 

 
 

Figure 10 - Avaya IP Office Primary Server VoIP 
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 Administer SIP Line 

A SIP Line is needed to establish the SIP connection between Avaya IP Office Server Edition and 

Cox Communications system. The recommended method for configuring a SIP Line is to use the 

template associated with these Application Notes. The template is an .xml file that can be used by 

Avaya IP Office Server Edition Manager to create a SIP Line. Follow the steps in Section 5.6.1 to 

create the SIP Line from the template. 

 

Some items relevant to a specific customer environment are not included in the template or may 

need to be updated after the SIP Line is created. Examples include the following: 

• IP addresses 

• SIP Credentials (if applicable) 

• SIP URI entries 

• Setting of the Use Network Topology Info field on the Transport tab 

 

Therefore, it is important that the SIP Line configuration be reviewed and updated if necessary after 

the SIP Line is created via the template. The resulting SIP Line data can be verified against the 

manual configuration shown in Section 5.6.2. 

 

Also, the following SIP Line settings are not supported on Basic Edition: 

• SIP Line – Originator number for forwarded and twinning calls 

• Transport – Second Explicit DNS Server 

• SIP Credentials – Registration Required 

• SIP Advanced Engineering 

 

Alternatively, a SIP Line can be created manually. To do so, right-click Line in the Navigation Pane 

and select New → SIP Line. Then, follow the steps outlined in Section 5.6.2. 

For the compliance test, SIP Line 17 was used as trunk for both outgoing and incoming calls. 
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 Create SIP Line from Template 

1. Create a new folder in computer where Avaya IP Office Server Edition Manager is installed 

(e.g., C:\Cox Communications\Template). Copy the template file to this folder and rename 

the template file to COX-IPO11SBC722.xml (for SIP Line 17). 

2. Import the template into Avaya IP Office Server Edition Manager: From Avaya IP Office 

Server Edition Manager, select Tools → Import Templates in Manager. This action will 

copy the template file from step 1 into the IP Office template directory. 

  

 
 

Figure 11 – Import Template for SIP Line 

 

In the pop-up window (not shown) that appears, select the folder where the template file was 

copied in Step 1. After the import is complete, a final import status pop-up window below 

will appear stating success (or failure). Then click OK to continue. 

 

 

 

 

 

 

 

 

 

 

Figure 12 – Import Template for SIP Line successfully 
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3. Create the SIP Trunk from the template: Right-click on Line in the Navigation Pane, then 

navigate to New from Template → Open from file.  

 

 

Figure 13 – Create SIP Line from Template 
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4. Select the Template Files (*.xml) and select the imported template from step 2 at IP Office 

template directory C:\Program Files\Avaya\IP Office\Manager\manager_files\template\. 

Click Open button to create a SIP line from template.  

 

 
 

Figure 14 – Create SIP Line from IP Office Template directory 
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A pop-up window below will appear stating success (or failure). Then click OK to continue. 

 

 
 

Figure 15 – Create SIP Line from Template successfully  

 

5. Once the SIP Line is created, verify the configuration of the SIP Line with the configuration 

shown in Section 5.6.2. 
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 Create SIP Line Manually 

To create a SIP line, begin by navigating to Line in the left Navigation Pane, then right-click in the 

Group Pane and select New → SIP Line (not shown).  

On the SIP Line tab in the Details Pane, configure the parameters as shown below: 

• Select available Line Number: 17 

• Check the In Service and Check OOS box 

• Input ITSP Domain Name: 10.10.80.88 (This is Avaya SBCE internal IP address) 

• Input Local Domain Name: 10.10.80.104 (This is Avaya IP Office SE LAN2 IP address) 

• Set URI Type to SIP URI 

• For Session Timers, set Refresh Method to Auto with Timer (sec) to On Demand 

• Set Name Priority to Favor Trunk. As described in Section 5.4, the Default Name 

Priority parameter may retain the default Favor Trunk setting or can be configured to 

Favor Directory. As shown below, the default Favor Trunk setting was used in the 

reference configuration 

• For Redirect and Transfer, set Incoming Supervised REFER and Outgoing Supervised 

REFER to NEVER. Note: Cox Communications does not fully support SIP Refer in off-net 

call redirection during the compliance testing (See Section 2.1 for item not tested in detail)  

• Default values may be used for all other parameters 

• Click OK to commit then press Ctrl + S to save 

 

 
 

Figure 16 – SIP Line Configuration  
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On the Transport tab in the Details Pane, configure the parameters as shown below: 

• The ITSP Proxy Address was set to the IP address of Avaya SBCE internal interface: 

10.10.80.88 as shown in Figure 1. This is the SIP Proxy address used for outgoing SIP calls  

• In the Network Configuration area, TLS was selected as the Layer 4 Protocol and the Send 

Port was set to 5061 

• The Use Network Topology Info parameter was set to None. The Listen Port was set to 

5061. Note: For the compliance testing, the Use Network Topology Info field was set to 

None, since no NAT was using in the test configuration.  In addition, it was not necessary to 

configure the System → LAN2 → Network Topology tab for the purposes of SIP trunking. If 

a NAT is used between Avaya IP Office and the other end of the trunk, then the Use Network 

Topology Info field should be set to the LAN interface (LAN2) used by the trunk and the 

System → LAN2 → Network Topology tab needs to be configured with the details of the 

NAT device 

• The Calls Route via Registrar was unchecked as Cox Communications did not support the 

dynamic Registration on the SIP Trunk 

• Other parameters retain default values 

• Click OK to commit then press Ctrl + S to save 

 

 
 

Figure 17 – SIP Line Transport Configuration  
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The SIP URI entry must be created to match any DID number assigned to an Avaya IP Office user 

and Avaya IP Office will route the calls on this SIP line. Select the Call Details tab; click the Add 

button and the New Channel area will appear at the bottom of the pane (not shown). To edit an 

existing entry, click an entry in the list at the top, and click Edit… button. In the example screen 

below, a previously configured entry is edited 

 

A SIP URI entry was created that matched any DID number assigned to an Avaya IP Office user. 

The entry was created with the parameters shown below: 

• Associate this SIP line with an incoming line group in the Incoming Group field and an 

outgoing line group in the Outgoing Group field. This line group number will be used in 

defining incoming and outgoing call routes for this line. For the compliance test, a new line 

group 17 was defined that only contains this line (line 17) 

• Set Max Sessions to the number of simultaneous SIP calls that are allowed using this SIP 

URI pattern 

• Select Credentials to 0: <None> 

• Check P Asserted ID and Diversion Header options (See Section 2.2 for Diversion/PAI 

headers issue) 

• Set the Display and Content of Local URI, Contact, P Asserted ID and Diversion Header 

to Use Internal Data 

• In Field meaning: Set Forwarding/Twinning of Local URI, P Asserted ID and Diversion 

Header to Original Caller 

• Click OK to submit the changes 

 

Figure 18 – SIP Line Call Details Configuration  
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Select the VoIP tab to set the Voice over Internet Protocol parameters of the SIP line. Set the 

parameters as shown below: 

• The Codec Selection can be selected by choosing Custom from the pull-down menu, 

allowing an explicit ordered list of codecs to be specified. The G.711 ULAW 64K codec is 

selected. Avaya IP Office Server Edition supports this codec, which is sent to the Cox 

Communications, in the Session Description Protocol (SDP) offer 

• Check the Re-invite Supported box 

• Set Fax Transport Support to T38 or G.711 from the pull-down menu. Note: Cox 

Communications supports both G.711 pass through and T.38 FAX during the compliance 

testing  

• Set the DTMF Support to RFC2833/RFC4733 from the pull-down menu. This directs 

Avaya IP Office Server Edition to send DTMF tones using RTP events messages as defined 

in RFC2833 and RFC4733 

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

 
 

Figure 19 – SIP Line VoIP Configuration 
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 Outgoing Call Routing 

The following section describes the Short Code for outgoing calls to Cox Communications. 

 Short Code and IP Office Line in Primary System 

Define a short code to route outbound traffic on the SIP line to Cox Communications. To create a 

short code, select Short Code in the left Navigation Pane, then right-click in the Group Pane and 

select New (not shown). On the Short Code tab in the Details Pane, configure the parameters for the 

new short code to be created. The screen below shows the details of the previously administered 

“9N;” short code used in the test configuration. 

 

• In the Code field, enter the dial string which will trigger this short code, followed by a semi-

colon. In this case, 9N;, this short code will be invoked when the user dials 9 followed by 

any number 

• Set Feature to Dial. This is the action that the short code will perform 

• Set Telephone Number to N. The value N represents the number dialed by the user 

• Set the Line Group ID to the Outgoing Group 17 defined on the Call Details tab on the 

SIP Line in Section 5.6.2. This short code will use this line group when placing the 

outbound call  

• Set the Locale to United States (US English) 

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

Figure 20 – Short Code 9N for Primary System 
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The feature of incoming calls from mobility extension to idle-appearance FNE (Feature Name 

Extension) is hosted by Avaya IP Office Server Edition. The Short Code FNE00 was configured 

with following parameters: 

• For Code field, enter FNE feature code as FNE00 for dial tone  

• Set Feature to FNE Service 

• Set Telephone Number to 00 

• Set Line Group ID to 0 

• Set the Locale to United States (US English) 

• Default values may be used for other parameters  

• Click OK to submit the changes 

 

 
 

Figure 21 – Short Code FNE 

 

Verify the ID of the IP Office line connecting the Primary System to the Expansion System. To do 

this, select Line on the navigation pane and select the IP Office Line on the Group pane (line 2 on 

the screen below). Make note of the Outgoing Group ID 99999 on the Details pane. The Address is 

Avaya IP Office Expansion System LAN1 IP address 172.16.199.60. 

 

 
 

Figure 22 – IP Office Line for Primary System 
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Verify the VoIP Settings of the IP Office line connecting the Primary System to the Expansion 

System. Select Fax Transport Support to T38 or G.711 (This setting should be as same as the 

VoIP settings in SIP line of Primary System and the VoIP settings in IP Office Line of Expansion 

System). Default values may be used for all other parameters. Click OK to submit the changes. 

 

 
 

Figure 23 – IP Office Line for Primary System VoIP Settings 
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 Short Code and IP Office Line in Expansion System 

Define a short code to route outbound traffic on the SIP line to Cox Communications. This short 

code is used for analog and digital phones which are connected to Expansion System. To create a 

short code, select Short Code in the left Navigation Pane, then right-click in the Group Pane and 

select New (not shown). On the Short Code tab in the Details Pane, configure the parameters for the 

new short code to be created. The screen below shows the details of the previously administered 

“9N;” short code used in the test configuration. 

 

• In the Code field, enter the dial string which will trigger this short code, followed by a semi-

colon. In this case, 9N;, this short code will be invoked when the user (using Avaya analog or 

digital phones) dials 9 followed by any number 

• Set Feature to Dial. This is the action that the short code will perform 

• Set Telephone Number to 9N 

• Set the Line Group ID to 99999 defined on the Outgoing Group ID of the IP Office line 

connecting the Expansion System to the Primary System. This short code will use this line 

group when placing the outbound call via Avaya IP Office Server Edition Primary Server  

• Default values may be used for all other parameters 

• Click OK to submit the changes 

 

 
 

Figure 24 – Short Code 9N for Expansion System 
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Verify the ID of the IP Office line connecting the Expansion System to the Primary System. To do 

this, select Expansion Line on the navigation pane and select the IP Office Line on the Group pane 

(line 17 on the screen below). Make note of the Outgoing Group ID 99999 on the Details pane. The 

Address is Avaya IP Office Server Edition LAN1 IP address 10.33.10.56 

 

 
 

Figure 25 – IP Office Line for Expansion System 

 

Verify the VoIP Settings of the IP Office line connecting the Expansion System to the Primary 

Server. Select Fax Transport Support to T38 or G.711 (This setting should be as same as the VoIP 

settings in SIP line and IP Office Line of Primary System). Default values may be used for all other 

parameters. Click OK to submit the changes. 

 

 
 

Figure 26 – IP Office Line for Expansion Server VoIP Settings 
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 User  

Configure the SIP parameters for each user that will be placing and receiving calls via the SIP Line 

defined in Section 5.6. To configure these settings, first select User in the left Navigation Pane, then 

select the name of the user to be modified in the center Group Pane. In the example below, the name 

of the user is 402XXX5730. Select the SIP tab in the Details pane.   

 

The values entered for the SIP Name and Contact fields are used as the user part of the SIP URI in 

the From header for outgoing SIP trunk calls. They also allow matching of the SIP URI for incoming 

calls without having to enter this number as an explicit SIP URI for the SIP line. The example below 

shows the settings for user 402XXX5730. The SIP Name and Contact are set to one of the DID 

numbers assigned to the enterprise provided by Cox Communications. The SIP Display Name 

(Alias) parameter can optionally be configured with a descriptive name. If all calls involving this 

user and a SIP Line should be considered private, then the Anonymous box may be checked to 

withhold the user’s information from the network. 

 

 
 

Figure 27 – User Configuration 
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One of the H.323 IP Deskphones at the enterprise site uses the Mobile Twinning feature. The 

following screen shows the Mobility tab for User 402XXX5730. The Mobility Features and 

Mobile Twinning boxes are checked. The Twinned Mobile Number field is configured with the 

number to dial to reach the twinned mobile telephone, in this case 91613XXX5096. Check Mobile 

Call Control to allow incoming calls from mobility extension to access FNE00 (defined in Section 

5.7.1). Other options can be set according to customer requirements. 

 

 
 

Figure 28 – Mobility Configuration for User 
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 Incoming Call Route 

An Incoming Call Route maps an inbound DID number on a specific line to an internal extension.  

This procedure should be repeated for each DID number provided by service provider. To create an 

incoming call route, select Incoming Call Route in the left Navigation Pane, then right-click in the 

center Group Pane and select New (not shown). On the Standard tab of the Details Pane, enter the 

parameters as shown below:  

• Set the Bearer Capability to Any Voice 

• Set the Line Group ID to the Incoming Group 17 defined on the Call Details tab on the 

SIP Line in Section 5.6.2 

• Set the Incoming Number to the incoming DID number on which this route should match 

• Default values can be used for all other fields  

 

 
 

Figure 29 – Incoming Call Route Configuration 

 

On the Destination tab, select the destination extension from the pull-down menu of the Destination 

field. In this example, incoming calls to 402XXX5730 on line 17 are routed to Destination 5730 

402XXX5730 as below screenshot: 

 

 
 

Figure 30 – Incoming Call Route for Destination 402XXX5730  
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For Feature Name Extension Service testing purpose, the incoming calls to DID number 

402XXX7903 were configured to access FNE00. The Destination was appropriately defined as 

FNE00 as below screenshot: 

 

 
 

Figure 31 – Incoming Call Route for Destination FNE  

 

For Voice Mail testing purpose, the incoming calls to DID number 402XXX8367 were configured to 

access VoiceMail. The Destination was appropriately defined as VoiceMail as below screenshot: 

 

 
 

Figure 32 – Incoming Call Route for Destination VoiceMail 

 Save Configuration 

Navigate to File → Save Configuration in the menu bar at the top of the screen to save the 

configuration performed in the preceding sections. 
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 Configure Avaya Session Border Controller for Enterprise 
This section describes the configuration of Avaya SBCE necessary for interoperability with the 

Avaya IP Office and Cox Communications SIP Trunk Service. 

 

Avaya elements reside on the Private side and the Cox Communications SIP Trunk Service resides 

on the Public side of the network, as illustrated in Figure 1.  

 

Note: The following section assumes that Avaya SBCE has been installed and that network 

connectivity exists between the systems. For more information on Avaya SBCE, see relevant 

product documentation references in Section 10 of these Application Notes. 

 Log in to the Avaya SBCE  

Access the web interface by typing “https://x.x.x.x/sbc/” (where x.x.x.x is the management IP 

address of the Avaya SBCE). 
 

Enter the Username and Password 
 

 

 

Figure 33 – Avaya SBCE Login 
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The Dashboard main page will appear as shown below. 

 

 
 

Figure 34 - Avaya SBCE Dashboard 

 

To view system information that has been configured during installation, navigate to System 

Management. A list of installed devices is shown in the right pane. In the compliance test, a single 

Device Name SBCE was already added. To view the configuration of this device, click View as 

shown in the screenshot below. 
 

 
 

Figure 35 - Avaya SBCE System Management 
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The System Information screen shows General Configuration, Device Configuration, Network 

Configuration, DNS Configuration and Management IP(s) information provided during 

installation and corresponds to Figure 1. The Box Type was set to SIP and the Deployment Mode 

was set to Proxy. 

 

 
 

Figure 36 - Avaya SBCE System Information 
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 Global Profiles  

When selected, Global Profiles allows for configuration of parameters across all Avaya SBCE 

appliances.  

 Configure Server Interworking Profile – Avaya IP Office   

Server Interworking profile allows administrator to configure and manage various SIP call server-

specific capabilities such as call hold, 180 handling, etc.  

 

From the menu on the left-hand side, select Global Profiles → Server Interworking  

• Select avaya-ru in Interworking Profiles 

• Click Clone 

• Enter Clone Name: IPO and click Finish (not shown) 

• Click Edit button 

• Check T.38 Support or uncheck this option and click Finish (not shown). Note: Un-check 

this option as default for Fax G.711 pass-through mode 

 

The following screen shows that Avaya IP Office server interworking profile (named: IPO) was 

added. 
 

 
 

Figure 37 - Server Interworking – Avaya 
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 Configure Server Interworking Profile – Cox Communications 

From the menu on the left-hand side, select Global Profiles → Server Interworking → Add 

• Enter Profile Name: SP (not shown) 

• Click Next button to leave all options at default and click Finish (not shown) 

• Click Edit button 

• Check T.38 Support or uncheck this option and click Finish (not shown). Note: Un-check 

this option as default for Fax G.711 pass-through mode 

 

The following screen shows that Cox Communications server interworking profile (named: SP) was 

added. 
 

 
 

Figure 38 - Server Interworking – Cox Communications 
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 Configure Server – Avaya IP Office  

The Server Configuration screen contains six tabs: General, Authentication, Heartbeat, 

Registration, Ping and Advanced. Together, these tabs allow one to configure and manage various 

SIP call server specific parameters such as port assignment, IP Server type, heartbeat signaling 

parameters and some advanced options 

  

From the menu on the left-hand side, select Global Profiles → Server Configuration → Add 

 

Enter Profile Name: IPO (not shown). 

On the General tab, enter the following: 

• Server Type: Select Call Server 

• TLS Client Profile: Select AvayaSBCClient. Note: During the compliance test in the lab 

environment, demo certificates are used and are not recommended for production use. 

Consult the appropriate Avaya product documentation for further information regarding 

security certificate and encryption capabilities supported by Avaya product 

• IP Address/FQDN: 10.10.80.104 (Avaya IP Office SE LAN2 IP address)  

• Port: 5061  

• Transport: TLS 

• Click Finish (not shown) 

 

 
 

Figure 39 – Avaya Server Configuration – General  

 



 
HV; Reviewed: 

SPOC 4/7/2020 

Solution & Interoperability Test Lab Application Notes 

©2020 Avaya Inc. All Rights Reserved. 

45 of 97 

         COX-IPO11SBC722 

 

On the Heartbeat tab, click Edit button to enter the following: 

• Check Enable Heartbeat option 

• Method: OPTIONS 

• Frequency: 60 seconds 

• From URI: ping@10.10.80.88 

• To URI: ping@10.10.80.104 

• Click Finish (Not shown) 

 

 
 

Figure 40 – Avaya Server Configuration – Heartbeat 
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On the Advanced tab, click Edit button to enter the following: 

• Check Enable Grooming box 

• Select IPO for Interworking Profile (see Section 6.2.1) 

• Click Finish (not shown) 
 

 
 

Figure 41 – Avaya Server Configuration – Advanced 
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 Configure Server – Cox Communications 

From the menu on the left-hand side, select Global Profiles → Server Configuration → Add 

 

Enter Profile Name: SP (not shown) 

On General tab, enter the following: 

• Server Type: Select Trunk Server  

• Add IP Address/FQDN: 10.10.80.87 (Cox managed CPE LAN IP address) 

• Port: 5060 

• Transport: UDP 

• Click Finish (not shown) 

 

 
 

Figure 42 – Cox Communications Server Configuration – General 
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On the Authentication tab, click Edit button to enter the following: 

• Check Enable Authentication box 

• User Name: 402XXX4705 (Provided by Cox Communications) 

• Password: ******** (Provided by Cox Communications) 

• Confirm Password: ******** (Provided by Cox Communications) 

• Click Finish 

 

 
 

Figure 43 – Cox Communications Server Configuration – Authentication 

 

On the Heartbeat tab, click Edit button to enter the following: 

• Check Enable Heartbeat box 

• Method: OPTIONS 

• Frequency: 60 seconds 

• From URI: ping@10.10.80.89 

• To URI: ping@10.10.80.87 

• Click Finish (not shown) 

 

mailto:ping@10.10.80.89
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Figure 44 – Cox Communications Server Configuration – Heartbeat 

 

On the Registration tab, click Edit button to enter the following: 

• Check Register with All Servers option 

• Refresh Interval: 60 seconds 

• From URI: 402XXX4705@10.10.80.89 

• To URI: 402XXX4705@10.10.80.87 

• Click Finish (Not shown) 

 

 
 

Figure 45 – Cox Communications Server Configuration – Registration 

 

mailto:402XXX4705@10.10.80.8
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On the Advanced tab, click Edit button to enter the following: 

• Interworking Profile: Select SP (see Section 6.2.2) 

• Click Finish (not shown) 

 

 
 

Figure 46 – Cox Communications Server Configuration – Advanced  

 Configure Routing – Avaya IP Office 

Routing profiles define a specific set of packet routing criteria that are used in conjunction with other 

types of domain policies to identify a particular call flow and thereby ascertain which security 

features will be applied to those packets. Parameters defined by Routing Profiles include packet 

transport settings, name server addresses and resolution methods, next hop routing information, and 

packet transport types. 

  

From the menu on the left-hand side, select Global Profiles → Routing and click Add as 

highlighted below.  

 

Enter Profile Name: To_IPO and click Next button (not shown) 

• Select Load Balancing: Priority 

• Check Next Hop Priority  

• Click Add button to add a Next-Hop Address 

• Priority/Weight: 1 

• Server Configuration: IPO (see Section 6.2.3). This selection will automatically populate 

the Next Hop Address field with 10.10.80.104:5061 (TLS) (Avaya IP Office LAN2 port IP 

address) 

• Click Finish 
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Figure 47 - Routing to Avaya IP Office  
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 Configure Routing – Cox Communications  

From the menu on the left-hand side, select Global Profiles → Routing and click Add as 

highlighted below. 

 

Enter Profile Name: To_SP (not shown) 

• Load Balancing: Priority 

• Check Next Hop Priority 

• Click Add button to add a Next-Hop Address 

• Priority/Weight: 1  

• Server Configuration: SP (see Section 6.2.4). This selection will automatically populate the 

Next Hop Address field drop-down menu. Select 10.10.80.87:5060 (UDP) (Cox managed 

CPE LAN IP Address)  

• Click Finish 
 

 
 

Figure 48 - Routing to Cox Communications 
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 Configure Topology Hiding – Avaya IP Office   

The Topology Hiding screen allows an administrator to manage how various source, destination and 

routing information in SIP and SDP message headers are substituted or changed to maintain the 

integrity of the network. It hides the topology of the enterprise network from external networks.  

 

From the menu on the left-hand side, select Global Profiles → Topology Hiding  

• Select default in Topology Hiding Profiles 

• Click Clone 

• Enter Clone Name: To_IPO and click Finish (not shown) 

• Select To_IPO in Topology Hiding Profiles and click Edit button to modify as below: 

For the Header Request-Line,  

- In the Criteria column, select IP/Domain   

- In the Replace Action column, select Overwrite  

- In the Overwrite Value column, enter 10.10.80.104 (Avaya IP Office LAN2 port IP 

address) 

For the Header From,  

- In the Criteria column, select IP/Domain  

- In the Replace Action column, select Overwrite  

- In the Overwrite Value column, enter 10.10.80.88 (Avaya SBCE internal IP address)  

For the Header To,  

- In the Criteria column, select IP/Domain  

- In the Replace Action column, select Overwrite  

- In the Overwrite Value column, enter 10.10.80.104 (Avaya IP Office LAN2 port IP 

address)  

• Click Finish (not shown)  

 

 
 

Figure 49 - Topology Hiding Avaya IP Office 
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 Configure Topology Hiding – Cox Communications 

From the menu on the left-hand side, select Global Profiles → Topology Hiding  

• Select default in Topology Hiding Profiles 

• Click Clone 

• Enter Clone Name: To_SP and click Finish (not shown) 

 

 
 

Figure 50 - Topology Hiding Cox Communications 
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 Domain Policies  

The Domain Policies feature allows administrator to configure, apply, and manage various rule sets 

(policies) to control unified communications based upon various criteria of communication sessions 

originating from or terminating in the enterprise. These criteria can be used to trigger different 

policies which will apply on call flows, change the behavior of the call, and make sure the call does 

not violate any of the policies. There are default policies available to use, or an administrator can 

create a custom domain policy.  

 Create Application Rules  

Application rules define the type of SBC-based Unified Communication (UC) applications Avaya 

SBCE protects. You can also determine the maximum number of concurrent voice and video 

sessions that your network can process before resource exhaustion.  

  

From the menu on the left-hand side, select Domain Policies → Application Rules  

• Select the default rule and click on Clone button 

• Enter Clone Name: App-Rules and click Finish button (not shown) 

• Select the App-Rules rule from the list of Application Rules and click on Edit button 

• Set Maximum Concurrent Sessions to 500 and Maximum Sessions Per Endpoint to 500 

• Click Finish button (not shown) to save the changes 
 

 
 

Figure 51 – Application Rule 
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 Create Endpoint Policy Groups  

The End-Point Policy Group feature allows one to create Policy Sets and Policy Groups. A Policy 

Set is an association of individual, SIP signaling-specific security policies (rule sets): application, 

border, media, security, and signaling, each of which was created using the procedures contained in 

the previous sections. A Policy Group is comprised of one or more Policy Sets. The purpose of 

Policy Sets and Policy Groups is to increasingly aggregate and simplify the application of Avaya 

SBCE security features to very specific types of SIP signaling messages traversing through the 

enterprise.  

 

From the menu on the left-hand side, select Domain Policies → End Point Policy Groups  

• Select Add  

• Enter Group Name: EndPoint-Policy  

- Application Rule: App-Rules (See Section 6.3.1) 

- Border Rule: default 

- Media Rule: default-low-med 

- Security Rule: default-low 

- Signaling Rule: default 

- Leave other options as default  

• Select Finish (not shown) 

 

 
 

Figure 52 – End Point Policy 
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 Device Specific Settings 

The Device Specific Settings feature for SIP allows one to view aggregate system information, and 

manage various device-specific parameters which determine how a particular device will function 

when deployed in the network. Specifically, one has the ability to define and administer various 

device-specific protection features such as Message Sequence Analysis (MSA) functionality, end-

point and session call flows and Network Management.  

 Manage Network Settings 

From the menu on the left-hand side, select Device Specific Settings → Network Management 

• Select Networks tab and click the Add button to add a network for the internal interface as 

follows:  

- Name: Network_A1 

- Default Gateway: 10.10.80.1  

- Network Prefix or Subnet Mask: 255.255.255.128 

- Interface: A1 (This is the Avaya SBCE internal interface) 

- Click the Add button to add the IP Address for internal interface: 10.10.80.88 and the 

Gateway Override: 10.10.80.1  

- Click the Finish button to save the changes 

 

 
 

Figure 53 - Network Management – Internal Interface 
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From the menu on the left-hand side, select Device Specific Settings → Network Management 

• Select Networks tab and click the Add button to add a network for the external interface as 

follows:  

- Name: Network_B1 

- Default Gateway: 10.10.80.1  

- Network Prefix or Subnet Mask: 255.255.255.128 

- Interface: B1 (This is the Avaya SBCE external interface) 

- Click the Add button to add the IP Address for external interface: 10.10.80.89 and the 

Gateway Override: 10.10.80.1  

- Click the Finish button to save the changes 

 

 
 

Figure 54 - Network Management – External Interface 

 

From the menu on the left-hand side, select Device Specific Settings → Network Management 

• Select the Interfaces tab  

• Click on the Status of the physical interfaces being used and change them to Enabled state  

 

 
 

Figure 55 - Network Management – Interface Status 
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 Create Media Interfaces 

Media Interfaces define the type of media on the ports. The default media port range on the Avaya 

SBCE can be used for both inside and outside ports. 

 

From the menu on the left-hand side, Device Specific Settings → Media Interface  

• Select the Add button and enter the following in the configuration window (not shown):  

- Name: InsideMedia  

- IP Address: Select Network_A1 (A1, VLAN 0) and 10.10.80.88 (Avaya SBCE internal 

IP address toward Avaya IP Office)  

- Port Range: 35000 – 40000  

- Click Finish (not shown) 

• Select the Add button and enter the following in the configuration window (not shown): 

- Name: OutsideMedia  

- IP Address: Select Network_B1 (B1, VLAN 0) and 10.10.80.89 (Avaya SBCE external 

IP address toward Cox managed CPE)  

- Port Range: 35000 – 40000  

- Click Finish (not shown)  

 

The screen below shows the configured media interfaces: 

 

 

Figure 56 - Media Interface 
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 Create Signaling Interfaces 

Signaling Interfaces define the type of signaling on the ports. 

 

From the menu on the left-hand side, select Device Specific Settings → Signaling Interface  

• Select the Add button and enter the following in the configuration window (not shown):  

- Name: OutsideUDP 

- IP Address: Select Network_B1 (B1, VLAN 0) and 10.10.80.89 (Avaya SBCE external 

IP address toward Cox managed CPE)  

- UDP Port: 5060 

- Click Finish (not shown)  

From the menu on the left-hand side, select Device Specific Settings → Signaling Interface  

• Select the Add button and enter the following in the configuration window (not shown): 

- Name: InsideTLS  

- IP Address: Select Network_A1 (A1, VLAN 0) and 10.10.80.88 (Avaya SBCE internal 

IP address toward Avaya IP Office)  

- TLS Port: 5061 

- TLS Profile: AvayaSBCServer. Note: During the compliance test in the lab 

environment, demo certificates are used and are not recommended for production use. 

Consult the appropriate Avaya product documentation for further information regarding 

security certificate and encryption capabilities supported by Avaya product 

- Click Finish (not shown)  

 

The screen below shows the configured signaling interfaces: 

 

 

Figure 57 - Signaling Interface 
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 Configure Server Flows 

Server Flows allow an administrator to categorize signaling and apply various policies. 

 Create End Point Flows – Avaya IP Office  

From the menu on the left-hand side, select Device Specific Settings → End Point Flows 

• Select the Server Flows tab  

• Select Add, enter the followings:  

- Flow Name: IPO Flow 

- Server Configuration: IPO (see Section 6.2.3)  

- URI Group: * 

- Transport: *  

- Remote Subnet: *  

- Received Interface: OutsideUDP (see Section 6.4.3)  

- Signaling Interface: InsideTLS (see Section 6.4.3) 

- Media Interface: InsideMedia (see Section 6.4.2) 

- Secondary Media Interface: None  

- End Point Policy Group: EndPoint-Policy (see Section 6.3.2) 

- Routing Profile: To_SP (see Section 6.2.6) 

- Topology Hiding Profile: To_IPO (see Section 6.2.7) 

- Leave other options as default 

- Click Finish 

 

 
 

Figure 58 - End Point Flow 1 
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 Create End Point Flows – Cox Communications 

From the menu on the left-hand side, select Device Specific Settings → End Point Flows  

• Select the Server Flows tab  

• Select Add, enter the followings:  

- Flow Name: SP Flow 

- Server Configuration: SP (see Section 0) 

- URI Group: * 

- Transport: *  

- Remote Subnet: *  

- Received Interface: InsideTLS (see Section 6.4.3) 

- Signaling Interface: OutsideUDP (see Section 6.4.3)  

- Media Interface: OutsideMedia (see Section 6.4.2) 

- Secondary Media Interface: None  

- End Point Policy Group: EndPoint-Policy (see Section 6.3.2) 

- Routing Profile: To_IPO (see Section 6.2.5) 

- Topology Hiding Profile: To_SP (see Section 6.2.8) 

- Leave other options as default 

- Click Finish 

 

 
 

Figure 59 - End Point Flow 2 
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 Cox Communications SIP Trunk Configuration 
Cox Communications is responsible for the configuration of Cox Communications SIP Trunk 

Service. Cox Communications will provide the Cox managed CPE to the customer when the 

customer orders the Cox Communications SIP trunk service. Cox Communications will be 

responsible for managing the Cox managed CPE. Customer must provide the IP address used to 

reach the Cox managed CPE WAN port at the enterprise. Cox Communications will provide the 

customer necessary information to configure the SIP connection between Avaya enterprise and Cox 

Communications. The provided information from Cox Communications includes: 

• IP address and port number used for signaling or media servers through any security devices 

• DID numbers 

• Cox Communications SIP Trunk Specification (if applicable) 
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 Verification Steps 
The following steps may be used to verify the configuration: 
 

• Use the Avaya IP Office System Status application to verify the state of the SIP connection.  

Launch the application from Start → Programs → IP Office → System Status on the PC 

where Avaya IP Office  Manager was installed. Select the SIP Line of interest from the left 

pane. On the Status tab in the right pane, verify that the Current State for each channel. 

(The below screen shot showed two active calls at the time.) 

 

 
 

Figure 60 – SIP Trunk status 
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• Use the Avaya IP Office System Status application to verify that no alarms are active on the 

SIP line. Launch the application from Start → Programs → IP Office → System Status on 

the PC where Avaya IP Office Manager was installed. Select Alarm → Trunks to verify that 

no alarms are active on the SIP line. 
 

 
 

Figure 61 – SIP Trunk alarm 

 

• Verify that a phone connected to the PSTN can successfully place a call to Avaya IP Office  

with two-way audio. 

• Verify that a phone connected to Avaya IP Office can successfully place a call to the PSTN 

with two-way audio.  

• Capture SIP call traces on Avaya SBCE by executing command via the Command Line 

Interface (CLI): Login Avaya SBCE with root user and enter the command: #traceSBC. The 

tool updates the database directly based on which trace mode is selected. 
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 Conclusion 
Cox Communications passed compliance testing with the limitation listed in Section 2.2. These 

Application Notes describe the procedures required to configure SIP trunk connectivity between 

Avaya IP Office 11.0 and the Avaya SBCE 7.2.2 to support Cox Communications SIP Trunking 

service, as shown in Figure 1. 

 Additional References 
[1] Administering Avaya IP Office Platform with Manager, Release 11.0, February 2019. 

[2] Avaya IP Office™ Platform Release 11.0 – Release Notes / Global IP Office Technical Bulletin 

223, 22nd January 2020 

[3] Avaya Session Border Controller for Enterprise 7.2.2.3 Release Note, Issue 1, October 2019 

 

Product documentation for Avaya products may be found at: http://support.avaya.com. Additional IP 

Office documentation can be found at: 

http://marketingtools.avaya.com/knowledgebase/ipoffice/general/rss2html.php?XMLFILE=manuals.

xml&TEMPLATE=pdf_feed_template.html   

 

Product documentation for Cox Communications SIP Trunking may be found at: 

http://www.cox.com 

 

 

 

 

 

http://support.avaya.com/
http://marketingtools.avaya.com/knowledgebase/ipoffice/general/rss2html.php?XMLFILE=manuals.xml&TEMPLATE=pdf_feed_template.html
http://marketingtools.avaya.com/knowledgebase/ipoffice/general/rss2html.php?XMLFILE=manuals.xml&TEMPLATE=pdf_feed_template.html
http://www.cox.com/
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 Appendix A - Remote Worker Configuration via Avaya 
SBCE 

This section describes the process for connecting remote Avaya SIP endpoints on the public Internet 

to Avaya IP Office on the private enterprise network via the Avaya SBCE. The provisioning builds 

on the reference configuration described in previous sections of this document. 

 

For more information, refer to Section 10. 

 

Note – This Remote Worker configuration is based on provisioning the Avaya SBCE. It is not to be 

confused with “native” Avaya IP Office Remote Worker configurations. 

 

In the configuration for the compliance test, Avaya IXTM Workplace (SIP mode) was used as the 

Remote Worker SIP endpoint. 

 

The reference configuration for the compliance test, including the Remote Worker endpoint, is 

shown in Figure 1 in Section 3.  
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 Provisioning Avaya SBCE for Remote Worker 

Provisioning of the Avaya SBCE to support Avaya IP Office SIP connection to the service provider 

is described in Section 6. The following sections build on that provisioning. 

 Network Management  

This section shows the Network Management configuration of the Avaya SBCE to support Remote 

Worker. For this purpose, the Avaya SBCE is configured with a second internal IP address assigned 

to physical interface A1, and a second external IP address assigned to physical interface B1.  

 

The following IP addresses were used on the Avaya SBCE in the configuration used for the 

compliance test:  

• 10.10.80.88 is the internal IP address previously provisioned for SIP Trunking with Avaya IP 

Office (see Section 6.4.1).  

• 10.10.80.106 is the new internal IP address for Remote Worker.  

• 10.10.80.89 is the external IP address previously provisioned for SIP Trunking with Cox 

managed CPE (see Section 6.4.1).  

• 10.10.80.105 is the new external IP address for Remote Worker.  

 

On the Networks tab, select Add to create an entry for 10.10.80.106 on interface A1, then select 

Save (not shown).  

On the Networks tab, select Add to create an entry for 10.10.80.105 on interface B1, then select 

Save (not shown). 

  

 
 

Figure 62 – Remote Worker Network Management 
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 Signaling Interfaces 

Two new Signaling interfaces were created for the internal and external IP interfaces used for 

Remote Worker SIP traffic. Both interfaces InsideRW and OutsideRW support TLS Port 5061.  

From Device Specific Settings on the left-hand menu, select Signaling Interface. Click on the Add 

button to create Signaling Interface InsideRW 

• Signaling IP = 10.10.80.106  

• TLS Port = 5061 

• TLS Profile = AvayaSBCServer 

From Device Specific Settings on the left-hand menu, select Signaling Interface. Click on the Add 

button to create Signaling Interface OutsideRW  

• Signaling IP = 10.10.80.105  

• TLS Port = 5061 

• TLS Profile = AvayaSBCServer 

 

 
 

Figure 63 – Remote Worker Signaling Interface 

 

Signaling Interface InsideRW is used in the Remote Worker Server Flow (Refer to Section 

11.1.8.2). Signaling Interface OutsideRW is used in the Remote Worker Subscriber Flow (Refer to 

Section 11.1.8.1), and in the Remote Worker Server Flow (Refer to Section 11.1.8.2). 
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 Media Interface 

Two new Media interfaces were created for the internal and external IP interfaces used for Remote 

Worker SIP traffic. 

From Device Specific Settings on the left-hand menu, select Media Interface. Click on the Add 

button to create Media Interface InsideRW using the parameters shown below: 

• Media IP = 10.10.80.106  

• Port Range = 35000 – 40000  

From Device Specific Settings on the left-hand menu, select Media Interface. Click on the Add 

button to create Media Interface OutsideRW using the parameters shown below: 

• Media IP = 10.10.80.105  

• Port Range = 35000 – 40000  

 

 
 

Figure 64 – Remote Worker Media Interface 

 

Media Interface InsideRW is used in the Remote Worker Server Flow (Refer to Section 11.1.8.2). 

Media Interface OutsideRW is used in the Remote Worker Subscriber Flow (Refer to Section 

11.1.8.1). 
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 Server Profile for Avaya IP Office  

The existing IPO Server Profile (Defined in Section 6.2.3) is used for Remote Worker.  

 

 
 

Figure 65 – Remote Worker Server Configuration 
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 Routing Profiles 

Two Routing Profiles are required to support Remote Worker  

The existing To_IPO Routing (see Section 6.2.5) is used for Remote Worker.  

 

 
 

Figure 66 – Remote Worker Routing 
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From the menu on the left-hand side, select Global Profiles → Routing →Add 

Enter Profile Name: defaultRW 

• Check Load Balancing: DNS/SRV 

• NAPTR box is checked 

Click Finish 

 

 
 

Figure 67 – Remote Worker Default Routing 

 

The Routing Profile To_IPO is used in the Remote Worker Subscriber Flow (Refer to Section 

11.1.8.1). The Routing Profile defaultRW is used in the Remote Worker Server Flow (Refer to 

Section 11.1.8.2). 
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 User Agent 

User Agents are created for each type of Remote Worker endpoint used. In the compliance test, the 

Avaya IXTM Workplace (SIP) softphone was used, and its configuration is shown below.  

From the menu on the left-hand side, select Global Parameters → User Agents, and click Add 

button to create a new User Agent.  

Enter the following:  

• Name = Remote Worker  

• Regular Expression = Avaya Communicator.*  

 

In this expression, “Avaya Communicator.*” will match any software version listed after the user 

agent name. 

 

 
 

Figure 68 – Remote Worker User Agent 

 

The Remote Worker User Agent is defined in the Remote Worker Subscriber Flow (see Section 

11.1.8.1). 
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 End Point Policy Groups 

Use End Point Policy Group EndPoint-Policy defined in Section 6.3.2 for the Remote Worker 

connection 

 

 
 

Figure 69 – Remote Worker Endpoint Policy Group 

 
End Point Policy Group EndPoint-Policy is used in the Subscriber Flow (Refer to Section 11.1.8.1) 

and in the Server Flow (Refer to Section 11.1.8.2). 
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 End Point Flows 

A Subscriber Flow and a Server Flow are created for Remote Worker. 

 Subscriber Flow 

A Subscriber Flow is defined as follows:  

From the menu on the left-hand side, select Device Specific Settings → End Point Flows.  

On Subscriber Flows tab, click on Add and the Criteria window will open.  

• Enter Flow Name (e.g., Remote Worker).  

• URI Group = * 

• User Agent = Remote Worker (Refer to Section 11.1.6) 

• Source Subnet = * (default)  

• Via Host = * (default)  

• Contact Host = * (default) 

• Signaling Interface = OutsideRW (Refer to Section 11.1.2)  

 

 
 

Figure 70 – Remote Worker Subscriber Flow 1 

 

Click on Next and the Profile window will open. Enter the followings:  

• Source = Subscriber  

• Methods Allowed Before REGISTER: Leave as default.  

• Media Interface = OutsideRW (Refer to Section 11.1.3) 

• Secondary Media Interface = None 

• Received Interface = None  

• End Point Policy Group = EndPoint-Policy (Refer to Section 11.1.7)  

• Routing Profile = To_IPO (Refer to Section 11.1.5)  

• TLS Client Profile = None 

• Signaling Manipulation Script = None  
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• Presence Server Address = Blank  

• Click Finish to submit the changes.  

 

 
 

Figure 71 – Remote Worker Subscriber Flow 2 
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The Subscriber Flows tab shown below displays the finished Subscriber Flow Remote Worker. 

 

 
 

Figure 72 – Remote Worker Subscriber Flow 3 
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Click on the highlighted View link brings up the following View Flow window. 

 

 
 

Figure 73 – Remote Worker Subscriber Flow 4 

 Server Flow 

The following section shows the new Server Flow settings for Remote Worker. The new Remote 

Worker Server Flow (IPO RW) is configured for the SIP traffic flow from Avaya IP Office to 

Remote Worker via Avaya SBCE. Two existing Trunking Server Flows (IPO Flow in Section 

6.4.4.1 and SP Flow in Section 6.4.4.2) are also used for Remote Worker.  
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From the menu on the left-hand side, select Device Specific Settings → End Point Flows  

On Server Flows tab, click on Add to create a new server flow for Remote Worker 

Enter the following:  

• Flow Name = IPO RW  

• Server Configuration = IPO (Refer to Section 11.1.4)  

• URI Group = * (default)  

• Transport = * (default)  

• Remote Subnet = * (default)  

• Received Interface = OutsideRW (Refer to Section 11.1.2)  

• Signaling Interface = InsideRW (Refer to Section 11.1.2)  

• Media Interface = InsideRW (Refer to Section 11.1.3) 

• Secondary Media Interface = None 

• End Point Policy Group = EndPoint-Policy (Refer to Section 11.1.7)  

• Routing Profile = default_RW (Refer to Section 11.1.5)  

• Topology Hiding Profile = None 

• Signaling Manipulation Script = None  

• Remote Branch Office = Any 

• Click Finish to submit the changes  

 

 
 

Figure 74 – Remote Worker Server Flow 1 
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If the Remote Worker server flow is listed ahead of the flow for SIP Trunking IPO Flow (defined in 

Section 6.4.4.1), enter 2 in the Priority box at the start of the Remote Worker flow entry and click 

the Update button under the server name. The completed flow should show up in the Server Flows 

tab as below. 

 

 
 

Figure 75 – Remote Worker Server Flow 2  
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 Remote Worker Endpoint Configuration on Avaya IP Office  

The Remote Worker - Avaya IXTM Workplace endpoint is added to the Avaya IP Office User and 

Extension configuration. 

 Extension and User Configuration 

No special configurations are required to create the Remote Worker extension and user in Avaya IP 

Office. Follow the same standard procedures for creating a local extension and user for Avaya IXTM 

Workplace.  

 

The Remote Worker user provisioned is shown below. Note that since the Remote Worker endpoint 

used in the reference configuration is Avaya IXTM Workplace softphone, the Enable Softphone 

option is selected.  

 

Note: Do not check the Enable Remote Worker option. This is only enabled for Avaya IP Office 

“native” Remote Worker configurations, not for Remote Worker configurations utilizing the Avaya 

SBCE. 

 

 
 

Figure 76 – Remote Worker User Configuration 1 

 

The SIP tab for the Remote User is configured the same way as with a local Avaya IP Office user 

(see Section 5.8). 
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Figure 77 – Remote Worker User Configuration 2  

 Incoming Call Route 

Follow the same procedures described in Section 5.9 for defining an Incoming Call Route to the 

Remote Worker. 

 

 
 

Figure 78 – Remote Worker Incoming Call Route 
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 Remote Worker - Avaya Communicator for Windows Settings 

The following screen illustrates Avaya IXTM Workplace administration settings for Remote Worker 

as used in the reference configuration. 

After opening the Avaya IXTM Workplace application, select the Options and Settings icon 

 

Select Accounts from the menu, and enter the following:  

• In Workplace, enter Username and Password 

• In Phone Service, enter Extension and Password 

• Click DONE the save the changes.  

 

Select Services → Phone Service, and enter the following:  

• Server Address: 10.10.80.105 (Avaya SBCE external interface IP address for remote 

worker) 

• Server Port: 5061 

• Domain: 10.10.80.104 (Avaya IP Office LAN2 IP address) 

• Enable Use TLS 

• Adhoc Conference Address: ConfServer@avaya.com 

 

mailto:ConfServer@avaya.com
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Figure 79 – Remote Worker - Avaya IXTM workplace for Windows Settings 

 

Note: For this compliance testing, only audio calls were tested with RTP media for Avaya IXTM 

Workplace. 
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 Appendix B - Cox managed CPE Configuration 
The Cox managed CPE is configured to manage all SIP signaling and provides voice quality 

management. All data traffic also traverses the Cox managed CPE. It is part of the Cox 

Communications SIP trunk service and Cox Communications will provide it to the customer when 

the customer orders the Cox Communications SIP trunk service. Cox Communications manages it 

and the end-customer does not manage. 

 

Note: Cox managed CPE is part of Cox Communications SIP trunk service offering and it is 

Cox Communications’ responsibility for all the aspect of the Cox managed CPE (i.e. support, 

detail configuration, maintenance and etc). The Cox managed CPE’s sample configuration 

included in this document is used during this compliance testing. 

 Cox managed CPE Login 

The Cox managed CPE was configured with a local LAN address of 10.10.80.87 and a subnet mask 

of 255.255.255.128. A personal computer is configured with Ethernet IP address assigned to any 

address other than 10.10.80.87 in the same subnet mask, for example 10.10.80.86 

Launch a web browser on personal computer and enter the following URL: http://10.10.80.87 and hit 

enter. 

 

The following login window should appear: 

 

 
 

Figure 80 – Cox managed CPE Login 
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• Enter user name and password field 

• Click OK and the system page should be appeared next 

 Network Configuration  

From the Configuration Menu, select Network menu option.  

Under Network, input the public and private networks as followings: 

• LAN Interface Settings:  

- IP Address: 10.10.80.87 

- Subnet Mask: 255.255.255.128 

- Check Enable VLAN Support 

- Default VLAN ID: 1 

• WAN Interface IPv4 Settings:  

- Check Static IP 

-  IP Address: 10.10.80.103 (Provide this IP address to service provider to set up the 

connectivity) 

-  Subnet Mask: 255.255.255.128  

• Network Settings: 

- Default Gateway: 10.10.80.1 

 
Submit the changes. 
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Figure 81 – Cox managed CPE Network Configuration 
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 VLAN Configuration 

There is a VLAN which has been created and configured as shown in capture below. Details how to 

create the VLAN is not shown. 

 

 
 

Figure 82 – Cox managed CPE VLAN Configuration 
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 VoIP Settings 

From the Configuration Menu, select VoIP menu option →  SIP option.  

Under SIP Settings, input the parameters as followings: 

• SIP Server Address: DUKEBWSSCM-MTC1-SA-XXXX.TC.AT.COX.NET (This is 

Cox Communications signaling server IP address) 

• SIP Server Port: 5060 

• SIP Server Transport: Pass Through  

• Check Use Custom Domain 

• SIP Server Domain: coxbusiness.com 

Submit the changes. 
 

 
 

Figure 83 – Cox managed CPE SIP Settings 
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From the Configuration Menu, select Survivability to check SIP Server Reachability status. 

When the SIP Server connectivity to Cox Communications is up, the status is Active. 

 

 
 

Figure 84 – Cox managed CPE SIP Server Survivability 
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 B2BUA Trunking Configuration  

From the Configuration Menu, select VoIP menu option →  SIP → B2BUA.  

Under Trunking Devices: 

• Input a recognizable Name for the trunking device: AvayaIPOffice  

• At Model pull down menu, choose Avaya IP Office 

• Select Transport: UDP  

• Input Username: 402XXX4705, which is pilot number for trunk registration to Avaya 

system 

• Input Password: xxxxxxxxxxx, which is provided by Cox Communications 

• Check Authentication Registration box 

• Select Update button to update the changes 

Under Credentials and Registration: 

• Input Username: 402XXX4705 

• Input Auth-User: 402XXX4705 

• Input Password and Confirm Password 

• Select Update button to update the changes 

 

When the trunk is successfully registered to Avaya system, Registration Status in Trunking 

Devices will be shown as Registered and Status in Credentials and Registration will be shown as 

OK. 
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Figure 85 – Cox managed CPE SIP Trunk Configuration 
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The following captured screens show the rest of the B2BUA Trunking Configuration page, continue 

from above screen. Detail configuration is not discussed here.  

 

 
 

Figure 86 – Cox managed CPE Inbound Action Configuration 
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Figure 87 – Cox managed CPE Outbound Action Configuration 
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Figure 88 – Cox managed CPE Inbound Match Configuration 

 

 
 

Figure 89 – Cox managed CPE Outbound Action Configuration 
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