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Abstract 
 

  
These Application Notes describe the configuration steps required for Resource Software 
International (RSI) Visual Rapport to work with Avaya IP Office and generate screen pops for 
inbound calls.  Visual Rapport is a visual communication console that provides employee 
telephone status, instant messaging, and screen pop at the client computer.  Information in 
these Application Notes was obtained through compliance testing and additional technical 
discussions.  Testing was conducted via the DeveloperConnection Program at the Avaya 
Solution and Interoperability Test Lab.  
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1. Introduction 
These Application Notes describe the configuration steps required for Resource Software 
International (RSI) Visual Rapport to work with Avaya IP Office.  RSI Visual Rapport is an 
intuitive integrated visual communication console that provides real-time employee telephone 
status, instant messaging, email, screen pop, call logging, and file transfer in the same product. 
 
Business calls are usually linked with information that exists in database software or contact 
management applications, such as Access, Outlook, Act!, Maximizer, Goldmine or even a 
unique in-house custom application.  As an example, a travel agency with a proprietary customer 
database could use Visual Rapport to receive screen pops at every agent’s desktop and access the 
details of each customer’s travel plans from their database. 
 
Visual Rapport simplifies call handling.  Perform time-consuming telephony functions 
(including Answer, Hold, Park, and Transfer) with a few mouse-clicks.  When an incoming call 
arrives, Visual Rapport can unobtrusively notify the user with the incoming Caller ID number 
information and enables the user to decide what to do with the call. 
 
Visual Rapport consists of a server and client module.  Each Visual Rapport client interfaces 
with the Avaya IP Office via TAPI 1st party (single-party) call control.  The Avaya IP Office 
TAPI driver must be installed on the Visual Rapport client PC to establish the connection to the 
Avaya IP Office for the extension to be controlled by the Visual Rapport client. 
 
The Visual Rapport clients also connect to the Visual Rapport server.  Each Visual Rapport 
client reports its status to the Visual Rapport server thereby providing the Visual Rapport server 
with the ability to propagate Busy Lamp Field (BLF) and other status information of all 
registered and logged-in Visual Rapport clients.  Communication between the Visual Rapport 
clients and server is via multicasting or broadcasting (user configurable) using a proprietary 
protocol.  For the purposes of these Application Notes, the Visual Rapport clients and server 
were configured with multicasting (default).  
 
NOTE:  The Visual Rapport server does not support TAPI 3rd party control.   Thus, the Visual 
Rapport server does not have the ability to report on the BLF or other status information of 
extensions and/or lines on the Avaya IP Office that do not have a TAPI 1st party call control link 
to a Visual Rapport client. 
 
The configuration in Figure 1 shows a network consisting of an Avaya IP412 Office, Avaya IP 
Office Manager PC, RSI Visual Rapport server and clients and an Avaya 4600 Series IP 
Telephone connected to the same network. 
 
The Avaya IP412 Office has PRI and analog trunks to the PSTN.  Analog telephones and Avaya 
6400 Series Digital Telephones are connected to Avaya IP400 Expansion modules, which 
connect to the Avaya IP412 Office.    



 
Each of the RSI Visual Rapport clients in Figure 1 have been configured with TAPI 1st party call 
control connectivity to the Avaya IP Office and is registered to a distinct extension.   Please refer 
to Table 1 for the mapping of extension to Visual Rapport client to Visual Rapport login User Id.  
 

Client Avaya IP Office 
extension 

Visual Rapport 
client User Id 

Visual Rapport client 1 x6501 6501 
Visual Rapport client 2 x6504 6504 
Visual Rapport client 3 x6517 6517 

 
Table 1 – RSI Client To Avaya IP Office Extension To Visual Rapport Client User Id 

Mapping 
 
The tested configuration is shown in Figure 1.   
 

 
Figure 1 – Network Configuration Diagram 

 
The Avaya IP Office was configured to route incoming calls to a hunt group or specific 
extensions, based on the test case being executed. During an incoming trunk call, the Avaya IP 
Office rang the destination extension.  While this event occurred, the Avaya IP Office also sent 
TAPI 1st party call control signaling to the Visual Rapport client associated with the destination 
extension.  The user then received visual notification of the incoming call from the Visual 
Rapport client in addition to the audible notification from the telephone.  The Visual Rapport 
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client could be configured to take different actions during an incoming call.  For the purposes of 
compliance testing and these Application Notes, the Visual Rapport clients were configured to 
generate a screen pop when an incoming call was answered at the extension.  Screen pop was in 
the form of Visual Rapport launching Notepad and the incoming call information was written to 
Notepad’s buffer.    
 

2. Equipment and Software Validated 
The following products and software were used for the configuration in Figure 1: 
 

Product Software/Version 
Avaya IP412 Office 3.1(48) 
Avaya IP400 Office Analog Module 5.1(48) 
Avaya IP400 Office Digital Module 5.1(48) 
Avaya IP400 Office Phone Module 5.1(48) 
Avaya IP Office Manager 5.1(48) 
Avaya 4620SW IP Telephone 2.3 
Avaya 6408D+ Digital Telephone - 
RSI Visual Rapport server 1.08 
RSI Visual Rapport client 1.08 
PCs for Avaya IP Office Manager and RSI Visual 
Rapport server and clients 

Windows 2000 Professional 
Service Pack 4 

Analog Telephone - 
 

Table 2 – Product and Software Version  
 

3. Configure Avaya IP Office 
The configuration information provided in this section describes the steps required to set up User 
extensions and passwords on Avaya IP Office.  While this is part of a typical Avaya IP Office 
configuration, the information is needed for the TAPI driver configuration on the Visual Rapport 
clients. 
 
For all other provisioning information, such as Avaya IP Office installation and configuration, 
etc., please refer to the Avaya IP Office product documentation in reference [1]. 
 
Step Description 

1.  Log into the IP Office Manager PC and go to Start → Programs → IP Office → Manager 
to launch the Manager application. Log into the Manager application using the appropriate 
credentials. 

2.  In the Manager window that appears, select File → Open to search for the IP Office system 
in the network. 
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Step Description 
3.  Log into the IP Office system using the appropriate login credentials to receive its 

configuration. 
4.  In the Manager window, go to the Configuration Tree and double-click User.  In the list of 

Users that appears in the right-hand pane, scroll down to the user and extension name 
mapped to the first Visual Rapport client listed in Table 1, select it then double-click it.  

 

 
 

5.  In the User window that appears, set Password to the password to use for this extension.    
Click OK. 
 

 
 

6.  Repeat Steps 4 – 5 for each extension listed in Table 1. 
7.  In the Manager window, select File → Save to push the configuration to the IP Office system 

and wait for the system to update.  This completes configuration of Avaya IP Office. 
 



4. Configure RSI Visual Rapport server 
The configuration information provided in this section describes the steps required to configure 
user accounts in RSI Visual Rapport server.  This information is provided for completeness since 
Visual Rapport server does not interface with Avaya IP Office. 
 
For all other provisioning information, such as software installation, installation of optional 
components, general configuration of Visual Rapport server, please refer to the RSI Visual 
Rapport product documentation in references [2] and [3]. 
 
The information provided in this section assumes the Visual Rapport server has already been 
successfully installed and licensed on the PC. 
 

Step Description 
1.  Log into the Visual Rapport server PC with the appropriate administrative credentials. 
2.  Select the RSI Visual Rapport Server application running on the desktop and click the switch 

icon to turn the Communication Services off. 
 

 
 

3.  In the RSI Visual Rapport Server window, select Tools → Directory Services… 
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Step Description 
4.  In the RSI Visual Rapport Server – Directory Services window that appears, click the  in 

the left-hand pane, enter a Group Name, and then click  to save the information. 
 

 
 

5.  In the RSI Visual Rapport Server – Directory Services window, click the  in the right-hand 
pane, set Extension to 6501, User Id to 6501, Password to the desired password, 
Administrative Group to the group name defined in Step 4, Display Name to Ext6501 and 
click  to save the information. 
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Step Description 
6.  Repeat Step 5 for each extension listed in Table 1.  When done, close the window. 

 

 
 

7.  In the RSI Visual Rapport Server window, select Tools → Options… 
8.  In the Options window that appears, make a note of the Server Ports, Client Ports and 

Multicast Group Address settings in the Communication tab, as it will be referenced in 
Section 5.2 Step 4. Select the Server Identification tab.  This example shows the default 
values. 
 

 
 

9.  In the Server Identification information that appears, make a note of the Name, Description 
and Network information entered, as it will be referenced in Section 5.2 Step 5.  This 
example shows values entered during installation.   If the information does not appear, refer 
to documentation in [2] and [3].  Click OK. 
 

 
 

10.  This completes configuration of the Visual Rapport server. 



 

5. Configure RSI Visual Rapport Client PC 
The configuration information provided in this section describes the steps required to configure 
the Visual Rapport client PC. 
 
For all other provisioning information, such as software installation, installation of optional 
components, configuration of Visual Rapport client software to integrate with other 3rd party 
products, etc., please refer to the RSI Visual Rapport product documentation in references [2] 
and [3]. 
 

5.1. Install and Configure Avaya TAPI Driver 
Step Description 

1.  Log into the Visual Rapport client PC with administrative privileges and launch the Avaya IP 
Office User Suite setup.exe on the CDROM drive. 

2.  Click Next in the InstallShield wizard until the Select Components window appears.  Check 
TAPI to install the IP Office TAPI driver on the PC. 
 

 
 

3.  Click Next to complete the installation of the Avaya IP Office User Suite.  At the 
InstallShield Wizard Complete window, click Finish. 

  
4.  Go to Start → Control Panel and double-click the Phone and Modem Options icon in the 

Control Panel window that appears. 
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Step Description 
5.  In the Phone and Modem Options window that appears, select the Advanced tab. 

 

 
 

6.  In the Advanced tab window that appears, highlight Avaya IP Office TAPI2 Service 
Provider and click Configure… 
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Step Description 
7.  In the Avaya TAPI2 configuration window that appears, set Switch IP Address to the IP 

Address of the Avaya IP Office, select Single User, set User Name to the name associated 
with the extension that will be controlled by this Visual Rapport client PC, e.g., Extn6501 
and set User Password to the password set for the User in Section 3 Step 5.  Click OK. 
 

 
 

8.  In the Phone and Modem Options window, click OK. 
9.  Reboot the client PC for the new changes to take effect.  This completes configuration of the 

Avaya TAPI Driver on the client PC. 
10.  Repeat Steps 1 – 9 for each Visual Rapport client listed in Table 1. 

 
 

5.2. Configure RSI Visual Rapport Client 
The information provided in this section assumes Visual Rapport client has already been 
successfully installed and licensed on the PC. 
 

Step Description 
1.  Log into the Visual Rapport PC with the appropriate administrative credentials and navigate 

to Start → Programs → RSI → Visual Rapport for TAPI → Desktop Console. 
2.  Click through the initial screens that appear, responding to prompts as appropriate for the 

local configuration.  
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Step Description 
3.  In the RSI Visual Rapport Client wizard window that next appears, click Next. 

 

 
 

4.  In the Messaging Configuration window that appears, set Visual Rapport Server Address to 
the IP Address of the Visual Rapport server as listed in Figure 1, verify Multicast Group 
Address, Service TCP & UDP Ports, and Client TCP & UDP Ports match the settings 
made on the Visual Rapport server configuration in Section 4 Step 8.  Click Test Insta-
Message Configuration… 
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Step Description 
5.  If a popup such as the one listed below appears, the connection between the Visual Rapport 

client and server is operational.  Close the popup.  If the popup does not appear, refer to [2] 
and [3] for troubleshooting information. 
 

 
 

6.  In the Messaging Configuration window, click Next. 
7.  In the TAPI Configuration window that appears, select Avaya IP Office TAPI2 Service 

Provider from the pull-down menu for Telephony Service Provider (TSP).  Verify that 
Callable, Internal and Owner are checked and click Next. 
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Step Description 
8.  In the Sign In window that appears, select the first Visual Rapport client extension number 

listed in Table 1 and enter the password defined for the Visual Rapport client in Section 4 
Step 5.  Click Finish. 
 

 
 

9.  In the RSI Visual Rapport client window that appears, confirm the bottom right corner shows 
the logged-in extension with a green background. 
 

 
 

10.  Repeat Steps 1 – 9 for each extension defined in Table 1.  This completes initial 
configuration of the Visual Rapport client. 

 
 



5.2.1. Configure Visual Rapport Client For Generic Screen Pop 
Step Description 

1.  Go to Start → Programs → RSI → Visual Rapport for TAPI → Desktop Console to 
launch the Visual Rapport client. 

2.  In the RSI Visual Rapport Client window that appears, select Tools → Macros… 
 

 
 

3.  In the Call Handling Macros window that appears, locate the entry with Inbound 1 in the 
Menu Caption field.  Check Enabled and Auto and click Edit Macro… 
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Step Description 
4.  In the Microsoft Visual Basic Scripting Edition – Editor window that appears, select File → 

Import Macro. 
 

 
 

5.  In the Open popup that appears, select NotepadDump.vbs and click Open. 
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Step Description 
6.  In the Microsoft Visual Basic Scripting Edition – Editor window, select File → Save. 

 

 
 

7.  In the Microsoft Visual Basic Scripting Edition – Editor window, select File → Exit. 
8.  Return to the Call Handling Macros window and click Close. 
9.  In the RSI Visual Rapport Client, select Tools → Customize… 
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Step Description 
10.  In the Customize window that appears, check Auto-pop inbound calls, select Immediately 

and click OK.  This completes configuration of Visual Rapport client to generate screen pop 
for inbound calls. 
 

 
 

11.  Repeat Steps 1 – 10 for each Visual Rapport client in Table 1. 
 

6. Interoperability Compliance Testing 
Interoperability compliance testing evaluated the ability of Visual Rapport to successfully 
generate screen pops for inbound calls.  Answer, Hang Up, Call Hold, Call Transfer, and Call 
Park of inbound, outbound and internal calls were verified successfully using the Visual Rapport 
clients. A load test was executed involving the use of a call generator and an automated 
RapidFire test script written to drive the Visual Rapport client to answer and hang-up incoming 
calls. 
 

6.1. General Test Approach 
The general test approach was to verify that manually placed intra-switch calls, inbound trunk 
and outbound trunk calls could be placed to and from Visual Rapport clients as well as 
telephones attached to the Avaya IP Office.  Features including Call Hold, Transfer, and Call 
Park were also verified.  
 
For the load test, a call generator was used to place calls over eight PRI trunk channels to the 
Avaya IP Office.  The Avaya IP Office routed the calls to a hunt group containing the extensions 
of all eight of the Visual Rapport clients setup for the load test.  The hunt group was setup to ring 
in a circular pattern.  As each incoming PRI call was routed to each Visual Rapport client 
extension, the RapidFire automated test tool drove the Visual Rapport client to answer the call 
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then hang up after approximately 15 seconds.  This behavior was repeated on all Visual Rapport 
clients for all incoming calls.  The load test duration was set for two hours.   
 

6.2. Test Results 
Except for Issue 1 described below, all test cases completed successfully.  The load test ran for 
two hours averaging 1680-1690 call attempts per hour. All Visual Rapport clients answered and 
hung up calls successfully.  The total number of calls placed by the call generator was reported to 
be 3,428 and the total number of calls answered by the clients was 3,428.  The call generator 
reported the average call length at ~14 seconds. 
 
Issue 1 – The Avaya IP Office TAPI did not provide ‘Connected’ message via TAPI for 
outbound T1 calls.  This prevented the ability to use the Visual Rapport client to properly handle 
call control such as placing calls on hold, initiating call transfers, etc. for outbound T1 calls. 
Status: A trouble ticket (CQ# 23413) was submitted to the Avaya IP Office team regarding this 
issue.  
 
The following observations, and/or issues not related to test cases, were noted during testing: 
 

• The Avaya IP Office does not provide Caller ID Name via TAPI for incoming trunk calls.  
A request to provide this functionality in the future via TAPI will be placed with the 
Avaya IP Office team. 

 
• Visual Rapport client requires a restart if the client’s associated extension is involved in a 

conference call.  Visual Rapport does not support Conference; however, the associated 
extension’s involvement in a Conference call should not adversely affect the client such 
that a restart of the client is required. RSI is investigating the issue. 

 
• Visual Rapport client does not support Voicemail and Message Waiting Indication 

(MWI). 
 

• Visual Rapport client does not support ‘Do Not Disturb’ and ‘Call Forwarding’; however, 
this should not prevent the ability to dial the ‘Do Not Disturb’ and ‘Call Forwarding’ 
shortcodes from the client.  RSI is investigating the cause of this issue. 

 

7. Verification Steps 
The following steps may be used to verify the configuration: 
 

• Verify each Visual Rapport client PC can successfully ping the Avaya IP Office as well 
as the RSI Visual Rapport server. 

 
• Place a call between two Visual Rapport client extensions and verify each Visual Rapport 

client can be used to answer and hang up the call. 
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• Verify each Visual Rapport client can be used to initiate and drop an inbound or 

outbound call. 
 

8. Support 
Technical support for Visual Rapport can be obtained by contacting Resource Software 
International Systems, Ltd. at: 

• Phone:   800.891.6014 / 905.576.4575 
• E-mail:  support@telecost.com 
• Web:     www.telecost.com 

 

9. Conclusion 
These Application Notes describe the steps for configuring the RSI Visual Rapport Clients to 
generate screen pops for inbound calls to their associated Avaya IP Office extension.  Except for 
Issue 1 described in Section 6.2, all test cases completed successfully.   
 

10. References 
The following Avaya product documentation can be found at http://support.avaya.com: 
 
[1] Avaya IP Office 3.1 Installation Manual, Issue 13l (23rd January 2006). 
 
The following Resource Software International product documentation is installed to the hard-
drive during the Visual Rapport installation process: 
 
[2] Visual Rapport Startup Guide  
[3] Visual Rapport User Guide 
 
 
 
 

http://support.avaya.com/
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