
 
TLT; Reviewed: 

SPOC 6/18/2009 

Solution & Interoperability Test Lab Application Notes 

©2009 Avaya Inc. All Rights Reserved. 

1 of 15 

IEX-PC4 

 

 

 

 

 

 

 Avaya Solution & Interoperability Test Lab 
 

Application Notes for IEX TotalView Workforce 

Management with Avaya Proactive Contact – Issue 1.0 
 

 

 

 

         

 

Abstract 
 

  

These Application Notes describe the configuration steps required for IEX TotalView 

Workforce Management to interoperate with Avaya Proactive Contact 4.0.  IEX TotalView 

Workforce Management is a work force management solution that provides forecasting and 

monitoring of work for contact center agents.  IEX TotalView Workforce Management uses 

the historical data from Avaya Proactive Contact to produce forecasts for contact center 

agents, and then uses the real-time data from Avaya Proactive Contact to check the agent 

adherence to the forecasts. 

 

Information in these Application Notes has been obtained through DevConnect compliance 

testing and additional technical discussions.  Testing was conducted via the DevConnect 

Program at the Avaya Solution and Interoperability Test Lab. 
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1. Introduction 
IEX TotalView Workforce Management is a work force management solution that provides 

forecasting and monitoring of work for contact center agents.  IEX TotalView Workforce 

Management uses the historical data from Avaya Proactive Contact to produce forecasts for 

contact center agents, and then uses the real-time data from Avaya Proactive Contact to check 

the agent adherence to the forecasts. 

 

For historical data, IEX TotalView Workforce Management queries the Avaya Proactive Contact 

Oracle database to obtain information on jobs and agents.  For real-time data, IEX TotalView 

Workforce Management uses the Avaya Proactive Contact Event Service interface to obtain 

events on agent states.   

1.1. Interoperability Compliance Testing 

The interoperability compliance test included feature and serviceability testing. 

 

The feature testing focused on verifying IEX TotalView Workforce Management’s receive, 

parse, and display of historical and real-time data from Avaya Proactive Contact.    

 

The serviceability testing focused on verifying the ability of the IEX TotalView Workforce 

Management server to recover from adverse conditions, such as disconnecting the Ethernet cable 

to the server. 

1.2. Support 

Technical support on IEX TotalView Workforce Management can be obtained through the 

following: 

 

 Web:     www.iex.com/service/service--support/support.html  

 Phone:   (800) 433-7692 

 Email: iexinfo@iex.com  

http://www.iex.com/service/service--support/support.html
mailto:iexinfo@iex.com
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2. Reference Configuration 
These Application Notes assume the configuration and connectivity between Avaya 

Communication Manager and Avaya Proactive Contact is already in place and will not be 

described.   

 

During the testing, the Avaya Proactive Contact Supervisor and the IEX TotalView Supervisor 

shown in Figure 1 were used for report verification purposes. 

 

 
 

Figure 1:  IEX TotalView Workforce Management with Avaya Proactive Contact  
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3. Equipment and Software Validated 
The following equipment and software were used for the sample configuration provided: 

 

Equipment Software 

Avaya S8700 Servers  
Avaya Communication Manager 5.1.2, 

R015x.01.2.416.4 

Avaya MCC1 Media Gateway 

 TN799DP   C-LAN Circuit Pack 

 

HW01  FW024 

Avaya Proactive Contact with PG230RM 4.0.1 

Avaya Proactive Contact Agent 4.0.1 

Avaya Proactive Contact Supervisor 4.0.1 

Avaya 9600 Series IP Telephones (H.323) 3.0 

IEX TotalView Workforce Management 

 Avaya Proactive V4 Generic Query 

3.12.4.0 

1.0 

IEX TotalView Supervisor 3.12.5.0 
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4. Configure Avaya Proactive Contact 
The detailed administration of contact center resources and connectivity between Avaya 

Communication Manager and Avaya Proactive Contact are not the focus of these Application 

Notes and will not be described.  For administration of contact center resources and connectivity 

to Avaya Proactive Contact, refer to the appropriate documentation listed in Section 9.   

 

This section provides the procedures for how to configure a hierarchy for jobs that are monitored 

by IEX TotalView Workforce Management, and on how to obtain the necessary Interoperable 

Object Reference (IOR) file and host name information that are required by IEX TotalView 

Workforce Management. 

4.1. Obtain IOR File 

IEX TotalView Workforce Management uses the Event Service interface from Avaya Proactive 

Contact to obtain real-time agent events.  The Event Service is a service based on the Common 

Object Request Broker Architecture (CORBA), and supports client application connection via 

several methods.  The IOR method is used by IEX TotalView Workforce Management to locate 

and connect to the CORBA objects on Avaya Proactive Contact.   

 

As part of installation, a copy of the IOR file from the Avaya Proactive Contact server needs to 

be provided to the IEX implementation team, and the path to the file is shown below: 

 

/opt/avaya/services/data/ns_ior 
 

4.2. Obtain Host Name 

As part of installation, the host name and the IP address of the Avaya Proactive Contact server 

needs to be provided to the IEX implementation team.  Log in to the Linux shell of the Avaya 

Proactive Contact server.  Use the “uname -a” command to obtain the host name.  In the 

compliance testing, the host name of the Avaya Proactive Contact server is “lzpds4b”, as shown 

below. 

 
 

$ uname -a 

Linux lzpds4b 2.6.9-42.0.10.ELsmp #1 SMP Fri Feb 16 17:17:21 EST 2007 i686 athlon i386 

GNU/Linux 

LZPDS4B(admin)@/opt/avaya/pds [4] 

$ 

 

 



 
TLT; Reviewed: 

SPOC 6/18/2009 

Solution & Interoperability Test Lab Application Notes 

©2009 Avaya Inc. All Rights Reserved. 

6 of 15 

IEX-PC4 

 

4.3. Administer Hierarchy 

Hierarchies are used in Avaya Proactive Contact to group and organize data, and to adjust the 

scope of data to monitor and view.  IEX TotalView Workforce Management requires the 

monitored jobs to be configured with hierarchy. 

 

From the Avaya Proactive Contact Supervisor PC, launch the Hierarchy Manager by selecting 

Start > Programs > Avaya Proactive Contact > Supervisor > Analyst, followed by selecting 

Tools > Hierarchy Manager from the top menu.  The Hierarchy Manager screen is displayed. 

 

From the Hierarchy Manager screen, create a new job hierarchy by selecting Job Hierarchies 

in the left pane, followed by File > New from the top menu.  The screen is updated with default 

hierarchy levels, and a list of available jobs to assign to the hierarchy, as shown below. 
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Rename the default levels for the hierarchy as desired, and use the click and drag method to 

assign the jobs monitored by IEX TotalView Workforce Management to the new hierarchy.  In 

the compliance testing, IEX TotalView Workforce Management monitored the “blend” and 

“outbnd” jobs.  

 

Select File > Save As from the top menu to save the hierarchy configuration, and provide a copy 

of this screenshot to the IEX implementation team. 
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5. Configure IEX TotalView Workforce Management 
IEX TotalView Workforce Management is installed and configured by the IEX implementation 

team.  Customers are provided with training on how to configure resources to map to the 

resources on Avaya Proactive Contact, and on how to use the IEX TotalView Supervisor.   

 

The procedure for installing and configuring IEX TotalView Workforce Management is outside 

the scope of these Application Notes and will not be covered.  For detailed information on 

installation and configuration, refer to the appropriate documentation listed in Section 9.   

 

These Application Notes assume that the IEX TotalView Workforce Management server has 

already been installed and configured with the job and agent information from Avaya Proactive 

Contact.  This section describes the configuration needed on the IEX TotalView Supervisor to 

establish a connection with the IEX TotalView Workforce Management server. 

5.1. Configure IEX TotalView Supervisor 

From the IEX TotalView Supervisor PC, launch the configuration application by selecting 

Programs > CCApps > TotalView Configuration.  The IEX TotalView Workforce 

Management Configuration screen is displayed.  Configure the fields as shown below.  The 

value to enter for the Default Customer ID field is provided by the IEX implementation team.  

In the Host Name or IP Address column, enter the IP address of the IEX TotalView Workforce 

Management server, and check the corresponding checkbox under the Selected column.  Click 

OK. 
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6. General Test Approach and Test Results 
The feature test cases were performed semi-automatically.  The outbound calls were launched 

automatically by Avaya Proactive Contact, whereas the inbound calls were placed manually. 

 

The serviceability test cases were performed manually by disconnecting/reconnecting the LAN 

cable to the IEX TotalView Workforce Management server. 

 

The verification of all tests included checking of proper display of data at the IEX TotalView 

Supervisor, and of comparing the displayed data with the Analyst report from the Avaya 

Proactive Contact Supervisor. 

 

All test cases were executed and passed. 
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7. Verification Steps 
This section provides the tests that can be performed to verify proper configuration of Avaya 

Proactive Contact and IEX TotalView Workforce Management. 

7.1. Verify Avaya Proactive Contact  

From the Avaya Proactive Contact Supervisor PC, launch the Health Manager by selecting Start 

> Programs > Avaya Proactive Contact > Supervisor > Health Manager.  From the Health 

Manager screen, select Data under Dialer Services in the left pane.  Verify that all services are 

up, as shown below. 
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7.2. Verify IEX TotalView Workforce Management 

From the IEX TotalView Supervisor PC, launch the TotalView application by selecting 

Programs > CCApps > TotalView.  The User Logon screen is displayed.  Log in with the 

proper credentials and click OK. 

 

 
 

7.2.1. Verify Historical Data 

The IEX TotalView Workforce Management main screen is displayed.  Select CT > Intraday 

from the top menu. 
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The Intraday screen is displayed next.  Click the icon next to the CT field to select the proper 

system, in this case “Avaya ProActive”.  Click the icon next to the Shift field to select the “All 

Day” value.  Select the proper value for the Date field, and click Retrieve. 

 

 
 

The Intraday screen is updated with the historical data received from Avaya Proactive Contact. 

 

 
 



 
TLT; Reviewed: 

SPOC 6/18/2009 

Solution & Interoperability Test Lab Application Notes 

©2009 Avaya Inc. All Rights Reserved. 

13 of 15 

IEX-PC4 

 

7.2.2. Verify Real-Time Data 

From the IEX TotalView Workforce Management main screen shown in Section 7.2.1, select 

MU > Real-time Adherence from the top menu.  The Schedule Adherence screen is displayed 

next.  Click the icon next to the MU field to select the proper system, in this case “Avaya 

ProActive”.  Click Retrieve. 

 

 
 

The Schedule Adherence screen is updated with the real-time agent state data received from 

Avaya Proactive Contact. 
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8. Conclusion 
These Application Notes describe the configuration steps required for IEX TotalView Workforce 

Management 3.12 to interoperate with Avaya Proactive Contact 4.0, via the Oracle database for 

historical data and the Event Service interface for real-time data.   All feature and serviceability 

test cases were completed successfully. 

9. Additional References  
This section references the product documentation relevant to these Application Notes.   

 

1. Administrator Guide for Avaya Communication Manager, Document 03-300509, Issue 4.0, 

Release 5.0, January 2008, available at http://support.avaya.com.  

 

2. Avaya Proactive Contact Release 4.0 Administering Avaya Proactive Contact, January 

2008, available at http://support.avaya.com.  

 

3. Avaya Proactive Contact Release 4.0 Software Developer’s Kit (SDK), January 2008, 

available at http://support.avaya.com.  

 

4. IEX TotalView Product Documentation, available on the IEX TotalView software CD. 

http://support.avaya.com/
http://support.avaya.com/
http://support.avaya.com/
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