Author Message
AlfredoSchmidt
Joined: Nov 9, 2013
Messages: 12
Offline
Hi,

Using OD6 with SP3 on an EP6.0

I'm working on an environment failover tests and I've found that when the EPM is down the application takes 5 seconds to fetch the CAVs and continue with the app flow.

Is there any parameter that we can use to reduce this timeout?

Following is a piece of call log example where I see that delay.

[APP]|[13 Nov 2013 13:41:17,177]|[DEBUG]|[MESSAGE: nTHLSDHNZhpQ64pZFmbHyLPvX5MGdfkc2MK8DLGg1CGYNzZJhPYf!1964709017!1384368077164:/PAYX_ProductMenu : AdminVarCache:init: load data from the Voice Portal/Experience Portal platform]
[APP]|[13 Nov 2013 13:41:23,204]|[ERROR]|[MESSAGE: nTHLSDHNZhpQ64pZFmbHyLPvX5MGdfkc2MK8DLGg1CGYNzZJhPYf!1964709017!1384368077164:/PAYX_ProductMenu : VPClientProxy:VPAppRuntimeVars.getAppRuntimeVars returns null]
[APP]|[13 Nov 2013 13:41:23,204]|[DEBUG]|[MESSAGE: nTHLSDHNZhpQ64pZFmbHyLPvX5MGdfkc2MK8DLGg1CGYNzZJhPYf!1964709017!1384368077164:/PAYX_ProductMenu : AdminVarCache:init: no data comes back from proxy.]


Thanks,
Alfredo
Anonymous

When you configure the app url in EPM, try adding a parameter as the following:

http://ip:port/appname/Start?getRuntimeVarsWSTimeout=3000

3000 stands for 3s.
Anonymous

is there a way to pass this parameter=value via web.xml?
MarceloPariggi [Avatar]

Joined: Nov 15, 2013
Messages: 24
Offline

where can I get more information about this paremeter?

Regards,
WilsonYu
Joined: Nov 6, 2013
Messages: 3937
Offline
It could be a property in a property file managed by the customer. Please follow the step below to configure it:

1. Stop Tomcat
2. Create a directory named as “config” under $CATALINA_HOME/lib
3. Copy VPAppLogClient_6.0.0.jar from $CATALINA_HOME/lib to some temporary directory and extract the “vpclientlog.properties” from the jar.
4. Copy “vpclientlog.properties” from Step #3 to $CATALINA_HOME/lib/config directory which is created in Step #2.
5. Modify the value of “getRuntimeVarsWSTimeout” in “vpclientlog.properties”.
The currently default is 5 seconds (5000 miliseconds).

getRuntimeVarsWSTimeout=5000

6. Restart Tomcat
MarceloPariggi [Avatar]

Joined: Nov 15, 2013
Messages: 24
Offline
We are using Weblogic 10, but I guess it should work too, right?

Regards,
WilsonYu
Joined: Nov 6, 2013
Messages: 3937
Offline
It should work the same way. Give it a try.
MatthewKopcienski
Joined: Nov 14, 2013
Messages: 89
Offline
I've set the launch URI to /Start?getRuntimeVarsWSTimeout=500 but there was no noticeable difference. There is still a 5 second delay in every call.
WilsonYu
Joined: Nov 6, 2013
Messages: 3937
Offline
Are you using OD 6.0 SP3 too?
MatthewKopcienski
Joined: Nov 14, 2013
Messages: 89
Offline
Same customer, same system.
Anonymous

I checked with the developer in the particular area. It turns out that the url parameter is not supported until OD 7. Sorry. You would need to modify the properties file the way I listed above.
Go to:   
Mobile view