Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
New DevConnect members must have forum permissions in order to post messages.
If the Reply and New Post buttons are not available to you, please request access using a General Support request ticket.
Forum Index » CSPortal WebAPI (Read-Only Archive) » Call Web Services within IC 7.3 Workflow, NullPointerException   XML
Author Message

Joined: 24/10/2014 07:49:49
Messages: 2

I implemented a JAX-WS WebClient and call it from a workflow using the "Call Web Services" feature of IC 7.3.
Unfortunatelly a NullPointerException is thrown when method "Service.getPort()" is called.
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)
	at Source)

Strange thing is that the same Java Web Client package is working fine if I call the ICJavaAdapter.invokeICJava(String) class using a small Main class.
I also tried to align Java environment / used libraries as much as possible, basically there should be no difference.
Does anyone have an idea what might go wrong?

Joined: 15/09/2014 07:00:12
Messages: 4

Maybe it's not exactly what you need.
Try to set ALL used libraries in "Java Class Path" in Workflow configuration. Like this:

Although all this packages were included in mytest.jar file, I got error like this: ClassNotFoundException: javax.xml.rpc.ServiceException

Joined: 07/11/2009 00:18:04
Messages: 3


Did you get it resolved? I am facing the same problem when I try to get a data returned from web service. I am using AIC 7.2.6. Please let me know.

I got this resolved and posting if anyone needs this.

I added all the libraries used for web service calling into the generated jar file and it worked. I tried putting all libraries in a separate folder but it didn't work, then added all the jars/libraries into the generated jar but still having issues, then I extracted all the required jars into the generated jar and it worked. Hope this help someone. Also, if anyone has any clue why the other methods didn't work, please let me know.

This message was edited 1 time. Last update was at 07/05/2015 04:55:01

Go to: