Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
New DevConnect members must have forum permissions in order to post messages.
If the Reply and New Post buttons are not available to you, please request access using a General Support request ticket.
Forum Index » AE Services General (Archive - Oct 2013 and earlier) » IP_API license acquired instead of DMCC_DMC   XML
 
Author Message
AbdulKA



Joined: 06/11/2013 06:10:44
Messages: 35
Offline

Hello,
we were testing with DMCC dash board application on AES version 6.1 and CM 6.0 . 6 numbers of DMCC_DMC license is available in AES. But DMCC is returning an error "3014 Registration Reject reason: resourceUnavailable
Invalid product ID is specified. Check the version of switch or license file 111" . I checked the FAQ regarding this issue and verified the points mentioned in the FAQ .

1. I am trying to start application session with protocol version 5.2 (i tried with 4.2 and 6.1 also)

2. we are using the latest dashboard application

3. There is a switch connection available between AES and CM

Please let me know what can be the causes of this issue. If any logs are required , we can provide you the same.

Thanks and Regards
Abdul Rasheed
JohnBiggs



Joined: 20/06/2005 14:06:52
Messages: 883
Location: Thornton, CO
Offline

There are a couple of threads where this error is discussed as well. Did you check through them?

The FAQ clearly needs updated.

I think Martin's response in this thread is useful
https://devconnect.avaya.com/public/forum/d_forum_3.jsp?t=12132&f=23

and my response in this thread
https://devconnect.avaya.com/public/forum/d_forum_3.jsp?t=6646&f=27
[WWW]
AbdulKA



Joined: 06/11/2013 06:10:44
Messages: 35
Offline

Dear John,

I could resolve the issue . In fact we were providing the CM IP address in the Switch IP Address field of Dashboard and leaving the Switch Name as blank. It is able to register the terminal after i put Switchname in the dashboard and then invoked the GetDevice and then the RegisterTerminal. But i have a few queries.

1. Is it mandatory to enter Switch name in the GetDeviceID and register terminal . In the previous version of AE services this was not mandatory

2. It is supporting all protocols of DMCC , i tried 3.0, 4.1 , 4.2 etc which looks contradictory to the FAQ which says that 4.2 protocol should be negotiated.

I request you to kindly clarify the queries above.

Thanks a lot for your prompt response as you always do.

Best Regards
Abdul Rasheed
JohnBiggs



Joined: 20/06/2005 14:06:52
Messages: 883
Location: Thornton, CO
Offline

1) It is not _manditory_, but things work better when you do use switch name... to avoid using changing the app to send switch name you can provision the H.323 Gatekeeper list associated with the switch connection and put the IP addresses you are using in it. That avoids changing the application to use switch name in the getDeviceId request.

2) I will look at the FAQ (please give me the Q string) and see if it can be improved. I am not sure what the question is here though.. the switch name is useful with call control services, call information services, and proper license negotiation. You can negotiate a protocol version by including more than one in your startApplicationSession request I believe.
[WWW]
AbdulKA



Joined: 06/11/2013 06:10:44
Messages: 35
Offline

Dear John,
The FAQ Q string is "When is a DMCC_DMC license allocated and when is it not?" it is mentioned under this question - "The DMCC protocol version of DMCC API referred in StartApplicationSession interface must be http://www-ecma-international.org/standards/ecma-323/csta/ed3/priv3 (AE Services R4.2.2) or later."

But i got it work with protocol version 3.0 and above.

Thanks and Regards
Rasheed
JohnBiggs



Joined: 20/06/2005 14:06:52
Messages: 883
Location: Thornton, CO
Offline

I looked around and cannot find where the protocol version statement came from; so I suspect it was a point of confusion at some point in time from whoever authored that FAQ. Based on your test results, older protocol versions work (at least with AE Services 6.1). In thinking about it I do not see a reason that AE Services would use the protocol version in deciding what license allocation strategy to use.

I am going to update the FAQ and indicate that the protocol version apparently doesn't matter and fix a number of other minor mistakes in it. Actually updating the FAQ will have to await our Webmaster's return.
[WWW]
 
 
Go to: