Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Forum Index » Engagement Designer » ED announcement flow   XML
 
Author Message
AshokJ



Joined: 12/10/2017 23:57:22
Messages: 8
Offline

HI,
I created a simple call flow to play& collect announcements:

1. Start with Call Intercept>Calling Party
2. Allow Call
3. Log Message #1
4. Play & Collect (Play to calling party, Interrupt Announcement yes, Timeout 10 sec, Collect Digits from Calling Party)
5. Log Message #2
6. End

*Basically i could have just used a play announcement block but that dint work either.

When i run the flow call goes through but the announcement never plays. The calling party cant hear anything. However the log messages 1, 2 do get printed. So the low reaches the Play & collect block. Is this the right flow or an i missing something here die to which no announcement is played?

I have attached a screen capture of the simple flow as attachment.
[Thumb - Untitled.png]
 Filename Untitled.png [Disk] Download
 Description Call Flow
 Filesize 68 Kbytes
 Downloaded:  13 time(s)

Vishal-Avaya



Joined: 24/07/2014 16:30:45
Messages: 36
Offline

Once you allow the call you cant do any Play announcement etc. Allow Call should be the last step in your workflow.
AshokJ



Joined: 12/10/2017 23:57:22
Messages: 8
Offline

Thanks Vishal, I have tried this approach i.e allow call block at the end, but in that case the call does not proceed any further from announcement block as seen from ED workflow instance, and the error reported is of a wrong ucid / no call id. Have you seen that?
RajeshChandrashekar



Joined: 27/10/2016 05:15:12
Messages: 24
Offline

Hi,
Could you please explain your use case here, i understand you are trying to play annc or play and collect on the calling party, so you have 2 options here for playing on calling party, either 1) or 2),
1) Put play Annc or Play and Collect task before allow call
2) after logmessage1, put a Receive tasl with CALL--CALL_ANSWERED--1 and criterion as Call. and then add PA or Pnc task.

So the above 2 makes sure that you have proper state of participant in the call. Make sure you have selected the participant as calling.

Please let us know if you still face issues.

Thanks,
Rajesh

JoelEzell



Joined: 15/11/2013 10:26:35
Messages: 449
Offline

Given the error that was reported, it sounds like the problem might be that the call ID is not being passed properly to the tasks. What version of Engagement Designer are you using? More recent versions automatically map call ID if the workflow is kicked off with a call event. Older versions required you to manually map the UCID / App ID from the start event into the communication / media tasks.
AshokJ



Joined: 12/10/2017 23:57:22
Messages: 8
Offline

Hi Joel,

I am using the 3.3.0.0.25042 one. It has the required mappings. I tried this flow. It does not report any error in the ED logs, but there isn't any audio from AMS either. Once the call is answered it gets stuck on the Play & Collect block.

The flow does go past Recieve block on call answer, but is stuck forever on the Play&Collect block. Even on ending the call, the instance can be seen as Active and needs to be manually terminated. There is no error in the ED logs.

EngagementDesigner-3.3.0.0.25042 - Its a call intercept,playing on calling leg, callId: 00003000091510115566
EngagementDesigner-3.3.0.0.25042 - playAnnouncement for callingparty:61298877007@sip.custnamexx.com.au
EngagementDesigner-3.3.0.0.25042 - play announcement for callID:00003000091510115566 succeeded...
EngagementDesigner-3.3.0.0.25042 - Done ... Executing the node PlayAnnouncement1 with id 1510114663693
EngagementDesigner-3.3.0.0.25042 - JustCompleted Task Type was PlayAnnouncementModel

 Filename announcement_simple (1).xml [Disk] Download
 Description edflow xml
 Filesize 38 Kbytes
 Downloaded:  12 time(s)

JoelEzell



Joined: 15/11/2013 10:26:35
Messages: 449
Offline

OK. A few more questions for you:

1. I'm guessing that this is not Collaboratory. Is that right?
2. Was this an upgrade from 3.2 (or earlier) to 3.3 or a clean install?
3. If it was an upgrade, did you follow the procedures for how to migrate the AAMS administration? We had a rather large change in how we interface to AAMS in 3.3.
JoelEzell



Joined: 15/11/2013 10:26:35
Messages: 449
Offline

If you are still having problems, please do a "ce dlogv" from the command line, then search through the log file (using vi) for any Exceptions, or logs at the WARNING/ERROR level. If you find any, please paste them here.
RajeshChandrashekar



Joined: 27/10/2016 05:15:12
Messages: 24
Offline

Thanks Joel,
Ashok
I used the attached wfd and able to hear the announcement and flow is completed, could you please do the following
On your breeze terminal,
ce dlogon
ce dlogon EngagementDesigner

Note down the timestamp,
Execute the scenario
Collect all logs using , ce-report command, attach the report it generated.

Also you may use the updated ED load @ https://bamboo.forge.avaya.com/browse/WORKFLOW-ED33S25-77/artifact
Am not sure if you have access to this, Please let me know any server where i can push this load for you.

Thanks,
Rajesh
AshokJ



Joined: 12/10/2017 23:57:22
Messages: 8
Offline

Hi Rajesh,

Thanks for helping with this. I was able to get it running and the problem was with the AMS part actually.

Thanks,
AJ
JoelEzell



Joined: 15/11/2013 10:26:35
Messages: 449
Offline

That's great. Thanks for keeping us posted.
 
 
Go to: