Author Message
AlokKulkarni

Joined: Jan 5, 2017
Messages: 30
Offline
Hi,
I am trying to run the Javascript sample application over a Aura setup and when I try to login a user I get following error in console:

AAWG_server_baseurl/csa/resources/tenants/default:1 GET https://AAWG_server_baseurl/csa/resources/tenants/default 500 (Internal Server Error)
AvayaClientServices-4.4.0.14.min.js:1 [12/19/2019, 6:19:00 PM] NetworkProvider: CallGatewayProvider,Network error occurred. Status: 500


Please note that if I directly access the AAWG portal, I am able to login the user but not through the sample app as it accesses the above URL before logging in. [Note: This is a fresh AURA setup at customer location]

If I use another AURA setup, the sample runs perfectly. Please help me what might be wrong
lfarias

Joined: Oct 7, 2019
Messages: 46
Offline
Hello AlokKulkarni,

In order to help you please provide us:

  • complete sdk debug logs

  • aawg version that is returning the error

  • aawg version that is working properly


  • Thanks,
    Avaya DevConnect support team
    AlokKulkarni

    Joined: Jan 5, 2017
    Messages: 30
    Offline
    Hi Ifarias,
    Following are the details
    I opened the about section on the web gateway portal. Here is what I got

    Working with Release: 3.7.0.0.225
    Not working release:  3.5.0.0.106

    Complete SDK Logs
    Attached with message
    Filename ConnectionErrorLogs.txt [Disk] Download
    Description No description given
    Filesize 25 Kbytes
    Downloaded: 6623 time(s)

    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    Hello AlokKulkarni,

    Is there any specific reason why this new aura setup is using an older version (3.5.0.0.106) of AAWG? We are investigating possible conflicts between versions, however we suggest you upgrade to 3.7.0.0.225 if possible.

    Thanks,
    Avaya DevConnect support team
    AlokKulkarni

    Joined: Jan 5, 2017
    Messages: 30
    Offline
    Hi Ifarias,
    Thanks for the update. I have initiated a request with the concerned team to check and possibly upgrade the system. However I would request you to check and let me know the updates .
    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    Hello AlokKulkarni,

    Using similar versions we have not been able to reproduce the scenario described. Have you been able to upgrade AAWG to 3.7?

    In case you still have this error please attach AAWG logs.

    Leandro,
    Avaya DevConnect support team
    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    Hello AlokKulkarni,

    We need to detect if the error returned by AAWG server in response to resource discovery is due to the client making a wrong request or is a server problem. In order to help you please upload:

  • AAWG server logs

  • Client console logs

  • Client network logs (.har)


  • Leandro,
    Avaya DevConnect support team.
    AlokKulkarni

    Joined: Jan 5, 2017
    Messages: 30
    Offline
    Hello Ifarias,
    We just got the lab upgraded to Release: 3.7.0.1.353
    However the issue still persists. I am getting the same error.
    PFA the logs. Also when I login to the AAWG admin, it shows an error for the Avaya Media Services. PFA screenshots of AAWG admin as well.
    AlokKulkarni

    Joined: Jan 5, 2017
    Messages: 30
    Offline
    Logs link
    https://drive.google.com/folderview?id=1--8iSa9ijq5-J1tXBFWeAyAGb8Ef7RQ2
    AlokKulkarni

    Joined: Jan 5, 2017
    Messages: 30
    Offline
    Hello Ifarias,
    We just got the lab upgraded to Release: 3.7.0.1.353
    However the issue still persists. I am getting the same error.
    PFA the logs. Also when I login to the AAWG admin, it shows an error for the Avaya Media Services. PFA screenshots of AAWG admin as well.
    Logs link
    https://drive.google.com/drive/folders/1--8iSa9ijq5-J1tXBFWeAyAGb8Ef7RQ2?usp=sharing
    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    I don't have permissions to access the Google drive document, please send it to lfarias@avaya.com

    Thanks,
    Avaya DevConnect support team
    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    Hi AlokKulkarni,

    I got access to the drive folder you provided, but the network activity logs are missing (.har) so I couldn't verify the failed request. Anyway, from the images you uploaded, the issue seems to be related to AMS situation, not the JSCSDK.

    I'll ask the responsible team of AAWG about this.

    Thanks,
    Avaya DevConnect support team
    lfarias

    Joined: Oct 7, 2019
    Messages: 46
    Offline
    Hi AlokKulkarni,

    I've been notified that the issues related to AAWG and AAMS have been solved, but you still have problems with the sample app and your own application.

    Could you please provide us with updated logs after AAWG/AAMS situation was fixed?
  • Javascript SDK logs

  • Javascript Network Activity logs

  • AAWG logs


  • Thanks,
    Avaya DevConnect support team
    Go to:   
    Mobile view