Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Forum Index » IP Office Contact Center Web Services Collection (WSC) (Read-Only Archive June 2021) » Make call using IPO CTI web services API   XML
 
Author Message
JeffG3



Joined: 28/02/2017 10:01:40
Messages: 1
Offline

When trying to use the Make Call service (using IPO CTI web services) a 202 Accepted response is received but no call is made. The users can make regular internal calls successfully using the Avaya communicator App. Below is a copy of the request made:

<ns2:MakeCall xmlns:ns14="http://recording.common.avaya.com/" xmlns:ns9="http://ccragent.common.avaya.com/" xmlns:ns5="http://com.avaya.inkaba.dal" xmlns:ns12="http://voicemail.common.avaya.com/" xmlns:ns6="http://com.avaya.inkaba.wstransfer" xmlns:ns13="http://calllog.common.avaya.com/" xmlns:ns7="http://com.avaya.common.csta.extended" xmlns:ns10="http://conferencing.common.avaya.com/" xmlns:ns8="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns11="http://conferencing.avaya.com/" xmlns:ns2="http://www.ecma-international.org/standards/ecma-323/csta/ed4" xmlns:ns4="http://schemas.xmlsoap.org/ws/2004/08/addressing" xmlns:ns3="http://schemas.xmlsoap.org/ws/2004/09/transfer">
<ns2:callingDevice switchingSubDomainInformationElements="3134382E3134372E3230362E313830" typeOfNumber="dialingNumber">1000</ns2:callingDevice>
<ns2:calledDirectoryNumber typeOfNumber="dialingNumber">1001</ns2:calledDirectoryNumber>
<ns2:autoOriginate>doNotPrompt</ns2:autoOriginate>
<ns2:correlatorData> <ns2:string>61356262613163622D623137342D343431642D383931342D313235343639343339646535</ns2:string> </ns2:correlatorData>
<ns2:mediaCallCharacteristics> <ns2:mediaClass><ns2:voice>true</ns2:voice></ns2:mediaClass> </ns2:mediaCallCharacteristics>
<ns2:subjectOfCall></ns2:subjectOfCall>
</ns2:MakeCall>

Has anyone came across this before? Or have any ideas as to why this is happening?
Matt-L.



Joined: 06/01/2020 03:45:28
Messages: 1
Offline

Hi ! I'm actually facing the same issue. Have you eventually solved your problem ?

This message was edited 1 time. Last update was at 27/10/2020 08:57:35

 
 
Go to: