Author Message
Tristan
Joined: Sep 10, 2018
Messages: 2
Offline
Hi All,

We have an application that is connecting via TSAPI and generally has no problems. Recently though we have seen on a site where we get a ACSERR_STREAM_FAILED status code which then looks like it might be causing a recovery problem within the application.

Example of the logs for this...
2021-02-25 12:21:52,645 DEBUG - REQ_THREAD LinkID=AVAYA_WOK ACSHandle=28985048  InvokeID=10 GenccAvayaHoldCall CallRef=0x2ed9 Device=*****

2021-02-25 12:21:52,645 DEBUG - REQ_PROC_THREAD LinkID=AVAYA_WOK ACSHandle=28985048 ThreadId=8592 InvokeID=10 GenccAvayaHoldCall CallRef=0x2ed9 Device=*****
2021-02-25 12:21:52,645 ERROR - Operation failure LinkID=AVAYA_WOK ACSHandle=28985048 InvokeID=10 Status=ACSERR_STREAM_FAILED


We are trying to recreate the problem so that we can be sure our code handles the scenario problem.

What is the best way to recreate a ACSERR_STREAM_FAILED status code?

Many Thanks
MartinFlynn
Joined: Nov 30, 2009
Messages: 1843
Offline
You could try removing AE Services from the network. if it's on a physical server, remove the ethernet cable. If it's in VMWare, reconfigure the Ethernet connection to a different VLAN.

Martin
JohnBiggs
Joined: Jun 20, 2005
Messages: 968
Location: Thornton, CO
Offline
pull a cable off a network switch to isolate either the AES or the application server. Don't be shy!
Tristan
Joined: Sep 10, 2018
Messages: 2
Offline
Will have a goat getting our PBX man to pull the cable then! Thanks
Go to:   
Mobile view