Author Message
RajaMohammed
Joined: Mar 9, 2014
Messages: 186
Offline
Hi, I am using OD 7.0.1/7.22 and EPMS 7.2.3. Here the License URL is updated successfully in runtime config for this ODs.
Now I upgraded to OD 8. But EPMS is same 7.22. In this case, the same License URL is giving error as License Url is invalid, or server is not up, or license version is too low. as per attachment. But application is working fine if I make call. Do we need to upgrade PEMS to 8?Or any other workaround solution available?
Please note that Appserver & WebLM servers are same.


IBMWAS Appserver Error Logs
####################
[5/24/21 14:39:59:221 GMT+03:00] 00000096 AxisConfigBui W org.apache.axis2.deployment.AxisConfigBuilder processDeployers Unable to instantiate deployer org.apache.axis2.deployment.ServiceDeployer; see debug logs for more details
[5/24/21 14:39:59:798 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O exception (org.apache.axis2.AxisFault) caught when processing request: Connection has been shutdown: javax.net.ssl.SSLException: Received fatal alert: protocol_version
[5/24/21 14:39:59:799 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry Retrying request
[5/24/21 14:39:59:807 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O exception (org.apache.axis2.AxisFault) caught when processing request: Connection has been shutdown: javax.net.ssl.SSLException: Received fatal alert: protocol_version
[5/24/21 14:39:59:808 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry Retrying request
[5/24/21 14:39:59:816 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry I/O exception (org.apache.axis2.AxisFault) caught when processing request: Connection has been shutdown: javax.net.ssl.SSLException: Received fatal alert: protocol_version
[5/24/21 14:39:59:816 GMT+03:00] 0000008c HttpMethodDir I org.apache.commons.httpclient.HttpMethodDirector executeWithRetry Retrying request
[5/24/21 14:39:59:840 GMT+03:00] 0000008c HTTPSenderImp I org.apache.axis2.transport.http.impl.httpclient3.HTTPSenderImpl sendViaPost Unable to sendViaPost to url[https://10.0.29.112/axis2/services/VP_POMAgentAPIService]
org.apache.axis2.AxisFault: Connection has been shutdown: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
at org.apache.axis2.transport.http.SOAPMessageFormatter.writeTo(SOAPMessageFormatter.java:78)
at org.apache.axis2.transport.http.AxisRequestEntity.writeRequest(AxisRequestEntity.java:85)
  • [Thumb - OD8_EPMS7.2.3_LicenseError.JPG]

WilsonYu
Joined: Nov 6, 2013
Messages: 3944
Offline
This error means OD may not be able to retrieve the runtime license but you are running on grace period. Since 7.2.3, OD has adopted the new weblm.jar (client library that talks to WebLM). There is a release note about it (below). However, for Websphere, I am not sure what directory it is looking at. It depends on the App Server Home variable. So you may take a look at the systemout.log and see what exception you get in order to figure out the path where you can place the trustedcert.properties file.



WebLM 8 client - The new WebLM client, which solves the https connection problem with
JBoss/Wildfly, requires a manual step to make it work. Particularly it requires the
trustedcert.properties file in a specific sub directory inside the app server deployment directory. The
directory is different for different app server type. For Tomcat, you have to copy the
trustedcert.properties from the lib directory into the webapps/WebLM/admin directory. Otherwise, you
would see an exception such as the following in the console log when configuring the https license url
in runtimeconfig or running the app for the first time. For other app server, take note of the similar
FileNotFoundException in the console log and move the trustedcert.properties to the sub directory
indicated in the exception.
java.io.FileNotFoundException: C:\OD723\deployment\apache-tomcat9.0.8\webapps\WebLM\admin\trustedcert.properties
RajaMohammed
Joined: Mar 9, 2014
Messages: 186
Offline
As I mentioned in previous post, the appserver SystemOut.log showing error as below. Full logs attached here.
[5/25/21 15:02:23:864 GMT+03:00] 00000089 HTTPSenderImp I org.apache.axis2.transport.http.impl.httpclient3.HTTPSenderImpl sendViaPost Unable to sendViaPost to url[https://10.0.29.112/axis2/services/VP_POMAgentAPIService]
org.apache.axis2.AxisFault: Connection has been shutdown: javax.net.ssl.SSLException: Received fatal alert: protocol_version
at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
Filename SSL_Error.txt [Disk] Download
Description OD8_POM_SSL_Error
Filesize 82 Kbytes
Downloaded: 452 time(s)

WilsonYu
Joined: Nov 6, 2013
Messages: 3944
Offline
The errors you attached has nothing to do with the weblm licensing. This is about a POM service. There must be another exception that happens when you enter the license url and hit update/save on Runtimeconfig.

[https://10.0.29.112/axis2/services/VP_POMAgentAPIService]
org.apache.axis2.AxisFault: Connection has been shutdown:
RajaMohammed
Joined: Mar 9, 2014
Messages: 186
Offline
You are correct. When I click Update I get error as below. But it is not showing required path of trustedcert file. Attached full exception after clicking update.

[5/25/21 23:17:07:271 GMT+03:00] 00000089 SystemErr R java.io.FileNotFoundException: trustedcert.properties (No such file or directory)
[5/25/21 23:17:07:272 GMT+03:00] 00000089 SystemErr R at java.io.FileInputStream.open0(Native Method)
[5/25/21 23:17:07:272 GMT+03:00] 00000089 SystemErr R at java.io.FileInputStream.open(FileInputStream.java:212)
[5/25/21 23:17:07:272 GMT+03:00] 00000089 SystemErr R at java.io.FileInputStream.<init>(FileInputStream.java:152)

Filename trustedcert_FileNotFound.txt [Disk] Download
Description Exception
Filesize 10 Kbytes
Downloaded: 448 time(s)

WilsonYu
Joined: Nov 6, 2013
Messages: 3944
Offline
Looks like new WebLM client jar doesn't support other app servers that well. Here are couple options.
1. Replace the weblm.jar with the version you used before for older version of OD.
2. Create a system environment variable named CATALINA_HOME and set it to a directory of chosen. In the directory create the subdirectory called webapps/WebLM/admin, then copy the trustedcert.properties file in there.
RajaMohammed
Joined: Mar 9, 2014
Messages: 186
Offline
I tried both options. Now there is no error in Appserver. But in runtimeconfig console, it is showing same error as
License Url is invalid, or server is not up, or license version is too low.
RajaMohammed
Joined: Mar 9, 2014
Messages: 186
Offline
I found another thing. Our WebLM has license for OD 7 as per atatchment. we Should upload for OD 8 also. Correct?
  • [Thumb - WebLM_Licenses_OD7.JPG]

WilsonYu
Joined: Nov 6, 2013
Messages: 3944
Offline
You need license version 8 for OD 8.
MatthewKopcienski
Joined: Nov 14, 2013
Messages: 89
Offline
WilsonYu wrote:Looks like new WebLM client jar doesn't support other app servers that well. Here are couple options.
1. Replace the weblm.jar with the version you used before for older version of OD.
2. Create a system environment variable named CATALINA_HOME and set it to a directory of chosen. In the directory create the subdirectory called webapps/WebLM/admin, then copy the trustedcert.properties file in there.


I don't think this is a good solution. By default the 07.23.08.03 is looking for webapps/WebLM/admin/trustedcert.properties

Why do I need to create a webapps/WebLM directory when I don't have WebLM installed. Is there someplace I could configure where to find the trustedcert file?
Go to:   
Mobile view