Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Forum Index » Avaya Orchestration Designer » Unable to load values of AEP variables   XML
 
Author Message
JaydeepH



Joined: 24/02/2017 04:50:54
Messages: 36
Offline

We have the following environment:
AEP 7.2.3
Windows Tomcat 8.5.66
AOD 7.2.1

We have configured AEP variables in our AOD application. However, the IVR application is unable to pick the values set from AEP web page.

This is what we see in our Application trace:

29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Initializing admin variables...
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:__VPVarAppDate is 1627555701322
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Timestamp is 07/29/21 11:48:21
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Appname is 0:CCMAppsTest
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: Timestamp is different; Load parameters....
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx : AdminVarCache:init: Module? false
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: load data from the Experience Portal platform
29/07/2021 11:48:37:735 ERROR - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: VPClientProxy:VPAppRuntimeVars.getAppRuntimeVars returns null
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: no data comes back from proxy.
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: app params: {}
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: Finish loading.
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: *** Reply for [/xxx/Start] ***



Ideally, what we should see is the following (this is a good call scenario of the same application from a different AEP and Application server):

22/07/2021 14:03:23:627 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: AdminVarCache:init: load data from the Experience Portal platform
22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: VPClientProxy get parameter|value|type - logsPath|D:\\Logs|String
22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: VPClientProxy get parameter|value|type - propFilePathExitVDN|D:\Tomcat8.5_AOD\CM-SDIVR-Tomcat-8.5.43\webapps\Config\abc.properties|String


22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: app params: {logsPath=D:\\Logs, propFilePathExitVDN=D:\Tomcat8.5_AOD\CM-SDIVR-Tomcat-8.5.43\webapps\Config\abc.properties}


Is this any known issue with AEP 7.2.3 platform? Or anything to do with our AOD application? Or with our Windows Application server?

I am unable to get any clue because same application picks up AEP variables values successfully from other setup of AEP - Tomcat environment.

The environment where it works fine is exactly the same:
AEP 7.2.3
Tomcat 8.5.43
AOD 7.2.1

This is preventing us to use dynamic values for the AEP variables.

Appreciate any inputs on this regard,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Raphael1001fly



Joined: 20/08/2020 16:26:56
Messages: 15
Offline

Im passing for the same problem,

I would contact avaya EPM support to help you, its a possible enviroment problem. Thats why the bold file returns null.

Have you ever tried it?

Hugs.
WilsonYu



Joined: 06/11/2013 14:29:24
Messages: 3831
Offline

There must be an error in the vpapplogclient.log (somewhere in the app server directory). Typically, restarting the EPM web service would help
JaydeepH



Joined: 24/02/2017 04:50:54
Messages: 36
Offline

Thanks a lot for your quick responses. I will share the final feedback / actions performed to resolve this issue.
JaydeepH



Joined: 24/02/2017 04:50:54
Messages: 36
Offline

Hi Wilson,

vpapplogclient shows the following message:


2021-08-02 07:43:53,907 818530 [VPAlarmMonitorThread: https://10.xxx.x.xx/axis2/services/VPAppLogService] ERROR - AlarmMonitorThread:EPMWebServicesClientBaseImpl:logAlarmsAxis2() - Caught Exception FAILED with AxisFault faultCode: null error: Connection timed out: connect to log entry size: 1 to URL: https://10.xxx.x.xx/axis2/services/VPAppLogService from AE server: CIBLVPxxxxxx002 First SID: cpd1-i1-mpp1-2021214063213-1 Last SID: cpd1-i1-mpp1-2021214063213-1 NOTE: It could be caused by this EPM is not online or some other network issues.


We have already performed an EPM reboot and yet the AEP variables values are not picked up by the application.

Is there any other workaround or action needs to be taken to resolve this issue?

Appreciate any further inputs on this regard,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
WilsonYu



Joined: 06/11/2013 14:29:24
Messages: 3831
Offline

This error seems to indicate there is a connection problem between the app server and EPM.
JaydeepH



Joined: 24/02/2017 04:50:54
Messages: 36
Offline

Ok fine, thanks Wilson for sharing this perspective.

I will re-check the connectivity between EPM and App server and share the feedback.
 
 
Go to: