Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
New DevConnect members must have forum permissions in order to post messages.
If the Reply and New Post buttons are not available to you, please request access using a General Support request ticket.
Forum Index » DMCC APIs » Some Agents switched to Aux state periodically   XML
 
Author Message
Oles'



Joined: 07/01/2020 03:44:06
Messages: 4
Offline

We have a problem now at customer side, when we have call in queue and agents, that should be ready to receive it, but they not received, because in Aux mode by some reason.

We added checking of agent state after each SetAgentState request and all looks good, so agent's shouldn't be at Aux mode.

What can be a cause of this problem?
What can have influence to workMode of agents? Could it be AutoIn workMode used in SetAgentState request?
MartinFlynn



Joined: 30/11/2009 05:00:18
Messages: 1791
Offline

Yes, workMode will affect the state an agent enters when a call ends. You can get a full description of the combinations in the "Set Agent State Service" section of the document "TSAPI for Avaya Communication Manager Programmer's Reference".

Martin
JohnBiggs



Joined: 20/06/2005 14:06:52
Messages: 883
Location: Thornton, CO
Online

Note also that Communication Manager can be configured to automatically place agents into an Aux work state for a period of time after call ends.
[WWW]
 
 
Go to: