Author Message
hkalyoncu
Joined: Jul 10, 2018
Messages: 21
Offline
Hi
We have problem with calls from webRTC connect mobile (IOS & Android) reference clients.
Calls rings on agent's phone. When agent answers the call mobile application throws error (screenshot attached).
Strangly voice can be heard both ways even application throws error but after few seconds application disconnects.

We have no problem with Javascript reference client. Javascript client can make successful calls.
Looking into traces I can see STUN/TURN communication between Javascript client and SBCE but there is no such communication between mobile clients and SBCE.

Versions:
-WebRTC Connect Client version: 4.0.1 (IOS&Android)
-SM / SBCE: 8.1.3
-AAGW: 3.9.1

I can supply logs & traces upon request.

Regards,

Hüseyin Kalyoncu
  • [Thumb - WhatsApp Image 2021-10-25 at 3.55.28 PM.jpeg]

  • [Thumb - WhatsApp Image 2021-10-22 at 5.20.47 PM.jpeg]

hkalyoncu
Joined: Jul 10, 2018
Messages: 21
Offline
Hi

For anyone experiencing the same problem, I disabled the SRTP across the platform and the issue resolved.

Happy days to everybody
Regards

Hüseyin
lapatil.avaya.com
Joined: Sep 25, 2019
Messages: 4
Offline
Hi Hüseyin,

Thanks for the information. Please let me know steps you took to disable the SRTP and if possible share the logs with & without SRTP.

Thanks & Regards,
Avaya DevConnect Support
hkalyoncu
Joined: Jul 10, 2018
Messages: 21
Offline
Hi lapatil

Below are the steps for disabling the SRTP on all components:

CM:
change ip-codec-set xx
then remove all the settings in encryption section and only set to 'none'

AAWG:
Go to Security settings -> Session security
Set SIP and SRTP Security Policy to None

AAMS:
Goto System Configuration » Media Processing » Media Security
Set Security Policy to SECURITY DISABLED

SBCE:
Goto Domain Policies > Media Rules
then click on the related rule
click edit and set the Preferred Formats to RTP


I can share the logs. But I can only upload them to sharepoint you provided because customer dont want the IP addresses shared on public forum.


Best regards
Hüseyin
lapatil.avaya.com
Joined: Sep 25, 2019
Messages: 4
Offline
Thanks Hüseyin, We trying to reproduce this issue with the provided information.

Regards,
Lalit
AlexandreMedeiros
Joined: May 17, 2017
Messages: 3
Offline
Hi team,
I was wondering if what else could cause this issue. I am working on a WebRTC Connect project here and receiving the same error when trying to call to a CM vector (with an announcement). I am using the version 4.0.4 of the Android sample client.
In the logs there are these errors:

CHTTPCallSession::ProcessInitialAnswer(): m_pMedia->ProcessAnswer failed
Unable to initialize received remote media capabilities

Appreciate any help on this.

Regards,

Alexandre
Go to:   
Mobile view