Author Message
Bala

Joined: Mar 17, 2014
Messages: 58
Offline
Hi Experts,

I am trying to decide the routing to an Agent with the JTAPI Applications.
I am able to see the RouteEvent recieved on JTAPI but CM is not using that AgentID which is passed of the SelectRoute(). Can someone suggest me what am i doing wrong?
Vector (same as example vector):
display vector 2 Page 1 of 6
CALL VECTOR
Number: 2 Name: Adjunct Route
Multimedia? n Attendant Vectoring? n Meet-me Conf? n Lock? n
Basic? y EAS? y G3V4 Enhanced? y ANI/II-Digits? y ASAI Routing? y
Prompting? y LAI? y G3V4 Adv Route? y CINFO? y BSR? y Holidays? y
Variables? y 3.0 Enhanced? y
01 wait-time 2 secs hearing silence
02 adjunct routing link 1
03 wait-time 2 secs hearing silence

JTAPI (exerciser sample app):

Registered Route Callback with 8101021.
Waiting for calls (please place a call to VDN 8101021)...

Received Route Callback Ended Event
RouteAddress=800000

Received Route Event
callingAddress=(ani)
currentRouteAddress=800000
routeSelectAlgorithm=0
setupInformation=null

Routing to destination '8490956'

cause=100
routeAddress=800000
state=ROUTE
Selected route: 8490956
RouteSession[0] state=ROUTE


800000 - vdn
8490956 - Agentid

I am trying to return agentid as part of routeHandler, But Call not routed to that Agent or never got the ROUTE_USED Event, always goes to the next step (fallback) in vector.

Please suggest
MartinFlynn

Joined: Nov 30, 2009
Messages: 1796
Offline
I see that when the JTAPI sample receives a routeEvent it pops up a dialog. The user must enter the destination number into this dialog.

I also see that your vector has a 2 second wait step after the adjunct route step. This means that the user has less than 2 seconds to enter the destination number into the dialog. If it fails to do this, the vector will continue.

I assume that you do not enter the destination number within 2 seconds as I don't think there is any way I would be able to. So, I suggest you increase the wait time to, say, 20 seconds to give yourself enough time.

Martin
Bala

Joined: Mar 17, 2014
Messages: 58
Offline
Thanks Martin,

I tried to setup the Wait time to 25 seconds as well.

01 wait-time 2 secs hearing silence
02 adjunct routing link 3
03 wait-time 25 secs hearing ringback

Destination is hard coded in the application to send response immediately for testing. still same. Any other thoughts? I am using the sample application of JTAPI sdk

Below is AES response:

<135>Nov 30 07:37:43 kksttlae01 DmccMain[12213] -05:00 2021 701 1 com.avaya.aes | :CstaUnMarshalerNode-3: com.avaya.api.cmapi FINE - invokeID= 10 Routing request=session[session A8318665396B356DD1F08F0D9972A972-8127] ch.ecma.csta.binding.reset.ResetApplicationSessionTimer@18e36b6
<135>Nov 30 07:37:43 kksttlae01 DmccMain[12213] -05:00 2021 701 1 com.avaya.aes | :CstaUnMarshalerNode-3: com.avaya.api.router FINER - Invoking method=public java.lang.Object com.avaya.sessionsvc.SessionServicesImpl.resetApplicationSessionTimer(ch.ecma.csta.binding.reset.ResetApplicationSessionTimer) with argument=session[session A8318665396B356DD1F08F0D9972A972-8127] ch.ecma.csta.binding.reset.ResetApplicationSessionTimer@18e36b6
<135>Nov 30 07:37:43 kksttlae01 DmccMain[12213] -05:00 2021 701 1 com.avaya.aes | :CstaUnMarshalerNode-3: com.avaya.api.router FINER - Reponse=session[null] ch.ecma.csta.binding.reset.ResetApplicationSessionTimerPosResponse@1cae529 as a result of invoking method=public java.lang.Object com.avaya.sessionsvc.SessionServicesImpl.resetApplicationSessionTimer(ch.ecma.csta.binding.reset.ResetApplicationSessionTimer) with argument=session[session A8318665396B356DD1F08F0D9972A972-8127] ch.ecma.csta.binding.reset.ResetApplicationSessionTimer@18e36b6
<135>Nov 30 07:37:43 kksttlae01 DmccMain[12213] -05:00 2021 701 1 com.avaya.aes | :CstaUnMarshalerNode-3: com.avaya.api.cmapi FINE - invokeID= 10 Sent response session[null] ch.ecma.csta.binding.reset.ResetApplicationSessionTimerPosResponse@1cae529
Bala

Joined: Mar 17, 2014
Messages: 58
Offline
This has been fixed. Looks like on the AES we would require the Advanced TSAPI License. which was missing. once installed, all good.
Go to:   
Mobile view