Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Forum Index » Avaya Aura® Contact Center (Archive - Oct 2013 and earlier) » SDK Sample Website   XML
 
Author Message
KevinManifold



Joined: 14/10/2013 01:16:20
Messages: 0
Offline

Have installed xammpp & SDKsample website onto seperate server. Amended file c:\xampp\htdocs\code\include\config.php' but webchat icon still not present, only email icon.

Says "no chat agents currently active" - which there are.

Any tips to check
FergusCameron


[Avatar]

Joined: 17/04/2012 08:18:32
Messages: 46
Location: Ireland
Offline

Certainly try turning on the debugging (also in 'config.php') and run the basic tests under 'debug' folder. If they work (i.e. you can contact the AACC) it should just be a case of double checking the skillset names and assignments.

NB: depeding on your XAMPP version, you'll probably want to correct the two 'str_replace' calls in 'get_history_since' so they pass correctly.

Fergus Cameron :: AVAYA :: DevConnect :: http://www.avaya.com/devconnect/
[WWW]
KevinManifold



Joined: 14/10/2013 01:16:20
Messages: 0
Offline

Hi Fergus.. think my issue may be admin rights related. When I install xampp i can't select the tickbox next to the apache service. Also get install messages warning about not running with admin rights, although I can configure and everything starts.

FergusCameron


[Avatar]

Joined: 17/04/2012 08:18:32
Messages: 46
Location: Ireland
Offline

You're kinda on your own there I'm afraid (or find an XAMPP forum) as I'm not really familiar with XAMPP specifics. That said, I'd doubt it's admin related -- if you get the web page then your XAMPP server's probably doing it's job. You could hack up a quick PHP test just to make sure that it's executing the PHP -- once you know that's working the application logs should help you debug.

If you're not confident with XAMPP and that stuff I'd recommend that you download the /exact/ version in the documentation -- as that's the /only/ version that's tested.

Fergus Cameron :: AVAYA :: DevConnect :: http://www.avaya.com/devconnect/
[WWW]
KevinManifold



Joined: 14/10/2013 01:16:20
Messages: 0
Offline

Final resolution. Downloaded latest Xammp version which doesn't work with the latest SDK. Removed and reinstalled with documented version and works ok.
 
 
Go to: