Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Messages posted by: JaydeepH
Forum Index » Profile for JaydeepH » Messages posted by JaydeepH
Message
Ok fine, thanks Wilson for sharing this perspective.

I will re-check the connectivity between EPM and App server and share the feedback.
Hi Wilson,

vpapplogclient shows the following message:


2021-08-02 07:43:53,907 818530 [VPAlarmMonitorThread: https://10.xxx.x.xx/axis2/services/VPAppLogService] ERROR - AlarmMonitorThread:EPMWebServicesClientBaseImpl:logAlarmsAxis2() - Caught Exception FAILED with AxisFault faultCode: null error: Connection timed out: connect to log entry size: 1 to URL: https://10.xxx.x.xx/axis2/services/VPAppLogService from AE server: CIBLVPxxxxxx002 First SID: cpd1-i1-mpp1-2021214063213-1 Last SID: cpd1-i1-mpp1-2021214063213-1 NOTE: It could be caused by this EPM is not online or some other network issues.


We have already performed an EPM reboot and yet the AEP variables values are not picked up by the application.

Is there any other workaround or action needs to be taken to resolve this issue?

Appreciate any further inputs on this regard,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Thanks a lot for your quick responses. I will share the final feedback / actions performed to resolve this issue.
We have the following environment:
AEP 7.2.3
Windows Tomcat 8.5.66
AOD 7.2.1

We have configured AEP variables in our AOD application. However, the IVR application is unable to pick the values set from AEP web page.

This is what we see in our Application trace:

29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Initializing admin variables...
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:__VPVarAppDate is 1627555701322
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Timestamp is 07/29/21 11:48:21
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: Initializer:applicationStarted:Appname is 0:CCMAppsTest
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: Timestamp is different; Load parameters....
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx : AdminVarCache:init: Module? false
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: load data from the Experience Portal platform
29/07/2021 11:48:37:735 ERROR - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: VPClientProxy:VPAppRuntimeVars.getAppRuntimeVars returns null
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: no data comes back from proxy.
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: app params: {}
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: AdminVarCache:init: Finish loading.
29/07/2021 11:48:37:735 DEBUG - DC83BC47FA9BD653FC35AF1372BC210A:/xxx: *** Reply for [/xxx/Start] ***



Ideally, what we should see is the following (this is a good call scenario of the same application from a different AEP and Application server):

22/07/2021 14:03:23:627 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: AdminVarCache:init: load data from the Experience Portal platform
22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: VPClientProxy get parameter|value|type - logsPath|D:\\Logs|String
22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: VPClientProxy get parameter|value|type - propFilePathExitVDN|D:\Tomcat8.5_AOD\CM-SDIVR-Tomcat-8.5.43\webapps\Config\abc.properties|String


22/07/2021 14:03:23:736 DEBUG - DF28110F05FC3BA83E5F92D4609CA6ED:/xxx: app params: {logsPath=D:\\Logs, propFilePathExitVDN=D:\Tomcat8.5_AOD\CM-SDIVR-Tomcat-8.5.43\webapps\Config\abc.properties}


Is this any known issue with AEP 7.2.3 platform? Or anything to do with our AOD application? Or with our Windows Application server?

I am unable to get any clue because same application picks up AEP variables values successfully from other setup of AEP - Tomcat environment.

The environment where it works fine is exactly the same:
AEP 7.2.3
Tomcat 8.5.43
AOD 7.2.1

This is preventing us to use dynamic values for the AEP variables.

Appreciate any inputs on this regard,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

Thanks for your response. The simulator eclipse tomcat is different than the application server tomcat.

Hi Jessica,

Thanks for your inputs as well. Although, I don't recollect if I did these steps to toggle the compiler compliance level; I managed to resolve this issue somehow; Followed these actions:
1. Deleting all the war files from local eclipse war folder
2. Deleting all xml files from eclipse tomcat -- conf -- Catalina -- localhost folder
3. Creating a new workspace and importing the project there
4. Freshly setting up Tomcat path (and may be I could have set the compiler level too... frankly speaking don't remember)
5. Generate the war file and deployed in windows application server

These steps picked the new call flow as designed/developed in the eclipse and verified it via application trace messages.

I would like to thank Wilson for his continuous efforts and quick responses/suggestions that encouraged me to keep on trying various options until I managed to reach till this point.

Thanks Jessica for your suggestions as well, this should definitely help our developers in future.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

I am still stuck at this point:

AOD Application works fine within AOD simulator. However, when I generate a war file and deploy it on AEP, it still picks up an old version of the application.

I did follow all the basic steps to deploy the war file:
- delete existing war files in war folder
- validate, generate project, generate fresh war file
- In the application server - webapps folder: stopped tomcat, then delete the war file as well as its associated folder, paste the new war file and restart tomcat service to generate a new folder structure

Yet, these steps are not helping. There is something new that I found today (see attached screenshot) - it's about Hot Code Replace failed - Delete method not implemented.

Is this something related to this issue which is avoiding getting a fresh war file generated for my application? What is the ideal action needs to be taken (Continue, Terminate or Restart)?

Appreciate any inputs on this topic.

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

I did not use the in-built RESTful service within AOD. I did manage to develop the customized java code to hit a webservice via https url involving proxy.

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Hello,

I am currently using AOD 7.2.1, Java 8, Tomcat 8.5.43 versions.

I am looking for a REST API sample java code trying to hit a https url.

Appreciate if you can please share it,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

I did enable MPP logs to FINEST level; however, it only shows PAVB errors without any more details:

@2021-04-14 07:38:21,108||FINE|SessMgr|9578||CCall::Disconnected Call [228099] has disconnected (1, NearEndDisconnect : Application exited. [ERRORS]), endpoint 681841 destroyed|MVSCCMMPPLD02####
@2021-04-14 07:38:21,108||FINEST|SessMgr|9578||******** Leaving Call.cpp:1159:Disconnected|MVSCCMMPPLD02####
@2021-04-14 07:38:21,109|PSESM00070|ERROR|SessMgr|9578|FileName=SessionMgr.cpp,LineNumber=2082|Application errors occurred for application ProductionTestApp, Session ID MVSCCMMPPLD02-2021104063759-15, [vxml: PAVB_00191, vxml: PAVB_03064]|MVSCCMMPPLD02####
@2021-04-14 07:38:21,108||FINER|SessMgr|9578||Call object destroyed, CallID 228099 - MVSCCMMPPLD02-Session Managers-1-2021104063759|MVSCCMMPPLD02####
@2021-04-14 07:38:21,108||FINE|SessMgr|9578||Session::Run: No calls for session, setting termination timeout to 300000, Shutdown requested 1|MVSCCMMPPLD02####
@2021-04-14 07:38:21,108||FINER|SessMgr|9578||Check for exit conditions for session: [Call 0, CCXML 0, VXML 0, Preparing 0, Msg 1], wait time = 320 ms|MVSCCMMPPLD02####

And with reference to deploying new war file in tomcat instance, I always stop tomcat service and then delete both the war file and its folder from webapps folder and place the new war file and start tomcat service so that a new folder is created for the war.

I am still searching for more clues/ideas on how to get this going as this is simply weird that application runs in AOD simulator; however, the same nodes are not working similarly while making test calls.

Warm regards,
Jaydeep Hatekar
Thanks for your response Wilson. I had already enabled the application trace along with MPP logs to finest level to get more clues about the application error. However, we are getting blank as per below:

12/04/2021 12:41:55:934 ERROR - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : session id:MVSCCMMPPWM02-2021102114550-18 | MnSGiftCard1:Error | System Error has occurred for Call ID | CallID : 10001513021618227950
12/04/2021 12:41:55:934 INFO - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : session id:MVSCCMMPPWM02-2021102114550-18 | MnSGiftCard1:Error | Error Thrown: | ddLastException:errorcode :
12/04/2021 12:41:55:934 INFO - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : session id:MVSCCMMPPWM02-2021102114550-18 | MnSGiftCard1:Error | Error Message: | ddLastException:message :
12/04/2021 12:41:55:934 INFO - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : session id:MVSCCMMPPWM02-2021102114550-18 | MnSGiftCard1:Error | Error Type: | ddLastException:type :
12/04/2021 12:41:55:934 INFO - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : session id:MVSCCMMPPWM02-2021102114550-18 | MnSGiftCard1:Error | | session:lasterror :
12/04/2021 12:41:55:934 INFO - 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 : Using SCESession 641E7169038C8E7BD549A03F644D80E8:/MnSGiftCard1 servlet : End

There is no clue from any of the application trace or MPP logs.

Additionally, I am facing a weird issue that each time I do some changes to trace in AOD data node and regenerate the war file and deploy it freshly, each time the old version of the application is fetched instead of new application.

Is this faced / experienced before? Any workaround so that new war file is fetched instead of old application?

Appreciate any inputs on this regard,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Dear DevConnect Team,

Here's the environment details:

AOD 7.2.1.0502
AEP 7.1.0.1.0004
MPP 7.1.0.1.0006
Windows based Tomcat Application Server (Tomcat 8.5.43)
Windows Server 2008 R2
Java version: JRE 1.8.0_181

Issue:
Application works fine in Simulation environment in AOD. However, when we attach the application on AEP applications page and try to call the DDI, it hits the application and fails at the beginning.

Is this any known issue or any workaround to get this work?

Another question - is there any limit to the number of items in Data node?

Description:
In simulation mode, the call covers all the logics within "AssignValues" data node and later move to welcome announcement. However, in actual call via AEP, the call is executed only till a certain point before disconnecting (as shown in attached screenshot of data node, the trace below red line is not executed at all, instead, we see application errors and call exits).

Additionally, we are getting these continuous HTTP 404 error in localhost access log file:

- - [12/Apr/2021:12:41:55 +0100] "POST /MnSGiftCard1/Greeting?___DDSESSIONID=641E7169038C8E7BD549A03F644D80E8%3A%2FMnSGiftCard1 HTTP/1.1" 404 1116
- - [12/Apr/2021:12:41:55 +0100] "GET /MnSGiftCard1/Error?___DDSESSIONID=641E7169038C8E7BD549A03F644D80E8%3A%2FMnSGiftCard1 HTTP/1.1" 404 1102
- - [12/Apr/2021:12:41:55 +0100] "GET /MnSGiftCard1/Error?___DDSESSIONID=641E7169038C8E7BD549A03F644D80E8%3A%2FMnSGiftCard1 HTTP/1.1" 404 1102
- - [12/Apr/2021:12:41:55 +0100] "GET /MnSGiftCard1/Error?___DDSESSIONID=641E7169038C8E7BD549A03F644D80E8%3A%2FMnSGiftCard1 HTTP/1.1" 404 1102

I will be happy to share / collect any additional log files/application details if required as this looks like a weird issue.

There are few other options more which I haven't tried yet - not sure whether this will help:
1. Restart MPP servers
2. Restart application server
3. Deploy the application in different environment (different application server and different MPP).

Appreciate any inputs on this,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Dear Team,

Environment:
AAEP 7 with SIP based integration

Call flow:
Call is in IVR --> Call transfer to Agent --> All Agents are busy --> Call remains in queue until an agent becomes available --> Caller need to be informed about queue position

Is this functionality / requirement (about playing queue position to the caller until an agent becomes available) possible via AOD IVR application?

My thinking - may be need to use Consultation Transfer instead of Blind Transfer? However, I saw in AOD guide it's Consultation Call (AES) which is not feasible with SIP based integration.

Any additional inputs would be appreciated,

Thanks for your support.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

Thanks for your quick response. This has worked perfectly as expected.

- Took backup of existing ddconfig.xml file and then removed the ddconfig.xml file from tomcat/lib directory
- Restart this particular tomcat instance
- New ddconfig.xml was created automatically upon tomcat restart
- Default password (ddadmin/ddadmin) was set automatically
- To restore old configurations, simply replaced the backup ddconfig.xml file

Thanks a lot again for your support.

Warm regards,
Jaydeep Hatekar
Hi Wilson,

We have forgotten the ddadmin password. Is there any way to reset it?

Our documentation asks us to approach Dialog Designer Support Team.

Warm regards,
Jaydeep Hatekar
Thanks Wilson for your response. The only suspicious thing I noticed was related to the length of aai data being passed during transfer as noticed in vb logs. I think there is a limit to send max 96 bytes of data during call transfer.

Anyways, let me check few things before I consult Avaya support.
 
Forum Index » Profile for JaydeepH » Messages posted by JaydeepH
Go to: