Please login or register to access secure site features.

Note: By continuing to use DevConnect Program Services you agree to our latest Registered Member Terms.

Sign in using DevConnect ID

Forgot password?

Trouble logging in?

Submit a ticket for Registration Support.

I have an SSO ID

?
sign in

Don't have a DevConnect or SSO ID ?

Create a DevConnect account or join the program.

register now
^
Messages posted by: AndersNilsson3
Forum Index » Profile for AndersNilsson3 » Messages posted by AndersNilsson3
Message
Hi,

I'm upgrading from EP 7.0.1.0.1601 to EP 7.2.0.0.1117 and noticed that some menus doesn't work anymore. Looking at trace.log I assume that it is the same problem as described in https://www.devconnectprogram.com/forums/posts/list/20504.page where some project variables relating to the menu is missing.

Probably not a new problem, I have looked back at old repositories and for an example menu_1416 is missing back already in VoicePortal 5.1 but for some reason it seems to have worked anyway.

I have tested to recreate the menus and that takes care of the problem.

So, my question isn't about the cause of the problem. It is more "is there a way to find these menus with missing variables other than manually go through all 100 applications"?

(I have another problem regarding prompts, but I'll take that in a separate thread when I have investigated it further)
42 is the answer to Life, the Universe and Everything! :-)

Old installation:
OD 7.0.1.0804
EP 7.0.1.0.1601
Java 7

New installation:
OD 7.2.0.00904
EP 7.2.0.0.1117
Java 8

So here's the thing: we have a module called AvayaCentralizedOpeningHours (ACOH), built in EP/OD 5.00.15.05.

If I install a web server (Tomcat) with Java 8 and runtime files from EP 7.0 ACOH works.
If I install a web server with Java 8 and runtime files from EP 7.2 ACOH stops working with an error referencing NoSuchMethodError -> getAbsoluteWEBINFPath

If I open a servlet in OD 7.0 and start typing mySession.getAbsoluteWE.... Eclipse suggests that there is a method called getAbsoluteWEBINFPath.

If I do the same in OD 7.2 Eclipse doesn't show that method, so I assume that it is removed?

One way to solve this is to continue to run the app servers with 7.0 runtime files (and continue to use OD 7.0) but that kind of removes the whole idea of upgrading. Any other ideas of solving it?
Hi,

We are upgrading from EP7.0 to 7.2 and planned to continue to use Java 7 on the application servers. Unfortunatelly that didn't work, we're having problems with configurable variables so we have upgraded to Java 8 which solved the CAV problem.

That introduced another problem though.

We are using an old APS developed module called AvayaCentralizedOpeningHours, and when we use that with Java 8 we get the error java.lang.Exception: java.lang.NoSuchMethodError: com.avaya.sce.runtimecommon.SCESession.getAbsoluteWEBINFPath()Ljava/lang/String; (repeated 1000 times per call; then the application stops).

Any suggestions?
Found the problem, too old Java version on the application server!
Hi,

It was a little bit premature to say that you saved my day... :-)

We reconfigured EP with ConfigureLegacyTLS.sh but it still doesn't work.

Attached is the trace.log from the application, and I changed vpAppLogClient to log Debug instead of warning, also attached.

/// Anders
Thank's! You saved my day!

:-)
Hi

We are upgrading from EP 7.0.1.0.1601 to EP 7.2.0.0.1117, but will continue to use the old application servers (Tomcat).

The problem is that we can't read the configurable variables from some reason (see vpAppLogclient.log).

I can access https://212.247.36.30/axis2/services/VPAppVarsService?wsdl from the application server, and from the EPMS I can retreive the AdminVariableInfo (through curl http://10.158.1.175:8080/appname/AdminVariableInfo )

Any suggestions what could be wrong?

Hi,

I have a REST web service, and I want to change the endpoint URL and password (basic auth).

Where and how do I do that?

Best regards

Anders
Can I edit web.xml directly, or will it be overwritten?
Hi,

I have an application with a web service which uses a web service with server IP 172.16.219.161

That server is going to be replaced by another server, so I have changed the old IP to a new in the wsop files.

If I search for the old IP after changing the wsop (and updating context and Regenerate Project) the old address is still there in WEB-INF/src/connectivity/ws/beans/Service1.wsdl and in web.xml

Should I be worried about that, or is it just old rubbish that never clears out?
If I were you I should check what connectionTimeout in server.xml (in the folder ../Tomcat/conf ) is set to.

I think the standard is 20 seconds, and after that Tomcat think that the connection is dead.
This is maybe a little bit late, but check the setting for connectionTimeout in server.xml

Example:
<Connector port="8080" protocol="HTTP/1.1"
connectionTimeout="20000"

In this case you can get problems if you play a single wav file that is longer than 20 seconds.
Hi,

After creating a Axis2 web service from the attached WSDL I get the following two errors in Eclipse:

org.apache.asiomom.OMElement.Factory cannot be resolved

The method serialize(OutputStream, OMOutputFormat) in the type OMNode is not applicable for the arguments (QName, OMFactory, MTOMAwareXMLStreamWriter)

Any suggestions what I can do about it?
Seems to be a bug in Eclipse.

More info in this thread: https://bugs.eclipse.org/bugs/show_bug.cgi?id=223992

Remember that it's always good to have a backup before you test any modification/patches!!
Found it!

It's META-INF/context.xml that is out of sync, and if I change the application name there and regenerate the project everything works again.

No idea why this has happened, but my guess would be that it is an old application, first developed by APS some 5 years ago and then we have exported and imported it several times (and most likely with different installations of Eclipse).
 
Forum Index » Profile for AndersNilsson3 » Messages posted by AndersNilsson3
Go to: